Subject: [mile] corrections to the SCI XML Schema

From: "Baker, Jon" <[email-masked]>
Date: Thu, 23 Feb 2012 15:25:03 +0000

Earlier this week I was working with the SCI XML Schema and noticed a few errors. 

First, in numerous places xsd:elements are declared using an element reference and also specifying an element name as follows:
<xsd:element name="Platform" ref="iodef-sci:Platform" minOccurs="0" maxOccurs="unbounded"/>

When declaring an xsd:element by a reference to another previously defined element, a @name cannot be specified. The correct definition should look like:
<xsd:element ref="iodef-sci:Platform" minOccurs="0" maxOccurs="unbounded"/>

Second, in the definition of the "XMLDATA" complex type the "dtype" attribute was improperly declared as follows:
<xsd:attribute name="dtype" type="iodef:dtype-type" use="prohibited" value="xml"/>

I believe that the intent was to set the value of the attribute to always be "xml" the proper way to do this is to use the @fixed attribute. A @value attribute is not defined on the xsd:attribute element. This type is defined as being a restriction on the iodef:ExtensionType and therefore it cannot have a @use attribute value other than "required". The attribute is defined and required in the base type. The correct declaration follows:
<xsd:attribute name="dtype" type="iodef:dtype-type" use="required" fixed="xml"/>

The attached .xsd has been revised to address these issues. 

Thanks,

Jon

============================================
Jonathan O. Baker
G022 - IA Industry Collaboration
The MITRE Corporation
Email: [email-masked]

---

From: "Takeshi Takahashi" <[email-masked]>
Date: Fri, 24 Feb 2012 01:03:27 +0900

Hi Jon,

I really appreciate your kind assistance onlne and offline.
Thank you very much.
I will reflect these changes to the next version of the SCI draft.

Thank you.
Take

> -----Original Message-----
> From: Baker, Jon [mailto:[email-masked]]
> Sent: Friday, February 24, 2012 12:25 AM
> To: [email-masked]
> Subject: [mile] corrections to the SCI XML Schema
> 
> First, in numerous places xsd:elements are declared using an element
> reference and also specifying an element name as follows:
> When declaring an xsd:element by a reference to another previously defined
> element, a @name cannot be specified. The correct definition should look
> like:
> Second, in the definition of the "XMLDATA" complex type the "dtype"
> attribute was improperly declared as follows:
> I believe that the intent was to set the value of the attribute to always
> be "xml" the proper way to do this is to use the @fixed attribute. A
@value
> attribute is not defined on the xsd:attribute element. This type is
> defined as being a restriction on the iodef:ExtensionType and therefore
> it cannot have a @use attribute value other than "required". The attribute
> is defined and required in the base type. The correct declaration follows: