Subject: [mile] IODEF-SCI tools available / MTI schema

From: "Takeshi Takahashi" <[email-masked]>
Date: Fri, 7 Jun 2013 15:30:47 +0900

Hello all,

We created simple tools that can generate, exchange, and parse (and store
and locate) IODEF-SCI documents.
They are Java-based tools and are available online.

https://github.com/TakeshiTakahashi/IODEF-SCI/wiki/IODEF-SCI-tools

Regarding the MTI schema, I am sorry for not being able to report anything
back until now.
It seems to be a bit difficult to embed the MMDEF itself inside the draft.
Thus I would like to propose to embed the attached schema.
The schema is not MMDEF version 1.2, but is generated based on that.
It should be able to suffice the purpose of MTI, I believe.
The draft will clearly state that the MTI schema embedded in the draft is
generated based on the MMDEF version 1.2 (the draft attached already states
that).

Take

> -----Original Message-----
> From: Takeshi Takahashi [mailto:[email-masked]]
> Sent: Friday, June 7, 2013 8:46 AM
> To: 'Panos Kampanakis (pkampana)'; 'Moriarty, Kathleen'; [email-masked]'
> Subject: RE: Request for draft reviews - review of SCI
> 
> Hi Panos,
> 
> Thank you very much for reviewing the draft again.
> I'll check the XML/schema once again.
> 
> Best regards,
> Take
> 
> 
> 
> From: Panos Kampanakis (pkampana) [mailto:[email-masked]]
> Sent: Friday, June 7, 2013 2:29 AM
> To: Moriarty, Kathleen; [email-masked]; Takeshi Takahashi
> ([email-masked])
> Subject: RE: Request for draft reviews - review of SCI
> 
> Hi Take,
> I have reviewed this a few times and  it is ready to go, in my mind. All
> my concerns have been addressed in previous iterations.
> The only thing I would do is to make sure that the XML in the appendix is
> syntactically correct.
> Rgs,
> Panos
> 
> 
> 
> From: [email-masked] [mailto:[email-masked]] On Behalf Of
> Moriarty, Kathleen
> Sent: Friday, May 17, 2013 2:13 PM
> To: [email-masked]
> Subject: [mile] Request for draft reviews
> 
> Greetings!
> 
> We have had a number of documents updated since the last meeting.  Thank
> you to all of the editors for making the requested changes!  The current
> list of drafts up for review (including those that will be a part of the
> WG after the charter update) include:
> 
> RFC5070-bis (IODEF Revision):
> http://datatracker.ietf.org/doc/draft-ietf-mile-rfc5070-bis/
> 
> Draft on IODEF Guidance:
> (input from experience, real use cases, and draft review will be helpful)
> http://datatracker.ietf.org/doc/draft-ietf-mile-iodef-guidance/
> 
> Structured Cybersecurity Information draft (close to final):
> http://datatracker.ietf.org/doc/draft-ietf-mile-sci/
> 
> IODEF Enumeration Reference Format:
> http://datatracker.ietf.org/doc/draft-montville-mile-enum-reference-fo
> rmat/
> 
> Resource-Oriented Lightweight Indicator Exchange (ROLIE):
> http://datatracker.ietf.org/doc/draft-field-mile-rolie/
> 
> Please take some time to review the drafts and provide feedback to the
> list.  It would be helpful if we can iterate on most of them prior to the
> next meeting.  A couple of the drafts are very close to being done.  The
> list of current drafts and published RFCs can be found at the following
> link:
> http://datatracker.ietf.org/wg/mile/
> 
> We will follow up soon on the charter update as well.
> 
> Thank you all in advance!
> Kathleen
> 
>

---

From: "Takeshi Takahashi" <[email-masked]>
Date: Fri, 7 Jun 2013 18:20:00 +0900

My sentences were not clear, so let me rewrite the below sentence.

> It seems to be a bit difficult to embed the MMDEF itself inside the draft.

It seems to be a bit difficult to copy & paste the MMDEF schema on the
IODEF-SCI draft since the MMDEF is an evolving specification and the
community is still very active.

Kind regards,
Take

> Takeshi Takahashi
> Sent: Friday, June 7, 2013 3:31 PM
> To: [email-masked]
> Subject: [mile] IODEF-SCI tools available / MTI schema
> 
> Hello all,
> 
> > I have reviewed this a few times and  it is ready to go, in my mind.
> > All my concerns have been addressed in previous iterations.
> > The only thing I would do is to make sure that the XML in the appendix
> > is syntactically correct.
> > Rgs,
> > Panos
> >
> >
> >
> > From: [email-masked] [mailto:[email-masked]] On Behalf
> > Of Moriarty, Kathleen
> > We have had a number of documents updated since the last meeting.
> > Thank you to all of the editors for making the requested changes!  The
> > current list of drafts up for review (including those that will be a
> > part of the WG after the charter update) include:
> >
> > list.  It would be helpful if we can iterate on most of them prior to
> > the next meeting.  A couple of the drafts are very close to being
> > done.  The list of current drafts and published RFCs can be found at
> > the following
> > link: