Subject: [mile] [Issue #2] Better citation to RecordPattern@type=regex

From: "Roman D. Danyliw" <[email-masked]>
Date: Mon, 29 Jul 2013 05:49:18 +0000

Per, http://trac.tools.ietf.org/wg/mile/trac/ticket/2

RecordPattern@type="regex" is currently cited as Appendix F of

   [3]   World Wide Web Consortium, "XML Schema Part 2: Datatypes Second
         Edition", W3C Recommendation , October 2004,
         <http://www.w3.org/TR/xmlschema-2/>.

Third hand feedback received from an implementer is that the W3C definition of regular expressions isn't sufficiently expressive.  For background, a comparison of features differences across regex implementations is summarized at http://www.regular-expressions.info/refflavors.html.

Do others implementers agree that the XML Schema citation should not be used?  If so, which definition would you like to use instead?  POSIX ERE (1003.2)? PERL 5? PCRE? Python?

Roman

---

From: Jerome Athias <[email-masked]>
Date: Mon, 29 Jul 2013 12:38:05 +0200

Hi,

I would say PCRE

Best regards

2013/7/29 Roman D. Danyliw <[email-masked]>

> Third hand feedback received from an implementer is that the W3C
> definition of regular expressions isn't sufficiently expressive.  For
> background, a comparison of features differences across regex
> implementations is summarized at
> http://www.regular-expressions.info/refflavors.html.
>
> Do others implementers agree that the XML Schema citation should not be
> used?  If so, which definition would you like to use instead?  POSIX ERE
> (1003.2)? PERL 5? PCRE? Python?
>
> Roman
> _______________________________________________
> mile mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/mile
>