Subject: [mile] Enumeration Version in ENUM-reference

From: Eric Burger <[email-masked]>
Date: Tue, 30 Jul 2013 17:42:58 +0200

I am not clear on the meaning of "Enumeration Version."  The entire specification is:

         Registry Version: The IANA-registry-specific version to which
         an enumeration identifier pertains as an integer greater than
         zero.  The Registry Version is intended to be incremented for
         each new entry, which permits any string representation for the
         Enumeration Version, but explicitly structures enumeration ID
         versions for the purpose of the registry.

         Enumeration Version: The version of the enumeration as a free-
         form string from the ASCII character set.

First of all, it is not clear that this means the Registry Version is the "most significant version thing" and Enumeration Version is the "less significant version thing."

Second, the specification, "a freeform string from the ASCII character set" does not say that it is the separator string.

Finally, my interpretation of the example,
      Full Name: Concept X Identifier
      Abbreviation: CXI
      Registry Version: 1
      Enumeration Version: any
      Specification URI: http://cxi.example.com/spec_url
tells me that I would expect a version in the table that would look something like "2any3any7". I do not think this is the intent.

---

From: Adam Montville <[email-masked]>
Date: Tue, 30 Jul 2013 15:49:24 +0000

Eric, I'm glad you asked this question.  It was one issue I wanted to discuss, aside from the "Enumeration Version" field discussion (new post forthcoming).

I would like to propose that "Registry Version" be changed to "Registry Entry" or "Registry Entry Number" or something similar.  Version was absolutely the wrong word to use and conveys the wrong semantics of the purpose of the registry entry.  

It is likely that we'll need to support multiple enumeration versions (i.e. CPE 2.2 and CPE 2.3 or CCE v4 and CCE v5) at the same time.  The presently named "Registry Version" integer is intended to provide an unambiguous way of pointing to the right specification.

Adam

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf Of
> Eric Burger
> Sent: Tuesday, July 30, 2013 8:43 AM
> To: <[email-masked]> IETF
> Subject: [mile] Enumeration Version in ENUM-reference
> 
> First of all, it is not clear that this means the Registry Version is the "most
> significant version thing" and Enumeration Version is the "less significant
> version thing."
> 
> Second, the specification, "a freeform string from the ASCII character set"
> does not say that it is the separator string.
> 
>       Specification URI: http://cxi.example.com/spec_url tells me that I would
> expect a version in the table that would look something like "2any3any7". I
> do not think this is the intent.
> 
> 
> 
> ...

This message and attachments may contain confidential information.  If it appears that this message was sent to you by mistake, any retention, dissemination, distribution or copying of this message and attachments is strictly prohibited.  Please notify the sender immediately and permanently delete the message and any attachments.