Subject: [mile] I-D Action: draft-ietf-mile-sci-08.txt

From: [email-masked]
Date: Fri, 05 Jul 2013 00:58:05 -0700

A New Internet-Draft is available from the on-line Internet-Drafts directories.
 This draft is a work item of the Managed Incident Lightweight Exchange Working Group of the IETF.

	Title           : IODEF-extension for structured cybersecurity information
	Author(s)       : Takeshi Takahashi
                          Kent Landfield
                          Thomas Millar
                          Youki Kadobayashi
	Filename        : draft-ietf-mile-sci-08.txt
	Pages           : 45
	Date            : 2013-07-05

Abstract:
   This document extends the Incident Object Description Exchange Format
   (IODEF) defined in RFC 5070 [RFC5070] to exchange enriched
   cybersecurity information among cybersecurity entities and facilitate
   their operations.  It provides the capability of embedding structured
   information, such as identifier- and XML-based information.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-mile-sci

There's also a htmlized version available at:
http://tools.ietf.org/html/draft-ietf-mile-sci-08

A diff from the previous version is available at:
http://www.ietf.org/rfcdiff?url2=draft-ietf-mile-sci-08

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: "Takeshi Takahashi" <[email-masked]>
Date: Fri, 5 Jul 2013 17:01:58 +0900

Hello all,

We've uploaded new version.
Just after we submitted the previous version (version-07) of the draft,
we've received email from the authors of MMDEF, and they kindly allowed us
to copy and paste MMDEF's schema inside the draft (though they also
preferred to paste only the web link instead of the schema itself if
possible).
So, this version includes the MMDEF 1.2's schema.

Thank you.
Take

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf Of
> [email-masked]
> Sent: Friday, July 5, 2013 4:58 PM
> To: [email-masked]
> Cc: [email-masked]
> Subject: [mile] I-D Action: draft-ietf-mile-sci-08.txt
> 
> 
> _______________________________________________
> mile mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/mile

---

From: Eric Burger <[email-masked]>
Date: Sun, 14 Jul 2013 18:02:16 -0400

The URL in the IANA section is broken. It goes nowhere. Did you mean http://grouper.ieee.org/groups/malware/malwg/Schema1.2/ ? If so, that is not an XSD, either.

If we have their approval, it would be easier to make the appendix the normative reference for MMDEF.

---

From: "Takeshi Takahashi" <[email-masked]>
Date: Mon, 15 Jul 2013 10:49:36 +0900

Hello Eric,

Thank you for your kind comment,
It seems to be that the "/" was missing from the web address.
Thank you very much for letting me know that.
I also see your point. That would be better.

Let me change the text as follows after the call.

Current text:
Reference URI: http://standards.ieee.org/develop
               indconn/icsg/mmdef.html

Correct one:
Reference URI: https://datatracker.ietf.org/doc/draft-ietf-mile-sci/
               http://standards.ieee.org/develop/
               indconn/icsg/mmdef.html,

Kind regards,
Take

> From: Eric Burger [mailto:[email-masked]]
> Sent: Monday, July 15, 2013 7:02 AM
> To: Takeshi Takahashi
> Cc: [email-masked]
> Subject: Re: [mile] I-D Action: draft-ietf-mile-sci-08.txt
> 
> The URL in the IANA section is broken. It goes nowhere. Did you mean
> http://grouper.ieee.org/groups/malware/malwg/Schema1.2/ ? If so, that is
> not an XSD, either.
> 
> > Just after we submitted the previous version (version-07) of the
> > draft, we've received email from the authors of MMDEF, and they kindly
> > allowed us to copy and paste MMDEF's schema inside the draft (though
> > they also preferred to paste only the web link instead of the schema
> > itself if possible).
> >> From: [email-masked] [mailto:[email-masked]] On Behalf
> >> Of [email-masked]

---

From: "Takeshi Takahashi" <[email-masked]>
Date: Mon, 15 Jul 2013 11:42:35 +0900

Comma was in a wrong place, sorry. Let me send it again.

Correct one:
Reference URI: https://datatracker.ietf.org/doc/draft-ietf-mile-sci/,
               http://standards.ieee.org/develop/
               indconn/icsg/mmdef.html

Kind regards,
Take

> Takeshi Takahashi
> Sent: Monday, July 15, 2013 10:50 AM
> To: 'Eric Burger'
> Cc: [email-masked]
> > http://grouper.ieee.org/groups/malware/malwg/Schema1.2/ ? If so, that
> > is not an XSD, either.
> >
> > > draft, we've received email from the authors of MMDEF, and they
> > > kindly allowed us to copy and paste MMDEF's schema inside the draft
> > > (though they also preferred to paste only the web link instead of
> > > the schema itself if possible).
> > >> From: [email-masked] [mailto:[email-masked]] On
> > >> Behalf Of [email-masked]