Subject: [mile] IODEF Enumeration Reference Format Issue - Is "Enumeration Verison" required in the IANA Registry?

From: Adam Montville <[email-masked]>
Date: Tue, 30 Jul 2013 15:49:56 +0000

During today's WG meeting we reviewed the most recent changes to the enumeration reference format [1].  At this point the registry will contain an ASCII string representing the "Enumeration Version".  The intent was to have some idea of what version of a particular enumeration the registry entry pertains.  For example, "Registry Version" 1 might relate to CPE 2.2 and "Registry Version" 2 might relate to CPE 2.3.  But, with the presence of "Specification URI" the "Registry Version" field may not be necessary.

Thoughts?

I think the "Enumeration Version" can safely be removed.

Adam

[1] https://datatracker.ietf.org/doc/draft-ietf-mile-enum-reference-format/

This message and attachments may contain confidential information.  If it appears that this message was sent to you by mistake, any retention, dissemination, distribution or copying of this message and attachments is strictly prohibited.  Please notify the sender immediately and permanently delete the message and any attachments.

---

From: "Panos Kampanakis (pkampana)" <[email-masked]>
Date: Wed, 31 Jul 2013 17:52:27 +0000

Hi Adam,

Given the Specification URI I think the IANA table does not need to include the Enumeration Version. But if I am an implemented and I see ID Abbreviation CXI, will I need to go parse the whole Specification URI to understand that this is CXI 2.3? It might be more functional for an implemented to be able to read the Enumeration Version at least for specs that he expects like CVE or CPE, for example.

For the Registry Version. If  I am an implementer and there is no Registry Version in the reference, how can I tell if the Abbreviation that says CXI refers to CXI 2.2 or 2.3?
            <EnumRef>
               <Abbreviation>CXI</Abbreviation>
               <ID>CXI-1234-XYZ</ID>
            </EnumRef>

Panos

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Adam Montville
Sent: Tuesday, July 30, 2013 11:50 AM
To: [email-masked]
Subject: [mile] IODEF Enumeration Reference Format Issue - Is "Enumeration Verison" required in the IANA Registry?

Thoughts?

Adam

This message and attachments may contain confidential information.  If it appears that this message was sent to you by mistake, any retention, dissemination, distribution or copying of this message and attachments is strictly prohibited.  Please notify the sender immediately and permanently delete the message and any attachments.
_______________________________________________
mile mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/mile

---

From: Adam Montville <[email-masked]>
Date: Wed, 31 Jul 2013 19:05:52 +0000

Panos, thank you for your feedback.  I'll try to clarify inline.

> From: Panos Kampanakis (pkampana) [mailto:[email-masked]]
> Sent: Wednesday, July 31, 2013 10:53 AM
> To: Adam Montville; [email-masked]
> Subject: RE: [mile] IODEF Enumeration Reference Format Issue - Is
> "Enumeration Verison" required in the IANA Registry?
> 
> Hi Adam,
> 
> Given the Specification URI I think the IANA table does not need to include
> the Enumeration Version. But if I am an implemented and I see ID
> Abbreviation CXI, will I need to go parse the whole Specification URI to
> understand that this is CXI 2.3? It might be more functional for an
> implemented to be able to read the Enumeration Version at least for specs
> that he expects like CVE or CPE, for example.

If we remove the "Enumeration Version" entry from the IANA table, then it is presumed that the version information would be explicitly discovered by resolving the Specification URI, yes.  If this is not desirable, then we might consider leaving "Enumeration Version" intact.

What do others think?

> 
> For the Registry Version. If  I am an implementer and there is no Registry
> Version in the reference, how can I tell if the Abbreviation that says CXI
> refers to CXI 2.2 or 2.3?
>             <EnumRef>

This comment, I believe, might focus on the other thread I sent out, which was suggesting that the string "Registry Version" be changed to something that does not indicate that it intends to track changes to an enumeration specification.  Instead, it's simply an integer that points to the appropriate entry in the IANA table.

So, your example might have something like:

<EnumRef>
  <Abbreviation>CXI</Abbreviation>
  <ID>CXI-1234-XYZ</ID>
  <RegistryEntry>1</RegistryEntry>
</EnumRef>

In this way, you should be able to find the appropriate information at the IANA table entry with the RegistryEntry value of 1.  Then, the table would complete the information required to determine the appropriate format of the ID.

> During today's WG meeting we reviewed the most recent changes to the
> enumeration reference format [1].  At this point the registry will contain an
> ASCII string representing the "Enumeration Version".  The intent was to have
> some idea of what version of a particular enumeration the registry entry
> pertains.  For example, "Registry Version" 1 might relate to CPE 2.2 and
> "Registry Version" 2 might relate to CPE 2.3.  But, with the presence of
> "Specification URI" the "Registry Version" field may not be necessary.
> 
> Thoughts?
> 
> This message and attachments may contain confidential information.  If it
> appears that this message was sent to you by mistake, any retention,
> dissemination, distribution or copying of this message and attachments is
> strictly prohibited.  Please notify the sender immediately and permanently
> delete the message and any attachments.
> ...

---

From: "Panos Kampanakis (pkampana)" <[email-masked]>
Date: Wed, 31 Jul 2013 19:58:13 +0000

Ah, makes sense with the   <RegistryEntry>1</RegistryEntry>
> Thank you

-----Original Message-----
From: Adam Montville [mailto:[email-masked]] 
Sent: Wednesday, July 31, 2013 3:06 PM
To: Panos Kampanakis (pkampana); [email-masked]
Subject: RE: [mile] IODEF Enumeration Reference Format Issue - Is "Enumeration Verison" required in the IANA Registry?

> Given the Specification URI I think the IANA table does not need to 
> include the Enumeration Version. But if I am an implemented and I see 
> ID Abbreviation CXI, will I need to go parse the whole Specification 
> URI to understand that this is CXI 2.3? It might be more functional 
> for an implemented to be able to read the Enumeration Version at least 
> for specs that he expects like CVE or CPE, for example.

What do others think?

> 
> For the Registry Version. If  I am an implementer and there is no 
> Registry Version in the reference, how can I tell if the Abbreviation 
> that says CXI refers to CXI 2.2 or 2.3?
>             <EnumRef>

<EnumRef>

> Subject: [mile] IODEF Enumeration Reference Format Issue - Is 
> enumeration reference format [1].  At this point the registry will 
> contain an ASCII string representing the "Enumeration Version".  The 
> intent was to have some idea of what version of a particular 
> enumeration the registry entry pertains.  For example, "Registry 
> Version" 1 might relate to CPE 2.2 and "Registry Version" 2 might 
> relate to CPE 2.3.  But, with the presence of "Specification URI" the "Registry Version" field may not be necessary.
> 
> Thoughts?
> 
> [1] 
> https://datatracker.ietf.org/doc/draft-ietf-mile-enum-reference-format
> /
> 
> This message and attachments may contain confidential information.  If 
> it appears that this message was sent to you by mistake, any 
> retention, dissemination, distribution or copying of this message and 
> attachments is strictly prohibited.  Please notify the sender 
> immediately and permanently delete the message and any attachments.