Subject: [mile] Consistent and descriptive naming of EmailInfo Subclasses

From: "Roman D. Danyliw" <[email-masked]>
Date: Mon, 13 Jan 2014 21:32:52 +0000

Hello!

Currently, the EmailInfo class is defined as:

+-------------------------+
| EmailInfo               |
+-------------------------+
{0..1}--[ Email            ]
{0..1}--[ EmailSubject     ]
{0..1}--[ X-Mailer         ]

Would there be interest in renaming some of these classes for consistency and descriptive clarity as follows:

** The name of the class "Email" is misleading to me since it represents not an email but the From: header field value (per the schema comments).  I would propose that the Email class be renamed to EmailFrom for clarity.
** In order to consistently name all subclasses of EmailInfo with the prefix "Email", I would propose that the "X-Mailer" class be renamed to "EmailX-Mailer".

Roman

---

From: "Stoecker, Paul" <[email-masked]>
Date: Mon, 13 Jan 2014 21:37:38 +0000

Agreed.  

Paul W. Stoecker, Ph.D.
Principal Product Manager
Regional Product Management Team
Pragmatic Marketing Certified - III
RSA, The Security Division of EMC
cell: 571.419.2578 | e: [email-masked]

On 1/13/14 4:32 PM, "Roman D. Danyliw" <[email-masked]> wrote:

>** The name of the class "Email" is misleading to me since it represents
>not an email but the From: header field value (per the schema comments).
>I would propose that the Email class be renamed to EmailFrom for clarity.
>** In order to consistently name all subclasses of EmailInfo with the
>prefix "Email", I would propose that the "X-Mailer" class be renamed to
>"EmailX-Mailer".
>
>Roman
>_______________________________________________
>mile mailing list
>[email-masked]
>https://www.ietf.org/mailman/listinfo/mile
>