Subject: [mile] Consistency in classes suffixes

From: "Roman D. Danyliw" <[email-masked]>
Date: Mon, 27 Jan 2014 21:51:33 +0000

Hello!

By organic convention, we have a number of a classes that end with the suffix "Data" -- EventData, DomainData, RecordData, and AdditionalData.  We've added a few classes with the suffix "Information" or "Info" -- HashInformation, EmailInfo, and reused ds:KeyInfo.

For naming consistency, I would recommend renaming these classes as follows:
** HashInformation --> HashData, that said, the class represents both signatures and hashes so perhaps there is an more descriptive name?
** EmailInfo --> EmailData or Email

How does the community feel about this change?

Roman

---

From: "Moriarty, Kathleen" <[email-masked]>
Date: Mon, 27 Jan 2014 17:33:30 -0500

+1   I am fine with the change, others?

-----Original Message-----
From: mile [mailto:[email-masked]] On Behalf Of Roman D. Danyliw
Sent: Monday, January 27, 2014 4:52 PM
To: [email-masked]
Subject: [mile] Consistency in classes suffixes

Hello!

Roman
_______________________________________________
mile mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/mile

---

From: Eric Burger <[email-masked]>
Date: Mon, 27 Jan 2014 17:56:15 -0500

+1

---

From: Jerome Athias <[email-masked]>
Date: Tue, 28 Jan 2014 12:40:56 +0300

+1 that a change is needed to have the same suffix
NB: the suffix could have been "Type" for the description, i.e: the
EventType class is used to describe information related to an event
and exchange EventData.

---

From: Brian Trammell <[email-masked]>
Date: Tue, 28 Jan 2014 11:54:48 +0100

hi Roman, all,

+1 for both of these.

Cheers,

Brian