Subject: Re: [mile] [Issue #2] Better citation to RecordPattern@type=regex

From: "Roman D. Danyliw" <[email-masked]>
Date: Sat, 11 Jan 2014 18:14:05 +0000

Hello!

I'm repeating this call to implementers.  Would there be interest in redefining the citation for regex?  If so how.

We have one suggestion to date for PCRE.

Roman

From: Jerome Athias [mailto:[email-masked]]
Sent: Monday, July 29, 2013 6:38 AM
To: Roman D. Danyliw
Cc: [email-masked]
Subject: Re: [mile] [Issue #2] Better citation to RecordPattern@type=regex

Hi,

I would say PCRE

Best regards

2013/7/29 Roman D. Danyliw <[email-masked]<mailto:[email-masked]>>
Per, http://trac.tools.ietf.org/wg/mile/trac/ticket/2

RecordPattern@type="regex" is currently cited as Appendix F of

   [3]   World Wide Web Consortium, "XML Schema Part 2: Datatypes Second
         Edition", W3C Recommendation , October 2004,
         <http://www.w3.org/TR/xmlschema-2/>.

Third hand feedback received from an implementer is that the W3C definition of regular expressions isn't sufficiently expressive.  For background, a comparison of features differences across regex implementations is summarized at http://www.regular-expressions.info/refflavors.html.

Do others implementers agree that the XML Schema citation should not be used?  If so, which definition would you like to use instead?  POSIX ERE (1003.2)? PERL 5? PCRE? Python?

Roman
_______________________________________________
mile mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/mile

---

From: "Harrington, Christopher" <[email-masked]>
Date: Sat, 11 Jan 2014 15:04:51 -0500

Although I am partial to Python I think PCRE is probably more widely used.

On Jan 11, 2014, at 1:14 PM, "Roman D. Danyliw" <[email-masked]<mailto:[email-masked]>> wrote:

Hello!

I’m repeating this call to implementers.  Would there be interest in redefining the citation for regex?  If so how.

Roman

From: Jerome Athias [mailto:[email-masked]]
Sent: Monday, July 29, 2013 6:38 AM
To: Roman D. Danyliw
Cc: [email-masked]<mailto:[email-masked]>
Subject: Re: [mile] [Issue #2] Better citation to RecordPattern@type=regex

Hi,

I would say PCRE

Best regards

Roman