Subject: [mile] extension mechanism

From: Chris Inacio <[email-masked]>
Date: Wed, 25 Mar 2015 14:36:40 +0000

Now that we’ve added the extension mechanism back into the schema, I recommend two more fields:

* extension canonical URI
* obsoleted by URI

the extension canonical URI can be used for public private extensions.
the obsoleted by URI can point to a previous version of the URI, presumably when an extension becomes standardized, it will point to an IANA reference point.

Thoughts?

--
Chris Inacio
[email-masked]

---

From: Robert Moskowitz <[email-masked]>
Date: Wed, 25 Mar 2015 10:07:45 -0500

Allow for, in 'private' extensions for the vendor to identify themselves 
to avoid collisions on extension naming.

In some areas, simply a text name of the vendor is used.  After all this 
is xml.

  But there IS a iana registry of enterprises:

http://www.iana.org/assignments/enterprise-numbers/enterprise-numbers

Even *I* have a number: 6715 (I got mine long ago when I was doing some 
PKI demos).

Last I looked, there is no charge to get an iana enterprise number.

---

From: Chris Inacio <[email-masked]>
Date: Wed, 25 Mar 2015 16:54:53 +0000

> On Mar 25, 2015, at 10:07 AM, Robert Moskowitz <[email-masked]> wrote:
> 
> Allow for, in 'private' extensions for the vendor to identify themselves to avoid collisions on extension naming.
> 
> In some areas, simply a text name of the vendor is used.  After all this is xml.
> 
> Even *I* have a number: 6715 (I got mine long ago when I was doing some PKI demos).
> 

The Private Enterprise Number (PEN) mechanism is used in IPFIX (and I’m sure countless other places) to provide this kind of namespace protection.  But what we’ve learned in IPFIX is the issue of one enterprise (e.g. PEN=1) defines the “magic attack” extension independently while another enterprise (e.g. PEN=2) does so simultaneously.  2 things happen under this scenario:

1) it would be really helpful to be able to point people to a public site to be able to grab information about the extension
2) assuming the private extension gets superseded by an IANA registered standard, it would be good to be able to express that to data consumers that in their database, what used to be known as (PEN=2,name=foo) is now (STD, name=bar) allowing those data points to be treated as equivalent as possible - potentially, exactly the same.

So I don’t know if IODEF would like to use PEN’s to create extension name spaces, but certainly, it would be beneficial to have a path from private extension to standard element and a way of expressing that older data that was a private extension is now expressed in a standard conforming way and express the equivalence to IODEF consumers/producers.

--
Chris Inacio
[email-masked]