Subject: Re: [mile] I-D Action: draft-ietf-mile-xmpp-grid-05.txt

From: Peter Saint-Andre <[email-masked]>
Date: Tue, 17 Apr 2018 09:49:46 -0600

On 2/12/18 12:30 PM, Peter Saint-Andre wrote:
> On 2/8/18 2:56 PM, [email-masked] wrote:

<snip/>

>> A diff from the previous version is available at:
>> https://www.ietf.org/rfcdiff?url2=draft-ietf-mile-xmpp-grid-05
> 
> This version is intended to fill a number of gaps in the text and
> examples regarding use of XMPP and its publish-subscribe extension.
> 
> Personally, I've not yet reviewed the spec with all of Dave Cridland's
> WGLC feedback [1] in mind. However, I will endeavor to do so before too
> much longer.
> 
> Dave, if you have a chance to glance through it that would be great.
> 
> Peter
> 
> [1] https://www.ietf.org/mail-archive/web/mile/current/msg02113.html
> 

The minutes from IETF 101 stated:

###

XMPP draft status, by Nancy Cam Winget (10 mins)
[draft-ietf-mile-xmpp-grid-05]
================================================
Slides:
https://datatracker.ietf.org/meeting/101/materials/slides-101-mile-draft-ietf-mile-xmpp-grid-05-00

Cridland confirmed that his previous comments have been addressed in the
-05 revision.
Cam-Winget asked for more review.
Montville, Munion, and Cridland offered to review the draft.
Banghart raised a concern that there is only one or two nromative
statements in the pre-Security Considerations sections.
Cam-Winget will review the text and add normative requirements as needed.

Takahashi(as chair) asked that comments on the draft be provided by the
end of April 2018 to allow the draft to progress quickly.

###

What were the results from the hackathon?

Have folks who offered to review the document by the end of April had a
chance to look at it?

Just trying to get this one done... :-)

Peter

---

From: "Nancy Cam-Winget (ncamwing)" <[email-masked]>
Date: Tue, 17 Apr 2018 17:42:11 +0000

Hi Peter,

A few (as noted below) agreed to review the draft....it was requested that we provide more clarification on the minimum XMPP (normative) requirements to make the 'sharing' work.  Bill also provided feedback believing there may be 'gaps' or other XMPP extensions that could be relevant (though not sure if they are hard requirements?).

I took the AI to update the draft on the normative qualifiers but am remiss on this too!

	Nancy

On 4/17/18, 8:50 AM, "Peter Saint-Andre" <[email-masked]> wrote:

    <snip/>

    
    ###

    
    
    ###

    
    
    Peter

---

From: Adam Montville <[email-masked]>
Date: Tue, 24 Apr 2018 13:45:36 -0500

Here's our write-up from the hackathon: https://github.com/CISecurity/Integration <https://github.com/CISecurity/Integration>

We've incorporated updates to our mandm architecture draft in the SACM working group to fill in gaps of the -05 xmpp-grid draft - https://datatracker.ietf.org/doc/draft-mandm-sacm-architecture/ <https://datatracker.ietf.org/doc/draft-mandm-sacm-architecture/>

Bill may have some additional comments, but the one thing I might comment on is that each client seeking to discover a MILE host will need to enumerate the list of topics, then query each topic for its type to find all the things that speak IODEF. An optimization might be possible if "MILEHost" were standardized as a topic name, which starts to get into the notion of expressing node capabilities.

So, for our hackathon, it was easy to set up an automated workflow where some configuration assessment policy was published, thus triggering a chain of events via pub/sub ultimately resulting in assessment results based on the updated policy being displayed in a dashboard.

What is less clear is how onboarding would work. I think we'd like to see some out-of-the-box interoperability among tools with minimal operator intervention, and right now if we were to perform discovery, we'd need to know more than a few things ahead of the curve. Nodes would need to be provisioned with certificates/certificate chains, they'd need to be added to the domain (again, I apologize if I'm not using the appropriate terminology), and they'd need to know what they are looking for then find the nodes of interest. Further, they'd have to be authorized to subscribe and/or publish to specific topics, which means that those topics would need to also be known.

Bill has the reins for our next hackathon effort - at least I know he has some ideas about what we'd like to do - and part of that could be to work some discovery on what would be needed to make out-of-the-box interoperability more of a reality...

Thoughts?

Adam

> On Apr 17, 2018, at 12:42 PM, Nancy Cam-Winget (ncamwing) <[email-masked]> wrote:
> 
> Hi Peter,
> 
> _______________________________________________
> mile mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/mile