Subject: [mile] revising the charter text

From: "Takeshi Takahashi" <[email-masked]>
Date: Thu, 16 Aug 2018 13:11:19 +0900

Hi all,

During the MILE session @ IETF102 in Montreal, we agreed to modify the
charter text.
Based on the discussion during the session, the co-chairs (Nancy, Dave, and
I) have drafted a revision.
Please see the attached files.

MILEcharterv2.docx: the revised text with change records
MILEcharterv2_clean.txt: the revised text without change records

We would like to hear your opinion on this revised text.
If you have any concerns, corrections, or additions, please kindly let us
know.

Thanks,
Take

---

From: Kathleen Moriarty <[email-masked]>
Date: Thu, 16 Aug 2018 09:41:26 -0400

Hello Take,

The update looks very good.  Thanks to you and the chairs for the first
draft.  There are a few grammar nits to clean up and I just have one edit
suggestion.

The first place where RID appears has not been expanded because of the
editing.

I think RID is useful as a reference and to incorporate the policy and
security aspects at this point rather than actually using it as a transport
protocol (it's of course possible, but there are better solutions as RID
development started a long time ago).  It probably doesn't make sense to
expand too much that thinking into the charter and the point is hit on in a
sentence that remains on it containing policy.  The ability to include
courses of actions in RID (I believe that was carried into ROLIE, but am
not positive off hand) and some of the other action handling is useful as
the requirements development for RID was quite an effort.  In other words,
it has a lot of lessons learned so we don't leave something out or
unnecessarily reinvent the wheel.  It also handled multi-party
authentication and there may be some information gleaned from that work
(that had lots of review) to do that in follow on protocols looking for
that capability using JOSE or COSE for example.

If I find a little time, I may try to add subtle wording suggestions to
make sure the usefulness of RID is understood and that it is not overstated
as it's SOAPy and we have better answers now for transport.  The security
requirements and solution development for policy and security controls I
think is where it is still useful.

Best regards,
Kathleen

On Thu, Aug 16, 2018 at 12:11 AM, Takeshi Takahashi <
[email-masked]> wrote:

> _______________________________________________
> mile mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/mile
>
>

-- 

Best regards,
Kathleen

---

From: Adam Montville <[email-masked]>
Date: Thu, 16 Aug 2018 08:57:34 -0500

I'm not as familiar with RID as Kathleen and others... Aside from Kathleen's comments, I think the charter looks pretty good - grammatical issues will be cleaned up eventually right? It seems like a tightly scoped effort, which is good.

Kind regards,

Adam

> On Aug 16, 2018, at 8:41 AM, Kathleen Moriarty <[email-masked]> wrote:
> 
> Hello Take,
> 
> The update looks very good.  Thanks to you and the chairs for the first draft.  There are a few grammar nits to clean up and I just have one edit suggestion.
> 
> The first place where RID appears has not been expanded because of the editing.
> 
> I think RID is useful as a reference and to incorporate the policy and security aspects at this point rather than actually using it as a transport protocol (it's of course possible, but there are better solutions as RID development started a long time ago).  It probably doesn't make sense to expand too much that thinking into the charter and the point is hit on in a sentence that remains on it containing policy.  The ability to include courses of actions in RID (I believe that was carried into ROLIE, but am not positive off hand) and some of the other action handling is useful as the requirements development for RID was quite an effort.  In other words, it has a lot of lessons learned so we don't leave something out or unnecessarily reinvent the wheel.  It also handled multi-party authentication and there may be some information gleaned from that work (that had lots of review) to do that in follow on protocols looking for that capability using JOSE or COSE for example.
> 
> If I find a little time, I may try to add subtle wording suggestions to make sure the usefulness of RID is understood and that it is not overstated as it's SOAPy and we have better answers now for transport.  The security requirements and solution development for policy and security controls I think is where it is still useful.
> 
> Best regards,
> Kathleen
> 
> 
> 
> On Thu, Aug 16, 2018 at 12:11 AM, Takeshi Takahashi <[email-masked] <mailto:[email-masked]>> wrote:
> Hi all,
> 
> [email-masked] <mailto:[email-masked]>
> https://www.ietf.org/mailman/listinfo/mile <https://www.ietf.org/mailman/listinfo/mile>
> 
> 
> 
> 
> -- 
> 
> Best regards,
> Kathleen

---

From: "Nancy Cam-Winget (ncamwing)" <[email-masked]>
Date: Thu, 16 Aug 2018 15:27:55 +0000

Thanks for the comments Kathleen….and yes, we will clean up the grammar though we’re happy to take other’s suggestions and assistance as well!

We retained RID for historical reasons and quite right that RID is a bit of both so your help in appropriate placement will be appreciated!

Best, Nancy

From: mile <[email-masked]> on behalf of Kathleen Moriarty <[email-masked]>
Date: Thursday, August 16, 2018 at 06:42
To: Takeshi Takahashi <[email-masked]>
Cc: MILE IETF <[email-masked]>
Subject: Re: [mile] revising the charter text

Hello Take,

Best regards,
Kathleen

On Thu, Aug 16, 2018 at 12:11 AM, Takeshi Takahashi <[email-masked]<mailto:[email-masked]>> wrote:
Hi all,

Thanks,
Take

_______________________________________________
mile mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/mile

--

Best regards,
Kathleen

---

From: "Nancy Cam-Winget (ncamwing)" <[email-masked]>
Date: Thu, 16 Aug 2018 15:28:33 +0000

Thanks Adam….and yes, we’ll definitely clean up grammatical and other editorial nits/comments before final copy!

Best, Nancy

From: mile <[email-masked]> on behalf of Adam Montville <[email-masked]>
Date: Thursday, August 16, 2018 at 06:57
To: Kathleen Moriarty <[email-masked]>
Cc: MILE IETF <[email-masked]>
Subject: Re: [mile] revising the charter text

Kind regards,

Adam

On Aug 16, 2018, at 8:41 AM, Kathleen Moriarty <[email-masked]<mailto:[email-masked]>> wrote:

Hello Take,

Best regards,
Kathleen

Hi all,

Thanks,
Take

--

Best regards,
Kathleen

---

From: "Banghart, Stephen A. (Fed)" <[email-masked]>
Date: Thu, 16 Aug 2018 16:25:56 +0000

Nancy, Take,

The proposed charter looks really good, thanks for putting this together. Agree with Adam, it’s tightly scoped and very understandable, avoids some of the pitfalls I’ve seen other chartering efforts fall into.

In regards to Kathleen’s comment on ROLIE/RID, ROLIE includes optional support for RID messages, that is, a ROLIE endpoint can be integrated with existing RID endpoints (thru the “/” resource, Section 5.5). Additionally, Course of Action is one of the extensions I’ve been thinking about putting together for native ROLIE support.

With that in mind, I agree with Kathleen. We should call out RID as existing work that we are going to learn from and build on (especially re: security policy and requirements), but that’s it’s not necessarily a target transport mechanism for MILE as we move forward with new work.

-Stephen

From: mile <[email-masked]> On Behalf Of Nancy Cam-Winget (ncamwing)
Sent: Thursday, August 16, 2018 11:29 AM
To: Adam Montville <[email-masked]>; Kathleen Moriarty <[email-masked]>
Cc: MILE IETF <[email-masked]>
Subject: Re: [mile] revising the charter text

Best, Nancy

From: mile <[email-masked]<mailto:[email-masked]>> on behalf of Adam Montville <[email-masked]<mailto:[email-masked]>>
Date: Thursday, August 16, 2018 at 06:57
To: Kathleen Moriarty <[email-masked]<mailto:[email-masked]>>
Cc: MILE IETF <[email-masked]<mailto:[email-masked]>>
Subject: Re: [mile] revising the charter text

Kind regards,

Adam

Hello Take,

Best regards,
Kathleen

Thanks,
Take

_______________________________________________
mile mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/mile<https://na01.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fmile&data=02%7C01%7Cstephen.banghart%40nist.gov%7Cceacad5d962848cef62408d6038cfd97%7C2ab5d82fd8fa4797a93e054655c61dec%7C1%7C0%7C636700301416938592&sdata=nxXxCMsm5rl%2FlMw%2FZc8OXNb9I4ZulxwVaFqULA7uyYQ%3D&reserved=0>

--

Best regards,
Kathleen

---

From: John Field <[email-masked]>
Date: Fri, 17 Aug 2018 10:53:16 -0400

+1

...and good to see the mention of STIX as potentially in scope for future
work.

John

On Thu, Aug 16, 2018 at 12:25 PM, Banghart, Stephen A. (Fed) <
[email-masked]> wrote:

> Nancy, Take,
>
>
>
> The proposed charter looks really good, thanks for putting this together.
> Agree with Adam, it’s tightly scoped and very understandable, avoids some
> of the pitfalls I’ve seen other chartering efforts fall into.
>
>
>
> In regards to Kathleen’s comment on ROLIE/RID, ROLIE includes optional
> support for RID messages, that is, a ROLIE endpoint can be integrated with
> existing RID endpoints (thru the “/” resource, Section 5.5). Additionally,
> Course of Action is one of the extensions I’ve been thinking about putting
> together for native ROLIE support.
>
>
>
> With that in mind, I agree with Kathleen. We should call out RID as
> existing work that we are going to learn from and build on (especially re:
> security policy and requirements), but that’s it’s not necessarily a target
> transport mechanism for MILE as we move forward with new work.
>
>
>
> -Stephen
>
>
>
> *From:* mile <[email-masked]> *On Behalf Of * Nancy Cam-Winget
> (ncamwing)
> *Sent:* Thursday, August 16, 2018 11:29 AM
> *To:* Adam Montville <[email-masked]>; Kathleen Moriarty <
> [email-masked]>
>
> *Cc:* MILE IETF <[email-masked]>
> *Subject:* Re: [mile] revising the charter text
>
>
>
> Thanks Adam….and yes, we’ll definitely clean up grammatical and other
> editorial nits/comments before final copy!
>
>
>
> Best, Nancy
>
>
>
> *From: *mile <[email-masked]> on behalf of Adam Montville <
> [email-masked]>
> *Date: *Thursday, August 16, 2018 at 06:57
> *To: *Kathleen Moriarty <[email-masked]>
> *Cc: *MILE IETF <[email-masked]>
> *Subject: *Re: [mile] revising the charter text
>
>
>
> I'm not as familiar with RID as Kathleen and others... Aside from
> Kathleen's comments, I think the charter looks pretty good - grammatical
> issues will be cleaned up eventually right? It seems like a tightly scoped
> effort, which is good.
>
>
>
> Kind regards,
>
>
>
> Adam
>
>
>
> <https://na01.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fmile&data=02%7C01%7Cstephen.banghart%40nist.gov%7Cceacad5d962848cef62408d6038cfd97%7C2ab5d82fd8fa4797a93e054655c61dec%7C1%7C0%7C636700301416938592&sdata=nxXxCMsm5rl%2FlMw%2FZc8OXNb9I4ZulxwVaFqULA7uyYQ%3D&reserved=0>
>
>
>
>
>
> --
>
>
>
> Best regards,
>
> Kathleen
>

-- 

John P. Field | Product Lead - Security and Compliance | Pivotal

Direct: (908) 962-3394 | jfield@ <[email-masked]>pivotal.io

---

From: "Nancy Cam-Winget (ncamwing)" <[email-masked]>
Date: Fri, 17 Aug 2018 16:26:00 +0000

Hi John,
Thanks for the feedback!  To be clear, STIX as an exchange format is not in scope but we are looking to
Document how MILE’s transport protocols could carry other exchange formats (STIX being one such other example with ROLIE….).

Warm regards, Nancy
From: mile <[email-masked]> on behalf of John Field <[email-masked]>
Date: Friday, August 17, 2018 at 07:53
To: "Banghart, Stephen A. (Fed)" <[email-masked]>
Cc: MILE IETF <[email-masked]>
Subject: Re: [mile] revising the charter text

+1

...and good to see the mention of STIX as potentially in scope for future work.

John

On Thu, Aug 16, 2018 at 12:25 PM, Banghart, Stephen A. (Fed) <[email-masked]<mailto:[email-masked]>> wrote:
Nancy, Take,

-Stephen

From: mile <[email-masked]<mailto:[email-masked]>> On Behalf Of Nancy Cam-Winget (ncamwing)
Sent: Thursday, August 16, 2018 11:29 AM
To: Adam Montville <[email-masked]<mailto:[email-masked]>>; Kathleen Moriarty <[email-masked]<mailto:[email-masked]>>

Best, Nancy

To: Kathleen Moriarty <[email-masked]<mailto:[email-masked]>>

Kind regards,

Adam

Hello Take,

Best regards,
Kathleen

Thanks,
Take

--

Best regards,
Kathleen

--

Direct: (908) 962-3394 | jfield@<mailto:[email-masked]>pivotal.io<http://pivotal.io>

---

From: Roman Danyliw <[email-masked]>
Date: Mon, 20 Aug 2018 17:08:12 +0000

Hello!

+1.  I support the proposed changes to the charter. It captures our discussion in Montreal to transport additional data formats.

Roman

From: mile [mailto:[email-masked]] On Behalf Of Nancy Cam-Winget (ncamwing)
Sent: Friday, August 17, 2018 12:26 PM
To: John Field <[email-masked]>; Banghart, Stephen A. (Fed) <[email-masked]>
Cc: MILE IETF <[email-masked]>
Subject: Re: [mile] revising the charter text

Hi John,

Warm regards, Nancy
From: mile <[email-masked]<mailto:[email-masked]>> on behalf of John Field <[email-masked]<mailto:[email-masked]>>
Date: Friday, August 17, 2018 at 07:53
To: "Banghart, Stephen A. (Fed)" <[email-masked]<mailto:[email-masked]>>
Cc: MILE IETF <[email-masked]<mailto:[email-masked]>>
Subject: Re: [mile] revising the charter text

+1

John

-Stephen

Best, Nancy

Kind regards,

Adam

Hello Take,

Best regards,
Kathleen

Thanks,
Take

--

Best regards,
Kathleen

--

---

From: John Field <[email-masked]>
Date: Mon, 20 Aug 2018 14:07:04 -0400

>we are looking to

>Document how MILE’s transport protocols could carry other exchange formats
(STIX being one such other example with ROLIE….).

Understood.  Makes perfect sense.

John

On Mon, Aug 20, 2018 at 1:08 PM, Roman Danyliw <[email-masked]> wrote:

> Hello!
>
>
>
> +1.  I support the proposed changes to the charter. It captures our
> discussion in Montreal to transport additional data formats.
>
>
>
> Roman
>
>
>
> *From:* mile [mailto:[email-masked]] *On Behalf Of *Nancy
> Cam-Winget (ncamwing)
> *Sent:* Friday, August 17, 2018 12:26 PM
> *To:* John Field <[email-masked]>; Banghart, Stephen A. (Fed) <
> [email-masked]>
>
> Document how MILE’s transport protocols could carry other exchange formats
> (STIX being one such other example with ROLIE….).
>
>
>
> Warm regards, Nancy
>
> *From: *mile <[email-masked]> on behalf of John Field <
> [email-masked]>
> *Date: *Friday, August 17, 2018 at 07:53
> *To: *"Banghart, Stephen A. (Fed)" <[email-masked]>
> *From:* mile <[email-masked]> *On Behalf Of *Nancy Cam-Winget
> (ncamwing)
> *To: *Kathleen Moriarty <[email-masked]
> <[email-masked]>>

--

---

From: "Takeshi Takahashi" <[email-masked]>
Date: Thu, 30 Aug 2018 18:54:19 +0900

Hello all,

Thank you very much for your kind feedbacks.
Based on them, the chairs have revised the document.
The attached file is the revision.

We would like to welcome any feedback.
If we hear no objection by September 15th, we would like to submit the revised charter text to our area director.

Thank you, and best regards,
Take

From: mile <[email-masked]> On Behalf Of John Field
Sent: Tuesday, August 21, 2018 3:07 AM
To: Roman Danyliw <[email-masked]>
Cc: MILE IETF <[email-masked]>; Nancy Cam-Winget (ncamwing) <ncamwing=[email-masked]>
Subject: Re: [mile] revising the charter text

John

On Mon, Aug 20, 2018 at 1:08 PM, Roman Danyliw <mailto:[email-masked]> wrote:
Hello!

Roman
 
From: mile [mailto:mailto:[email-masked]] On Behalf Of Nancy Cam-Winget (ncamwing)
Sent: Friday, August 17, 2018 12:26 PM
To: John Field <mailto:[email-masked]>; Banghart, Stephen A. (Fed) <mailto:[email-masked]>

Cc: MILE IETF <mailto:[email-masked]>
Subject: Re: [mile] revising the charter text
 
Hi John,
 
Warm regards, Nancy
From: mile <mailto:[email-masked]> on behalf of John Field <mailto:[email-masked]>
Date: Friday, August 17, 2018 at 07:53
To: "Banghart, Stephen A. (Fed)" <mailto:[email-masked]>
Cc: MILE IETF <mailto:[email-masked]>
Subject: Re: [mile] revising the charter text
 
+1  

John  
 
On Thu, Aug 16, 2018 at 12:25 PM, Banghart, Stephen A. (Fed) <mailto:[email-masked]> wrote:
Nancy, Take,

 
 
-Stephen
 
From: mile <mailto:[email-masked]> On Behalf Of Nancy Cam-Winget (ncamwing)
Sent: Thursday, August 16, 2018 11:29 AM
To: Adam Montville <mailto:[email-masked]>; Kathleen Moriarty <mailto:[email-masked]>

Cc: MILE IETF <mailto:[email-masked]>
Subject: Re: [mile] revising the charter text

Best, Nancy
 
From: mile <mailto:[email-masked]> on behalf of Adam Montville <mailto:[email-masked]>
Date: Thursday, August 16, 2018 at 06:57
To: Kathleen Moriarty <mailto:[email-masked]>
Cc: MILE IETF <mailto:[email-masked]>
Subject: Re: [mile] revising the charter text

Kind regards,
 
Adam
 
On Aug 16, 2018, at 8:41 AM, Kathleen Moriarty <mailto:[email-masked]> wrote:
 
Hello Take, 

 
I think RID is useful as a reference and to incorporate the policy and security aspects at this point rather than actually using it as a transport protocol (it's of course possible, but there are better solutions as RID development started a long time ago)..  It probably doesn't make sense to expand too much that thinking into the charter and the point is hit on in a sentence that remains on it containing policy.  The ability to include courses of actions in RID (I believe that was carried into ROLIE, but am not positive off hand) and some of the other action handling is useful as the requirements development for RID was quite an effort.  In other words, it has a lot of lessons learned so we don't leave something out or unnecessarily reinvent the wheel.  It also handled multi-party authentication and there may be some information gleaned from that work (that had lots of review) to do that in follow on protocols looking for that capability using JOSE or COSE for example.

Best regards,
Kathleen

On Thu, Aug 16, 2018 at 12:11 AM, Takeshi Takahashi <mailto:takeshi_takahashi@nict..go.jp> wrote:
Hi all,

Thanks,
Take

_______________________________________________
mile mailing list
mailto:[email-masked]
https://na01.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fmile&data=02%7C01%7Cstephen.banghart%40nist.gov%7Cceacad5d962848cef62408d6038cfd97%7C2ab5d82fd8fa4797a93e054655c61dec%7C1%7C0%7C636700301416938592&sdata=nxXxCMsm5rl%2FlMw%2FZc8OXNb9I4ZulxwVaFqULA7uyYQ%3D&reserved=0

-- 
 
Best regards,
Kathleen
mailto:[email-masked]

mailto:[email-masked]

-- 
John P. Field | Product Lead - Security and Compliance | Pivotal 
Direct: (908) 962-3394 | mailto:[email-masked]://pivotal.io  

mailto:[email-masked]

-- 
John P. Field | Product Lead - Security and Compliance | Pivotal 
Direct: (908) 962-3394 | mailto:[email-masked]://pivotal.io

---

From: Adam Montville <[email-masked]>
Date: Thu, 30 Aug 2018 07:00:31 -0500

Take, this revision looks great, thank you.

Kind regards,

Adam

> On Aug 30, 2018, at 4:54 AM, Takeshi Takahashi <[email-masked]> wrote:
> 
> Hello all,
> 
> ....and good to see the mention of STIX as potentially in scope for future work.
> 
> John  
> 
> <MILEcharterv4.docx>_______________________________________________
> mile mailing list
> [email-masked]