Subject: [Mip4] Re: FW: Comments on VPN Problem Statement Draft

From: Henrik Levkowetz <[email-masked]>
Date: Tue, 26 Aug 2003 12:15:06 +0200

Hi,

<co_chair_hat>

	I'm picking up this thread and putting it onto the main mip4 list.
Please remove the mip-vpn design team list address from future replies.

I would like to see this draft sent up to the IESG for consideration
ASAP. In case we get (unexpected) pushback, it would be good to get it
before the solutions draft is complete...

Please respond to Farid's query below, so we can wrap this up. If any
other minor adjustments are needed as a result of the WG last call, I'd
like them done and an updated draft out soon; at which point we will
send it to the ADs. If there are no adjustments to be done, we'll send
up the current draft ( -03 ).

Let's get's this one shipped, shall we?

</co_chair_hat>

<wg_member_hat>

As Section 2 of the draft explicitly discusses possible placements of HA
vs. VPN-GW, and (as we discussed in the design team) the co-location of
an FA with the VPN-GW is a possible optimization feature of a solution
to the problems posed, rather than a separate problem scenario, my
viewpoint is that we should not put this in the problem statement draft.

It should be described properly in a vpn-traversal optimization draft,
though.

</wg_member_hat>

	Regards,
		Henrik

On Tuesday, 12 Aug 2003, Farid wrote:
> Hello All,
> What do you think about Jayshree's request to add a new scenario to
> the problem statement draft?  
> BR,
> Farid
> 
> -----Original Message-----
> From: Jayshree Bharatia [mailto:[email-masked]] 
> Sent: Wednesday, August 06, 2003 12:13 PM
> To: Adrangi, Farid
> Cc: [email-masked]
> Subject: RE: Comments on VPN Problem Statement Draft
> 
> Hello Farid,
> 
> Please see my reply below.
> 
> Thanks,
> Jayshree
> -----Original Message-----
> From: Adrangi, Farid [mailto:[email-masked]] 
> Sent: Sunday, August 03, 2003 11:50 PM
> To: Bharatia, Jayshree [RICH1:2H13:EXCH]
> Cc: [email-masked]
> Subject: RE: Comments on VPN Problem Statement Draft
> 
> 
> > Hello Jayshree,
> > Thanks for following up on this.  You, Gopal, and I had a very brief
> > conversation on this during IETF-57 - but I am not sure if we
> > derived any conclusion on whether or not we should include this
> > scenario.  To be frank, I don't quite understand the point behind
> > adding this scenario because,
> > -       It seems to present a solution to a specific deployment
> > model rather than a deployment scenario 
> 
> [JB] My understanding is different from yours so please elaborate what
> you mean by deployment model vs deployment scenario in this particular
> context.
> 
> > -       I don't quite see the advantages of  a combined VPN+FA if it
> > does not support FA traversal and it does not avoid IPsec
> > renegotiation when MN moves from one subnet to another - perhaps you
> > can elaborate on this?
> 
> [JB] I think regardless this scenario has any advantages or not, it is
> one of the probable scenario which has potential issues (as you have
> indicated earlier). 
> 
> > -       Furthermore, Scenarios in section 2 of the problem statement
> > draft represents combinations of MIPv4 HA and VPN gateway placement
> > - adding this scenario is going to change semantics of the section
> > 2.
> 
> [JB] I am not sure what you mean by semantics change here. Do you
> think documenting this in new subsection (2.6) is a problem?
> 
> > I have no problem adding this scenario to the draft - I just wanted
> > to make sure that we clearly understand the reasons for adding this
> > scenario to the problem statement draft.  Design team members and
> > interested individuals are welcome to express their opinion on this.
> >  
> > 
> > Best regards,
> > Farid
> 
> 
> 
>  
>  
>  The   following   sub-sections   introduce   five   representative
>    combinations of MIPv4 HA and VPN gateway placement.
> 
> -----Original Message-----
> From: Jayshree Bharatia [mailto:[email-masked]] 
> Sent: Thursday, July 31, 2003 1:44 PM
> To: Adrangi, Farid
> Cc: [email-masked]'
> Subject: RE: Comments on VPN Problem Statement Draft
> 
> Hello Farid,
> 
> As per our earlier discussion during IETF-57, my understanding is that
> you will include the scenario of co-existed FA with the VPN gateway in
> the VPN Problem Statement draft.
> 
> I agree that this particular scenario has problems and it won't work
> if the MN is behind an FA in the foreign subnet. But again, this is a
> problem statement draft. Hence, I believe that this is the appropriate
> document for
> mentioning this scenario.
> 
> Thanks,
> Jayshree
> 
> -----Original Message-----
> From: Adrangi, Farid [mailto:[email-masked]] 
> Sent: Monday, April 07, 2003 2:58 PM
> To: Bharatia, Jayshree [RICH1:2H13:EXCH]
> Cc: [email-masked]'
> Subject: RE: Comments on VPN Problem Statement Draft
> Hello Jayshree
> This is a good point - I knew someone was to bring this up!  At the
> time of writing these scenarios, we (the design team) actually
> discussed this and concluded this scenario would fall into a solution
> space.  Maybe we did not make the right decision and we should rethink
> this.  But, before we take this discussion further please allow me to
> ask you a few questions about the details of the scenario (VPN+FA)
> that you have in mind .  Are you thinking to broadcast FA
> advertisements through the IPsec tunnel to the MN?  If so, how will
> this work if MN is already behind an FA in the foreign subnet? Or, If
> you had something different in mind, perhaps you can elaborate on
> that. Best regards,
> Farid
> 
> 
> -----Original Message-----
> From: Jayshree Bharatia [mailto:[email-masked]],
> Sent: Friday, April 04, 2003 3:14 PM
> To: [email-masked]'
> Cc: [email-masked]'
> Subject: Comments on VPN Problem Statement Draft
> 
> Hello Farid, 
> This draft (draft-ietf-mobileip-vpn-problem-statement-req-01)
> currently misses one scenario were the FA is co-existed with the VPN
> Gateway. I would think that there are no technical issues supporting
> this scenario. It will be good if you can add this scenario in the
> draft (perhaps as section 2.6?) for completeness.
> Thanks, 
> Jayshree 
> 

_______________________________________________
Mip4 mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/mip4

---

From: Gopal Dommety <[email-masked]>
Date: Wed, 27 Aug 2003 16:16:03 -0700

Farid and Henrik,

It would make sense to  add the scenario that jayshree was bringing 
up.   This was what I was bringing up during the initial discussion.

-Gopal

---

From: Gopal Dommety <[email-masked]>
Date: Wed, 27 Aug 2003 16:18:02 -0700

Henrik,

We should ship this with the added scenario. Do we have an agreement to add 
the scenario.

-Gopal

---

From: Henrik Levkowetz <[email-masked]>
Date: Thu, 28 Aug 2003 10:23:59 +0200

Hi Gopal,

So you see this scenario as one of the possible problem scenarios we
potentially would need to solve?

	Henrik

---

From: Henrik Levkowetz <[email-masked]>
Date: Thu, 28 Aug 2003 10:35:53 +0200

The way I tally it, we currently have 2 for (Jayshree, Gopal), 2 against
(Farid, Henrik) which makes it neither here nor there as far as rough
consensus goes. We'll have to get some more feedback on this before moving
on, either way.  Dorothy? Sami? Espen? Milind? Nitsan? Qiang? Others?
Please comment.

	Regards,
		Henrik

---

From: Henrik Levkowetz <[email-masked]>
Date: Thu, 28 Aug 2003 19:30:22 +0200

But the way I understand it, this scenario is not a problem, but rather
a component in one of the possible (optimized) solutions, which is why 
it doesn't quite make sense to me to put it in the problem statement ?

	Henrik

Thursday 28 August 2003, Gopal wrote:
> 
> My recommendation is to documet the sceanrio and not to solve it.
> 
> 
> At 10:35 AM 8/28/2003 +0200, Henrik Levkowetz wrote:

---

From: Gopal Dommety <[email-masked]>
Date: Thu, 28 Aug 2003 09:44:35 -0700

Henrik,

No!!! My recommendation is to document the scenario and state that we are 
not focus on it currently.
  I think documenting completes the scenarios. I think there will be a lot 
of issues to solve for this scenario.

Cheers
Gopal

---

From: Gopal Dommety <[email-masked]>
Date: Thu, 28 Aug 2003 09:45:12 -0700

---

From: "Qiang Zhang" <[email-masked]>
Date: Thu, 28 Aug 2003 13:33:07 -0400

Figure 10 in the Section 4 of problem statement actually presented the
scenario. I think it is reasonable to add a 2.6 to make this scenario
explicit thus to "complete" as Gopal mentioned.

Q

----- Original Message -----
From: "Gopal Dommety" <[email-masked]>
To: "Henrik Levkowetz" <[email-masked]>
Cc: <[email-masked]>; <[email-masked]>; "Adrangi, Farid"
<[email-masked]>
Sent: Thursday, August 28, 2003 12:44 PM
Subject: Re: [Mip4] Re: FW: Comments on VPN Problem Statement Draft