Subject: [Mip4] RE: [mobile-ip] New issue: 3012bis challenges in solicited agent advertisements

From: "Ahmad Muhanna" <[email-masked]>
Date: Wed, 6 Aug 2003 12:26:40 -0500

Hi Henrik,
Comments inline.

Regards,
Ahmad

> 
> Well, the thing is, there are implementations out there which 
> does not return a new challenge with all registration 
> replies. If we wish to arrange for better interoperability, 
> it doesn't really matter if we feel they are wrong in not 
> following the SHOULD, but rather that we decide what is the 
> behaviour needed for consistent interoperability, and require 
> that, no?
> 

OK. I understand BUT you are proposing a change anyway.
Why not proposing that those products follow the best recommendation of the
standard
And start including a fresh new challenge in RRP messages. 
This will solve the interoperability issue.

> 	Henrik

---

From: Henrik Levkowetz <[email-masked]>
Date: Wed, 6 Aug 2003 19:38:30 +0200

Hi Ahmad,

	I believe that if we want to ensure a certain implementation, the
correct way is to have the RFC text express what we want, rather than to
try to convince equipment manufacturers that a certain "SHOULD" in
practice should be read as a "MUST". In fact, I think that if I tried to
say something like that to them, they would be in their full right to
tell me to 'go and re-read the RFC, see, it actually says "SHOULD"'.
So if we agree on how to implement this, we need to have the RFC express
it. Of course, if we don't agree, then we instead need to re-examine the
issue on those grounds.

	Henrik

> This will solve the interoperability issue.

_______________________________________________
Mip4 mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/mip4