Subject: RE: [Mip4] RFC3012bis - Issue2-Change1

From: "Jayshree Bharatia" <[email-masked]>
Date: Wed, 8 Oct 2003 13:15:09 -0500

My response inline...

> -----Original Message-----
> From: Henrik Levkowetz [mailto:[email-masked]] 
> Sent: Wednesday, October 08, 2003 11:26 AM
> To: Bharatia, Jayshree [RICH1:2H13:EXCH]
> Cc: [email-masked]'
> Subject: Re: [Mip4] RFC3012bis - Issue2-Change1
> 
> 
> Hi Jayshree,
> 
> This looks pretty good, some minor proposed changes inline:
> 
> On Wednesday,  1 Oct 2003, Jayshree wrote:
> 
> > To:
> > The Foreign Agent SHOULD include a previously unused challenge
> "unused challenge" ==> "unused"
> 
> > Mobile-Foreign Challenge Extension in any Registration 
> Reply, successful or
> > not.  If the foreign agent includes this extension in a successful
> > Registration Reply, the extension SHOULD precede a Mobile-Foreign
> > authentication extension.  Suppose the Registration Reply includes a
> > Challenge extension from the Home Agent, and the foreign 
> agent wishes to
> > include another Challenge extension with the Registration 
> Reply for use by
> > the mobile node.  In that case, the foreign agent MUST 
> delete the Challenge
> > extension from the Home Agent from the Registration Reply, 
> along with any
> > Foreign-Home authentication extension, before appending the 
> new Challenge
> > extension to the Registration Reply. 
> > 
> > One example of a situation where the Foreign Agent MAY omit 
> the inclusion of
> > a Mobile-Foreign Challenge Extension in the Registration 
> Reply would be when
> > a new challenge has been multicast recently. 
> 
> In the original text proposal on the list, this paragraph 
> continued with:
>  "The Foreign Agent could then assume that the mobile node with high
>   likelihood has received and can use the multicast challenge."
> Unless there was some specific objection to this, I think it'd be good
> to keep this text, too.
[JB] According to email conversation I had with Pete on the mailing list
(Sept 03), we agreed that the above text doesn't provide any additional
normative information and hence agreed to remove it. 

> 
> > If a foreign agent has conditions in which it omits the 
> inclusion of a
> > Mobile-Foreign Challenge Extension in the Registration 
> Reply, it still MUST
> > respond with an agent advertisement containing a previously 
> unused challenge
> > in response to a subsequent agent solicitation from the 
> same mobile node.
> > Otherwise (when the said conditions are not met) the 
> foreign agent MUST
> > include a previously unused challenge in any Registration 
> Reply, successful
> > or not.
> >   
> > A mobile node MUST be prepared to use a challenge from a unicast or
> > multicast Agent Advertisement in lieu of one returned in a 
> Registration
> > Reply, and MUST solicit for one if it has not already 
> received one in a
> > Registration Reply.
> 
> Right.
> 

-- 
Mip4 mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/mip4

---

From: Henrik Levkowetz <[email-masked]>
Date: Wed, 8 Oct 2003 20:57:56 +0200

> normative information and hence agreed to remove it. 

Youre right, it doesn't provede normative information; but I think it
does make the section more understandable. But if you and Pete both find
the text better without it, go ahead.

	Henrik