Subject: [Mip4] review of draft-nakhjiri-radius-mip4-01.txt

From: Jari Arkko <[email-masked]>
Date: Tue, 23 Aug 2005 17:35:26 +0300

I read this draft. In general, it seems very useful to
document & standardize the aaa-side of the mobile ipv4
authentication protocols. (Would there be commitment
from pp2 to take this?)

I don't have a lot of comments, it seems pretty straightforward
given the things that we've already defined in other specifications.
I wish the Diameter - RADIUS translation was easier or even
automatic, but I don't see other way around this given that
RFC 4004 was already published.

Some technical comments:

Section 5 description of attributes that already exist
was confusing. Suggest splitting section 5 to new
attributes and instruction for the use of old attributes
parts.

Section 6 needs more details. Maybe ok for an -01, though.

Presumably this draft is still structurally and key-wise
the same as RFC 4004? If no, that would make the
implementation of a RADIUS-Diameter gateway even
harder.

Some editorial nits:

>    The HA may reside in the mobile nodeÆs home domain, in which case HA 

Non-ASCII char. In several places, applies to double quotes
too.

>    [DIAMIP] P. Calhoun, C. Perkins, ææDiameter Mobile IP applicationÆÆ,
>    IETF work in progress, draft-ietf-aaa-diameter-mobileip-18.txt, May
>    2004.

RFC 4004 now.

>    MIP-answer (HMA). RADIUS currently does not any messages that 

s/does not any/does not have any/

--Jari

-- 
Mip4 mailing list: [email-masked]
    Web interface: https://www1.ietf.org/mailman/listinfo/mip4
     Charter page: http://www.ietf.org/html.charters/mip4-charter.html
Supplemental site: http://www.mip4.org/

---

From: "Kent Leung \(kleung\)" <[email-masked]>
Date: Tue, 23 Aug 2005 11:08:16 -0700

Hi Jari. 

> authentication protocols. (Would there be commitment from pp2 
> to take this?)
> 

This draft is not specific to 3GPP2.  In fact, many non-3GPP2 Mobile IP
deployments today use Cisco vendor specific attributes due to lack of
standardized AVPs.  So it has general applicability.  Definitely 3GPP2
can leverage these new AVPs in the next revision for reference if they
like to.

Kent

---

From: "Avi Lior" <[email-masked]>
Date: Tue, 23 Aug 2005 15:49:06 -0400

FYI: We are considering this for WiMAX. 

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On 
> Behalf Of Kent Leung (kleung)
> Sent: Tuesday, August 23, 2005 2:08 PM
> To: Jari Arkko; [email-masked]
> Subject: RE: [Mip4] review of draft-nakhjiri-radius-mip4-01.txt
> 
> Hi Jari. 
> 
> > I read this draft. In general, it seems very useful to document & 
> > standardize the aaa-side of the mobile ipv4 authentication 
> protocols. 
> > (Would there be commitment from pp2 to take this?)
> > 
> 
> This draft is not specific to 3GPP2.  In fact, many non-3GPP2 
> Mobile IP deployments today use Cisco vendor specific 
> attributes due to lack of standardized AVPs.  So it has 
> general applicability.  Definitely 3GPP2 can leverage these 
> new AVPs in the next revision for reference if they like to.
> 
> Kent
> 
> --