Subject: RE: [Mip4] ARP with MIPv4

From: [email-masked]
Date: Tue, 20 Sep 2005 14:56:24 -0700

> > can someone please explain why a MN is not allowed to send an ARP 
> > Request containing its HoA on a foreign link?
> 
> I think in the case of FA CoA mode, the only way for MN to 
> talk to FA is  for MN to use its HoA on the foreign link, 
> which means MN does use ARP with respect to its HoA, and on 
> the foreign link.
> 

I disagree.  MN can talk with FA without using ARP.

Other comments in next followup email.

Kent

-- 
Mip4 mailing list: [email-masked]
    Web interface: https://www1.ietf.org/mailman/listinfo/mip4
     Charter page: http://www.ietf.org/html.charters/mip4-charter.html
Supplemental site: http://www.mip4.org/

---

From: [email-masked]
Date: Tue, 20 Sep 2005 15:00:15 -0700

ARPing is bad for a few reasons:

1) MN that sends ARP request will likely get an proxy ARP response from
the FA or router, which means when it gets back to the home network, the
ARP cache is invalid.

2) The ARP request/reply can confused other nodes on the foreign network
which may update its ARP cache (implementation dependent and in private
address case).

There's no reason to ARP as the communication is between MN and FA or
default gateway.

On the topic of private address support, FA should be able to
differentiate the MNs at the L2 address/link.  This was covered in RFC
3024 appendix.

Kent 

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On 
> Behalf Of Alexandru Petrescu
> Sent: Tuesday, September 20, 2005 8:58 AM
> To: [email-masked]
> Cc: [email-masked]; Alexandru Petrescu
> Subject: Re: [Mip4] ARP with MIPv4
> 
> [email-masked] wrote:
> 
> > Hi Alexandru,
> > 
> > thanks for your detailed answer. See some clarifications of 
> my initial 
> > question below.
> > 
> > RFC 3344 states: ---------------- While the mobile node is 
> away from  
> > home, it MUST NOT transmit any broadcast ARP Request or ARP Reply 
> > messages.  Finally, while the mobile node is away from 
> home, it MUST  
> > NOT reply to ARP Requests in which the target IP address is 
> its own  
> > home address, unless the ARP Request is unicast by a foreign agent 
> > with which the mobile node is attempting to register or a foreign 
> > agent with which the mobile node has an unexpired registration.
> > ---------------- So my question was "Why is a MN *not* allowed to 
> > transmit any broadcast ARP Request or ARP Reply messages while away 
> > from home?"
> 
> Sorry, it seems I'm once again revolving around some 
> confusion.  I guess the RFC contributors' intention was to 
> avoid that Home Address-MAC Address pairs get into the ARP 
> tables of any nodes other than FA present on the FA wireless 
> link.  Which is a good thing in a way (nodes under FA won't 
> fill ARP tables with Home Addresses intrinsically not 
> topological correct at that place) and less good in other ways (e.g.
> MN-to-MN packets under same FA must get through that FA, 
> while optimally they'd be direct).
> 
> >> There may be a risk of address collision when two Mobile Nodes of 
> >> different HAs have the same home address from the private space
> >> (10.x.x.x) and visit the same FA.
> > 
> > 
> > Let's call the two MNs A and B. If a third node C (of the 
> same network 
> > as B) attaches to the same FA (where A and B are already 
> attached to), 
> > a broadcast ARP Request of A would in general make C update its ARP 
> > cache to (IP@ of B, L2@ of A). Thus, when C returns to  its home 
> > network, it would not be able to send packets to B until 
> the ARP cache 
> > entry expires.
> > 
> > So is this *the* reason why a MN is not allowed to transmit 
> broadcast  
> > ARP Request or ARP Reply messages while away from home?
> 
> I guess so, yes, in some way that may be the reason why MN 
> not allowed to broadcast Requests or Replies.
> 
> However I think that _if_ private Home Addresses are used the 
> ARP behaviour as specified by 3344 still can't deal with the 
> fact that FA itself may become confused by two different MNs 
> having same Home Address on its wireless link and two 
> different MAC addresses.
> 
> Whether this is an issue in practice is another matter.  
> Probably Mobile
> IPv4 is deployed within a single closed system where a unique 
> authority assigns Home Addresses to all MNs and makes sure 
> they're unique.  Within this closed system the FA won't 
> accept the visit of other MNs of other systems, because 
> probably they don't have the right keys.
> 
> If however this becomes an issue in practice then maybe the 
> FA could use the visitor list info to distinguish between two 
> colliding Home Addresses of MNs on its "mobility" link.
> 
> Alex
> 
> 
> --