Subject: RE: [Mip4] Subnet mask in MIPv4

From: [email-masked]
Date: Tue, 20 Sep 2005 15:02:35 -0700

Reference to some open source Mobile Node software would give some
insight. :)

Kent 

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On 
> Behalf Of [email-masked]
> Sent: Tuesday, September 20, 2005 2:27 AM
> To: [email-masked]
> Subject: [Mip4] Subnet mask in MIPv4
> 
> Hi all,
> 
> let's assume a MN with one interface (I1). I1 is assigned the 
> MN HoA and the subnet mask of the MN's home network.
> 
> Let's further assume that the MN contains only one routing 
> table entry.
> That entry looks something like "0.0.0.0   GW   I1".
> 
> As far as I know, there is a requirement that the IP address 
> assigned to
> I1 (here MN HoA) and the IP address of the GW associated with 
> I1 in the routing table must lie in the same subnet indicated 
> by the subnet mask assigned to I1.
> 
> When the MN now moves to a foreign link and acquires a FA 
> CoA, the default GW is in general set to the FA CoA. However, 
> what is done with the subnet mask? Is it set to /0 in order 
> to meet the requirement?
> 
> Kind regards,
> 
> Rajendra
> 
> --
> Mip4 mailing list: [email-masked]
>     Web interface: https://www1.ietf.org/mailman/listinfo/mip4
>      Charter page: http://www.ietf.org/html.charters/mip4-charter.html
> Supplemental site: http://www.mip4.org/
> 

-- 
Mip4 mailing list: [email-masked]
    Web interface: https://www1.ietf.org/mailman/listinfo/mip4
     Charter page: http://www.ietf.org/html.charters/mip4-charter.html
Supplemental site: http://www.mip4.org/

---

From: "Qiang Zhang/Aber" <[email-masked]>
Date: Wed, 21 Sep 2005 10:15:43 -0400

On the MN--FA interface, ideally it should be using Link Layer addressing.
There are various hacks to implement this and they are different on
platforms, also depends on you are using a bump-in-stack or a virtual
interface...
----- Original Message ----- 
From: <[email-masked]>
To: <[email-masked]>; <[email-masked]>
Sent: Tuesday, September 20, 2005 6:02 PM
Subject: RE: [Mip4] Subnet mask in MIPv4

Kent