Subject: [Mip4] RE: Comments for your draft "draft-leung-mip4-proxy-mode-00.txt"

From: "Kent Leung \(kleung\)" <[email-masked]>
Date: Tue, 30 May 2006 23:03:08 -0700

Hi Lai.

> -----Original Message-----
> From: LAI OWEN [mailto:[email-masked]] 
> Sent: Tuesday, May 30, 2006 10:30 PM
> To: Kent Leung (kleung)
> Cc: [email-masked]
> Subject: Comments for your draft "draft-leung-mip4-proxy-mode-00.txt"
> 
> Dear Kent,
> 
> I read your draft "draft-leung-mip4-proxy-mode-00.txt", and 
> have some comments for it.
> 
> 1. How does MS get HoA? From local AAA in access network? or 
> From AAA in the home network?
> 

HoA is either manually configured or obtained via DHCP.

> 2. How can MS maintain its HoA after moving from one MPA to 
> another MPA? There is no mechanism for IP address continuity.
> 

MS maintains the same HoA when moving between MPAs.  There are various
methods how this can be accomplished (e.g. IP address or MAC address
detection).

Kent 

> If the IP address of MS changes everytime after handover, 
> then there should no IP session continuity betwwen MS and CN.
> 
> Regards,
> 
> Lai
> 

-- 
Mip4 mailing list: [email-masked]
    Web interface: https://www1.ietf.org/mailman/listinfo/mip4
     Charter page: http://www.ietf.org/html.charters/mip4-charter.html
Supplemental site: http://www.mip4.org/

---

From: Owen.Lai <[email-masked]>
Date: Wed, 31 May 2006 14:21:44 +0800

Thanks for your quick reply,

> HoA is either manually configured or obtained via DHCP.
1) if manual configured, is this address global or private IPv4 address?
2) if through dhcp assignment, when MS roam from MPA1 to MPA2
will MS get same IP address from same DHCP server.
3) is there only 1 dhcp server in 1 HA domain.

> methods how this can be accomplished (e.g. IP address or MAC address
Do you mean MS use IP address or MAC address as an Identifier (e.g.
NAI)  to get the same address after moving to new MPA?