Subject: RE: [Mip4] Issue with 3344bis

From: "Avi Lior" <[email-masked]>
Date: Thu, 1 Jun 2006 22:12:05 -0400

Hi ViJay,

Sorry but I don't think I agree with the MUST.  If I have a method for
bootstrapping MN-HA why MUST the MN be configured with an MN-HA?

I think we can come up with some text without specifically making a
reference to 4433 and 3957.

The problem is that the "MUST" requires that I configure at least one
MN-HA  to be compliant with 3344. 

> -----Original Message-----
> From: Vijay Devarapalli [mailto:[email-masked]] 
> Sent: Thursday, June 01, 2006 6:06 PM
> To: Avi Lior
> Cc: Mobile IPv4 Mailing List
> Subject: Re: [Mip4] Issue with 3344bis
> 
> Avi Lior wrote:
> >  
> > Sorry for the lateness of this comment...
> > 
> >  Section 3.6
> >   
> >  "A mobile node MUST be configured with a netmask and a mobility
> >     security association for each of its home agents."
> >   
> >  This seems to be a bad thing if we are talking about roaming and 
> > dynamic HA assignement.
> >   
> 
> I think this is ok. as far as 3344bis is concerned, at least 
> the netmask for the home link and a mobility security 
> association is required for the protocol to work. later 
> specifications talk about how the protocol in 3344bis would 
> work without having to pre-configere a netmask (RFC4433), or 
> without having to pre-configure a mobility security 
> association (for e.g. RFC 3957).
> 
> since there is a plan to advance 3344bis to draft standard we 
> don't want normative references to RFC 4433 or RFC 3957.
> 
> Vijay
> 

-- 
Mip4 mailing list: [email-masked]
    Web interface: https://www1.ietf.org/mailman/listinfo/mip4
     Charter page: http://www.ietf.org/html.charters/mip4-charter.html
Supplemental site: http://www.mip4.org/

---

From: Vijay Devarapalli <[email-masked]>
Date: Thu, 01 Jun 2006 19:50:57 -0700

> MN-HA  to be compliant with 3344. 

I don't see it that way. 3344bis says there MUST be a security
association between the MN and the HA for the protocol to work.
Since it does not specify a way to dynamically configure a
security association it *has* to say that a security association
MUST be configured on the MN. otherwise it cannot be standardized.

I think the MUST is needed in the spec.

perhaps we could add the following at the end of the paragraph.

   Future specifications may define mechanisms to dynamically
   assign a home agent to a mobile node and setup a mobility
   security association between them. In this case, the mobile
   node need not be manually configured with a netmask or a
   mobility security association with its home agent.

Vijay