Subject: [Mip4] Comments on draft-ietf-mip4-gen-ext-00.txt

From: Vijay Devarapalli <[email-masked]>
Date: Thu, 08 Jun 2006 14:20:32 -0700

hello,

I am curious about draft-ietf-mip4-gen-ext-00.txt. I can
see this mechanism being used when the mobile node wants
to get DNS/DHCP information from the home link. but from
a visited link, why would the FA send this information
through a registration reply? wouldn't it be better to
use agent advertisement? the mobile node might need the
DNS information even before it sends a registration
request. also the mechanism described here does not work
if the mobile node is using co-located CoA and wants
DNS/DHCP information from the visited link.

I wasn't involved in the earlier discussions of this
draft. so I might not be aware of certain things.

Vijay

-- 
Mip4 mailing list: [email-masked]
    Web interface: https://www1.ietf.org/mailman/listinfo/mip4
     Charter page: http://www.ietf.org/html.charters/mip4-charter.html
Supplemental site: http://www.mip4.org/

---

From: "Jayshree Bharatia" <[email-masked]>
Date: Fri, 9 Jun 2006 12:29:56 -0500

Hi Vijay,

Thanks for reviewing this draft. 

We have debated this point of supporting FA option earlier and I guess
it was brought up as a one of the open issue in one of the WG meeting.
Some of us like to see this option so that information like SIP server
address (resided in the visited network) can be exchanged. This
information is currently exchanged using specific link layer protocols
today. By having this mechanism makes the solution independent of link
layer hooks. 

You are right that information from the visited link for co-located CoA
is not possible. We will add this to our draft.

Thanks,
Jayshree
-----Original Message-----
From: Vijay Devarapalli [mailto:[email-masked]] 
Sent: Thursday, June 08, 2006 4:21 PM
To: [email-masked]
Subject: [Mip4] Comments on draft-ietf-mip4-gen-ext-00.txt

hello,

Vijay

---

From: Vijay Devarapalli <[email-masked]>
Date: Fri, 09 Jun 2006 12:53:24 -0700

> Thanks for reviewing this draft. 

it was more of a quick glance. :)

> address (resided in the visited network) can be exchanged. 

the SIP folks have specified a number of options
to discover the SIP proxy address from the visited
network.

> This

ok.

Vijay