Subject: RE: [Mip4] Issue with 3344bis

From: "Avi Lior" <[email-masked]>
Date: Fri, 2 Jun 2006 01:17:38 -0400

ViJay,

My original emails suggested that perhaps we say:

Instead it should say that it MAY be configured with .....
  
 or MUST be configurable with....

Either of those cases support the manual or static configuration and
also the Dynamic configuration.

The current wording only allows for static configuration of the MN-HA.

I agree with Vidya about the comments regarding your additional text.
It is not necessary. 

> -----Original Message-----
> From: Narayanan, Vidya [mailto:[email-masked]] 
> Sent: Friday, June 02, 2006 12:15 AM
> To: Vijay Devarapalli; Avi Lior
> Cc: Mobile IPv4 Mailing List
> Subject: RE: [Mip4] Issue with 3344bis
> 
> 
> > 
> > Avi Lior wrote:
> > > Hi ViJay,
> > > 
> > > Sorry but I don't think I agree with the MUST.  If I have a
> > method for
> > > bootstrapping MN-HA why MUST the MN be configured with an MN-HA?
> > > 
> > > I think we can come up with some text without 
> specifically making a 
> > > reference to 4433 and 3957.
> > > 
> > > The problem is that the "MUST" requires that I configure at
> > least one
> > > MN-HA  to be compliant with 3344.
> > 
> > I don't see it that way. 3344bis says there MUST be a security 
> > association between the MN and the HA for the protocol to work.
> > Since it does not specify a way to dynamically configure a security 
> > association it *has* to say that a security association MUST be 
> > configured on the MN. otherwise it cannot be standardized.
> > 
> 
> I agree with Avi on this. I don't see why there needs to be a 
> MUST on this one. If you say that an MN-HA SA MUST be 
> available to secure the RRQ/RRP, that makes sense - it does 
> not make sense to say that this MUST be "configured" per say. 
> 
> > I think the MUST is needed in the spec.
> > 
> > perhaps we could add the following at the end of the paragraph.
> > 
> >    Future specifications may define mechanisms to dynamically
> >    assign a home agent to a mobile node and setup a mobility
> >    security association between them. In this case, the mobile
> >    node need not be manually configured with a netmask or a
> >    mobility security association with its home agent.
> > 
> 
> But, we already have specifications that define this :) So, 
> to keep our eyes closed to the fact that we already have ways 
> of getting away from manual configuration does not seem to 
> make sense to me. 
> 
> If you want to say that in the absence of a dynamic mechanism 
> to acquire an MN-HA SA, it MUST be configured on the MN, that 
> would be fine. 
> 
> Vidya
> 
> > Vijay
> > 
> > > 
> > >> -----Original Message-----
> > >> From: Vijay Devarapalli [mailto:[email-masked]]
> > >> Sent: Thursday, June 01, 2006 6:06 PM
> > >> To: Avi Lior
> > >> Cc: Mobile IPv4 Mailing List
> > >> Subject: Re: [Mip4] Issue with 3344bis
> > >>
> > >> Avi Lior wrote:
> > >>>  
> > >>> Sorry for the lateness of this comment...
> > >>>
> > >>>  Section 3.6
> > >>>   
> > >>>  "A mobile node MUST be configured with a netmask and a mobility
> > >>>     security association for each of its home agents."
> > >>>   
> > >>>  This seems to be a bad thing if we are talking about 
> roaming and 
> > >>> dynamic HA assignement.
> > >>>   
> > >> I think this is ok. as far as 3344bis is concerned, at least the 
> > >> netmask for the home link and a mobility security association is 
> > >> required for the protocol to work. later specifications 
> talk about 
> > >> how the protocol in 3344bis would work without having to 
> > >> pre-configere a netmask (RFC4433), or without having to
> > pre-configure
> > >> a mobility security association (for e.g. RFC 3957).
> > >>
> > >> since there is a plan to advance 3344bis to draft standard
> > we don't
> > >> want normative references to RFC 4433 or RFC 3957.
> > >>
> > >> Vijay
> > >>
> > 
> > 
> > --
> > Mip4 mailing list: [email-masked]
> >     Web interface: https://www1.ietf.org/mailman/listinfo/mip4
> >      Charter page: 
> http://www.ietf.org/html.charters/mip4-charter.html
> > Supplemental site: http://www.mip4.org/
> > 
> 

-- 
Mip4 mailing list: [email-masked]
    Web interface: https://www1.ietf.org/mailman/listinfo/mip4
     Charter page: http://www.ietf.org/html.charters/mip4-charter.html
Supplemental site: http://www.mip4.org/

---

From: Vijay Devarapalli <[email-masked]>
Date: Fri, 02 Jun 2006 10:30:51 -0700

> Instead it should say that it MAY be configured with .....

for the HA discovery mechanism described in section
3.6.1.2 to work, the mobile node must be configured
with the netmask. so a MAY wouldn't work.

>  or MUST be configurable with....

thats obvious. a mobile node must be configurable.

Vijay