Subject: [Mip4] WGLC: draft-ietf-mip4-gen-ext-00.txt

From: "McCann Peter-A001034" <[email-masked]>
Date: Thu, 19 Oct 2006 17:13:04 -0400

This message announces a WG last call on:

   "MIPv4 Extension for Configuration Options Exchange"
   draft-ietf-mip4-gen-ext-00.txt

The last call will conclude at 24:00 UTC on Friday, 3 November 2006.

"MIPv4 Extension for Configuration Options Exchange" describes new
Mobile IPv4 extensions for carrying configuration information, where
the information is formatted according to existing DHCP configuration
options.

A URL for this internet draft is:

http://www.ietf.org/internet-drafts/draft-ietf-mip4-gen-ext-00.txt

Please respond to this WG last call:

* If you have no comments on the draft, and support its advancement,
  simply respond with a line containing something like

   "I support the advancement of this document to the IESG with a
    request for publication as proposed standard."

  If you have comments, please use a line similar to the one above, and
  supplement this with your comments.

* If you *don't* support its advancement, respond with a line containing
  something like the following, supplemented by your comments -

   "I don't support the advancement of this document to the IESG with
    a request for publication as proposed standard, for the following
    reasons:"
   ...

    Pete & Henrik

-- 
Mip4 mailing list: [email-masked]
    Web interface: https://www1.ietf.org/mailman/listinfo/mip4
     Charter page: http://www.ietf.org/html.charters/mip4-charter.html
Supplemental site: http://www.mip4.org/

---

From: Vijay Devarapalli <[email-masked]>
Date: Wed, 25 Oct 2006 19:06:48 -0700

this document needs some work before it can be sent
to the IESG.

at a high level we need to say that this document
defines a new configuration options exchange
extension, but we just use the extension to carry
the DHCP and BOOTP options as defined in RFC 2132.

the security considerations section needs some
serious consideration. :)

some specific comments.

>    This document describes the mechanism for providing the host
>    configuration information during Mobile IP registration.  

perhaps mention here that this is primarily for home
link information. for configuration information on
the visited link, you are better off using DHCP on
the visited link.

>    One or more
>    Configuration Options Exchange Extensions may be included in the
>    registration message to provide the Mobile Node the configuration
>    parameters needed for network service usage (e.g.  DNS).

what is "network service usage"? network access?

> 1.  Introduction
> 
>    Mobile IPv4 lacks the capability to dynamically configure the
>    interface parameters (e.g. home subnet mask) and network service
>    elements (e.g.  DNS servers) on the Mobile Node.  These information

s/these/this

>    There are possible
>    ways to deliver foreign network's configuration information to the
>    Mobile Node, but there is no method for the home network (where the
>    Mobile Node is logically anchored) to provide these parameters.

suggest re-wording to

   There are mechanisms such as DHCP for the mobile node to
   configure information from the foreign network, but not
   from the home network when the mobile node is not attached
   to the home network.

>    To configure the Mobile Node with the configuration parameters at the
>    time of MIPv4 registration an extension should be defined to carry
>    such information.  This document defines this MIPv4 extension.

suggest re-wording to

   This document defines a new extension that can be used to
   carry configuration parameters during Mobile IPv4
   registration.

> 2.  Configuration Options Exchange Extension
> 
>    The Mobile IPv4 extension has the format shown in this section to
>    carry configuration information.  This extension MAY be included as a
>    part of Mobile IP Registration Request or Registration Reply.
> 
>    0                   1                   2                   3
>    0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1
>    +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
>    |     Type      |    Length     | Entity-Type   |   Sub-Type    |
>    +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
>    |   Config-Data
>    +-+-+-+-+-+-...
> 
> 
>    Figure 1: Configuration Options Exchange Extension
> 
>       Type
> 
>          IPV4-CONF-OPTIONS-EXT-TYPE (This extension value will be
>          assigned by IANA from the numbering space defined in [RFC3344]
>          for skippable extensions)

IPV4-CONF-OPTIONS-EXT-TYPE is wierd. aren't the Mobile
IPv4 extensions known by a name? see RFC 3344.

instead say

         Type

            Configuration Options Exchange Extension

the text in the parenthesis can be removed because it
appears in the IANA Considerations section later.

>          This field indicates which Mobility Agent was asked or inserted
>          the extension in the Registration Request or Registration
>          Reply, respectively.  

suggest re-wording to

    This field indicates which mobility agent the request was
    sent to when the extension is present in a Registration
    Request and which mobility agent inserted the extension in
    a Registration Reply.

or something like that...

> 3.  Processing of Configuration Options Exchange Extension
> 
>    The Mobile Node may request values for specific configuration
>    parameters from the Home Agent and/or Foreign Agent by including the
>    'Parameter Request List' option in the Registration Request.  The

this is the first time the Parameter Request List
option is being mentioned in this document. I
guess we need to say that this option is defined
in RFC 2132.

>    list of requested parameters is specified as a string of octets,
>    where each octet is a valid DHCP option code as defined in [RFC2132].
>    If this extension is included in the Registration Request, the Home
>    Agent or Foreign Agent (indicated in the Entity-Type field) should
>    provide requested information in the Registration Reply.  The
>    Configuration Options Exchange extension should be repeated in the
>    Registration Request for parameter(s) request based on the Entity-
>    Type.  If there are no Configuration Options Exchange Extension in
>    the Registration Request, it's up to the Home Agent or Foreign Agent
>    to decide which configuration parameter to include in the
>    Configuration Options Exchange extension.  The configuration
>    parameter(s) should not be overwritten by the Foreign Agent if the
>    Home Agent has included them in the Configuration Options Exchange
>    extension.  The Entity-Type field is set to the Mobility Agent that
>    appended the extension in the Registration Reply.
> 
>    When a network entity (identified in the Entity-Type field of the
>    extension) 

network entity includes the mobile node also in this
case. wonder if "network entity" is the right term.

< adds a Configuration Options Exchange Extension to a
>    Registration Request or Registration Reply message, this extension
>    MUST appear prior to any authentication extensions added by that
>    entity.
> 
>    Example:
> 
>    Mobile Node wants to obtain the home network prefix mask and DNS
>    servers' IP addresses from its Home Agent during registration.  The
>    Registration Request would contain the following values in the
>    Configuration Options Exchange Extension.
> 
>    0               1                   2               3
>    0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1
>    +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
>    |     <Type>    |     <Len>=6   |    <Ent>=1    |    <Rsv>=0    |
>    +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+

what is "Rsv"?

>    |  <OpCode>=55  |   <OpLen>=2   |  <NetMask>=1  |    <DNS>=6    |
>    +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+

what is "OpCode=55"?

> 4.  IANA Considerations
> 
>    This draft defines new Mobile IPv4 extension of types IPV4-CONF-
>    OPTIONS-EXT-TYPE as defined in Section 2 of this document.  

suggest re-wording to

    This draft defines new Mobile IPv4 extension, the Configuration
    Options Exchange Extension as defined in Section 2.

> 5.  Security Considerations
> 
>    There are no additional security aspects imposed by this document in
>    addition to the one defined in [RFC3344].

is that true? typically information that is being
exchanged here is sent one-hop from the access
network to the mobile node. or at least it is
contained in the access network. now we are sending
this information across the Internet unencrypted.
for e.g. we are sending the IP address of the DNS
server to a remote mobile node without encrypting
the information. so its not possible that there are
no new security considerations.

Vijay