Subject: [Mip4] Comments on draft-ietf-nemo-v4-base-01.txt

From: Vijay Devarapalli <[email-masked]>
Date: Mon, 11 Dec 2006 19:21:46 -0800

Hello,

Here are some comments on draft-ietf-nemo-v4-base-01.txt

Some high level comments

- The terms "subnet", "prefix" and "mobile network" are
used interchangeably in many places. Needs to be fixed
throughout in the document.
- Support for mobile networks using the FA CoA mode is
not explained clearly.
- Running a dynamic routing protocol between the mobile
router and the home agent probably does not work when
FA-CoA mode is used.

> 	  IPv4 Network Mobility (NEMO) Basic Support Protocol

Lets just call it "IPv4 Network Mobility (NEMO) Protocol".
The Basic Support was used for NEMOv6 since there was a
plan to work on route optimization for NEMOv6 and this
was called Extended Support. Its not the same with MIPv4
and IPv4 NEMO.

>    This document describes the support of Mobile Networks, as defined in
>    Mobile IPv4, by the Mobile Router and Home Agent.  

This statement is confusing. What does "as defined in
Mobile IPv4" mean? Perhaps rephrase to

    This document describes a protocol for supporting Mobile Networks
    between a Mobile Router and a Home Agent by extending the Mobile
    IPv4 protocol.

>    This document describes protocol extensions to Mobile IPv4
>    ([RFC3344]) to enable support for Mobile Networks.  A Mobile Network
>    is defined as a network segment or subnet that can change its point
>    of attachment to the routing infrastructure.  Such movement is
>    performed by a Mobile Router, which is the mobility entity that
>    provides connectivity and reachability as well as session continuity
>    for all the nodes in the Mobile Network.  The Mobile Router typically
>    serves as the default gateway for the devices on the Mobile Network.

s/devices/hosts/

>    Mobility for the Mobile Network is supported by the Mobile Router
>    registering the point of attachment to its Home Agent.  This
>    signaling sets up the tunnel between the two entities.  The Mobile
>    Networks (either implicitly configured on the Home Agent or
>    explicitly identified by the Mobile Router) are advertised by the
>    Home Agent for route propagation.  Traffic to and from nodes in the
>    Mobile Network are tunneled by the Home Agent to the Mobile Router,
>    and vice versa.  Though packets from the Mobile Network can be
>    forwarded directly without tunneling when reverse tunneling is not
>    enabled, 

Not just "not enabled" but also "not used".

> reachability is still subject to ingress filtering
>    conditions for the path in this case.

What reachability? I guess you want to say packets can
be dropped if ingress filtering is turned on.

>    This document specifies an additional tunnel between Mobile Router's
>    Home Address and the Home Agent.  This tunnel is encapsulated within
>    the normal tunnel between the Care-of Address (CoA) and Home Agent.
>    In Foreign Agent CoA mode, the tunnel between the Mobile Router and
>    Home Agent is needed to allow the Foreign Agent to direct the
>    decapsulated packet to the proper visiting Mobile Router.  

Lets take an example.

IPv4 hdr (src=HA, dst=FA-CoA)
IPv4 hdr (src=HA, dst=HoA)
IPv4 hdr (src=CN, dst=MNN)
Payload

I borrowed the MNN terminology for NEMOv6 to indicate a
host that is attached to the mobile network. The above
packet format is always used for FA CoA mode, correct?

> However,
>    in Collocated CoA mode, the additional tunnel is not essential and
>    can be eliminated because the Mobile Router is the recipient of the
>    encapsulated packets for the Mobile Network.

This would give us

IPv4 hdr (src=HA, dst=CoA)
IPv4 hdr (src=CN, dst=MNN)
Payload

This gives us a unique case of the packet overhead being
the same for the co-located CoA mode and the FA CoA mode. :)

>    A similar protocol has been documented in [RFC3963] for supporting
>    IPv6 moving networks with Mobile IPv6 extensions.

s/moving networks/mobile networks/

>    Although Mobile IPv4 stated that Mobile Network can be supported by
>    the Mobile Router and Home Agent using static configuration or
>    running a routing protocol, there is no solution for explicit
>    registration of the Mobile Networks served by the Mobile Router.  

Perhaps elaborate to say that there is no mechanism for
the home agent to know that the mobile router is
authorized to send routing updates for a particular
mobile network prefix? Is this the intention of the above
sentence?

> 4.2.  Mobile Network Acknowledgement Extension
> 
>    The Registration Reply contains zero, one or several Mobile Network
>    Acknowledgement extensions in addition to any other extensions
>    defined by or in the context of ([RFC3344]).  For Implicit Mode,
>    the Mobile Network Acknowledgement informs the Mobile Router the
>    prefixes served by the Home Agent.  

You mean owned by the Mobile Router? The Home Agent only
sets up forwarding for the mobile network prefix. Is this
what you mean by "served by the Home Agent"?

>    In accordance with this specification, a Mobile Router may operate in
>    one of the following two modes: explicit and implicit.  In explicit
>    mode, the Mobile Router includes Mobile Network Prefix information in
>    all Registration Requests (as Mobile Network Request extensions),
>    while in implicit mode it does not include this information in any
>    Registration Request.  In this latter case, the Home Agent obtains
>    the Mobile Network Prefixes by other means than Mobile IP.

Perhaps give one example, like configuration on the home
agent.

>    A Mobile Router can obtain a Collocated or Foreign Agent Care-of-
>    Address while operating in explicit or implicit modes.

Whether the mobile router is using the explicit or implicit
mode it has no impact on FA or colocated CoA mode, right?
Anyway re-phrase the above sentence to

    A Mobile Router MAY use either Co-located or Foreign Agent
    Care-of Address while operating in explicit or implicit mode.

>    1.  Check that the subnet information is valid

s/subnet/Mobile Network Prefix/

We have used mobile network prefix or just mobile network so
far.

>    2.  Ensure such subnet is authorized to be on the Mobile Router

Same as above.

> 6.2.1.  Registration Table
> 
>    The registration table in the Home Agent, in accordance with
>    ([RFC3344]), contains binding information for every mobile node
>    registered with it.  

Mention that the Registration Table is already defined in
RFC 3344.

>    If all checks are successful, the Home Agent either creates a new
>    entry(ies) for the Mobile Router or updates an existing binding
>    entry(ies) for it 

Isn't there only one entry per Mobile Router? Are you
considering multiple home addresses per mobile router?
Anyway a registration request can only modify one
binding cache entry at a time. It cannot modify more
than one, right?

> 6.4.  Advertising Mobile Network Reachability
> 
>    If the mobile network prefixes served by the Home Agent are
>    aggregated with the home network prefix and if the Home Agent is the
>    default router on the home network, the Home Agent does not have to
>    do anything different than normal.  

s/do anything different than normal/advertise the mobile network prefixes.

 > The routes for the mobile network
>    prefix are automatically aggregated into the home network prefix.  

Mention that it is assumed that the mobile network
prefixes are automatically aggregated under the home
network prefix.

If
>    the Mobile Router updates the mobile network prefix routes via a
>    dynamic routing protocol, the Home Agent SHOULD propagate the routes
>    on the appropriate networks.

This is the first mention of running a dynamic routing
protocol between the MR and the HA. Perhaps it should
be described briefly somewhere earlier on how to run
a dynamic routing protocol between the mobile router
and the HA.

Vijay

-- 
Mip4 mailing list: [email-masked]
    Web interface: https://www1.ietf.org/mailman/listinfo/mip4
     Charter page: http://www.ietf.org/html.charters/mip4-charter.html
Supplemental site: http://www.mip4.org/

---

From: Alexandru Petrescu <[email-masked]>
Date: Tue, 12 Dec 2006 13:39:09 +0100

Vijay thanks for the comments, will address soon.  Let me thread one
terminology topic separately.

> s/moving networks/mobile networks/

I think 'moving networks' is more illustrative of NEMO than 'mobile
networks' which could mean too fixed networks supporting mobility.  I.e.
  it is common in telecom industry to call a 3GPP network a 'mobile
network' which is not moving actually.  A 'moving network' doesn't have
that ambiguity.

On another hand both the mobility terminology rfc3753 and the
draft-ietf-nemo-terminology suggest 'mobile network' instead.

I'm personally inclined to go with 'moving network', per the reason
above.  A s/x/y isn't hard to do either.  Let's see.

Alex

> Perhaps elaborate to say that there is no mechanism for the home
> agent to know that the mobile router is authorized to send routing
> updates for a particular mobile network prefix? Is this the intention
> of the above sentence?
> 
> You mean owned by the Mobile Router? The Home Agent only sets up
> forwarding for the mobile network prefix. Is this what you mean by
> "served by the Home Agent"?
> 
>> In accordance with this specification, a Mobile Router may operate
>> in one of the following two modes: explicit and implicit.  In
>> explicit mode, the Mobile Router includes Mobile Network Prefix
>> information in all Registration Requests (as Mobile Network Request
>> extensions), while in implicit mode it does not include this
>> information in any Registration Request.  In this latter case, the
>> Home Agent obtains the Mobile Network Prefixes by other means than
>> Mobile IP.
> 
> Perhaps give one example, like configuration on the home agent.
> 
> Whether the mobile router is using the explicit or implicit mode it
> has no impact on FA or colocated CoA mode, right? Anyway re-phrase
> the above sentence to
> 
> A Mobile Router MAY use either Co-located or Foreign Agent Care-of
> Address while operating in explicit or implicit mode.
> 
> We have used mobile network prefix or just mobile network so far.
> 
> Mention that the Registration Table is already defined in RFC 3344.
> 
> Isn't there only one entry per Mobile Router? Are you considering
> multiple home addresses per mobile router? Anyway a registration
> request can only modify one binding cache entry at a time. It cannot
> modify more than one, right?
> 
>> aggregated with the home network prefix and if the Home Agent is
>> the default router on the home network, the Home Agent does not
>> have to do anything different than normal.
> 
>> The routes for the mobile network prefix are automatically
>> aggregated into the home network prefix.
> 
> Mention that it is assumed that the mobile network prefixes are
> automatically aggregated under the home network prefix.
> 
> If
>> dynamic routing protocol, the Home Agent SHOULD propagate the
>> routes on the appropriate networks.
> 
> This is the first mention of running a dynamic routing protocol
> between the MR and the HA. Perhaps it should be described briefly
> somewhere earlier on how to run a dynamic routing protocol between
> the mobile router and the HA.
> 
> Vijay
>