Subject: Re: [Mip4] Question about draft-leung-mip4-proxy-mode

From: "John.zhao"<[email-masked]>
Date: Thu, 26 Jul 2007 11:39:05 -0500

Hi,kent

	Could I ask for two problems about this draft?
	1)What is the defination of you have just mentioned the Mobility Agent Advertisement Extension?
	2)What is the origination of pseudo MAC address?

			Best Rgds,
Thanks,

	　　　　　　　　John.zhao
　	　	　　　　　[email-masked]
　　　	　	　　　　　　2007-07-26
======= 2007-07-26 12:00:00 You have said:=======
>
>Kent Leung (kleung) wrote:
>> Hi Bruno.  Sorry, I missed this question.
>>
>> In this case, the Router Advertisement will not have the Mobility Agent
>> Advertisement Extension.
>>   
>Since a router implementing MIP4 proxy mode includes FA function, isn't 
>it logical and consistent to include a Mobility Agent Advertisment 
>extension in RA to indicate FA support?
>I would suggest this behaviour can be added to your draft, possibly 
>extending the Mobility Agent Advertisment extension to indicate PMIP 
>support (i think some place is left for RFU in the format).
>
>What do you think?
>
>Such addition is not intended to be processed (understandable) by simple 
>IP terminals, but rather by terminals that might behave as simple IP or 
>MIP and need to choose which protocol to use.
>
>Thanks in advance for your reply.
>Bruno.
>> Kent 
>>
>> -----Original Message-----
>> From: Bruno Mongazon-Cazavet
>> [mailto:[email-masked]] 
>> Sent: Thursday, July 19, 2007 8:48 AM
>> To: Mobile IPv4 Mailing List
>> Subject: [Mip4] Question about draft-leung-mip4-proxy-mode
>>
>> Hello,
>>
>> When a router implements this draft, how should it reacts to Router
>> Solicitation?
>> In particular:
>> -should the router fill the Mobility Agent Advertisement extension in
>> the reply?
>> -should the FA capability be set if only PMIP is supported?
>>
>> Thanks, Bruno.
>>

-- 
Mip4 mailing list: [email-masked]
    Web interface: https://www1.ietf.org/mailman/listinfo/mip4
     Charter page: http://www.ietf.org/html.charters/mip4-charter.html
Supplemental site: http://www.mip4.org/

---

From: Jun AWANO <[email-masked]>
Date: Thu, 26 Jul 2007 21:22:43 -0500

Hi, kent

Please let me ask about your draft.

Your draft says,
"This document describes WiMAX Forum and 3GPP2 solution
 for the base Proxy Mobile IPv4 function which enables
 another entity to provide mobility support on behalf of
 an unaltered and mobility-unaware IPv4 device."

But, I think that the PMIPv4 described in your draft seems
different from the one specified in WiMAX Forum spec
(WiMAX Forum Network Architechture stage2/3).

Do you plan to change the PMIPv4 spec of WiMAX Forum to
match your draft?

Best Regards,
Jun

---

From: "Kent Leung \(kleung\)" <[email-masked]>
Date: Fri, 27 Jul 2007 09:28:31 -0700

Hi Jun.

We are working with WiMAX Forum members to address the technical gaps in the draft.  Currently, we are collecting the review comments and will update the draft accordingly.

Kent 

-----Original Message-----
From: Jun AWANO [mailto:[email-masked]] 
Sent: Thursday, July 26, 2007 7:23 PM
To: mip4
Subject: pmipv4 of WiMAX forum (Re: [Mip4] Question aboutdraft-leung-mip4-proxy-mode)

Hi, kent

Your draft says,
"This document describes WiMAX Forum and 3GPP2 solution  for the base Proxy Mobile IPv4 function which enables  another entity to provide mobility support on behalf of  an unaltered and mobility-unaware IPv4 device."

But, I think that the PMIPv4 described in your draft seems different from the one specified in WiMAX Forum spec (WiMAX Forum Network Architechture stage2/3).

Do you plan to change the PMIPv4 spec of WiMAX Forum to match your draft?

Best Regards,
Jun

John.zhao wrote:
>>> In this case, the Router Advertisement will not have the Mobility 
>>> Agent Advertisement Extension.
>>>   
>> Since a router implementing MIP4 proxy mode includes FA function, 
>> isn't it logical and consistent to include a Mobility Agent 
>> Advertisment extension in RA to indicate FA support?
>> Such addition is not intended to be processed (understandable) by 
>> simple IP terminals, but rather by terminals that might behave as 
>> simple IP or MIP and need to choose which protocol to use.
>>
>>> -should the router fill the Mobility Agent Advertisement extension 
>>> in the reply?

---

From: "Kent Leung \(kleung\)" <[email-masked]>
Date: Fri, 27 Jul 2007 09:31:25 -0700

Let me clarify that we will be updating our draft,
draft-leung-mip4-proxy-mode, accordingly to address the gaps.

Kent 

-----Original Message-----
From: Kent Leung (kleung) 
Sent: Friday, July 27, 2007 9:29 AM
To: Jun AWANO; mip4
Subject: RE: pmipv4 of WiMAX forum (Re: [Mip4]
Questionaboutdraft-leung-mip4-proxy-mode)

Hi Jun.

We are working with WiMAX Forum members to address the technical gaps in
the draft.  Currently, we are collecting the review comments and will
update the draft accordingly.

Kent 

-----Original Message-----
From: Jun AWANO [mailto:[email-masked]]
Sent: Thursday, July 26, 2007 7:23 PM
To: mip4
Subject: pmipv4 of WiMAX forum (Re: [Mip4] Question
aboutdraft-leung-mip4-proxy-mode)

Hi, kent

Your draft says,
"This document describes WiMAX Forum and 3GPP2 solution  for the base
Proxy Mobile IPv4 function which enables  another entity to provide
mobility support on behalf of  an unaltered and mobility-unaware IPv4
device."

But, I think that the PMIPv4 described in your draft seems different
from the one specified in WiMAX Forum spec (WiMAX Forum Network
Architechture stage2/3).

Do you plan to change the PMIPv4 spec of WiMAX Forum to match your
draft?

Best Regards,
Jun

---

From: "Yoshi Tsuda \(yotsuda\)" <[email-masked]>
Date: Sat, 28 Jul 2007 01:27:37 +0800

Hi Awano-san,

 What do you think the major technical differences between current
 Kent's draft and the current WiMAX spec?
 You know, most people in this MIP4 mailinglist doesn't have enough
 time to check the specific WiMAX spec.  So, we would appreciate,
 if you point out the MIPv4-related technical differences instead of
just
 saying different.
 
Thanks in advance.
-Yoshi

> Sent: Friday, July 27, 2007 9:31 AM
> To: Jun AWANO; mip4
> Subject: RE: pmipv4 of WiMAX forum (Re: 
> [Mip4]Questionaboutdraft-leung-mip4-proxy-mode)
> 
> We are working with WiMAX Forum members to address the 
> technical gaps in the draft.  Currently, we are collecting 
> the review comments and will update the draft accordingly.
> 
> Kent 
> 
> "This document describes WiMAX Forum and 3GPP2 solution  for 
> the base Proxy Mobile IPv4 function which enables  another 
> entity to provide mobility support on behalf of  an unaltered 
> and mobility-unaware IPv4 device."
> 
> different from the one specified in WiMAX Forum spec (WiMAX 
> Forum Network Architechture stage2/3).
>

---

From: Jun AWANO <[email-masked]>
Date: Fri, 27 Jul 2007 15:57:55 -0500

Hi Kent,

Thank you for your early reply.

I've understood your intention.
I'll wait for your updated draft.:)

Best Regards,
Jun

-- 
-----------------------------------------------
Jun AWANO <[email-masked]>
NEC System Platforms Research Laboratories
Tel:+81 44 431 7638, FAX:+81 44 431 7609

---

From: Jun AWANO <[email-masked]>
Date: Fri, 27 Jul 2007 18:13:28 -0500

Hi Tsuda-san,

O.K. Tsuda-san.
I think I couldn't pick up all of differences.
But I try to enumerate them.

The differences are as following.

1. Terminologies
  draft-leung-mip4-proxy-mode says
  LMA,MAG,PRRQ,PRRP.
  But WiMAX spec doesn't use such terminologies.
  Just, HA, FA & PMIP Client, RRQ, RRP,respectively.

2. New extensions
  draft-leung-mip4-proxy-mode defines new MIPv4 extensions,
  Proxy Mobile IPv4 Mode Extension and PMIPv4 Per-Node
  Authentication Method Extension. And enfocing to use them.
  But WiMAX spec doesn't support them.

3. New error codes
  draft-leung-mip4-proxy-mode defines new error codes,
  PMIP_UNSUPPORTED and PMIP_DISALLOWED.
  But WiMAX spec doesn't use them.

4. How to use Registration Revocation
  When a MN moves to a new MAG.
  Registration Revocation message is sent to the
  previous MAG according to draft-leung-mip4-proxy-mode.
  I'm not sure it's different or not.
  But at least WiMAX spec doesn't say explicitly that
  a LMA(HA) uses Registration Revocation in this case.

5. Processing Proxy Registration Request
  Whole sentence described at "8.1.  Processing Proxy
  Registration Requests" is different from WiMAX spec.
  A HA specified in WiMAX performs as per RFC3344.
  So the HA doesn't perform like described at "8.1.".
  i.e. The HA doen't use Sequence Number and doesn't
  send error RRP like described at "8.1.".

6. Moving to a New MAG
  I think draft-leung-mip4-proxy-mode assumes that
  the MAG which sends RRQ on behalf of a MN is relocated
  when the MN has moved to a new MAG.
  But In WiMAX spec, PMIP client which sends RRQ on behalf
  of a MN is anchored even when the MN has moved to a new FA.
  Are you following the proceeding of netlmm WG?
  And do you know Ajoy's PMIPv6 draft?
  http://tools.ietf.org/wg/netlmm/draft-singh-netlmm-protocol-03.txt
  The MAG described in the draft is anchored while moving.
  The PMIP client specified in WiMAX is similar to it.
  So, WiMAX PMIP client isn't required to transfer any MN's
  contexts(e.g. MN-HA key) when the MN has moved.

Best Regard,
Jun

---

From: Jun AWANO <[email-masked]>
Date: Sat, 28 Jul 2007 00:26:25 -0500

Hi Tsuda-san and Kent,

I forgot to say about supporting IPv6/DS host.
Of cource, draft-leung-mip4-proxy-mode could include
the feature to support IPv6/DS host although WiMAX spec PMIPv4
doesn't have such a feature (at least so far).

But I think there are issues about this.
The first issue:
The draft refers to draft-navali-ip6-over-netmip4-00
(I found out -02 ver.) to achieve support for dual stack feature.
You know, mip4 WG already have dsmipv4 draft.
It's draft-ietf-mip4-dsmipv4.

Although some modifications might be needed to adapt
draft-ietf-mip4-dsmipv4 to proxy mode. (e.g. RRQ MUST include
IPv6 Tunneling Mode Ext.)
Extensions defined at draft-ietf-mip4-dsmipv4 can be reused.
The draft defines IPv4 Prefix Ext and IPv6 Code Ext to request,
bind and get IPv6 HoA.
OTOH, draft-navali-ip6-over-netmip4 defines IPv6 Home Address
Request Ext and IPv6 Home Address Extension for the same aims.

IMO, I don't want to have different extension to achieve the
  same effect.
I want to reuse extensions and procedures described in 
draft-navali-ip6-over-netmip4 as much as possible.

The second issue:
I think there might be an argument about necessity of PMIPv4 DS
support.
Because PMIPv6 draft + IPv4 support draft can cover almost the
  same scenario as PMIPv4 DS can.

What do you think?

Thanks,
Jun

Jun AWANO wrote:
>>> From: Kent Leung (kleung) Sent: Friday, July 27, 2007 9:31 AM
>>> To: Jun AWANO; mip4
>>> We are working with WiMAX Forum members to address the technical gaps 
>>> in the draft.  Currently, we are collecting the review comments and 
>>> will update the draft accordingly.
>>>
>>> Kent