Subject: [Mip6] Question on draft-montavont-mobileip-multihoming-pb-statement

From: Tobias Küfner <[email-masked]>
Date: Thu, 6 Nov 2003 17:31:07 +0100

Dear authors,

I read your draft and followed your recent discussion 
about multihomed MNs on the mailing list.

Anyhow, I'm not sure whether I understand your taxonomy,
especially  scenario 6 and 7, where there's a MN with
two or more interfaces but only one HoA (1,*,n).

What happens when this MN is at home?
Which interface uses the HoA?
Or is the HoA shared by two or more interfaces (L2 addresses)?

How can the MN use a HoA and a CoA at the same time
if it only has _one_ HoA (scenario 7)?
What happens to packets addressed to the HoA?
Are they delivered to the HA or to the MN?

Thank you,
Tobias

_______________________________________________
Mip6 mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/mip6

---

From: Nicolas Montavont <[email-masked]>
Date: Thu, 13 Nov 2003 21:22:44 +0100

Hi Tobias,

Thank you for your comments, and please apology for the delay of this reply.
Please find some answers inline.

>Anyhow, I'm not sure whether I understand your taxonomy,
Yes, this is one of our todo. We will explain our taxonomy in the next 
revision of the draft.

>What happens when this MN is at home?
First of all, the taxonomy does not give how the MN is currently 
connected to the network (maybe it's needed). For some scenarios, it is 
implicit, but for most of them, it is not given. Do you think that it 
would be interesting to consider how the MN is connected to the network 
(I mean which interface is connected at home and which is not)

So, in scenario 6, it is not implicitly said whether the MN is connected 
to its home network or not. All its interfaces can be connected to a 
visited network or one or several interfaces can be connected to the 
home network. I think that this scenario is one of the most important 
and need further discussion, especially what happen when several 
interfaces are connected to home and other not. These kind of discussion 
will be proposed in the next revision of the draft

In scenario 7,  the only case where the MN is multihomed is when the MN 
is connected to the home network with one of its 2 interfaces and 
connected to a visited network with another one.

>Which interface uses the HoA?
This is an implementation issue. The HoA can be allocated to a virtual 
interface (Kame or Ryuji's interface). In that case, we have to consider 
what happen when connected at home.
Otherwise, the home address can be allocated to a particular interface 
(Linux implementation).

>Or is the HoA shared by two or more interfaces (L2 addresses)?
I don't really get your question... Can you detail more ?

>if it only has _one_ HoA (scenario 7)?
If you are talking about scenario 7, the MN can use his HoA as a normal 
IPv6 address to communicate with CNs (I mean no MIP6 processings)
The other interface, which is connected to a visited network, can use RO 
to communicate with CN.

>Are they delivered to the HA or to the MN?
They go to the interface connected to the home network and are delivered 
directly to the MN (the HA has no binding for the MN)

Hope it helps to clarify !

Nicolas

---

From: Tobias Küfner <[email-masked]>
Date: Fri, 14 Nov 2003 11:15:25 +0100

Dear Nicolas,

thank you very much for your explanation.
My comments are inline.

> (I mean which interface is connected at home and which is not)

IMO it would be helpful to point out the restrictions 
to the use of the CoA(s) in scenario 6 and 7 (1,*,n).
As your draft says in 4.3 "the CoAs can not be registered 
with the home agent serving to MN on the home link it is 
connected to".

IMO this is especially important for scenario 6 and 7 (1,*,n).
If you consider a MN connected to its _one and only_ home link 
in scenario 6 and 7, the MN _must_ use RO with its CoA(s)
assigned to its interface(s) connected to visited links.

Or am I missing something?
 
> I don't really get your question... Can you detail more ?

Not necessary. It is clear to me now.

> IPv6 address to communicate with CNs (I mean no MIP6 
> processings) The other interface, which is connected to a 
> visited network, can use RO 
> to communicate with CN.

I agree.
 
But IMO it would be helpful to point out, that in this case
the MN has to send/receive HoTI/HoT _directly_ to the CN 
without tunneling it to/from the HA. 

This has been the point I misunderstood.

Tobias
_____________
Tobias Küfner
Institute of Telematics, University of Karlsruhe, Germany

---

From: Nicolas Montavont <[email-masked]>
Date: Wed, 19 Nov 2003 14:24:24 +0100

Hi Tobias,

>Or am I missing something?
You're right and we will add some explanation in the next revision of 
the draft.
Thank you for pointing out the intersesting scenarios, because now we 
will focus on some scenarios and we will investigate them deeper.

>without tunneling it to/from the HA. 
Good point too. Thank you again for these remarks.

Nicolas