Subject: [Mip6] suggested contents of the IANA registry for MIPv6

From: Jari Arkko <[email-masked]>
Date: Mon, 10 Nov 2003 23:39:13 +0200

For your information, here's the suggested the IANA
registry for MIPv6. It consists of changes in the current
IPv6 registry (MH HAO -- other DOs not removed yet):

   http://www.iana.org/assignments/ipv6-parameters

ICMPv6 registry (ICMPs and ND options):

   http://www.iana.org/assignments/icmpv6-parameters

as well as a new registry shown below (MH types, options, and
status codes):

Mobile IPv6 parameters - per [RFC-ietf-mobileip-ipv6-24.txt]

(last updated 2003-11-09)

1. Mobility Header Types - per [RFC-ietf-mobileip-ipv6-24.txt]
    - for the MH Type field in the Mobility Header

    Value  Description                  Reference
    -----  ---------------------------  ---------
        0  Binding Refresh Request      [RFC-ietf-mobileip-ipv6-24.txt]
        1  Home Test Init               [RFC-ietf-mobileip-ipv6-24.txt]
        2  Care-of Test Init            [RFC-ietf-mobileip-ipv6-24.txt]
        3  Home Test                    [RFC-ietf-mobileip-ipv6-24.txt]
        4  Care-of Test                 [RFC-ietf-mobileip-ipv6-24.txt]
        5  Binding Update               [RFC-ietf-mobileip-ipv6-24.txt]
        6  Binding Acknowledgement      [RFC-ietf-mobileip-ipv6-24.txt]
        7  Binding Error                [RFC-ietf-mobileip-ipv6-24.txt]

    Future values of the MH Type can be allocated using standards action.

2. Mobility Options - per [RFC-ietf-mobileip-ipv6-24.txt]

    Value  Description                  Reference
    -----  ---------------------------  ---------
        0  Pad1                         [RFC-ietf-mobileip-ipv6-24.txt]
        1  PadN                         [RFC-ietf-mobileip-ipv6-24.txt]
        2  Binding Refresh Advice       [RFC-ietf-mobileip-ipv6-24.txt]
        3  Alternate Care-of Address    [RFC-ietf-mobileip-ipv6-24.txt]
        4  Nonce Indices                [RFC-ietf-mobileip-ipv6-24.txt]
        5  Authorization Data           [RFC-ietf-mobileip-ipv6-24.txt]

    Future values of the Option Type can be allocated using standards action.

3. Status Codes - per [RFC-ietf-mobileip-ipv6-24.txt]

    Value  Description                              Reference
    -----  ---------------------------              ---------
        0  Binding Update accepted                  [RFC-ietf-mobileip-ipv6-24.txt]
        1  Accepted but prefix discovery necessary  [RFC-ietf-mobileip-ipv6-24.txt]
      128 Reason unspecified                        [RFC-ietf-mobileip-ipv6-24.txt]
      129 Administratively prohibited               [RFC-ietf-mobileip-ipv6-24.txt]
      130 Insufficient resources                    [RFC-ietf-mobileip-ipv6-24.txt]
      131 Home registration not supported           [RFC-ietf-mobileip-ipv6-24.txt]
      132 Not home subnet                           [RFC-ietf-mobileip-ipv6-24.txt]
      133 Not home agent for this mobile node       [RFC-ietf-mobileip-ipv6-24.txt]
      134 Duplicate Address Detection failed        [RFC-ietf-mobileip-ipv6-24.txt]
      135 Sequence number out of window             [RFC-ietf-mobileip-ipv6-24.txt]
      136 Expired home nonce index                  [RFC-ietf-mobileip-ipv6-24.txt]
      137 Expired care-of nonce index               [RFC-ietf-mobileip-ipv6-24.txt]
      138 Expired nonces                            [RFC-ietf-mobileip-ipv6-24.txt]
      139 Registration type change disallowed       [RFC-ietf-mobileip-ipv6-24.txt]

    Future values of the Status field can be allocated using standards action.

REFERENCES
----------
[RFC-ietf-mobileip-ipv6-24.txt]
             D. Johnson, C. Perkins, and J. Arkko, "Mobility Support in IPv6",
             RFC XXXX, Month Year.

(Registry created 2003-11-03)

[]

_______________________________________________
Mip6 mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/mip6

---

From: Vijay Devarapalli <[email-masked]>
Date: Tue, 11 Nov 2003 08:21:39 -0800

the Mobility Header is listed at

http://www.iana.org/assignments/protocol-numbers

   135     Mobility Header          [RFC-ietf-mobileip-ipv6-24.txt]

Vijay

---

From: Keiichi SHIMA / 島慶一 <[email-masked]>
Date: Wed, 12 Nov 2003 08:00:12 -0600 (CST)

Hi all,

From: Jari Arkko <[email-masked]>
Subject: [Mip6] suggested contents of the IANA registry for MIPv6
Date: Mon, 10 Nov 2003 23:39:13 +0200

>    http://www.iana.org/assignments/icmpv6-parameters

The above text has duplicated code numbers for ND option of MIP6.

> IPv6 NEIGHBOR DISCOVERY OPTION FORMATS
> --------------------------------------
> 
> The IPv6 Neighbor Discovery has options that are identified by an Option
> Format Type field [RFC2461].
> 
> Type    Description                             Reference
> ----    -----------                             ---------       
> 1       Source Link-layer Address               [RFC2461]
> 2       Target Link-layer Address               [RFC2461]
> 3       Prefix Information                      [RFC2461]
> 4       Redirected Header                       [RFC2461]
> 5       MTU                                     [RFC2461]
> 
> 6       NBMA Shortcut Limit Option              [IPV6-NBMA]
> 7       Advertisement Interval                  [MOBILE-IPv6]
> 8       Home Agent Information                  [MOBILE-IPv6]
> 
> 9       Source Address List			[RFC3122]
> 10      Target Address List                     [RFC3122]
> 11      Advertisement Interval Option           [RFC-ietf-mobileip-ipv6-24.txt]
> 12      Home Agent Information Option           [RFC-ietf-mobileip-ipv6-24.txt]

Should we use 11 and 12 instead of 7 and 8?

---
Keiichi SHIMA

---

From: Jari Arkko <[email-masked]>
Date: Wed, 12 Nov 2003 17:55:17 +0200

> The above text has duplicated code numbers for ND option of MIP6.

Yes. I have already notified IANA that they should just have
one set of numbers, and that those numbers should be 7 and 8.

--Jari

---

From: Jari Arkko <[email-masked]>
Date: Mon, 17 Nov 2003 14:21:20 +0200

An update. Apparently MLDv2 folks have been using ICMP #143
already, so we'd like to move the MIPv6 numbers one higher,
i.e. 144 and onwards:

  144  Home Agent Address Discovery Request Message     [RFC-ietf-mobileip-ipv6-24.txt]
  145  Home Agent Address Discovery Reply Message       [RFC-ietf-mobileip-ipv6-24.txt]
  146  Mobile Prefix Solicitation                       [RFC-ietf-mobileip-ipv6-24.txt]
  147  Mobile Prefix Advertisement                      [RFC-ietf-mobileip-ipv6-24.txt]

unless there are objections.

--Jari