Subject: Re: [Mip6] draft-jang-mip6-smreg-00

From: "Heejin jang" <[email-masked]>
Date: Mon, 3 Nov 2003 09:55:24 +0900

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_______________________________________________Mip6 mailing [email-masked]://www.ietf.org/mailman/listinfo/mip6

---

From: Ryuji Wakikawa<[email-masked]>
Date: Mon, 03 Nov 2003 21:15:14 +0900

Hi Heejin

At Mon, 3 Nov 2003 09:55:24 +0900,
Heejin jang wrote:
> 
> Hi, Soohong.
> 
> Thanks for your interest and my answer is as follows.
> If you have some comments or more questions, kindly let me know it. :)
> 
> (Now it seems that our smtp server doesn't work well but pop3 is ok.
> so please use the mail to heejin.jang @samsung.com if you have something to talk with me.)
> 
> -------------------------------------------------------------------------
> 1) Which applicability is possible ? network mobility (NEMO) ?
> - My draft is not dedicated to just NEMO environment. 
>   I desinged it for usual mipv6 network.
> 
> 2) Comparison with previous job (Ryuji's draft), It seems like a similar approach to me where the multiple CoA
> are binded by new option. Sorry if I am missing something.
> - My draft is focus on how to support Simultaneous Registration with single BU and avoiding duplicate msg overheads.

The main difference between our drafts is whether multiple CoAs are
assigned on single interface or different interface. You draft is
basically focus on only single interface. right?

When CoAs are assigned to different interfaces, it is rare to happen
movement (i.e. address change) for all CoAs at once.  For this reason,
I do not introduce optimized mode (i.e. piggyback multiple CoAs into a
BU) in my draft. My personal view is that most of CoA is basically
changed independently.  I think optimized mode is not always efficient
for individual management.

Moreover, you should consider when HA rejects a primary CoA for the
binding. Can HA accept non-primary CoAs which is carried by
the rejected primary CoA?  I don't like that MN uses only the primary CoA
to transmit BU to either HA or CN. If the primary CoA goes something
wrong or RR status is expired for the primary CoA, MN needs to re-try
registration for all CoAs again.

regards,
ryuji

> In ipv6 network, MN can be assigned multiple addresses and utilize them for CoA as Ryuji mentioned it in his draft.
> However, each DAD completion time varies and MN should register them one by one by using seperate BU which
> can lead the signaling overhead with duplicate contents in mipv6 networks.
> (Also in normal situation, it's essential to select and register one CoA ASAP which completes DAD most quickly
> to minimize the handover latency. And others may be registered later one by one.)
> 
> But if we are based on Optimized DAD solutions, it's possible to register multiple CoAs by using single BU without 
> additional delay and it's expected to reduce signaling &  processing overheads in network.ÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÌŠž¦j)bž	b²Ó"§¯âz×ÿ¢¸!¶ÚlÿÿðÃâz×ÿ¢¸?™¨¥™©ÿ–+-Šwèþh©

_______________________________________________
Mip6 mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/mip6

---

From: Heejin Jang <[email-masked]>
Date: Tue, 04 Nov 2003 14:03:25 +0900

Hi, Wakikawa. 
Here is inline-comment for your question. :)

The main difference between our drafts is whether multiple CoAs are
assigned on single interface or different interface. You draft is
basically focus on only single interface. right?
-> My draft is not limited to single interface. 
     It can be adopted to both the case with single and multiple interfaces.

When CoAs are assigned to different interfaces, it is rare to happen
movement (i.e. address change) for all CoAs at once. For this reason,
I do not introduce optimized mode (i.e. piggyback multiple CoAs into a
BU) in my draft. My personal view is that most of CoA is basically
changed independently.  I think optimized mode is not always efficient
for individual management.
-> Yeb. until now,  I agree with your view that it is rare to happen movement for all CoAs at once.
    But think about that MN's handoff is supported by the L2 trigger which is discussed actively.
    Based on L2 trigger, MN can detect its movement immediately after it switches to another link 
    and  its multiple interfaces can detect the handover at the same time. Then MN can be assigned 
    CoAs on each interface at the same time supported by optimized dad solutions as i mentioned in 
    my draft. I think that if the CoAs is available on all interface simultaneously, there is no need to 
    send the seperate BUs and this time the number of interfaces doesn't matter.

Moreover, you should consider when HA rejects a primary CoA for the
binding. Can HA accept non-primary CoAs which is carried by
the rejected primary CoA?  I don't like that MN uses only the primary CoA
to transmit BU to either HA or CN. If the primary CoA goes something
wrong or RR status is expired for the primary CoA, MN needs to re-try
registration for all CoAs again.
-> You can think that seperate BUs/BAs are aggregated to single message respectively when MN wants 
    to register to HA or CN. Just the BUs/BAs are integrated to avoid signaling overhead but the 
    binding processing and its related data structures are handled independently. (according mipv6 draft)
    And each binding result for each CoA is notified to MN via Multiple CoA binding reply option.
    The primary binding result is independent on the non-primary bindings. 
    Except the exchange of BU and BA with single msg,  the rest part is same when MN issues BUs seperately. 
    MN can retry the registration only for the failed CoAs.
    
regards,
Heejin.