Subject: [Mip6] questions and comments on the haha draft

From: Jari Arkko <[email-masked]>
Date: Thu, 13 Nov 2003 18:29:09 +0200

I read the draft on the way here to Minneapolis, and now
found the time to write this e-mail. I apologize if
these issues have been discussed before, I have not
read the long thread related to this draft on the
mailing list...

Here are the questions and comments:

Substantive:

- Section 3. Given that current mobile ipv6 security
   mechanisms require specific configuration for home
   addresses, home agents need some configuation per
   prefix / mobile node combination. As a result, it
   might be sufficient even if HAHA did not exchange
   prefix information between the home agents.

- Section 3, trigger & dhaad. I'm not sure I understand
   why we need to (a) send the new home agent's address
   in the switch request, and then do dhaad. Dhaad does
   give you more than the addresses of the home agents,
   and their priority order. But the address and the highest
   priority appears to be covered in the switch request
   already, no?

- Section 4.1.2, can you include exactly one PI option,
   or also 0...N? 0..N would make more sense, imho.

- I wonder what the reason was behind making the BIR message
   an ICMP instead of MH. I'm not suggesting it should be
   MH, just curious about the thought process that led
   to this particular choice.

- Section 4.2.[12]. It seems that in your protocol, the
   Binding Information Reply message is not always solicited.
   How about naming the messages to Binding Information Solicitation
   (BIS) and Binding Information Advertisement (BIA)?

- Section 7.2. I don't understand whether you require
   the previous registration to be deleted when moving to
   another home agent. ANd if you do, what is the sequence
   of events?

- The document needs a better explanation of how the
   routing is expected to work. I'm not sure I understand
   how you intend multiple places to get the same packets.
   Or I may understand that in the case of NEMO, but not with
   basic MIPv6.

Editorial:

- There's some confusion in the document in the use
   of the term node, host, and router. E.g. section 3
   appears to use mobile router term when mobile node
   would appear to be a better suited term for the
   context.

- In section 3, last paragraph. One sentence says that
   the intercepted packets are sent either to the mn or
   the primary ha, another sentence says the mobile node
   receives tunneled packets from _the_ home agent.

- s/filed/field/g

- Section 4.1.1, s/... other Home Agents/... another home agent/

- Section 4.2.3, s/contain the valid global/contain a valid global/

- Section 4.3.1 last paragraph has some missing words.

- The document sometimes talks about NEMO and basic MIPv6 as
   if NEMO did not employ MIPv6. Suggest using terms like
   "for a mobile host, ... for a mobile router ..."

- Section 11, add to the end of the last sentence "related to
   them".

--Jari

_______________________________________________
Mip6 mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/mip6

---

From: Ryuji Wakikawa <[email-masked]>
Date: Fri, 14 Nov 2003 04:14:52 +0900

Hi Jari

thanks for detailed comments. 
please find my answer inline.

>    prefix information between the home agents.

Could you elaborate a little fuhrer,
I don't think I get your point.

>    priority appears to be covered in the switch request

The address in the switch request is useful when a home agent want a
mobile node to change the primary home agent explicitly
The current mip6 spec does not guarantee that MN always selects the
highest priority home agent. (MN may select the home agent randomly)

>    or also 0...N? 0..N would make more sense, imho.

yes, I agree.

>    to this particular choice.

BIR message is defined as MH.

>    (BIS) and Binding Information Advertisement (BIA)?

OK. 

>    another home agent. ANd if you do, what is the sequence

deregistration is not mandate. The home agent which receives BU just
updates the binding at the other home agents since binding is maintained
at all home agents.

On the other hand, if only single home agent is activated, then need
some scheme to guarantee the binding uniqueness. 

>    Or I may understand that in the case of NEMO, but not with

I will add more explanation how to distribute home agents.

>    would appear to be a better suited term for the

Yes, I already noticed that the current draft mixed up 
mobile node and mobile router. 

> - Section 11, add to the end of the last sentence "related to

We will fix these, too. 

thanks,
ryuji