Subject: Re: [Mip6] I-D on route optimization hints

From: Jari Arkko <[email-masked]>
Date: Tue, 11 Nov 2003 16:23:17 +0200

Keiichi SHIMA wrote:

> draft-shima-mip6-rohints-00.txt

Hi Keiichi,

Thank you for writing this draft. I believe it is an
important task for the WG to start thinking about when
to do RO and when not.

However, in the meeting some issues were raised about
whether the firewalls really are a problem, why the base
specification approach of just failing the RO setup
was not enough, and whether there were other RO usage issues
that your draft did not address.

I'd like to suggest a slightly different approach
which would imho be more general and work better.
Instead of *signaling* from the home agent when we
should and should not do route optimization, it
might make more sense to have a learning, soft
state mechanism. The base specification already
says something about remebering that a particular
node does not do route optimization; that would also
work in the firewall case, I think. In addition,
a mobile node could measure the delays through birectional
tunneling and route optimization by comparing the
response times of HOTI and COTI, or measure other
traffic. The mobile node could track movement
frequency, and have some information about the
types of traffic flows that it is sending. Together
this information would perhaps help in deciding when
to start route optimization and when not.

In contrast, it does not seem easy to have a central
configuration about all the situations of when to do
RO. The home agent would not know about the firewalls
between two random care-of locations, for instance.

--Jari

_______________________________________________
Mip6 mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/mip6

---

From: Vijay Devarapalli <[email-masked]>
Date: Tue, 11 Nov 2003 08:05:26 -0800

agree completely!

Vijay

---

From: "Youn-Hee Han" <[email-masked]>
Date: Wed, 12 Nov 2003 01:32:21 +0900

Hello Jari and Keiichi, 

> important task for the WG to start thinking about when

I agree. Although RO is a fundamental part of mipv6,
it is not mendatory function. So, we start to think how to 
determine when to do RO. 
 
> that your draft did not address.

I agree too. The draft must metion the other cases when to do 
RO and when not. But, it is clear that Firewall is such a case.   

> to start route optimization and when not.

I think that it is good approach. Movement tracking can 
be easily by MN itself. So, it can manage a mobility profile,
which has the frequency rate of movement, visiting time at 
a link, etc. I also think that comaparing the response times 
of HOTI and COTI is a good tool. 
One extreme case is that MN moves very frequenty and 
ROed packets from a CN are more delayed than Tunneled 
packets. At this case, IMO, switching off RO is of benefit.

As you may know, there have been some research papers related 
to this issues. That is, IMO, this issue may attract many mobileip 
people's attention. So, if possible, I hope mip6 wg hugs this issue. 
However, I am now sure that this issue is really one which need 
to be standard. Maybe, informational (or experimental) may be enough. 

-- YH"§©šŠX§‚X¬´È©ê'~Šà†Ûi³ÿðÃžµú+ƒùšŠYšŸùb²Ø§~æŠž

---

From: Joe Lau <[email-masked]>
Date: Tue, 11 Nov 2003 10:27:46 PST

I got "page not found" error when I tried to access
the following URL for the IETF 58 MIP6 slides.

http://www.mindspring.com/~bpatil/IETF58/MIP6

Is the URL correct?

Thanks.

Joe

---

From: "T.J. Kniveton" <[email-masked]>
Date: Tue, 11 Nov 2003 13:36:39 -0800

That URL works fine for me... make sure you have a good connection and 
DNS is working.

---

From: Keiichi SHIMA / 島慶一 <[email-masked]>
Date: Wed, 12 Nov 2003 07:45:50 -0600 (CST)

Hello,

Thank you for all of your comments and replies.

I see the firewall case is not the best and only case to describe ro
hints.  Also, the idea Jari suggests looks good to me too.  I'll try
to list any possible ways to get information to judge the initiation
of RO in the next draft.

---
Keiichi SHIMA

From: Jari Arkko <[email-masked]>
Subject: Re: [Mip6] I-D on route optimization hints
Date: Tue, 11 Nov 2003 16:23:17 +0200