Subject: RE: multi-interfaced vs multi-addressed [Re: [Mip6] Draft Agenda for WG meeting at IETF58]

From: Soliman Hesham <[email-masked]>
Date: Mon, 3 Nov 2003 22:36:01 -0500

Hi Charlie,

 > >Case 2: Two addresses on two different interfaces.
 > >Now, the MN may want to put some connections on i/f 1
 > >and others on i/f 2, why? because i/f 1 is cheap and free
 > >but doesn't provide QoS for instance so it's ok to put my 
 > >web browsing on that. On the other hand i/f 2 provides QoS
 > >(for a price) so I'll only use it for real time apps.
 > >
 > >Today MIPv6 does not allow case 2 to take place. Of course
 > >you could do the same with case 1 (i.e. just to be a pain
 > >the MN wants to use two CoAs assigned to the same interface) 
 > >but there is no benefit. The benefit is clearer when there 
 > >are two interfaces. 
 > >
 > How does Mobile IPv6 prevent case 2?
 > 
 > If I want my applications to bind to a case 2 address/socket,
 > why does Mobile IP get in the way?

=> Here is the problem: Mobile IP allows only one CoA to be bound
to a given HoA, in a node's binding cache. So I should have clarified
that if the communication was with the same CN, then MIP does 
not allow the mobile node to use two different CoAs simultaneously.

 > 
 > Furthermore, I dispute your claim that case 1 has no benefit.
 > Clearly, it does when the addresses have separate DNS names.

=> I didn't think that we'd want CoAs to be put in the 
DNS. Case 1 was discussing having two different CoAs. 
I was always assuming that the MN will have on HoA. 

Hesham

 > Regards,
 > Charlie P.

_______________________________________________
Mip6 mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/mip6

---

From: Charlie Perkins <[email-masked]>
Date: Mon, 03 Nov 2003 21:21:42 -0800

Hello Hesham,

>not allow the mobile node to use two different CoAs simultaneously.
It does just fine if the mobile node uses return routability.

>I was always assuming that the MN will have on HoA. 
Ohhh... I was thinking about multiple home addresses here.  But, even so,
it is possible once again to make use of multiple care of addresses with
return routability.

Is it a restriction in the "applicability statement" for this thread that
a mobile node can only have a single home address?

Regards,
Charlie P.