Subject: RE: multi-interfaced vs multi-addressed [Re: [Mip6] Draft Agenda for WG meeting at IETF58]

From: Soliman Hesham <[email-masked]>
Date: Tue, 4 Nov 2003 07:13:31 -0500

> On Tue, 4 Nov 2003, Soliman Hesham wrote:
 > [multi-addressed, single-interface scenario]
 > >  I meant that it requires more work than just MIPv6. But 
 > MIPv6 needs to
 > > support multiple CoAs per HoA anyway.
 > 
 > No, I disagree here.  You're implying that MN with two 
 > interfaces would
 > not need more work.  This does not seem to be correct: 
 > clearly, the user
 > (or someone) must specify the attributes/preferences for the
 > prefixes/interfaces being used.  The same with just one interface but
 > multiple addresses.
 > 
 > Perhaps you're assuming that the implementation (or the 
 > user) could just
 > have default values like, "WLAN interface is preferred over 
 > GPRS", based
 > on some characteristics and knowledge, and try to avoid 
 > having to have
 > more fine-grained control for example on the ISPs being used 
 > (one could
 > offer QoS service, other might not)?

=> I was trying to narrow the scope to what needs to be done
on a protocol level. Actually, I've written a few pages on this for another
publications and one can easily write 100 pages. So if you 
want a "system" approach to this problem you need the following:

1. A number of inputs to an interface selection algorithm.
These inputs should be weighted. They can include: user pref, 
cost, link characteristics, application preference ....etc

2. An interface selection algorithm (which translates into
a CoA selection)

3. A signalling mechanism to ensure that communication with
that CoA is possible (i.e. this is the MIP part). 

 > My point is that I don't believe it is really possible to 
 > have these kinds
 > of coarse preferences without user interaction -- 

=> Why not? User interaction is only one of the inputs. 
How much interaction does a user have today when it comes
to their VPN setup? None typically! Your IPsec tunnel
could include all your traffic (to go through the company 
FW) or could filter based on the IP address. Corporate users
typically have no choice here. It'd be nice if they do, 
but it's not required.

   so the 
 > situation should
 > be pretty close to having to pick between service from ISP X 
 > and ISP Y.

=> Not really, those are "admin" issues and could be factored 
into the algorithm I mentioned above. The different links could 
belong to the same ISP, in which case the admin part is not 
an issue. 

 > > => That's possible, but:
 > > 1. Not all MNs will have more than one HoA. 
 > 
 > We might be able to mandate it (not sure if that's feasible, but that
 > might be an option).

=> I don't think it's a realistic one. We can't mandate
operational issues.

 > > 2. Even if they do, this does not help because the 
 > > CN might pick any of those addresses to communicate
 > > with. E.g. 
 > > - CN first picks the MN's HoA_1. 
 > > - MN binds HoA_1 --> CoA_1 
 > > - CN then picks HoA_1 again for another connection. 
 > > Now the MN wants to bind HoA_1 --> CoA_2 for that
 > > connection (?). 
 > 
 > I take it you mean the problems occur because we can't 
 > signal to CN which
 > HoA it should be using, and we couldn't control which path
 > ("cheap/expensive") between the HoA and the CoA is chosen?

=> Or: we can't signal that it should accept multiple CoA.

 > There might be ways to work around this problem, but it 
 > might be that 
 > multiple CoA's per HaO would be needed.

=> There are also other benefits for this when it comes 
to handover optimisations. But I won't go through that 
yet. 

Hesham

 > 
 > -- 
 > Pekka Savola                 "You each name yourselves king, yet the
 > Netcore Oy                    kingdom bleeds."
 > Systems. Networks. Security. -- George R.R. Martin: A Clash of Kings
 > 
 > 

_______________________________________________
Mip6 mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/mip6

---

From: Nicolas Montavont <[email-masked]>
Date: Tue, 04 Nov 2003 14:42:00 +0100

>that CoA is possible (i.e. this is the MIP part).
I totally agree with this scheme and that is on what we work in our lab. 
But I think that the task of IETF is only point 3. The way the selection 
between interfaces/CoAs is independant from the signalling for spreading 
the flows on interfaces/addresses.

In draft-montavont-mip6-mmi-01 
(http://www.ietf.org/internet-drafts/draft-montavont-mip6-mmi-01.txt) we 
tried to describe different granularities of flows spreading and 
proposed some mechanisms useful for multihomed MNs. This document includes:
    - how to rediect flows between interfaces: especially, what happens 
if the MN has a single or a multiple HoAs
    - how to perform a per-CN mobility
    - per-flow mobility
    - load balancing operations

We would be very pleased to have some feedback on this document too.

Nicolas