Subject: RE: multi-interfaced vs multi-addressed [Re: [Mip6] Draft Agenda for WG meeting at IETF58]

From: Soliman Hesham <[email-masked]>
Date: Tue, 4 Nov 2003 02:22:53 -0500

> On Mon, 3 Nov 2003, Soliman Hesham wrote:
 > > Case 1: The MN has two different addresses on the same interface. 
 > > In this case, the characteristics of that i/f is unchanged whether
 > > you use address 1 or address 2. The address itself is irrelevant, 
 > > it's the interface it represents that matters. So if both addresses
 > > represent the same interface, then either one will do. 
 > >
 > > Case 2: Two addresses on two different interfaces.
 > > Now, the MN may want to put some connections on i/f 1
 > > and others on i/f 2, why? because i/f 1 is cheap and free
 > > but doesn't provide QoS for instance so it's ok to put my 
 > > web browsing on that. On the other hand i/f 2 provides QoS
 > > (for a price) so I'll only use it for real time apps.
 > 
 > Right, but the addresses assigned on the interface might 
 > have different
 > properties even if assigned on a single interface, e.g. 
 > "expensive" and
 > "cheap" ISP.

=> Sure, but generally we seem to have made the assumption 
that different ISPs do not share the same links
in a way that makes them both visible to the IP
layer. Maybe this is something that needs to be revisited
but as you said it's not critical to the MIPv6 part of 
the solution.

 > 
 > I certainly agree that the multi-interface scenarios are 
 > typically more 
 > motivating, but what I'm lookíng for is a technical 
 > explanation *why* 
 > these issues are different with multiple interfaces.. 
 > because in many 
 > cases, you just don't need to care -- if you can support multiple 
 > addresses, you get multiple interfaces free!

=> Well, I see where you're coming from and I agree to
a large extent. But when explaining the scenarios it just
seems more relevant to use multiple interfaces. 
As for the difference between multiple addresses and 
multiple interfaces, the only technical issue here is 
the support of multiple routing tables Vs a single global
table. I think one table per interface is infinitely more
flexible. But none of this is critical to the MIPv6 part
of the solution.

 > (And, looking at the problem statement, it seems that case 1 
 > would require 
 > some modifications on its own if you want to distinguish the 
 > use use of 
 > addresses somehow..)

=> If you want to do that, there are some serious questions
to be asked about how those ISPs got to share the same link
and made themselves visible to the IP layer, simultaneously. 
We can take it off list or in a separate thread if you want.
There is a number of issues here mostly irrelevant to MIPv6
and relevant to IPv6.

Hesham

_______________________________________________
Mip6 mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/mip6

---

From: Pekka Savola <[email-masked]>
Date: Tue, 4 Nov 2003 09:45:53 +0200 (EET)

On Tue, 4 Nov 2003, Soliman Hesham wrote:
[...]
> There is a number of issues here mostly irrelevant to MIPv6

It's not just this.  One concrete example is a home network, where there
are two ADSL routers connected to two ISPs, and a signle Ethernet link
where both the routers advertise their prefixes -- and a mobile node
attached to that link.

The key point is that e.g. in scenarios related to site multihoming, the
addresses may have different properties although the end-nodes would only
have a single interface.

-- 
Pekka Savola                 "You each name yourselves king, yet the
Netcore Oy                    kingdom bleeds."
Systems. Networks. Security. -- George R.R. Martin: A Clash of Kings