Subject: RE: multi-interfaced vs multi-addressed [Re: [Mip6] Draft Agenda for WG meeting at IETF58]

From: Soliman Hesham <[email-masked]>
Date: Tue, 4 Nov 2003 07:25:30 -0500

> > Multi6/ipv6 only need to be involved to solve the problem
 > > of associating certain attributes to a prefix. MIPv6 needs
 > > to allow for more than one coa to be associated with a single
 > > hoa. Implementers need to put the pieces together and do
 > > their own interface/coa selection algorithms. 
 > 
 > I'm trying to understand different ways to factor this problem set.
 > 
 > One aspect is that between a single home agent and a single 
 > home address
 > one can envision multiple tunnels to different CoAs, and 
 > then effectively
 > do multipath routing across those. In addition to the 
 > establishment of
 > such tunnels one also need to have a mechanism to determine 
 > the liveness
 > of the alternative paths/tunnels. (Perhaps that is what you mean by 
 > interface/coa selection algorithms.)

=> Actually, by the interface selection I meant that the 
MN would select the appropriate interface (i.e. CoA) depending
on several factors (link charateristics, QoS, delays, app, cost...etc). 

I'm not sure if having multiple tunnels requires a liveness
determination mechanism. I.e. if it's not done for a single 
tunnel today (apart from the lifetime field in the binding 
which can be used for other bindings), why is it needed
when more tunnels are introduced?

I'm assuming that we do not want to split a single connection
across multiple paths of course ;) 

 > 
 > Moving this to a correspondent is effectively just a way to 
 > propagate the
 > tunnel endpoints to a different place in the topology.

=> Agreed.

 > 
 > There is also the more traditional multihoming aspect of 
 > having multiple HoAs
 > assigned to the same node, which can provide additional 
 > resiliency and
 > perhaps load spreading when a mobile node has two relatively 
 > far apart
 > home agents. Presumably this is not mobility specific; a 
 > stationary node at
 > a homehomed household might want to benefit from this as well.

=> Agreed that this is not mobility specific.

 > 
 > Somewhat separately, there is the desire to do packet classification
 > at the sender so that different types of traffic can use different
 > paths (in the general case) or "tunnels" in the mobile-ip case.
 > Is this something that would only apply to the one 
 > HoA/multiple CoA case?

=> Not really. I think it's a general problem for multihomed
host. But for non-mobile nodes I think this can be done without
introducing new bits on the wire. For instance, multi-addressed/multihomed
nodes are free to select their source address on a per-connection
basis. The same goes for mobile nodes that either have more
than one home address, or want to split traffic going to 
different CNs. I.e. use a different binding with different 
CNs, for the same HoA. I think things get more difficult
when different bindings are needed for the same end point
(be it HA or CN). 

 > 
 > Well, no. If there was such a capability why not be able to 
 > use it when there
 > are multiple HoAs as well? And be able to use if for 
 > multi-addressed nodes
 > that are not using Mobile IP.

=> Agreed. But what is needed for stationary nodes
(I mean protocol-wise)?

 > One could also envision using such a classification 
 > mechanism as a way for
 > a node (mobile or not) at the end of a slow link to inform its access
 > router (at the other end of the slow link) which flows to prioritize 
 > across that slow link.

=> Hmm, I agree with the need for this, but this seems
more like a QoS signalling function over the first hop,
as opposed to a "routing" function done on a per-connection
basis.

Hesham

_______________________________________________
Mip6 mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/mip6

---

From: Erik Nordmark <[email-masked]>
Date: Tue, 4 Nov 2003 13:31:18 +0100 (CET)

> when more tunnels are introduced?

Because one reason for multiple tunnels is higher availability.
For instance, so that when your tunnel over the WLAN stops working
due to being out of reach, the traffic will switch over to the tunnel
over the GPRS.

> across multiple paths of course ;) 

No, but you want to be able to perform failovers I think.

> when different bindings are needed for the same end point

For outgoing traffic the host can select the source address.
But that isn't true for inbound traffic to lillen.france.sun.com;
all the initiator has is one or more IP addresses returned by the DNS.

  Erik

---

From: "James Kempf" <[email-masked]>
Date: Tue, 4 Nov 2003 10:40:15 -0800

> across multiple paths of course ;)

But there are credible proposals for applications that are suggesting this
multilink kind of capability. In fact, I believe
draft-elmalki-mobileip-bicasting-v6-03.txt, on which you were a co-author,
did suggest splitting a flow across interfaces.

            jak