Subject: [Mip6] processing of unsolicited advertisements

From: Ramin Rezaiifar <[email-masked]>
Date: Sun, 23 Nov 2003 13:49:01 -0800

==========Excerpt from draft-ietf-mobileip-ipv6-24.txt==============

When a mobile node receives a Mobile Prefix Advertisement, it MUST

validate it according to the following test:

[...]

If the ICMP Identifier value matches the ICMP Identifier
value of the most recently sent Mobile Prefix Solicitation and no other
advertisement has yet been received for this value, then the
advertisement is considered to be solicited and will be processed
further. Otherwise, the advertisement is unsolicited, and MUST be
silently discarded. In this case the mobile node SHOULD send a Mobile
Prefix Solicitation.

=============================================================

Does the above statement imply that the MN is to process
unsolicited advertisements if it does not have an outstanding solicit?
It is somewhat confusing.

The above bullet implies that if the mobile node has an
outstanding solicit and then it receives a "non-matcing" advertisement,
then the mobile node is to send another solicit message.  Why is this
required?  What goes wrong if the MN accepts the unsolicited
advertisement as a response to its solicitation and not send another
solicitation?

Since the statement does not require the ICMP identifier for
the new solicit (the is sent as a result of receiving the unsolicited
advertisement) to be the same as the outstanding one, this seem to
cause the mobile node to get into an infinite loop of sending
solicits.  The following diagram shows such a scenario:

MN                                   HA

---Solicit w/ ICMP identifier 1------>
.......+

<----unsolicited Advertise------------        |

+......---Solicit w/ ICMP identifier 2------>        |

|      <--Advertise w/ ICMP identifier 1----- .......+

|      ---Solicit w/ ICMP identifier 3------>

+......<--Advertise w/ ICMP identifier 2------

...

-Ramin

_______________________________________________
Mip6 mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/mip6

---

From: Vijay Devarapalli <[email-masked]>
Date: Tue, 25 Nov 2003 10:53:05 -0800

Ramin Rezaiifar wrote:
>     * If the ICMP Identifier value matches the ICMP Identifier value of the most
>       recently sent Mobile Prefix Solicitation and no other advertisement has
>       yet been received for this value, then the advertisement is considered to
>       be solicited and will be processed further. Otherwise, the advertisement
>       is unsolicited, and MUST be silently discarded. In this case the mobile
>       node SHOULD send a Mobile Prefix Solicitation.
> 
>    1. Does the above statement imply that the MN is to process unsolicited
>       advertisements if it does not have an outstanding solicit?  It is somewhat
>       confusing.

nope. the draft says never process an unsolicited Mobile Prefix
Advertisement. only process solicited advertisements.

>    2. The above bullet implies that if the mobile node has an outstanding
>       solicit and then it receives a "non-matcing" advertisement, then the
>       mobile node is to send another solicit message.  Why is this required? 
>       What goes wrong if the MN accepts the unsolicited advertisement as a
>       response to its solicitation and not send another solicitation?
>    3. Since the statement does not require the ICMP identifier for the new
>       solicit (the is sent as a result of receiving the unsolicited
>       advertisement) to be the same as the outstanding one, this seem to cause
>       the mobile node to get into an infinite loop of sending solicits.  The
>       following diagram shows such a scenario:
> 
> 
>                MN                                   HA   
>                 ---Solicit w/ ICMP identifier 1------> .......+

this wont happen because the MN does exponential backoff while
sending Mobile Prefix Solicitations.

Vijay

---

From: Ramin Rezaiifar <[email-masked]>
Date: Tue, 25 Nov 2003 11:23:27 -0800

Thanks for the response.  Please see my comment below.

Vijay Devarapalli wrote:

>> [snip]

Then why would the HA ever send unsolicited Mobile Prefix Ads (as 
specified in section 10.6.2 of the draft) if the MN is not to process them?

==========from draft-ietf-mobileip-ipv6-24.txt===================
10.6.2 Scheduling Prefix Deliveries
A home agent serving a mobile node will schedule the delivery of new 
prefix information to that mobile node when any of the following 
conditions occur:
MUST:
o The state of the flags changes for the prefix of the mobile node's 
registered home address.
o The valid or preferred lifetime is reconfigured or changes for any 
reason other than advancing real time.
o The mobile node requests the information with
============================================================

thanks,

-Ramin

---

From: Vijay Devarapalli <[email-masked]>
Date: Tue, 25 Nov 2003 11:38:29 -0800

> specified in section 10.6.2 of the draft) if the MN is not to process them?

to inform the mobile node that something has changed with respect
to the prefixes being advertised on the home link.

the Home Agent stops sending unsolicited prefix advertisements
once it gets a solicitation from the mobile node.

I dont remember why it was decided that the Mobile Node should
not process unsolicited advertisements. I need to sift through the
issues list. the list of issues are at
http://users.piuha.net/jarkko/publications/mipv6/MIPv6-Issues.html

Vijay

---

From: Frank Quick <[email-masked]>
Date: Tue, 25 Nov 2003 12:33:39 -0800

>>>Advertisement. only process solicited advertisements.

The confusion, I think, results from the statement that

         Otherwise, the advertisement is unsolicited, and MUST be silently 
discarded.

Immediately followed by

         In this case the mobile node SHOULD send a Mobile Prefix Solicitation.

The latter hardly agrees with the accepted definition of "silently 
discarded."  But I suppose everyone will know what is intended and will 
ignore the first MUST...?

>>o The mobile node requests the information with

Frank Quick
office   +1-858-658-3608 fax +1-858-651-1940
portable +1-619-890-5749
paging   [email-masked]
RSA: 29EA D619 31F2 B4D3  8815 3D59 4340 FA43
D-H: 2A24 131C D38F 12E6 4D6A  46EE 8BBF B50A 754E F63D

---

From: Vijay Devarapalli <[email-masked]>
Date: Tue, 25 Nov 2003 14:19:23 -0800

Frank Quick wrote:
>         Otherwise, the advertisement is unsolicited, and MUST be 
> silently discarded.
> 
> Immediately followed by
> 

I guess. the text should have said an unsolicited advertisement
is ignored and the mobile node SHOULD send a Mobile Prefix
Solicitation.

Vijay