Subject: RE: multi-interfaced vs multi-addressed [Re: [Mip6] Draft Agenda for WG meeting at IETF58]

From: Soliman Hesham <[email-masked]>
Date: Mon, 3 Nov 2003 22:12:38 -0500

[...]
 > > Basavaraj, I am sorry but I do not believe that 
 > multi-interfaces on a 
 > > mobile node is only a research problem. There are several 
 > commercial 
 > > mobile nodes with at least 2 interfaces, and we need to 
 > address this 
 > > topic. It seemed to me that the good WG was the MIP6 WG ?
 > 
 > Could someone clarify what does this have to do with 2 interfaces?
 > 
 > Aren't all the MIPv6-specific issues identical is two 
 > different addresses
 > (e.g., from different ISPs)  are configured on one interface?

=> It is pretty difficult to motivate the case with
a single interface. But it's fairly straight forward to motivate
the work for the case where the MN has two interfaces. 

Case 1: The MN has two different addresses on the same interface. 
In this case, the characteristics of that i/f is unchanged whether
you use address 1 or address 2. The address itself is irrelevant, 
it's the interface it represents that matters. So if both addresses
represent the same interface, then either one will do. 

Case 2: Two addresses on two different interfaces.
Now, the MN may want to put some connections on i/f 1
and others on i/f 2, why? because i/f 1 is cheap and free
but doesn't provide QoS for instance so it's ok to put my 
web browsing on that. On the other hand i/f 2 provides QoS
(for a price) so I'll only use it for real time apps.

Today MIPv6 does not allow case 2 to take place. Of course
you could do the same with case 1 (i.e. just to be a pain
the MN wants to use two CoAs assigned to the same interface) 
but there is no benefit. The benefit is clearer when there 
are two interfaces. 

Hesham

 > 
 > This would seem to suggest that we don't understand the 
 > problem (or have 
 > failed to describe it) to begin with..
 > 
 > -- 
 > Pekka Savola                 "You each name yourselves king, yet the
 > Netcore Oy                    kingdom bleeds."
 > Systems. Networks. Security. -- George R.R. Martin: A Clash of Kings
 > 
 > 
 > _______________________________________________
 > Mip6 mailing list
 > [email-masked]
 > https://www.ietf.org/mailman/listinfo/mip6
 > 

_______________________________________________
Mip6 mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/mip6

---

From: Pekka Savola <[email-masked]>
Date: Tue, 4 Nov 2003 09:09:39 +0200 (EET)

> (for a price) so I'll only use it for real time apps.

Right, but the addresses assigned on the interface might have different
properties even if assigned on a single interface, e.g. "expensive" and
"cheap" ISP.

I certainly agree that the multi-interface scenarios are typically more 
motivating, but what I'm lookíng for is a technical explanation *why* 
these issues are different with multiple interfaces.. because in many 
cases, you just don't need to care -- if you can support multiple 
addresses, you get multiple interfaces free!

(And, looking at the problem statement, it seems that case 1 would require 
some modifications on its own if you want to distinguish the use use of 
addresses somehow..)

That is, I'd like to get people out of this "multiple interfaces are
special" mindset unless it's really warranted -- just consider them
addresses of different properties!

---

From: Nicolas Montavont <[email-masked]>
Date: Tue, 04 Nov 2003 09:04:27 +0100

Hi Pekka,

>addresses, you get multiple interfaces free!
Of course multiple interfaces is a more interesting scenario, but, as we 
suggest in our draft on problem statement, we would like to consider 
"multihomed MN" that we defined as :
    - multi-prefixed
    - multi-interfaced
    - multi-linked
    - multi-sited

Multi-interfaces MN is then a subset of multihomed MN.

Nicolas

---

From: Thierry Ernst <[email-masked]>
Date: Tue, 4 Nov 2003 21:55:33 +0900

> some modifications on its own if you want to distinguish the use use of 

Pekka, just to be sure about what you mean about "problem statement" so
that we are not confused:  do you speak about the problem statement as
stated in a specific draft (i.e.
draft-montavont-mobileip-multihoming-pb-statement-00.txt) ?

Thierry.