Subject: Re: [Mip6] I am still puzzled in DAD mechanism in mipv6

From: Gregory Daley <[email-masked]>
Date: Sun, 04 Jan 2004 20:29:08 +1100

Hi Jari and Lee,

Sorry about the delay in response,
I've been playing with my childrens' toys.

----- Original Message -----
From: Jari Arkko <[email-masked]>
Date: Friday, December 26, 2003 8:35 pm
Subject: Re: [Mip6] I am still puzzled in DAD mechanism in mipv6

> Lee Garth wrote:
> 
> >    In a draft issued in July:draft-park-ipv6-dad-problem-wlan-00.txt
> >    The author says besides the time cost in the procedure that 
> MN proceeds the DAD itself, there is mechanical deficiency in 
> applying DAD in wireless environment.
> > 
> >    In chapter 2, it says:
> >     "In this case, IPv6 DAD will not be able to detect duplicate 
> address>      in 802.11 environment because if am 802.11 end 
> station recevies
> >      a DAD packet from a node which is having same MAC, the 
> 802.11 end      station discards the frame and will not be able to 
> defend the DAD. 
> (snip)
> >         But I don't see any subsequent draft concerning this 
> defect and 
> > thinking over further implementations. All drafts and 
> discussions I have 
> > read are about reducing the time cost in DAD procedure. Have it 
> already 
> > been avoided or amended in draft24? What is the solution then? I 
> would 
> > be very thankful if anyone here illuminates it to me.
> 
> I am not aware of any discussion regarding this, but it is possible
> that DNA BOF/WG has discussed it. Greg?
> 
> Draft 24 certainly does not (and will not) address the defect that
> you mention. The issue is not mobility specific. It might even be
> a non-IETF problem.

I believe that there's been some discussion on this topic, 
but I can't recall if it was on the list or at a meeting.

The DNA archive is at:
http://ecselists.eng.monash.edu.au/~warchive/dna/

I've not found it yet, but Daniel (the draft author)
may know about such discussions.

As Jari said, this may not even be an IETF specific
problem.

I've got the feeling that other types of packet delivery
may fail (apart from DAD) due to duplicate MAC addresses
(and not just in WLAN).  Ethernet switching may go awry 
even when IP layer address collisions don't occur (for
example if distinct CGA addresses or 3041 addresses are in use).

Greg.

_______________________________________________
Mip6 mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/mip6

---

From: "O.L.N.Rao" <[email-masked]>
Date: Fri, 30 Jan 2004 10:10:59 +0530

Hi,

    ASAP we are going to update this draft to bringout the possible solutions (although vague).
    draft-park-ipv6-dad-problem-wlan-00.txt.  

    Also to note, the next draft mostly follows the name draft-<OneOfAuthor>-ipv6-over-wifi-01.txt.

    This is FYI plz.

Regards,
O.L.N.Rao

===================================

Hello to all:
In a draft issued in July:draft-park-ipv6-dad-problem-wlan-00.txt
The author says besides the time cost in the procedure that MN proceeds the DAD itself, there is mechanical deficiency in applying DAD in wireless environment.

In chapter 2, it says:
"In this case, IPv6 DAD will not be able to detect duplicate address
in 802.11 environment because if am 802.11 end station recevies
a DAD packet from a node which is having same MAC, the 802.11 end station discards the frame and will not be able to defend the DAD.
So the DAD always succeeds even though there are two end stations with the same MAC address.
Consequently, IPv6 node generates its address without any duplication,
but this address is not unique address but duplicated address. This concludes that "Multicast Packet Filtering based on Source Address" makes "Duplicate Address Detection" procedure trivial."

This draft provides in Chapter 3.2 two possible solutions:
* Enhanced Multicast Filtering at Layer 2
* Selective Filtering at Layer 2
But I don't see any subsequent draft concerning this defect and thinking over further implementations. All drafts and discussions I have read are about reducing the time cost in DAD procedure. Have it already been avoided or amended in draft24? What is the solution then? I would be very thankful if anyone here illuminates it to me.

Happy Christmas to all....

Yours Garthdawn
'spamcontrol '