Subject: [Mip6] which implementations.

From: paul van den bergen <[email-masked]>
Date: Thu, 8 Jan 2004 15:28:16 +1100

Hi all.

I am wondering what mobile IP implementations there are out there.

Specifically I am most interested in Open Source - *BSD and linux 
implementations for IPv4 and/or IPv6.

I am aware of KAME for *BSD/ IPv6.

If you know of a mobile IP implementation, could you drop me an email with;

Mobile IP implementation name
Operating system(s) - e.g. windows, MacOS, *BSD, linux distro
IPv4 or IPv6.
state... e.g. Commercial or Open Source; Experimental, Beta or 
Stable/Mature...

thanks.

-- 
Dr Paul van den Bergen
Centre for Advanced Internet Architectures
caia.swin.edu.au
[email-masked]
IM:bulwynkl2002
"And some run up hill and down dale, knapping the chucky stones 
to pieces wi' hammers, like so many road makers run daft. 
They say it is to see how the world was made."
Sir Walter Scott, St. Ronan's Well 1824 

_______________________________________________
Mip6 mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/mip6

---

From: "Ed Remmell" <[email-masked]>
Date: Thu, 8 Jan 2004 09:58:16 -0800

Paul -

Elmic Systems has a commercial source code implementation of Mobile
IPv4, as well as Mobile IPv6 compliant with the latest IETF drafts
(including the MIPv6 IPsec/IKE requirements). Our products are source
code implementations of Internet protocols, specifically
designed/optimized for embedded systems, and can work with or without an
RTOS. Typically, our products are either used without any RTOS (all
calls are non-blocking, and the stack runs as a single task called by a
main program "super loop"), or are fully integrated with a customer's
proprietary preemptive or non-preemptive RTOS, or are fully integrated
with a commercial off-the-shelf RTOS such as uC/OS, VxWorks, etc.

Our product datasheet for our Mobile IPv6 product is available here:
http://www.elmic.com/pdf/MobileIPv6_data.pdf

A Win32 port (binary demo) of our dual stack + applications + Mobile
IPv6 + IPsec/IKE is available for download here:
http://www.elmic.com/TreckDemo.zip

Please note that Elmic Systems is soon to be changing its name to Treck
Inc.

Thanks.
- Ed Remmell
Treck, Inc. (formerly Elmic Systems, USA)

Best of Show Winner, ESC 2003
Click on the link and take a look!
http://cmp.iconvention.com/escshowdaily/v33/index.cvn?ID=10183

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On 
> Behalf Of paul van den bergen
> Sent: Wednesday, January 07, 2004 8:28 PM
> To: [email-masked]
> Subject: [Mip6] which implementations.
> 
> 
> Hi all.
> 
> ---
> Incoming mail is certified Virus Free.
> Checked by AVG anti-virus system (http://www.grisoft.com).
> Version: 6.0.542 / Virus Database: 336 - Release Date: 11/18/2003
>  
> 

---
Outgoing mail is certified Virus Free.
Checked by AVG anti-virus system (http://www.grisoft.com).
Version: 6.0.542 / Virus Database: 336 - Release Date: 11/18/2003