Subject: [Mip6] for your information - Mobile IP v4 and v6 implementations.

From: paul van den bergen <[email-masked]>
Date: Tue, 20 Jan 2004 14:35:17 +1100

Hi all,
a few weeks ago I asked for mobile IP implementations...

just thought you'd all be interested to see what I found...

IP	Operating Systems	Name			Source and Comments
6	FreeBSD 4.9		KAME			http://www.kame.net/
	NetBSD 1.6.1						Stable, MIP code experimental, actively updated
	OpenBSD 3.3

4	NetBSD 1.1		Monarch			http://www.monarch.cs.cmu.edu/software.html
	FreeBSD 2.2.2						Rich University, old
6	INRIA's IPv6 code
	and FreeBSD 2.2.2

4	linux				Secure Mobile Net	http://www.cs.pdx.edu/research/SMN/
	FreeBSD 2.2.8, 4.6					actively updated
	4.8, 4.9, 5.2

4	Linux				Dynamics			Helsinki University of Technology
	Windows client						http://dynamics.sourceforge.net/
6	Linux				MIPL				http://www.mipl.mediapoli.com/
									GPL, stable

4	Linux				UoB-NOMAD		http://www.mobileip.org/
									SPL, based on NOMADv4

6	Linux				HMIPv6			http://www.ctie.monash.edu.au/ipv6/hmipv6.htm

4	Windows			SEGCO			http://www.secgo.com/
	Linux								commercial

4	Linux kernel 2.2.16	MosquitoNet		http://mosquitonet.stanford.edu/mip/

4	Windows			IPunplugged		http://www.ipunplugged.com/
									commercial
4	Windows			Birdstep			http://www.birdstep.com/
	embedded systems					commercial

4 & 6 embedded			Elmic Systems		http://www.elmic.com/
	OS independant						commercial, now Treck Inc.

4	Userland			MobileIP
	(platform independent)
	(linux 2.0.3)
									http://www.hpl.hp.com/personal/Jean_Tourrilhes/MobileIP/index.html

-- 
Dr Paul van den Bergen
Centre for Advanced Internet Architectures
caia.swin.edu.au
[email-masked]
IM:bulwynkl2002
"And some run up hill and down dale, knapping the chucky stones 
to pieces wi' hammers, like so many road makers run daft. 
They say it is to see how the world was made."
Sir Walter Scott, St. Ronan's Well 1824 

_______________________________________________
Mip6 mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/mip6

---

From: Tsuyoshi MOMOSE <[email-masked]>
Date: Tue, 20 Jan 2004 14:50:29 +0900

Hi,

> 	NetBSD 1.6.1						Stable, MIP code experimental, actively updated

Current KAME MIP6 doesn't support OpenBSD yet.
I'm now working to port it.

---
MOMOSE Tsuyoshi
NEC Corporation
KAME Project		http://www.kame.net/
Nautilus Project	http://www.nautilus6.org/

---

From: Henrik Levkowetz <[email-masked]>
Date: Tue, 20 Jan 2004 11:02:49 +0100

Hello Paul,

> just thought you'd all be interested to see what I found...

<snip table of implementations>

Useful and interesting indeed.  I've taken the liberty of duplicating
the information here:

 <http://www.mip4.org/2004/mip-implementations.html>

	Thanks,
		Henrik

---

From: Henrik Levkowetz <[email-masked]>
Date: Tue, 20 Jan 2004 22:31:01 +0100

Hi Qiang

Tuesday 20 January 2004, Qiang Zhang wrote:
> I know there are several other commercials, such as
> ecutel.com

As more implementations are mentioned on the mailing list, I'll put them
into the table at <http://www.mip4.org/2004/mip-implementations.html>.

I would need a bit more information to do so, though.  Would you be kind
enough to provide / IP version / OS / Name / URL / status /  for the
implementations you know of?

	Henrik

---

From: paul van den bergen <[email-masked]>
Date: Wed, 21 Jan 2004 11:51:22 +1100

Hey Henrik,

thanks for that! I'm glad this information has a home! (I might steal your 
page and duplicate it at wikipedia too, if I get a moment.)

FYI, I am winding up here this week, so this email address will disappear. but 
anyone who wants to talk to the people who will no doubt follow after me (I 
speak of the researcher who is greater than me, whos very operational 
parameters I am unworthy to even calculate) can go to www.caia.swin.edu.au 
and have a look around there... :-)

> implementations you know of?
IP	OS				Name	URL				Comments
4	Windows client/server	Viatores	www.ecutel.com/		commercial
	Linux server

---

From: Qiang zhang <[email-masked]>
Date: Tue, 20 Jan 2004 10:27:37 -0800 (PST)

Dr. Paul Bergen,

Qiang
>  <http://www.mip4.org/2004/mip-implementations.html>

__________________________________
Do you Yahoo!?
Yahoo! Hotjobs: Enter the "Signing Bonus" Sweepstakes
http://hotjobs.sweepstakes.yahoo.com/signingbonus

---

From: Kent Leung <[email-masked]>
Date: Thu, 22 Jan 2004 09:27:29 -0800

Hi Henrik.

Here's Cisco's info:

IP: 4 & 6
OS: Cisco IOS
Name: Cisco Systems (URL: http://www.cisco.com/go/mobile_ip)
Comments: MIPv4 commercial, MIPv6 technology preview

Kent

At 10:31 PM 1/20/2004 +0100, Henrik Levkowetz wrote:

>Mip4 mailing list
>[email-masked]
>https://www.ietf.org/mailman/listinfo/mip4

---

From: Henrik Levkowetz <[email-masked]>
Date: Sat, 24 Jan 2004 16:45:50 +0100

> Comments: MIPv4 commercial, MIPv6 technology preview

Thanks, Kent. 

I've added this to the page at <http://www.mip4.org/2004/implementations/>.
If there are any updates, let me know.

	Regards,

		Henrik