Subject: RE: [Mip6] Preconfigured Kbm as working group document

From: "Soliman Hesham" <[email-masked]>
Date: Thu, 11 Mar 2004 22:43:49 -0500

> >- We discussed this before for the base spec and 
 > >I believe it was suggested that a CoA test would 
 > >be needed, thoughts?
 > >  
 > >
 > No, because the correspondent node has to have some reason
 > to believe that the mobile node is trustworthy.  This is very
 > reasonable for many situations, like between you and your
 > co-workers for instance.  Or, since I actually don't know
 > about that, then between me and my co-workers, but I would
 > assume so for you also.

=> If this is the intended scenario then it would be 
helpful to say that in the draft to avoid mistaking it
with other types of deployments. I don't have a problem
with using it for this purpose.

 > 
 > >- What's the max lifetime for the BSA in this scenario?
 > >I didn't see anything in the draft about that.
 > >  
 > >
 > There isn't any max lifetime defined for the BSA.

=> I know, should there be one? or at least should 
there be a statement that says there is no upper
limit (except the size of the field) for the lifetime?
If for nothing else, to distinguish this from RR based
Kbms.

 > 
 > >- Why does the draft say that if nonces exist the "MAY be
 > >ignored" ? shouldn't they just be ignored? under what circumstances
 > >are the nonces acceptable?
 > >  
 > >
 > According to the standards language conventions, "MAY" does not
 > presuppose a list of conditions.  It means that the protocol partner
 > must be prepared for the possibility that they be ignored.  It means
 > that the sender doesn't have any particularly good reason to include
 > the nonces, but it is not an error to do so.

=> It's a matter of taste I think. I prefer to
have one way of doing it because it simplifies
the implementation of the CN (the part where 
it receives and processes the BU). 

Hesham

_______________________________________________
Mip6 mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/mip6

---

From: "Charles E. Perkins" <[email-masked]>
Date: Thu, 11 Mar 2004 20:49:18 -0800

Hello Hesham,

Soliman Hesham wrote:

>--DS-3429925659732912225
I thought the draft did say that, but I will look to see and make sure.

>If for nothing else, to distinguish this from RR based
O.K.  I will put that in, thanks.

>it receives and processes the BU).
Well, that's fine except unless your platform is different than someone
else's platform in a way that causes different views of what is easier.
On the other hand, if the ambiguity is viewed as problematic then
I don't have a problem one way or the other and if the nonces are
strictly disallowed it makes the packet smaller and less processing.
But I don't see that as an issue anyway.

Regards,
Charlie P.