Subject: RE: [Mip6] draft-perkins-mip6-precfgKbm-00.txt

From: [email-masked]
Date: Wed, 21 Apr 2004 17:20:47 -0500

Jari Arkko wrote:
>
>Hi,
>
>> There is consensus in the WG to make I-D :
>> draft-perkins-mip6-precfgKbm-00.txt a WG document.
>
>I'm not opposed to making this document a WG item, but
>I was kind of hoping to get an answer to some of my
>questions from the chairs before we make a decision.

Apologies for not responding to your questions before making the
decision. But let me provide some answers here:

>Here are the questions from my March 22nd e-mail
>to you and James Kempf:
>
>> Re: charter. The draft does fall within the charter,
>> and I think we should do it (perhaps with some
>> agreement first on how ambitious scope it should have).
>> But I believe we have also other issues that we should
>> take care of in the RO space, perhaps even higher priority
>> issues. So I'd really like to ensure that we can actually
>> do more than Charlie's draft. This brings me to ...
>> 
>> Raj: You didn't answer my question on whether
>> more than one improvement can be adopted by the
>> WG. My reading of the charter item:
>> 
>>     - Route optimization will require security mechanisms for
>>       trusting and updating the binding information.Return-routability
>>       is the basic mechanism for route-optimization. Mechanisms using
>>       a shared secret Key/Security Association will be considered.
>>       Methods for establishing a security association between the
>>       mobile node and the correspondent node are out of the scope
>>       of the WG.
>> 
>> is that shared secrets are just one example and other
>> mechanisms can be considered. If that's your interpretation
>> as well, then I don't need to worry that we are preventing
>> other necessary work to take place.

As you state above, using shared secrets between MNs and CNs is one
way of doing RO. It does not imply that the WG will not consider other
RO schemes as well. The Preconfigured keys mechanism is a RO method
whose applicability is limited and is fairly simple to
implement. So the intent is to get this standardized quickly while
being open to alternate proposals for RO as well.

>> 
>> Also, I have a question about the charter It says:
>> 
>>   It should be noted that there are potential optimizations
>>   that might make mobile IP more attractive for use by certain
>>   applications (e.g., making handovers "faster"). The latter
>>   category of optimizations is explicitly out-of-scope at this
>>   time; this WG will focus on issues for which there is strong
>>   consensus that the work is needed to get basic mobility
>>   deployable on a large scale.
>> 
>> What does this mean, exactly? Why does it not apply to
>> the kbm draft, as its main purpose (I think) is to have
>> less signaling and delay? Would it apply other alternatives
>> to RR? Or is this paragraph in the charter to avoid collision
>> with MIPSHOP? That's my interpretation, but I'm not sure
>> this is the way others read it... 

The intent of the statement above in the charter is to ensure that
signaling optimizations that are developed with the primary intent of
enhancing handoffs should be taken up in the MIPSHOP WG. 
However, I think its a bit of a grey area. The WG would not be averse
to taking on work whose intent was to optimize MIP6 signaling that may
or may not benefit handovers. Most optimization schemes would benefit
handoffs anyway... Hence we cannot necessarily rule it out of the
scope of the WG. 

-Basavaraj

_______________________________________________
Mip6 mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/mip6

---

From: Jari Arkko <[email-masked]>
Date: Thu, 22 Apr 2004 14:24:05 +0300

Ok. Thanks for the response.

--Jari