Subject: RE: HA nreliability Problem Statement [was Re: [Mip6] IETF59: Minutes of MIP6 WG meeting]

From: "Soliman Hesham" <[email-masked]>
Date: Fri, 23 Apr 2004 00:31:58 -0400

> HA reliability can be accomplished by hardware redundancy or 
 > by protocol work.
 >   do we have a consensus that protocol work is needed at 
 > this present time?
 > Do you think we should ask the people who have HA 
 > implementations to express
 > their short term preference?.

=> I don't have a particular bias but I'm curious why
you used "short term" above? 

I think if we go down the road of protocol work, we should
stick to the basic requirement: A protocol that transfers
state between two or more HAs sharing a link, detects
HA failures and elects a new HA.

Hesham

 > 
 > 
 > Thanks,
 > -Gopal
 > 
 > 
 > At 12:16 AM 4/23/2004 +0900, Ryuji Wakikawa wrote:
 > 
 > >Hello Jahanzeb and all.
 > >
 > >What is the status of draft-jfaizan-mipv6-ha-reliability?
 > >It seems there are any comments on this draft.
 > >
 > >To WG Chairs
 > >Is it time to make it WG doc and move on a solution?
 > >
 > >regards,
 > >ryuji
 > >
 > > >
 > > > Meeting minutes of Mobility for IPv6 (MIP6) WG from IETF59
 > > > ----------------------------------------------------------
 > >
 > >   <SNIP>
 > >
 > > > 4. HA reliability problem statement
 > > > ***********************************
 > > > Presenter: Ryuji Wakikawa 
 > <draft-jfaizan-mipv6-ha-reliability-01.txt>
 > > >
 > > > - HA failure. Home link failure. Failure detection, how 
 > an MN detects
 > > >   failure. Current base spec is not clear. Service
 > > >   interruption. Recovery? Who initiates recovery. IPsec SA
 > > >   assoc. establishment. Correct ordering, if HA changes, 
 > new HA does
 > > >   not know the order.
 > > > - HA reliability is in current milestones, we need a problem
 > > >   statement.
 > > >
 > > > Deng Hui: Round robin load balancing can be used, i.e. 
 > redundancy is
 > > >      built into the HA machine. Also reliability can be 
 > accomplished
 > > >      by having a multi-blade server type of machine as the HA.
 > > > Gopal. Reliability solution should be built into the
 > > >      protocol. Hardware solutions are another approach 
 > to reliability.
 > > > Raj. Reliability is a WG charter item. Once we have 
 > consensus on the
 > > >      problem statement and scope we will move to solutions.
 > > >      The problem statement I-D will be made a WG item 
 > after obtaining
 > > >      consensus on the WG ML.
 > > >
 > >
 > >_______________________________________________
 > >Mip6 mailing list
 > >[email-masked]
 > >https://www.ietf.org/mailman/listinfo/mip6
 > 
 > 
 > _______________________________________________
 > Mip6 mailing list
 > [email-masked]
 > https://www.ietf.org/mailman/listinfo/mip6
 > 

========================================================
This email may contain confidential and privileged material for the sole
use of the intended recipient.  Any review or distribution by others is 
strictly prohibited.  If you are not the intended recipient please contact
the sender and delete all copies.
========================================================

_______________________________________________
Mip6 mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/mip6

---

From: "Xiaolong Huang" <[email-masked]>
Date: Sun, 25 Apr 2004 23:20:24 -0700

The dynamimc load balance mechanism developed here should be able to be 
embedded in both Mipv4 and Mipv6. We implemented it in Mipv6, and partly 
implementedt in Mipv4 in NS2.

Xiaolong

>From: "Soliman Hesham" <[email-masked]>
>To: "Jahanzeb Faizan" <[email-masked]>,        "Mohan Parthasarathy" 
><[email-masked]>,        "Ryuji Wakikawa" <[email-masked]>,     
>    "Gopal Dommety" <[email-masked]>
>CC: <[email-masked]>, <[email-masked]>
>Subject: RE: HA nreliability Problem Statement [was Re: [Mip6] IETF59:  
>Minutes of MIP6 WG meeting]
>Date: Mon, 26 Apr 2004 00:58:00 -0400
>
>
>
>  > >=> You seem to imply that MIPv4 doesn't allow two HAs on
>  > the same link (?)
>  > >I'd like to know why this is the case.
>  >
>  > JF> I don't mean that MIP4 can't have two HAs on the same
>  > link. It could
>  > have but the point is
>  > in MIP6 there is builtin suppport for multiple HAs (
>  > refering to anycast
>  > addressing scheme, Dynamic
>  > HA discovery ...) which differs it from MIP4.
>
>=> Sure, that's a bit clearer. But the DHAAD in MIPv6
>is only useful in letting the MN know that there are
>multiple HAs. If the current HA fails the MN will need
>to be told and it needs to be told who the new HA is.
>
>In MIPv4 this can be done by the new HA. So while
>this part of the solution might be different, the
>inter-HA protocol can be the same. I think we
>should try to use protocols that work for both v4 and v6
>as much as possible.
>
>  >
>  > >=> No. If you have HW redundancy then the "two"
>  > >HAs look like a single entity to the IP layer.
>  > >Failure detection, switching ...etc are all handled
>  > >internally. There are no security issues here.
>  >
>  > JF> But this is not the way the routers are deployed on the
>  > link. we always
>  > have redundant routers over the IP layer.
>  > That is why IETF came up with VRRP4 and VRRP6 standards.
>
>=> Not always, it's generally cheaper to have
>redundancy in the protocol than to have it in the
>product. I'm not trying to say that we shouldn't have
>IP layer redundancy. I was specifically refuting the
>suggestion that HW redundancy does not work.
>
>Hesham
>
>
>
>
>  >
>  > The issue over here is not about providing redundancy above
>  > or below the IP
>  > layer. We can leave this issue to the vendors.
>  > The point is that does not matter how the redundancy is provided the
>  > "protocol should be reliable and capable of providing
>  > seamless,efficient and secure failover".
>  >
>  > Thanks
>  > Jahanzeb
>  > ----- Original Message -----
>  > From: "Soliman Hesham" <[email-masked]>
>  > To: "Jahanzeb Faizan" <[email-masked]>; "Mohan Parthasarathy"
>  > <[email-masked]>; "Ryuji Wakikawa"
>  > <[email-masked]>; "Gopal
>  > Dommety" <[email-masked]>
>  > Cc: <[email-masked]>; <[email-masked]>
>  > Sent: Sunday, April 25, 2004 3:25 AM
>  > Subject: RE: HA nreliability Problem Statement [was Re:
>  > [Mip6] IETF59:
>  > Minutes of MIP6 WG meeting]
>  >
>  >
>  >
>  >  > >=> Of course the above is not correct. There _is_
>  >  > >a single point of failure problem and the fact
>  >  > >that more than one HA can be supported is actually
>  >  > >irrelevant because they can't serve the same HoA.
>  >  > >In this regard there is no difference between MIPv4 and
>  >  > >MIPv6. So I don't know why we can't have one protocol
>  >  > >for both.
>  >  >
>  >  > JF> I don't agree with the point because according to
>  > MIP6 all the HA
>  >  > coexist on the same link
>  >  >  called the "home link". So MN can switch from one HA to
>  >  > another in case of
>  >  > its serving HA failure
>  >  >  keeping its HoA same. That's why there is no single point
>  >  > of failure and
>  >  > that is the purpose of providing
>  >  > multiple HAs on the same link. This differs mip6 from mip4.
>  >  >
>  >
>  > => You seem to imply that MIPv4 doesn't allow two HAs on the
>  > same link (?)
>  > I'd like to know why this is the case.
>  >
>  >
>  >  > >=> No. If you have redundant HW there is no problem
>  >  > >unless both planes fail (active and standby). I've
>  >  > >worked with product development of such systems for years
>  >  > >and the probability of this happening is pretty much nil if
>  >  > >the system is designed well.
>  >  >
>  >  > JF>There are problems of failure detection, switching from
>  >  > one HA to other
>  >  > and security problems etc.
>  >
>  > => No. If you have HW redundancy then the "two"
>  > HAs look like a single entity to the IP layer.
>  > Failure detection, switching ...etc are all handled
>  > internally. There are no security issues here.
>  >
>  > Hesham
>  >
>  >  >
>  >  > Thanks
>  >  > Jahanzeb
>  >  >
>  >  >
>  >  >
>  >  >
>  >  >
>  >  >
>  >  > ----- Original Message -----
>  >  > From: "Soliman Hesham" <[email-masked]>
>  >  > To: "Jahanzeb Faizan" <[email-masked]>; "Mohan Parthasarathy"
>  >  > <[email-masked]>; "Ryuji Wakikawa"
>  >  > <[email-masked]>; "Gopal
>  >  > Dommety" <[email-masked]>
>  >  > Cc: <[email-masked]>; <[email-masked]>
>  >  > Sent: Saturday, April 24, 2004 12:52 AM
>  >  > Subject: RE: HA nreliability Problem Statement [was Re:
>  >  > [Mip6] IETF59:
>  >  > Minutes of MIP6 WG meeting]
>  >  >
>  >  >
>  >  >
>  >  >  > Actually in MIP6 multiple HAs are supported so there is no
>  >  >  > single point of
>  >  >  > failure problem.
>  >  >  > The problem lies in the mip6 protocol itself. These problems
>  >  >  > are related to
>  >  >  > failure detection,
>  >  >  > failure recovery, security  etc.. (discussed in our draft
>  >  >  > http://www.ietf.org/internet-drafts/draft-jfaizan-mipv6-ha-re
>  >  >  > liability-01.txt )
>  >  >
>  >  > => Of course the above is not correct. There _is_
>  >  > a single point of failure problem and the fact
>  >  > that more than one HA can be supported is actually
>  >  > irrelevant because they can't serve the same HoA.
>  >  > In this regard there is no difference between MIPv4 and
>  >  > MIPv6. So I don't know why we can't have one protocol
>  >  > for both.
>  >  >
>  >  > We can certainly solve the problem with a redundant
>  >  > HA that provides redundancy below the IP layer
>  >  > (i.e. HW). This is up to vendors to decide.
>  >  >
>  >  >
>  >  >  >
>  >  >  > Even if we have redundant hardware these problems exists in
>  >  >  > MIP6.
>  >  >
>  >  > => No. If you have redundant HW there is no problem
>  >  > unless both planes fail (active and standby). I've
>  >  > worked with product development of such systems for years
>  >  > and the probability of this happening is pretty much nil if
>  >  > the system is designed well.
>  >  >
>  >  > Hesham
>  >  >

_________________________________________________________________
Is your PC infected? Get a FREE online computer virus scan from McAfee® 
Security. http://clinic.mcafee.com/clinic/ibuy/campaign.asp?cid=3963

---

From: "Soliman Hesham" <[email-masked]>
Date: Mon, 26 Apr 2004 09:24:06 -0400

> 
 > If there is case when a HA operates both MIpv4 and Mipv6, it makes
 > sense to use single protocol for v4 and v6.

=> Do you mean a deployment case? If so, then of course there
is. An operator might run both in parallel for different MNs.
Of course we can't say where this is happening today since
there is zero commercial deployment of MIPv6. 

But I don't think this question should be a prerequisite
anyway. There are advantages in implementing one protocol
for both if possible. This is orthogonal to whether this 
protocol will be run for both v4 and v6 in the same node
at the same time. The benefit of implementing one protocol
stands regardless. 

Hesham

---

From: "DENG, HUI -HCHIBJ" <[email-masked]>
Date: Tue, 27 Apr 2004 10:51:34 +0800

Hesham

> Taking the words "load balancing" literally, of course
>HW solutions can solve it ;). All you need to do
>is to have a cluster that shows one HA entity to the 
>outside world. There is nothing new here, similar server
>designs are available today. Of course if you have a
>mental association between the HA (being a single 
>physical card or box) and the IP address, then you 
>might think that HW solutions can't solve load balancing. 
>But this is not true.
this wellknow technology which we already considered
one year before, but the conlusion we made is  such dispatcher
system can not be used directly in Home Agent, 
Because HA will not only taken signal message and binding 
cache information, but also HA will take some tentative 
traingle traffic.

>Another point on load balancing. If it is needed, then this
>can be done today with larger granularity. I.e. different 
>MNs can use different HAs. This is clearly load balancing. 
As far as what you described here, I think that this is just 
a kind of static load balance, carrier doesn't like such 
static load balance, it will cost their lots of time, and 
also there are lots of dynamic factor inside.

>However, I can see the benefit of allowing a MN to have
>two HAs serving it, not for load balancing reasons but for
>"seamless" recovery from HA failures. I.e. this allows one
> HA to take over immediately when another one fails. But 
>I don't see load balancing itself as a goal here because it 
>can be done without such finer granularity which doesn't 
>seem to buy much. 
Here you returned to the start point again, inside HW, 
there are already two HAs serving one MN. but after after
taking over, mip6 basic specificatin doesn't give a solution
how HA notify this changes, only MN will initiate such anycast
to find a new HA. 

> I think protocol work is a good thing if people want
>a cheaper option. I also think one protocol for v4 and v6
>would be much more useful than two protocols.
Our solution can be run at both v4 and v6.
Please refere to :
http://www.ietf.org/internet-drafts/draft-deng-mip6-ha-loadbalance-01.txt

Hui

---

From: "Kai Zhang" <[email-masked]>
Date: Tue, 27 Apr 2004 23:17:39 +0800

I think is not a cheaper option to use several backup and standby HAs  for
one serving HA. In HW solutions, only a few redundant HAs are needed for
several active HAs.

Regurads,
Kai

----- Original Message ----- 
From: "Soliman Hesham" <[email-masked]>
To: "Ryuji Wakikawa" <[email-masked]>
Cc: <[email-masked]>
Sent: Monday, April 26, 2004 8:32 PM
Subject: RE: HA nreliability Problem Statement [was Re: [Mip6] IETF59: Minutes of MIP6 WG meeting]

First a couple of disclaimers: 
I'm not trying to promote HW solutions only, and,
I haven't read the problem statement draft (didn't even know that it
existed).
I'm trying to clarify a few points.

=> I think protocol work is a good thing if people want
a cheaper option. I also think one protocol for v4 and v6
would be much more useful than two protocols.

Hesham

_______________________________________________
Mip6 mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/mip6
"§©šŠX§‚X¬´È©ê'~Šà†Ûi³ÿðÃžµú+ƒùšŠYšŸùb²Ø§~æŠž

---

From: [email-masked]
Date: Tue, 27 Apr 2004 12:58:24 -0500

Hello Jahnzeb,
 
Some comments below:
 
>Hello all,
> 
>I would like to share with you my concerns and arguments regarding
>this consensus. 
> 
>Hardware solution is not feasible.
 
I disagree with what you seem to be stating as a conclusion. I think
there are plenty of people in this WG who think otherwise.
 
> 
>Some people are of the opinion that HA reliability problem can be
>solved by hardware solution. The proposed solution is to provide
>hardware redundancy below the IP layer in the form of
>cluster/highly-reliable-one-box/active-standby kind of scheme so that
>to the IP layer the underlying hardware redundancy seems to be a
>single HA. I think this solution is not feasible due to following
>reasons. 
 
Note also the fact that the IETF's RSERPOOL WG has developed a
standardized solution for achieving redundancy of servers (equivalent
to clustering). So is there any reason why you would believe that an
Rserpool like protocol for example could not provide the
redundancy/reliability to HAs?
 
> 
>1. Physically HA is nothing but a router. What makes router a HA is
>   just an extra software component. Moreover on a single link there
>   are usually several routers/HAs to share the load of MNs. So for a
>   single router why we are introducing  so much complexity and using
>   redundant hardware resources down the IP layer. I think it is not
>   feasible. 
 
Its not every router that is an HA. Redundancy/Reliability for the HA
comes at a cost and irrespective of whether it is a hardware of
software (Protocol) solution. 
 
>2. Will there be any company ready to pay high cost for such
>   routers. Absolutely none. 
 
Hmmm.... You seem to speak for a lot of companies here.
 
> 
>3. With these solutions we will make mip6 software dependent on the
>   hardware and will restrict the companies to buy such expensive
>   hardwares along with mip6 software for reliable services. This is
>   totally infeasible because companies are going to deploy mip6 over
>   their existing network and hardware. 
 
I dont think that there is any dependency being introduced for
deployment of MIP6 w.r.t redundancy/reliability. I think the
justification for a protocol solution for MIPv6 HA reliability are far
from your assumptions here. The business case (which is what you seem
to be making, is a lot of handwaving).
 
>4. By making mip6 dependent on the underlying hardware we can not
>   achieve world wide deployment of mip6. 
 
Okay.... Lets just agree to disagree.
 
>5. These hardware solutions are not standards.
> 
>Protocol work is the most feasible solution
 
Biased view here....But given your I-D, I guess you have to find the
justifications. 
 
>1. Protocol should be independent of the underlying hardware. Does not
>   matter what the hardware configuration is mip6 should work reliably
>   over any hardware implementation. The problem is in the protocol
>   and the solution should also be based on protocol. 
> 
>2. Protocol solution is cheaper and easy to deploy.
 
I dont think it is any cheaper or for that matter easier to
deploy. These are claims that are ungrounded.
 
>3. Cisco have highly reliable routers and other hardware solutions but
>   still they came up with protocols based on the VRRP4 and VRRP6 IETF
>   standards. So my concern is if we can come up with VRRP4 and VRRP6
>   standards for the reliability of routers then why can't we come up
>   RELIABLE MIP6.... 
> 
>4. If some has a hardware solution for the problem then we can not
>   base on just one solution. There are also protocol based
>   solutions. 
 
I think you are missing the point. There are lots of solutions out
there (w.r.t MIPv6) that need a problem. And this seems to be one of
those cases. I dont think your arguments are convincing enough that
require the WG to consider this an immediate issue. 
 
>Thanks for your time.
>Jahanzeb Faizan
 
-Basavaraj