Subject: RE: HA nreliability Problem Statement [was Re: [Mip6] IETF59: Minutes of MIP6 WG meeting]

From: "Soliman Hesham" <[email-masked]>
Date: Sat, 24 Apr 2004 01:52:45 -0400

> Actually in MIP6 multiple HAs are supported so there is no 
 > single point of
 > failure problem.
 > The problem lies in the mip6 protocol itself. These problems 
 > are related to
 > failure detection,
 > failure recovery, security  etc.. (discussed in our draft
 > http://www.ietf.org/internet-drafts/draft-jfaizan-mipv6-ha-re
 > liability-01.txt )

=> Of course the above is not correct. There _is_
a single point of failure problem and the fact
that more than one HA can be supported is actually
irrelevant because they can't serve the same HoA. 
In this regard there is no difference between MIPv4 and
MIPv6. So I don't know why we can't have one protocol
for both.

We can certainly solve the problem with a redundant
HA that provides redundancy below the IP layer 
(i.e. HW). This is up to vendors to decide. 

 > 
 > Even if we have redundant hardware these problems exists in 
 > MIP6. 

=> No. If you have redundant HW there is no problem
unless both planes fail (active and standby). I've
worked with product development of such systems for years 
and the probability of this happening is pretty much nil if 
the system is designed well.

Hesham

========================================================
This email may contain confidential and privileged material for the sole
use of the intended recipient.  Any review or distribution by others is 
strictly prohibited.  If you are not the intended recipient please contact
the sender and delete all copies.
========================================================

_______________________________________________
Mip6 mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/mip6

---

From: "Jahanzeb Faizan" <[email-masked]>
Date: Sun, 25 Apr 2004 01:27:12 -0500

Please find my comments below....

>MIPv6. So I don't know why we can't have one protocol

JF> I don't agree with the point because according to MIP6 all the HA
coexist on the same link
 called the "home link". So MN can switch from one HA to another in case of
its serving HA failure
 keeping its HoA same. That's why there is no single point of failure and
that is the purpose of providing
multiple HAs on the same link. This differs mip6 from mip4.

>the system is designed well.

JF>There are problems of failure detection, switching from one HA to other
and security problems etc.

Thanks
Jahanzeb

----- Original Message ----- 
From: "Soliman Hesham" <[email-masked]>
To: "Jahanzeb Faizan" <[email-masked]>; "Mohan Parthasarathy"
<[email-masked]>; "Ryuji Wakikawa" <[email-masked]>; "Gopal
Dommety" <[email-masked]>
Cc: <[email-masked]>; <[email-masked]>
Sent: Saturday, April 24, 2004 12:52 AM
Subject: RE: HA nreliability Problem Statement [was Re: [Mip6] IETF59:
Minutes of MIP6 WG meeting]

Hesham

---

From: Gopal Dommety <[email-masked]>
Date: Mon, 26 Apr 2004 10:30:18 -0700

Jahanzeb,

It is possible to solve the problem as Mohan suggested (I know of 
implementation that solve using this approach).
The question is do we need alternative approaches (opinions will vary on 
both sides of the argument) in the near term.
Will wait for more people to chim in and see what the  WG thinks.

Thanks
-Gopal

---

From: "Jahanzeb Faizan" <[email-masked]>
Date: Tue, 27 Apr 2004 10:52:28 -0500

Hi Gopal,

I am interested in learning more about this hardware solution. Would you
please send me the link to its documentation.

Thanks
Jahanzeb

----- Original Message ----- 
From: "Gopal Dommety" <[email-masked]>
To: "Jahanzeb Faizan" <[email-masked]>
Cc: "Soliman Hesham" <[email-masked]>; "Mohan Parthasarathy"
<[email-masked]>; "Ryuji Wakikawa" <[email-masked]>;
<[email-masked]>; <[email-masked]>
Sent: Monday, April 26, 2004 12:30 PM
Subject: Re: HA nreliability Problem Statement [was Re: [Mip6] IETF59:
Minutes of MIP6 WG meeting]

---

From: "Mohan Parthasarathy" <[email-masked]>
Date: Tue, 27 Apr 2004 11:31:01 -0700

If you want to look at some standardization efforts in this area :

www.saforum.org
http://www.intel.com/technology/atca/

I am not speaking for any of these. Just pointing out the efforts that is happening in the industry today.

-mohan