Subject: RE: [Mip6] Preconfigured Kbm as working group document

From: "Soliman Hesham" <[email-masked]>
Date: Thu, 8 Apr 2004 00:18:18 -0400

>> Here is the new text:
 > >>
 > >>    There is no upper bound on the lifetime defined for the
 > >>    preconfigured Kbm                    ........
 > > 
 > > => To make it simpler for implementations to adopt this
 > > draft, perhaps the upper bound should be the lifetime
 > > field in the BU. This way a CN implementation of the binding
 > > cache will not need to know if the Kbm is manually configured
 > > or done through RR. If there is no upper bound then the
 > > CN will need to add a flag in the BCE to indicate that
 > > the entry is never removed.
 > > The upper bound in the BU is large enough anyway for any
 > > practical purposes.
 > 
 > The lifetime of the BU indicates how long the care-of
 > address is valid.  However, Jari's point was that, in
 > case there is no valid care-of address, the key would
 > be vulnerable to loss if it were still tied to the
 > lifetime of the BCE.  My belief is that in this case
 > it is a mistake to make the association between the
 > lifetimes.  In fact, I think it is a mistake to _ever_
 > make the association, but I don't want to get diverted
 > into that discussion just now.
 > 
 > BTW, the upper bound on the lifetime in the Binding
 > Update would otherwise surely be sufficient, since
 > that is defined to be "infinity" :-).

=> Exactly. My point was that the method used
to configure the Kbm should not be visible to
the BC management SW. I forgot that infinity was
still feasible in the BU, I thought this was removed.
So I'm ok with this now.

Hesham

 > Regards,
 > Charlie P.

========================================================
This email may contain confidential and privileged material for the sole
use of the intended recipient.  Any review or distribution by others is 
strictly prohibited.  If you are not the intended recipient please contact
the sender and delete all copies.
========================================================

_______________________________________________
Mip6 mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/mip6

---

From: Brian Haley <[email-masked]>
Date: Thu, 08 Apr 2004 11:51:34 -0400

> still feasible in the BU, I thought this was removed.

Infinite lifetimes were removed in draft 22, max is 262140 seconds, or 
72 hours.

-Brian

---

From: "Charles E.Perkins" <[email-masked]>
Date: Thu, 08 Apr 2004 09:22:15 -0700

Hello Brian,

Sorry, I see I was looking at an old version.

But then...

>> the BC management SW.

I definitely agree with this statement.

It still does not mean that the key lifetime should
be related to the lifetime of the Binding Update,
and thus it does mean that a correspondent node
using this feature needs to store the key in a way
so that its lifetime is not controlled by the binding
cache management.

Regards,
Charlie P.