Subject: RE: HA nreliability Problem Statement [was Re: [Mip6] IETF59: Minutes of MIP6 WG meeting]

From: "Soliman Hesham" <[email-masked]>
Date: Mon, 26 Apr 2004 08:32:29 -0400

First a couple of disclaimers: 
I'm not trying to promote HW solutions only, and,
I haven't read the problem statement draft (didn't even know that it
existed).
I'm trying to clarify a few points.

 > Although HA reliability can be achieved by hardware, there are
 > issues that hardware work can not solve.
 > 
 > The current MIP6 specification supports multiple HAs at a home
 > link. However, there isn't enough specification to utilize them.
 > Even, there are issues related to multiple HAs (ex. section 3.5 of pb
 > statement draft). 
 > 
 > When MN registers to HA1 and suddenly loses HA1, HA1 re-registers to
 > new HA2. However, HA2 finds DAD failure because HA1 still 
 > defends MN's
 > HoA.  HA2 returns BA with an error code. What can MN do then?

=> So here HA1 didn't fail since it's still defending
the HoA, right? So I assume this is what you refer 
to by "load balancing".

 > I am not 100% sure, but load-balancing among HAs (section 3.6) is one
 > thing that hardware work can not solve?!

=> Taking the words "load balancing" literally, of course
HW solutions can solve it ;). All you need to do
is to have a cluster that shows one HA entity to the 
outside world. There is nothing new here, similar server
designs are available today.
Of course if you have a mental association between the 
HA (being a single physical card or box) and the IP address,
then you might think that HW solutions can't solve load
balancing. But this is not true.

Another point on load balancing. If it is needed, then this
can be done today with larger granularity. I.e. different MNs
can use different HAs. This is clearly load balancing. 

However, I can see the benefit of allowing a MN to have
two HAs serving it, not for load balancing reasons but for
"seamless" recovery from HA failures. I.e. this allows
one HA to take over immediately when another one fails.
But I don't see load balancing itself as a goal here because
it can be done without such finer granularity which doesn't
seem to buy much. 

 > Hardware work is fine, but it is better to solve HA reliability by 
 > protocol work. As Hesham noted, a common protocol for Mipv4 and Mipv6
 > might be good idea.
 > 

=> I think protocol work is a good thing if people want
a cheaper option. I also think one protocol for v4 and v6
would be much more useful than two protocols.

Hesham

========================================================
This email may contain confidential and privileged material for the sole
use of the intended recipient.  Any review or distribution by others is 
strictly prohibited.  If you are not the intended recipient please contact
the sender and delete all copies.
========================================================

_______________________________________________
Mip6 mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/mip6

---

From: Ryuji Wakikawa <[email-masked]>
Date: Mon, 26 Apr 2004 22:09:49 +0900

Hi

At Mon, 26 Apr 2004 08:32:29 -0400,
> the HoA, right? So I assume this is what you refer 

This can happen even without "load balancing" support.

When HA becomes out of services, the failed HA may not stop operations
completely.  For example, BCs are all deleted, but proxy ND caches are
still active. (half-down and half-alive). Then the above situation is
occurred.

Another case is when one of routers (maybe ARs) between MN and HA
drops BUs sent to HA1 because of overload, hardware problem,
etc. Then, MN may try to send another BU to HA2 while HA1 is still
active.

I understood these scenarios are a bit tricky.

> balancing. But this is not true.

Thanks, it is clear now:-)
I had in mind that "different" Home Agents share load.

With HW solution, doesn't MIP6 need to support multiple HAs at a home
link. DHAAD is needed to change HA address, but outer advertisements,
HA lists, etc. are no longer necessary...

> can use different HAs. This is clearly load balancing. 

Yes.

> it can be done without such finer granularity which doesn't

Yes. Seamless recovery is one advantage. 
If we can define a protocol for HAs, we possibly have seamless recovery,
load balancing, HA reliability, etc by the protocol. 

> would be much more useful than two protocols.

If there is case when a HA operates both MIpv4 and Mipv6, it makes
sense to use single protocol for v4 and v6.

regards,
ryuji

---

From: "Jahanzeb Faizan" <[email-masked]>
Date: Mon, 26 Apr 2004 12:17:00 -0500

>it can be done without such finer granularity which doesn't

JF>  That's what we have proposed in our solution
http://www.ietf.org/internet-drafts/draft-jfaizan-mipv6-vhar-02.txt

Thanks
Jahanzeb

Hesham