Subject: RE: HA nreliability Problem Statement [was Re: [Mip6] IETF59: Mi nutes of MIP6 WG meeting]

From: "Mohamed Khalil" <[email-masked]>
Date: Fri, 23 Apr 2004 09:21:46 -0500

-----Original Message-----
From: Mohan Parthasarathy [mailto:[email-masked]] 
Sent: Thursday, April 22, 2004 9:18 PM
To: Ryuji Wakikawa; Gopal Dommety
Cc: [email-masked]; [email-masked]; [email-masked]
Subject: Re: HA nreliability Problem Statement [was Re: [Mip6] IETF59:
Minutes of MIP6 WG meeting]

> Ryuji and et all,
> 
> HA reliability can be accomplished by hardware redundancy or by protocol
work.
>   do we have a consensus that protocol work is needed at this present 
> time? Do you think we should ask the people who have HA 
> implementations to express their short term preference?.
> 
In my past job, we have developed a MIPv4 HA that is resilient to a single
point failure without the need of any protocol support from MIPv4. If we
were developing MIPv6 then, i don't know why it would not have been possible
to do the same thing. Note that any telco box has to provide high
availability for all other protocols running in the box. Just not for MIP.

MK>> The reason you need a standard method is because the HAs on the
subnetwork(s) does not need to be from the same vendors. An example, are
routers today have to understand VRRP even if they are from different
vendors. Early thinking about issues related to such protocol is better than
addressing those issues when MIPv6 is already deployed.

Mohamed
> 
> Thanks,
> -Gopal
> 
> 
> At 12:16 AM 4/23/2004 +0900, Ryuji Wakikawa wrote:
> 
> >Hello Jahanzeb and all.
> >
> >What is the status of draft-jfaizan-mipv6-ha-reliability?
> >It seems there are any comments on this draft.
> >
> >To WG Chairs
> >Is it time to make it WG doc and move on a solution?
> >
> >regards,
> >ryuji
> >
> > >
> > > Meeting minutes of Mobility for IPv6 (MIP6) WG from IETF59
> > > ----------------------------------------------------------
> >
> >   <SNIP>
> >
> > > 4. HA reliability problem statement
> > > ***********************************
> > > Presenter: Ryuji Wakikawa 
> > > <draft-jfaizan-mipv6-ha-reliability-01.txt>
> > >
> > > - HA failure. Home link failure. Failure detection, how an MN detects
> > >   failure. Current base spec is not clear. Service
> > >   interruption. Recovery? Who initiates recovery. IPsec SA
> > >   assoc. establishment. Correct ordering, if HA changes, new HA does
> > >   not know the order.
> > > - HA reliability is in current milestones, we need a problem
> > >   statement.
> > >
> > > Deng Hui: Round robin load balancing can be used, i.e. redundancy is
> > >      built into the HA machine. Also reliability can be accomplished
> > >      by having a multi-blade server type of machine as the HA. 
> > > Gopal. Reliability solution should be built into the
> > >      protocol. Hardware solutions are another approach to 
> > > reliability. Raj. Reliability is a WG charter item. Once we have
consensus on the
> > >      problem statement and scope we will move to solutions.
> > >      The problem statement I-D will be made a WG item after obtaining
> > >      consensus on the WG ML.
> > >
> >
> >_______________________________________________
> >Mip6 mailing list
> >[email-masked]
> >https://www.ietf.org/mailman/listinfo/mip6
> 
> 
> _______________________________________________
> Mip6 mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/mip6

_______________________________________________
Mip6 mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/mip6

---

From: "Mohamed Khalil" <[email-masked]>
Date: Fri, 23 Apr 2004 10:30:43 -0500

I think if we go down the road of protocol work, we should stick to the
basic requirement: A protocol that transfers state between two or more HAs
sharing a link, detects HA failures and elects a new HA.

MK>> I think we should be in agreement that a document which have those
basic requirements should be published early. Since standardization of a
document in IETF takes a long time, it is better to discuss those basic
requirements as early as we can. Once again we should not wait until MIPv6
is deployed and think about those requirements.

Mohamed

 > > > Meeting minutes of Mobility for IPv6 (MIP6) WG from IETF59  > > >
 > > >      protocol. Hardware solutions are another approach 
 > to reliability.
 > > > Raj. Reliability is a WG charter item. Once we have 
 > consensus on the

========================================================
This email may contain confidential and privileged material for the sole use
of the intended recipient.  Any review or distribution by others is 
strictly prohibited.  If you are not the intended recipient please contact
the sender and delete all copies.
========================================================

---

From: "Mohamed Khalil" <[email-masked]>
Date: Tue, 27 Apr 2004 11:02:37 -0500

-----Original Message-----
From: Kai Zhang [mailto:[email-masked]] 
Sent: Tuesday, April 27, 2004 10:18 AM
To: Soliman Hesham
Cc: [email-masked]
Subject: Re: HA nreliability Problem Statement [was Re: [Mip6] IETF59:

I think is not a cheaper option to use several backup and standby HAs  for
one serving HA. In HW solutions, only a few redundant HAs are needed for
several active HAs.

MK>> Sometimes, one serving HA with a high reliable hardware might cost a
lot more than if you have 2 HAs in active/standby mode. To give you an
example look at the cost of a high reliable sun workstation and the  price
of a regular work station which is running XP or linux. 

Mohamed

----- Original Message ----- 
From: "Soliman Hesham" <[email-masked]>
To: "Ryuji Wakikawa" <[email-masked]>
Cc: <[email-masked]>
Sent: Monday, April 26, 2004 8:32 PM
Subject: RE: HA nreliability Problem Statement [was Re: [Mip6] IETF59:

First a couple of disclaimers: 
I'm not trying to promote HW solutions only, and,
I haven't read the problem statement draft (didn't even know that it
existed). I'm trying to clarify a few points.

=> I think protocol work is a good thing if people want
a cheaper option. I also think one protocol for v4 and v6
would be much more useful than two protocols.

Hesham

_______________________________________________
Mip6 mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/mip6
2*z™¨¥Šx%ŠËLŠž¢z×è®m¶›?ÿ0‰ë_¢¸?™¨¥™©ÿ–+-Šwèþh©