Subject: [Mip6] Question regarding routing in mip6

From: "Jahanzeb Faizan" <[email-masked]>
Date: Mon, 19 Apr 2004 15:43:41 -0500

Hi,

I have a question regarding the order in which different datastructures are
searched by the HA when a packet is intercepted by the HA from CN or MN.
Each HA is maintaining following datastructures

1. Binding Cache (based on mip6)
2. Neighbour Cache (based on IPv6 neighbour discovery)
3. Routing table (based on fundamental IPv6 routing mechanisms)

Thanks

Jahanzeb

_______________________________________________
Mip6 mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/mip6

---

From: Ryuji Wakikawa <[email-masked]>
Date: Thu, 22 Apr 2004 23:55:32 +0900

At Mon, 19 Apr 2004 15:43:41 -0500,
> Each HA is maintaining following datastructures

I don't know if I understand your question correctly.
When HA tunnels intercepted packets to MN, the order is like: 
     1 (to get CoA of the packets) 
     3 (to get rt-entry of the CoA) 
     2 (to get ndcache of the rt-entry).

BTW, some implementations maintain BC in a Routing table.

ryuji