Subject: RE: [Mip6] Preconfigured Kbm as working group document

From: "Soliman Hesham" <[email-masked]>
Date: Tue, 6 Apr 2004 23:39:59 -0400

Just one nit below

 > >> There isn't any max lifetime defined for the BSA.
 > >
 > >=> I know, should there be one? or at least should 
 > >there be a statement that says there is no upper
 > >limit (except the size of the field) for the lifetime?
 > >If for nothing else, to distinguish this from RR based
 > >Kbms.
 > 
 > Here is the new text:
 > 
 >    There is no upper bound on the lifetime defined for the 
 > preconfigured
 >    Kbm.  As noted, the key is very, very likely to be quite secure
 >    over the lifetime of the security association and usefulness of 
 >    applications between a mobile node and correspondent node that fit
 >    the terms specified in section 2.
 > 

=> To make it simpler for implementations to adopt this
draft, perhaps the upper bound should be the lifetime
field in the BU. This way a CN implementation of the binding 
cache will not need to know if the Kbm is manually configured
or done through RR. If there is no upper bound then the 
CN will need to add a flag in the BCE to indicate that 
the entry is never removed. 
The upper bound in the BU is large enough anyway for any 
practical purposes. 

Hesham

========================================================
This email may contain confidential and privileged material for the sole
use of the intended recipient.  Any review or distribution by others is 
strictly prohibited.  If you are not the intended recipient please contact
the sender and delete all copies.
========================================================

_______________________________________________
Mip6 mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/mip6

---

From: "Charles E.Perkins" <[email-masked]>
Date: Wed, 07 Apr 2004 10:26:51 -0700

Hello Hesham,

Thanks for your suggestion.  But, it seems to me
that there are two lifetimes, and we have to
keep them distinct.

Soliman Hesham wrote:

>>    preconfigured Kbm                    ........
> 

The lifetime of the BU indicates how long the care-of
address is valid.  However, Jari's point was that, in
case there is no valid care-of address, the key would
be vulnerable to loss if it were still tied to the
lifetime of the BCE.  My belief is that in this case
it is a mistake to make the association between the
lifetimes.  In fact, I think it is a mistake to _ever_
make the association, but I don't want to get diverted
into that discussion just now.

BTW, the upper bound on the lifetime in the Binding
Update would otherwise surely be sufficient, since
that is defined to be "infinity" :-).

Regards,
Charlie P.