Subject: RE: HA nreliability Problem Statement [was Re: [Mip6] IETF59: Minutes of MIP6 WG meeting]

From: "Soliman Hesham" <[email-masked]>
Date: Sun, 25 Apr 2004 04:25:30 -0400

> >=> Of course the above is not correct. There _is_
 > >a single point of failure problem and the fact
 > >that more than one HA can be supported is actually
 > >irrelevant because they can't serve the same HoA.
 > >In this regard there is no difference between MIPv4 and
 > >MIPv6. So I don't know why we can't have one protocol
 > >for both.
 > 
 > JF> I don't agree with the point because according to MIP6 all the HA
 > coexist on the same link
 >  called the "home link". So MN can switch from one HA to 
 > another in case of
 > its serving HA failure
 >  keeping its HoA same. That's why there is no single point 
 > of failure and
 > that is the purpose of providing
 > multiple HAs on the same link. This differs mip6 from mip4.
 > 

=> You seem to imply that MIPv4 doesn't allow two HAs on the same link (?)
I'd like to know why this is the case.

 > >=> No. If you have redundant HW there is no problem
 > >unless both planes fail (active and standby). I've
 > >worked with product development of such systems for years
 > >and the probability of this happening is pretty much nil if
 > >the system is designed well.
 > 
 > JF>There are problems of failure detection, switching from 
 > one HA to other
 > and security problems etc.

=> No. If you have HW redundancy then the "two"
HAs look like a single entity to the IP layer.
Failure detection, switching ...etc are all handled
internally. There are no security issues here.

Hesham

 > 
 > Thanks
 > Jahanzeb
 > 
 > 
 > 
 > 
 > 
 > 
 > ----- Original Message ----- 
 > From: "Soliman Hesham" <[email-masked]>
 > To: "Jahanzeb Faizan" <[email-masked]>; "Mohan Parthasarathy"
 > <[email-masked]>; "Ryuji Wakikawa" 
 > <[email-masked]>; "Gopal
 > Dommety" <[email-masked]>
 > Cc: <[email-masked]>; <[email-masked]>
 > Sent: Saturday, April 24, 2004 12:52 AM
 > Subject: RE: HA nreliability Problem Statement [was Re: 
 > [Mip6] IETF59:
 > Minutes of MIP6 WG meeting]
 > 
 > 
 > 
 >  > Actually in MIP6 multiple HAs are supported so there is no
 >  > single point of
 >  > failure problem.
 >  > The problem lies in the mip6 protocol itself. These problems
 >  > are related to
 >  > failure detection,
 >  > failure recovery, security  etc.. (discussed in our draft
 >  > http://www.ietf.org/internet-drafts/draft-jfaizan-mipv6-ha-re
 >  > liability-01.txt )
 > 
 > => Of course the above is not correct. There _is_
 > a single point of failure problem and the fact
 > that more than one HA can be supported is actually
 > irrelevant because they can't serve the same HoA.
 > In this regard there is no difference between MIPv4 and
 > MIPv6. So I don't know why we can't have one protocol
 > for both.
 > 
 > We can certainly solve the problem with a redundant
 > HA that provides redundancy below the IP layer
 > (i.e. HW). This is up to vendors to decide.
 > 
 > 
 >  >
 >  > Even if we have redundant hardware these problems exists in
 >  > MIP6.
 > 
 > => No. If you have redundant HW there is no problem
 > unless both planes fail (active and standby). I've
 > worked with product development of such systems for years
 > and the probability of this happening is pretty much nil if
 > the system is designed well.
 > 
 > Hesham
 > 
 > ========================================================
 > This email may contain confidential and privileged material 
 > for the sole
 > use of the intended recipient.  Any review or distribution 
 > by others is
 > strictly prohibited.  If you are not the intended recipient 
 > please contact
 > the sender and delete all copies.
 > ========================================================
 > 
 > 

_______________________________________________
Mip6 mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/mip6

---

From: "Jahanzeb Faizan" <[email-masked]>
Date: Sun, 25 Apr 2004 13:03:05 -0500

>I'd like to know why this is the case.

JF> I don't mean that MIP4 can't have two HAs on the same link. It could
have but the point is
in MIP6 there is builtin suppport for multiple HAs ( refering to anycast
addressing scheme, Dynamic
HA discovery ...) which differs it from MIP4.

>internally. There are no security issues here.

JF> But this is not the way the routers are deployed on the link. we always
have redundant routers over the IP layer.
That is why IETF came up with VRRP4 and VRRP6 standards.

The issue over here is not about providing redundancy above or below the IP
layer. We can leave this issue to the vendors.
The point is that does not matter how the redundancy is provided the
"protocol should be reliable and capable of providing
seamless,efficient and secure failover".

Thanks
Jahanzeb
----- Original Message ----- 
From: "Soliman Hesham" <[email-masked]>
To: "Jahanzeb Faizan" <[email-masked]>; "Mohan Parthasarathy"
<[email-masked]>; "Ryuji Wakikawa" <[email-masked]>; "Gopal
Dommety" <[email-masked]>
Cc: <[email-masked]>; <[email-masked]>
Sent: Sunday, April 25, 2004 3:25 AM
Subject: RE: HA nreliability Problem Statement [was Re: [Mip6] IETF59:
Minutes of MIP6 WG meeting]

Hesham