Subject: Re: [Mipshop] Re: [Mip6] Mobile IPv6 Interop Testing Draft

From: "T.J.Kniveton" <[email-masked]>
Date: Fri, 24 Sep 2004 08:41:21 -0700

Hi Keiichi,

Sorry it took me 11 months to reply. But thanks for your comment. Right 
now we are revising this draft, and the virtual home link is one topic 
to revisit. Of course, there have been various discussions about 
virtual home links since then.

In terms of configuring the home agent end to allow the right prefix 
and routing info, I would imagine a few couple possibilities that might 
work which I will try to describe.

1. The first scenario you described: a physical link and then multiple 
point-to-point tunnels. The physical link owns the prefix, but the 
local and remote addresses of the tunnel also come from that prefix. If 
necessary, a host route for the MN can be added with the tunnel 
interface as outgoing interface. rtadvd would also have to be signaled 
to send advertisements on each tunnel (haven't tried that personally; 
hopefully it's possible).

2. The physical link does, or does not exist. Either way, bridging is 
enabled between all of the tunnels and either a virtual or real link, 
which owns the prefix. The tunnel has a local and remote address on a 
different prefix (or no address, depending on tunneling used), but then 
the home address is configured from RAs that are echoed to the tunnel 
by the bridge.

3. ? There are probably more ways to do this.

On Oct 24, 2003, at 5:32 AM, Keiichi SHIMA / 島慶一 wrote:

> Hello Samita and T.J.,
>
> It is very interesting and good idea to establish a remote test
> environment. (and we are interested in participating the test, of
> course :-)
>
> By the way, I have a question (or concern) about the virtual home link
> described in Section 8 in the draft.
>
> Section 8 proposes the method for mobile node implementers to test
> 'returning to home' with other home agent vendor's implementation,
> even when the mobile node cannot access the real home link of the home
> agent.
>
> My question is, how is a home agent (and a home link) configured?
>
> I imagined the following network, for example.
>
>
>       ----+----------  home link P::/64
>   	  |
>           |P::1 (home agent address)
>        IF1|200.0.0.1
>        +--+-+
>        | HA |    IF3(200.0.0.1 - 100.0.0.1)
>        +--+-+
>        IF2|
> 	  |
>      ((Internet))
> 	  |
> 	  |
>        ---+---------+------------ visited link of MN tester Q::/64
> 	      	    |
> 	      	    |Q::100 (care-of address)
> 	      	 IF1|100.0.0.1
> 	      	 +--+-+
>        	       	 | MN |   IF2(100.0.0.1-200.0.0.1)
> 		 +----+
>
> HA has physically two interfaces, IF1 and IF2.  In this case, IF2 has
> nothing to do with this scenario, I ignore it.  HA also has one tunnel
> interface IF3 between 200.0.0.1 and 100.0.0.1.
>
> MN has physically one interface IF1, and one tunnel interface IF2
> between 100.0.0.1 and 200.0.0.1.
>
> The draft says, MN receives a router advertisement for home link from
> HA via the tunnel interface IF2.  However I think it is difficult,
> since HA must have two different interfaces and those interfaces must
> be assigned the same prefix (in this case, P::/64).  This means HA is
> required to support a kind of multi-link subnet technology.  (Or did I
> misread?)
>
> If there is no physical home link, I think it is possible to configure.
> For example,
>
>        +--+-+  IF1(200.0.0.1 - 100.0.0.1)
>        | HA |       P::1/64 (home address)
>        +--+-+
>        IF2|200.0.0.1
> 	  |
>      ((Internet))
> 	  |
> 	  |
>        ---+---------+------------ visited link of MN tester Q::/64
> 	      	    |
> 	      	    |Q::100 (care-of address)
> 	      	 IF1|100.0.0.1
> 	      	 +--+-+
>        	       	 | MN |   IF2(100.0.0.1-200.0.0.1)
> 		 +----+
>
> In this case, I see no problem.  However, this scenario requires as
> many home subnets as the number of mobile nodes, since HA must arrange
> different tunnel interface and home prefix for each mobile node.
>
> I don't think the former scenario is not appropriate.  It is of course
> more efficient than the latter, if HA can do that.  But I just think
> not so many home agent can do it.  I may be wrong...
>
> Best Regards,
> ---
> Keiichi SHIMA
> IIJ Research Laboratory <[email-masked]>
> KAME Project <[email-masked]>
>
> _______________________________________________
> Mipshop mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/mipshop

_______________________________________________
Mip6 mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mip6

---

From: "T.J.Kniveton" <[email-masked]>
Date: Fri, 24 Sep 2004 08:44:43 -0700

The idea of that setup is just to get some rudimentary testing of MN 
returning home without it physically going to the home agent. Of 
course, face to face interops are necessary to get truly good test 
coverage. And if you are in favor of deploying virtual home networks, 
well.. then you can just skip that section of the draft. :-)

On Oct 24, 2003, at 12:22 PM, Ed Remmell wrote:

> Gee, it seems like it will be difficult to test the "MN return-to-home"
> and/or "MN move-from-home" scenarios this way, but no biggie, I'd 
> prefer
> if MIPv6 was deployed using virtual home networks implemented internal
> to the HA anyways since that's a big simplification to MIPv6 protocol
> operation. So, we probably won't test MN operation on the home link via
> this remote testing, instead our MN will always be attached to a 
> foreign
> link. Still, you can get some good test coverage this way.
>
> Thanks.
> - Ed
>
>> -----Original Message-----
>> From: [email-masked] [mailto:[email-masked]] On
>> Behalf Of Samita Chakrabarti
>> Sent: Friday, October 24, 2003 12:17 PM
>> To: [email-masked]
>> Cc: [email-masked]; [email-masked]
>> Subject: Re: [Mip6] Mobile IPv6 Interop Testing Draft
>>
>>
>>
>>
>> We need to discuss more and flush out the configuration of HA
>> and virtual home tunnel without changing the HA
>> implementation. Working group comments would be helpful for this.
>>
>>>
>> I think the draft meant virtual tunnel interface. The idea is
>> that the MN would setup the tunnel when it thinks it comes
>> back home and when it is away, it should disable the tunnel
>> and thus not receive any HA adv. It would require some
>> special configuration on HA side. I don't know if that is not
>> possible or complicated - TJ and others in the design team
>> may have comments on that.
>>
>>> If there is no physical home link, I think it is possible to
>>> configure. For example,
>>>
>> This scenario looks ok to me for adv. But not sure how HA
>> would receive packets from CN to relay to MN on a different tunnel.
>>
>> Thanks,
>> -Samita
>>
>>
>> https://www.ietf.org/mailman/listinfo/mip6
>>
>> ---
>> Incoming mail is certified Virus Free.
>> Checked by AVG anti-virus system (http://www.grisoft.com).
>> Version: 6.0.522 / Virus Database: 320 - Release Date: 9/29/2003
>>
>>
>
> ---
> Outgoing mail is certified Virus Free.
> Checked by AVG anti-virus system (http://www.grisoft.com).
> Version: 6.0.522 / Virus Database: 320 - Release Date: 9/29/2003
>
>
>

---

From: "T.J.Kniveton" <[email-masked]>
Date: Fri, 24 Sep 2004 09:09:09 -0700

On Nov 6, 2003, at 11:41 AM, Bound, Jim wrote:

> I don't think that is required I hope.  But we have a lot of people
> banging on IPv6 issues that are good operational issues for
> configuration and use that are not relative to the standard for writing
> the code. But, is good input to implementors, and this point is very
> useful.  We will never ship standards on time if we try to solve world
> hunger and dictate to implementation (which will usually be ignored). 
> We
> have enough work to get the standards functions done correctly.  The
> other thing is in my work from now on if I put little hints in specs
> that are not really part of the standard I am going to put clear huge
> text that this is not part of the standard but information for
> implementors and operators.  Or something.
>
> thanks
> /jim
>
>> From: [email-masked] [mailto:[email-masked]]
>> On Behalf Of Samita Chakrabarti
>> Sent: Thursday, November 06, 2003 1:19 PM
>> To: Bound, Jim
>> Cc: [email-masked]; [email-masked]; [email-masked]
>> Subject: RE: [Mipshop] RE: [Mip6] Mobile IPv6 Interop Testing Draft
>>
>>
>>
>>
>>> This is fine optimization for lab or testing but don't expect
>>> production MN's to do this or assume it in any specs std or
>>> operational.

Jim,

Was there some sort of operation in particular that we shouldn't expect 
MNs to do? Are you talking about the dual-stack operations mentioned in 
this message? Or the virtual home tunneling we were talking about in 
the other messages? Or were you saying that this spec in general should 
be clearly stated to be for testing only?

Some people are interested in virtual home links as we know, but we can 
state more clearly that this draft is intended for testing purposes, if 
you think it needs to be emphasized.

TJ

>>>
>>
>> Agreed. The draft only talks about the testing scenario.
>> Perhaps it can be clarified further in the document to avoid
>> any confusion.
>>
>> Thanks,
>> -Samita
>>
>>
>>>> From: [email-masked] [mailto:[email-masked]]
>>>> On Behalf Of Samita Chakrabarti
>>>> Sent: Monday, October 27, 2003 2:27 PM
>>>> To: [email-masked]
>>>> Subject: Re: [Mipshop] RE: [Mip6] Mobile IPv6 Interop
>> Testing Draft
>>>>
>>>>
>>>>
>>>>
>>>>>
>>>>>    5.3.1. Home Agent
>>>>>
>>>>>     -  Company and contact information
>>>>>
>>>>>     -  Home agent IPv6 address and the corresponding IPv4
>>>> addresses (if
>>>>>        dual stack)
>>>>>
>>>>> --> Is there more than one corresponding IPv4 address
>> for one IPv6
>>>>> address ?
>>>>>
>>>>
>>>>
>>>> Actually listing IPv4 addresses are not necessary. But
>>>> sometimes knowing the corresponding IPv4 address helps in
>>>> finding out whether the node is dead or having trouble with
>>>> IPv6 connection. Thus one IPv4 address on the node should be
>>>> fine, I think.
>>>>
>>>>>     -  List of home-addresses it assigns.  This list must
>>>> also indicate
>>>>>        which home-addresses are presently used and which
>>>> are available.
>>>>>        Example:
>>>>>        HOA1 (used by KEIO Univ.- contact name)
>>>>>        HOA2 (available)
>>>>>        HOA3 (available)
>>>>>
>>>>> --> Is there more than one home-address for one home agent ?
>>>>>
>>>>
>>>> Yes. It depends on the administrator of the home-agent. I
>>>> assume, usually they would allow multiple mobile-nodes
>> for testing.
>>>>
>>>>
>>>> -Samita
>>>>
>>>>
>>>>>
>>>>> From: Samita Chakrabarti [mailto:[email-masked]]
>>>>> Sent: 20 October 2003 19:54
>>>>> To: [email-masked]; [email-masked]
>>>>> Subject: [Mip6] Mobile IPv6 Interop Testing Draft
>>>>>
>>>>>
>>>>>
>>>>> As per Basavaraj Patil's recommendation, a mip6-interop design
>>>>> team
>>>>> has been formed and the team has worked on producing the
>>>> first draft
>>>>> on the Mobile IPv6 remote interop testing requirements,
>>>> scenarios and
>>>>> procedures.
>>>>>
>>>>> The draft has been submitted as an individual draft for
>> now, but
>>>>> it is targeting to be a working group draft in the next
>> revision.
>>>>> It is available through T.J Kniveton's webpage until the draft
>>>>> becomes available at the IETF directory.
>>>>>
>>>>>
>>>> http://www.mipv6.org/specs/draft-kniveton->
>>> mipv6-remote-testing-00.txt
>>>>>
>>>>>
>>>>> Thanks.
>>>>>
>>>>> The mip6-interop design team.
>>>>> T.J Kniveton,
>>>>> Basavaraj Patil,
>>>>> Hesham Soliman,
>>>>> Henrik Petander,
>>>>> Samita Chakrabarti
>>>>>
>>>>>
>>>>> [email-masked] https://www1.ietf.org/mailman/listinfo/mipshop
>>>>>
>>>>
>>>>
>>>> [email-masked] https://www1.ietf.org/mailman/listinfo/mipshop
>>>>
>>>
>>
>>