Subject: RE: [Mip6] New Draft with Bootstrapping Protocol

From: Gerardo Giaretta <[email-masked]>
Date: Thu, 09 Dec 2004 14:32:40 +0100

Hi Junghoon,

~snip~

> 
> Could you give me information about discussions and the 
> decision of the problem statement design team ?
> 

if interested, you can find the archives of Bootstrapping PS Design Team
Discussion at http://vesuvio.ipv6.tilab.com/pipermail/mip6-boot/

Regards,
--Gerardo

> In my opinion, the Mobile IP service is an IP-based service. 
> So only authenticated and authorizaed
> MN can access the network and can use the Mobile IP service. 
> If we decouple the network access service from mobility 
> serivice, unauthorized MN can access the visited domain's network.
> 
> Related with this, draft-ietf-mip6-bootstrap-ps-01.txt has a 
> following statement.
> Section 6.  Network Access and Mobility services
> [Page 14]
> Only having Mobile IPv6 service is not possible, since the 
> Mobile IPv6 protocol requires ability to send and receive 
> IPv6 packets.
> 
> 
> Junghoon
> 
> >             jak
> > 
> > 
> > ----- Original Message ----- 
> > From: "Junghoon Jee" <[email-masked]>
> > To: "James Kempf" <[email-masked]>; "Tschofenig Hannes"
> > <[email-masked]>; <[email-masked]>
> > Sent: Monday, December 06, 2004 11:04 PM
> > Subject: Re: [Mip6] New Draft with Bootstrapping Protocol
> > 
> > 
> > > Hi ! James,
> > >
> > > As I already said in this MIP6 mailing-list thorough review of
> > draft-ietf-mip6-bootstrap-ps-01.txt,
> > > I think we have to decide what scenario our MIP6 
> bootstrapping solution
> > should support.
> > >
> > > I havea question about this.
> > >
> > > Does our bootstrapping solution should consider 
> infrastructure-less
> > scenario or not ?
> > >
> > > For your convinence,
> > > I attach my review of draft-ietf-mip6-bootstrap-ps-01.txt.
> > > This can be helpful for our discussion.
> > > 
> --------------------------------------------------------------
> ------------
> > --------------------
> > > Q1. Should the network access service be always performed 
> when a MN
> > bootstraps ?
> > >
> > > Section 6.  Network Access and Mobility services
> > > [Page 14]
> > > Only having Mobile IPv6 service is not possible, since 
> the Mobile IPv6
> > protocol requires
> > > ability to send and receive IPv6 packets.
> > > => It seems that network authentication service should be always
> > performed.
> > >
> > > Section 7.1  Mobility Service Subscription Scenario
> > > => There is no words about network authentication service.
> > >
> > > Q2. Does we have to consider the case of  
> infrastructure-less scenario
> > > when we develop a bootstrapping solution or not ?
> > >
> > > Section 7.4 Infrastructure-less scenario
> > > [Page 17]
> > > This specific scenario is not supported in this document. 
>  The reason
> > > for this is described in Section 9.
> > >
> > > Section 9. Security Considerations
> > > Thus, the case of infrastructure-less network where there 
> is absolutely
> > > no pre-mediated trust is kept outside of scope of this document.
> > >
> > > => It seems that we don't need to consider the infrastructure-less
> > scenario
> > >      when we create a bootstrapping solution.
> > > 
> --------------------------------------------------------------
> ------------
> > ---------------
> > >
> > > Junghoon
> > >
> > >
> > > ----- Original Message ----- 
> > > From: "James Kempf" <[email-masked]>
> > > To: "Tschofenig Hannes" <[email-masked]>; 
> <[email-masked]>
> > > Sent: Tuesday, December 07, 2004 3:22 AM
> > > Subject: Re: [Mip6] New Draft with Bootstrapping Protocol
> > >
> > >
> > > >
> > > >
> > > > > > Yes, that's the idea. Most hotspots today in the US and some
> > > > > > I've used in Europe and Japan don't use EAP. Also, there's
> > > > > > the enterprise and nonintegrated mobility service provider
> > > > > > examples. You'll recall that we discussed the nonintegrated
> > > > > > case in the problem statement design team. An EAP on network
> > > > > > entry bootstrapping approach won't work for that case.
> > > > >
> > > > > that's certainly true and also true for network 
> access scenarios. the
> > > > > drawbacks of these approaches are also known. i am, 
> however, not quite
> > > > sure
> > > > > what you would like to standardize in this case.
> > > > >
> > > >
> > > > A specified, interoperable way of doing HA 
> configuration without AAA
> > would,
> > > > I think, be useful. As you mention, most of the rest 
> can be handled by
> > > > IKEv2. Perhaps actually writing down how to use IKEv2 
> for bootstrapping
> > in
> > > > this context would also be useful as an example, since 
> the IKEv2 spec is
> > 108
> > > > pages long, and Vijay's draft probably shouldn't go 
> into bootstrapping
> > in
> > > > detail, since it needs to be applicable to both cases.
> > > >
> > > >             jak
> > > >
> > > >
> > > >
> > > > _______________________________________________
> > > > Mip6 mailing list
> > > > [email-masked]
> > > > https://www1.ietf.org/mailman/listinfo/mip6
> > 
> >
> 

Gruppo Telecom Italia - Direzione e coordinamento di Telecom Italia S.p.A.

====================================================================
CONFIDENTIALITY NOTICE
This message and its attachments are addressed solely to the persons
above and may contain confidential information. If you have received
the message in error, be informed that any use of the content hereof
is prohibited. Please return it immediately to the sender and delete
the message. Should you have any questions, please send an e_mail to
[email-masked]. Thank you
====================================================================

_______________________________________________
Mip6 mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mip6

---

From: "Junghoon Jee" <[email-masked]>
Date: Fri, 10 Dec 2004 09:06:30 +0900

Hi, Genardo,

Thank you very much for this information.

Junghoon

----- Original Message ----- 
From: "Gerardo Giaretta" <[email-masked]>
To: "Junghoon Jee" <[email-masked]>
Cc: "James Kempf" <[email-masked]>; <[email-masked]>
Sent: Thursday, December 09, 2004 10:32 PM
Subject: RE: [Mip6] New Draft with Bootstrapping Protocol

Hi Junghoon,

~snip~

Regards,
--Gerardo