Subject: Re: [Mip6] Alternate care of address????

From: "Anurag Uxa" <[email-masked]>
Date: Fri, 21 Jan 2005 13:22:10 +0530

Very true Francis.
The care-of address for the binding MUST be used as the Source  Address in
the packet's IPv6 header, unless an Alternate Care-of
 Address mobility option is included in the Binding Update  message. This
option MAY be included when the mobile node so
 desires, and MUST be included if the mobile node can not  be assured that
the IPsec AH protocol is used to secure the
 Binding Update. The ESP protocol will not be able to  protect care-of
addresses in the IPv6 header. Mobile IPv6
 implementations which are unaware of how IPsec secures their messaging
will therefore need to use the Alternate
 Care-of Address option.
But question comes here. ESP protocol may be able to protect AltCoA but how
will it protect CoA. Every time when Mn moves to foreign should it form two
addresses one called CoA and another AltCoA? Agree with "Mn will send
packet to HA with source address as CoA and with AltCoA"
Q1.but which basis it will select this perticular address should me mine
CoA and another AltCoA?
Q2. Its every time overhead for creating two or more address?

Regards
Anurag Uxa
Communication & Embedded systems
Larsen & Toubro Infotech Limited
# 2, Church street, Bangalore - 01
phone :080-5323734/5/6 Extn: 122

------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------

( ) L&T Infotech Proprietary & Confidential
(+) L&T Infotech Confidential
( ) L&T Infotech Internal Use only
( ) General Business Information
------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------

                      Francis Dupont                                                                                                        
                      <Francis.Dupont@enst-b        To:       "Awadhesh Paswan" <[email-masked]>                           
                      retagne.fr>                   cc:       [email-masked]                                                                 
                      Sent by:                      Subject:  Re: [Mip6] Alternate care of address????                                      
                      [email-masked]                                                                                                 

                      20/01/2005 06:53 PM                                                                                                   

 In your previous mail you wrote:

             Can somebody tell me why alternate care of address is used in
   MIPv6?

=> in two cases:
 - when the care of address is not the source address
 - when the care of address needs to be repeated in a protected part
   of the packet.

   when should Mobile node send Binding update with Alternate care of
   address?

=> in one of the two cases. Please note that home registrations are
protected by IPsec ESP in transport mode and this is in the second case.

Regards

[email-masked]

_______________________________________________
Mip6 mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mip6

______________________________________________________________________

______________________________________________________________________

_______________________________________________
Mip6 mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mip6

---

From: Francis Dupont <[email-masked]>
Date: Fri, 21 Jan 2005 12:05:50 +0100

will it protect CoA.

=> when an AltCoA option is used because of ESP, the same address is put
in the source address field of the IPv6 header (the CoA) and in the
option (the AltCoA).

Regards