Subject: [Mip6] Extension header order

From: "Vasudevan Pillai, Padmakumar A" <[email-masked]>
Date: Tue, 11 Jan 2005 11:55:52 +0530

Hi Jari,

Can we have more than two destination option header possible in an ipv6
packet.

2460 says

"Each extension header should occur at most once, except for the

   Destination Options header which should occur at most twice (once

   before a Routing header and once before the upper-layer header).

   If the upper-layer header is another IPv6 header (in the case of IPv6

   being tunneled over or encapsulated in IPv6), it may be followed by

   its own extension headers, which are separately subject to the same

   ordering recommendations."

But consider the following case

1.      The Home Address option MUST be placed as follows: 
*       After the routing header, if that header is present 
2.      Before the Fragment Header, if that header is present 
3.      Before the AH Header or ESP Header, if either one of those
headers are present 

Extending the above rules, Consider the scenario Two MN communicating
each other. Consider also that there exists a security association
between these 2. Also the application generate packets with inner and
outer dst-ops header and a Routing header type 0.

IPv6

Destination Option (Outer)

Routing Header - Type 0

Dst-Ops (Inner)

After Applying IPSec Policy

IPv6

Destination Option (Outer)

Routing Header - Type 0

AH

Destination Option (Inner)

Assume that both the MN are moved and are bound each other then The
packet format would be

IPv6

Destination Option (Outer)

Routing Header - Type 0

Routing Header - Type 2

Destination Option (Home Address Option)

AH

Destination Option (Inner)

And if fragmentation happens in the worst case : 

IPv6

Destination Option (Outer)

Routing Header - Type 0

Routing Header - Type 2

Destination Option (Home Address Option)

Fragment Header

AH

Destination Option (Inner)

Is that possible.

Thanks and regards

pav

_______________________________________________
Mip6 mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mip6

---

From: Vijay Devarapalli <[email-masked]>
Date: Wed, 12 Jan 2005 12:03:00 -0800

yup. your packet formats are correct.

Vijay

Vasudevan Pillai, Padmakumar A wrote:
> Consider the scenario Two MN communicating 
> *_After Applying IPSec Policy_*
> 
> IPv6
> 
> *_Assume that both the MN are moved and are bound each other then The 
> packet format would be_*
> 
> IPv6
> 
> *_And if fragmentation happens in the worst case : _*
> 
> IPv6
> 
> ------------------------------------------------------------------------
>