Subject: RE: [Mip6] Security Section Commentsondraft-ietf-mip6-bootstrap-ps-01.txt

From: Gerardo Giaretta <[email-masked]>
Date: Wed, 23 Feb 2005 12:03:41 +0100

Hi James,

please see below..

> 
> Hi John,
> 
> >> In addition to these attacks, there are other 
> considerations that are
> >> important in achieving a good security design. Because mobility and
> network
> >> access authentication are separate services, any keys for 
> these services
> >> need to be cryptographically separate, separately named, and have
> separate
> >> lifetimes that are not exceeded. This is necessary because 
> a mobile host
> >> must be able to move from one serving (or roaming) network access
> provider
> >> to another without needing to change its mobility access provider.
> Finally,
> >> basic cryptographic processes must provide for multiple 
> algorithms in
> order
> >> to accommodate the widely varying deployment needs.
> >
> >Could you more fully explain this statement.
> >
> >Because mobility and network access authentication are 
> separate services
> ...
> >
> >One one level, in some deployments, these are indeed 
> seperate.  However, in
> some,
> >you want fate-sharing between the two - if either fails, the 
> other should
> fail.
> >Since mobility is needed (in some deployments) network access
> authentication
> >is not sufficient.
> >
> >However, I think you might be suggesting that the network 
> access provider
> may be
> >seperate from the mobility access provider, therefore they 
> keying material
> needs
> >to be seperate.  Is this more along the lines of what you mean?
> 
> Actually, I think we want to keep the keys separate even if 
> the network
> access provider and mobility service provider are the same. 
> From a security
> standpoint, it makes sense to maintain separate keys, so that 
> if one is
> compromised the other won't be.  I suppose one could argue 
> that "well, if
> the network access service is compromised, the user is so hosed, so it
> really doesn't matter if mobility service is compromised" but 
> the othe way
> around is something different. If the mobility service key is 
> compromised,
> the mobile host could stay put at the same place and 
> re-establish secure
> mobility access service, as long as network access service is not
> compromised. If the two keys are the same, then the mobile 
> host must go
> through re-establishing secure network access service before mobility
> service security can be repaired.
> 
> Does this make sense? If so, perhaps the draft should make this point
> explicitly.
> 

I think this makes sense. Even if the network access provider and the
mobility service provider are the same, network access and mobility are
different services. For this reason the keys must be kept separate and I
agree we should mention this explicitly in the draft.

Note that obviously you can exploit the network access keying material
(i.e. EAP keying hierarchy) to derive cryptographically separated keys
for mobility service. But this could be solution specific and I'm not
sure we should mention it in the problem statement draft.

--Gerardo

>             jak
> 
> 
> 
> 
> 
> _______________________________________________
> Mip6 mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/mip6
> 

Gruppo Telecom Italia - Direzione e coordinamento di Telecom Italia S.p.A.

====================================================================
CONFIDENTIALITY NOTICE
This message and its attachments are addressed solely to the persons
above and may contain confidential information. If you have received
the message in error, be informed that any use of the content hereof
is prohibited. Please return it immediately to the sender and delete
the message. Should you have any questions, please send an e_mail to 
[email-masked]. Thank you
====================================================================

_______________________________________________
Mip6 mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mip6

---

From: Gerardo Giaretta <[email-masked]>
Date: Fri, 25 Feb 2005 15:39:54 +0100

James,

the text sounds good. 

Do you think we need to mention explicitly that in this case we are
referring to scenarios where access service authorizer and mobility
service authorizer are the same? 
I'm not sure about that, since it is obvious that, if access service
authorizer and mobility service authorizer are different, the keys are
separate and the way you handle mobility service is orthogonal to the
way you handle access service.

--Gerardo

> -----Original Message-----
> From: James Kempf [mailto:[email-masked]] 
> Sent: Thursday, February 24, 2005 7:13 PM
> To: Gerardo Giaretta; [email-masked]
> Cc: [email-masked]
> Subject: Re: [Mip6] Security Section 
> Commentsondraft-ietf-mip6-bootstrap-ps-01.txt
> 
> 
> Gerardo,
> 
> How about if we change the sentence to:
> 
> "In addition, for scenerios where the access service 
> authorizer and mobility
> service provider are different, maintaining separate keys 
> allows the host to
> move from one access network to another without undergoing a 
> new round of
> mobility service authorization."
> 
>         jak
> 
> 
> ----- Original Message ----- 
> From: "Gerardo Giaretta" <[email-masked]>
> To: <[email-masked]>; <[email-masked]>
> Cc: <[email-masked]>
> Sent: Thursday, February 24, 2005 5:18 AM
> Subject: RE: [Mip6] Security Section
> Commentsondraft-ietf-mip6-bootstrap-ps-01.txt
> 
> 
> Hi John and James,
> 
> please see a comment below.
> 
> >
> >  In addition to these attackes, there are other
> > considerstions that are important
> >  in achieving a good security design. As mobility and network
> > access authentication
> >  are seperate services, keys for these services need to be
> > cryptographically
> >  seperate, seperately named and have seperate lifetimes. This
> > is needed because
> >  if one service is compromised, the other service is not.
> > This is necessary
> >  so that a mobile host can move from one serving (or roaming)
> > network access
> >  provider to another without needing to change its mobility
> > access provider.
> >  Finally, basic cryptographic processes must provide for
> > multiple algorithms in order
> Since it's not clear to me which scenario you are referring to, could
> you please clarify on this sentence of your proposed text:
> 
> "
> This is necessary  so that a mobile host can move from one serving (or
> roaming) network access provider to another without needing to change
> its mobility access provider.
> "
> 
> Thanks,
> --Gerardo
> 
> 
> > John
> >

---

From: Gerardo Giaretta <[email-masked]>
Date: Fri, 25 Feb 2005 15:49:23 +0100

John,

just to understand correctly what text you'd like to replace, are you
suggesting to change the text to:

"
In addition to these attacks, there are other considerations that are
important in achieving a good security design. As mobility and network
access authentication are seperate services, keys for these services
need to be cryptographically seperate, seperately named and have
seperate lifetimes. This allows the mobile node to change access
networks without performing a new mobility service authorization.
Finally, basic cryptographic processes must provide for multiple
algorithms in order to accommodate the widely varying deployment needs.
"

--Gerardo

> From: [email-masked] [mailto:[email-masked]] 
> Sent: Friday, February 25, 2005 7:09 AM
> To: [email-masked]; [email-masked]
> Cc: [email-masked]
> James & Gerardo,
> I get Gerardo's point, but the text starts to get unwieldy.
> Howabout something simple like:
> 
>  It allows the mobile node to change access networks without
>  performing a new mobility service authorization.
> 
> I would like not to get bogged down in deployment models, etc.
> but just discuss what the benefit is for seperating the keys.
> Maybe its best to stick to higher level issues; service providers
> will deploy as they see fit, but the draft should talk about
> the more egeneral properties and what it allows for.
> 
> John
> 
> 
> 
> > From: ext James Kempf [mailto:[email-masked]]
> > Sent: 24 February, 2005 20:13
> > To: Gerardo Giaretta; Loughney John (Nokia-NRC/Helsinki)
> > Cc: [email-masked]

---

From: [email-masked]
Date: Mon, 28 Feb 2005 08:54:46 +0200

Hi Gerardo,

It seems that I forgot about my original text, and I didn't really
rewrite much!

Anyhow, what I meant to say was that this text should not be based
(or refer to) any specific scenario - by supporting cryptographically
seperate keys, deployments can get a benefit, which is that MNs don't
need to re-authenticate the mobility service if the MN changes access
network.  Its another story if deployments want this feature or not,
but that, as said, is another story.

John

> From: ext Gerardo Giaretta [mailto:[email-masked]]
> Sent: 25 February, 2005 16:49
> To: Loughney John (Nokia-NRC/Helsinki)
> Cc: [email-masked]; [email-masked]