Subject: Re: [Mip6] HA prefix = HoA prefix?

From: Alexandru Petrescu <[email-masked]>
Date: Fri, 04 Feb 2005 16:20:54 +0100

Vijay Devarapalli wrote:
> it is actually a bit restrictive.

I find it not restricctive but allowing one-interface HAs 
non-default-routers to exist.

> our HA implementation does not do this check.

Ours does.

> instead, it just checks if the HoA of the MN falls in one of the
> prefixes that the HA is configured to serve.

Ours doesn't.  Our HA is a standalone one-interface machine, does not 
serve a link's prefix, the link is served by a separate Gateway that is 
the Default Router for that link.

> RFC 3963 relaxes this requirement for Mobile Routers. a Mobile Router
> has an option of configuring its HoA from the Mobile Network Prefix
> (delegated to the Mobile Router for use in the Mobile Network). the
> Mobile Network Prefix can be different from the home prefix.

That's another issue.

Alex

> 
> Vijay
> 
> Pete McCann wrote:
> 
>> Hi,
>> 
>> My apologies if this question has been raised/answered here before.
>> 
>> 
>> Given the following text in RFC 3775, section 6.1.7:
>> 
>> 
>>> Home Registration (H)
>>> 
>>> The Home Registration (H) bit is set by the sending mobile node
>>> to request that the receiving node should act as this node's home
>>>  agent.  The destination of the packet carrying this message MUST
>>>  be that of a router sharing the same subnet prefix as the home 
>>> address of the mobile node in the binding.
>> 
>> 
>> 
>> does this imply that the HA address (the destination of the packet)
>>  must share the same prefix with the home address?
>> 
>> A possible alternative interpretation is that the router must have 
>> some interface on the home link but this is not necessarily used as
>>  the the destination of the packet.
>> 
>> Thoughts?
>> 
>> -Pete
>> 
>> 
>> _______________________________________________ Mip6 mailing list 
>> [email-masked] https://www1.ietf.org/mailman/listinfo/mip6
> 
> 
> 
> _______________________________________________ Mip6 mailing list 
> [email-masked] https://www1.ietf.org/mailman/listinfo/mip6

_______________________________________________
Mip6 mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mip6

---

From: Vijay Devarapalli <[email-masked]>
Date: Sun, 06 Feb 2005 23:23:45 -0800

Alex,

it doesnt matter whether the check is restrictive or not.
you can have your one-interface, non-default-router, HA
implementation either way.

Vijay

Alexandru Petrescu wrote:
> ------------------------------------------------------------------------
>