Subject: RE: [Mip6] Consensus call: draft-giaretta-mip6-aaa-ha-goals-00.txt

From: Gerardo Giaretta <[email-masked]>
Date: Tue, 08 Feb 2005 15:27:32 +0100

Hi Yoshi,

thanks for your comments. Please see below.. 

> 
> On Fri, Feb 04, 2005 at 11:54:11AM -0600, 
> [email-masked] wrote:
> > 
> > The goals/reasons for a standardized interface between the 
> HA and AAA
> > were discussed at IETF61 in Gerardo's I-D :
> > draft-giaretta-mip6-aaa-ha-goals-00.txt 
> > Such an interface is required from the perspective of 
> bootstrapping a
> > MN in operator owned network environments. 
> > 
> > We would like to make this I-D a working group document 
> that captures
> > the goals and requirements for the interface between the HA and AAA
> > and is used as input in the design of the bootstrapping 
> solution that
> > relies on AAA.
> 
> I agree on making the I-D as a WG document, but I think the I-D needs
> to be revised in terms of Scenario 2.
> 
> Scenario 2 would need more discussion, considering potential
> variations and complexity in integrating MIPv6 bootstrapping and
> network access authentication.  Especially, I don't think there is a
> WG consensus as to whether piggybacking MIPv6 parameters in EAP, or
> carrying them in some other ways (using AAA protocol, EAP lower layer
> and/or DHCP), or both should be supported.
> 

Surely there is no WG consensus on any of these mechanisms. This draft
aims at describing the possible scenarios/frameworks for the integration
between AAA and MIP6 and at identifying the related goals for AAA-HA
interface. It is not a solution draft. 

In particular, the purpose of section 4.2 was to list existing proposals
that fall in scenario 2 and to highlight that a single AAA-HA interface
can be designed for all these proposals, no matter if bootstrapping
parameters are carried by EAP, AAA protocol, EAP lower layer or DHCP. 

> Having said that, I think Scenario 2 should be described in most
> generic way at this moment, perhaps with integration of Figures 3 and
> 4 without mentioning piggybacking MIPv6 parameters in EAP, RADIUS or
> L2 specific extensions.
> 

Figures 3 and 4 have been included in order to highlight that the design
of the AAA-HA interface is independent from the bootstrapping solution
peculiarities in the AAA-MN path. 

Comments?

Regards,
--Gerardo

> Best regards,
> 
> Yoshihiro Ohba
> 
> 
> 
> > 
> > Please comment if you do not agree to making this a WG document and
> > your reasons by Feb 10th, 05. 
> > 
> > -Basavaraj
> > 
> > _______________________________________________
> > Mip6 mailing list
> > [email-masked]
> > https://www1.ietf.org/mailman/listinfo/mip6
> 
> _______________________________________________
> Mip6 mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/mip6
> 

Gruppo Telecom Italia - Direzione e coordinamento di Telecom Italia S.p.A.

====================================================================
CONFIDENTIALITY NOTICE
This message and its attachments are addressed solely to the persons
above and may contain confidential information. If you have received
the message in error, be informed that any use of the content hereof
is prohibited. Please return it immediately to the sender and delete
the message. Should you have any questions, please send an e_mail to 
[email-masked]. Thank you
====================================================================

_______________________________________________
Mip6 mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mip6

---

From: Yoshihiro Ohba <[email-masked]>
Date: Tue, 08 Feb 2005 17:46:04 -0500

Hi Gerardo,

> interface. It is not a solution draft. 

OK.  If the draft has more explicit description on this about Scenario
2 in particular, I am fine.

Regards,

Yoshihiro Ohba