Subject: [Mip6] Question about MIPv6 deployment issues

From: "Junghoon Jee" <[email-masked]>
Date: Mon, 21 Feb 2005 18:24:28 +0900

Hello, ALL.

During current discussions about MIPv6 bootstrapping, 
I've come up with several questions related with this.

1. Is the MIPv6 bootstrapping is a deployment issue or not ?

AFAIK, MIPv6 bootstrapping is for a wide spread deployment of MIPv6.
Currently MIP6 WG charters(http://www.ietf.org/html.charters/mip6-charter.html)  says about this like below,
"bootstrap mechanism for setting up security associations between the Mobile Node (MN) and Home Agent (HA) that would enable easier deployment of Mobile IPv6."

2. If the MIPv6 bootstrapping mechanism is a deployment issue,
Do you agree that a bootstrapping solution should be designed minimizing the change
of the current infrastructure ?

If your answer is YES,
I would like to ask you whether the use of DNSsec is a right choice for bootstrapping solution or not.
In my opinion, I think the use of DNSsec is NOT a right choice because the DNSsec is rarely deployed.

I don't agree the approach of requiring the rarely deployed protocol
to support the MIPv6 bootstrapping because the MIPv6 bootstrapping mechanism is 
originally for a easy deployment of the Mobile IPv6 protocol.

IMHO, the deployment of the network access AAA infrastructure is more likely easier 
than the wide spread deployment of DNSsec.

3. When we design a bootstrapping solution, do you agree to opening the 
MN's HA address information to anyone without any restriction ?

I think that the HA address information is not an public information that
can be easily accessible to anyone ,like using the public DNS.

If you agree to open this, what about opening the HA address to the public web server 
as Vijay made an example. 

--Junghoon

_______________________________________________
Mip6 mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mip6

---

From: "James Kempf" <[email-masked]>
Date: Tue, 22 Feb 2005 10:25:30 -0800

Junghoon,

Currently, there is only one ISP in the US that is offering IPv6 service
(NTT Verio) and nobody is offering Mobile IPv6. With so little deployment of
IPv6, restricting discussion to current IPv4 deployed technology is way too
pessimistic, IMHO. DNSSEC is an important, next generation security
technology for DNS, just as IPv6 itself is next generation technology for
the Internet, and Mobile IPv6 is for next generation mobility. So it makes
sense to include DNSSEC into bootstrapping, if one of the proposed
bootstrapping solution requires it, as we've suggested for bmip. Note that I
say "one of" here, because I don't believe there will be just a single
bootstrapping solution for all the scenerios covered by the problem
statement. Some of them don't require DNSSEC, but they are limited to
particular deployment situations.

            jak

----- Original Message ----- 
From: "Junghoon Jee" <[email-masked]>
To: <[email-masked]>
Sent: Monday, February 21, 2005 1:24 AM
Subject: [Mip6] Question about MIPv6 deployment issues

> Currently MIP6 WG
charters(http://www.ietf.org/html.charters/mip6-charter.html)  says about
this like below,
> "bootstrap mechanism for setting up security associations between the
Mobile Node (MN) and Home Agent (HA) that would enable easier deployment of
Mobile IPv6."
> as Vijay made an example.

----------------------------------------------------------------------------
----