Subject: [Mip6] Question about mip6-aaa framework 4

From: "Junghoon Jee" <[email-masked]>
Date: Mon, 21 Feb 2005 18:22:40 +0900

Hello, ALL.
I've come up with a question about Framework 4.

Alper says,
~~~~~~~~~~~~~~~~~~~~~~~~~~
Framework 4:
------------
A backend AAA protocol is executed between the HA and the AAA server in
response to the MIP6 signaling between the MN and the HA. Similar to the
use of AAA protocols with MIPv4 co-located care-of address case.

Related I-Ds:

draft-giaretta-mip6-aaa-ha-goals-00.txt
draft-yegin-mip6-aaa-fwk-00.txt

Discussion:
This one appears to be the most needed framework. It is assumed that MN
already knows the HA address. 
~~~~~~~~~~~~~~~~~~~~~~~~~~~~

=> What's the exact meaning of assumption of knowing the HA ?
Is this mean that the pre-configuration of the HA address to the MN ?
I would like to repeat my previous comments about this for clarity because there is no answer
about this.
"As I know, dynamic HA assignment is owing to the issues of the home agent discovery,
independent network management, local home agents and ease of deployment
as specified in the draft-ietf-mip6-bootstrap-ps-01.txt. Also it is very related with the home address assignment."

If the assumption means pre-configuration of HA address,
I have a question whether the framework 4 is for a MIPv6 bootstrapping or not.
If the HA address is pre-configured, the HoA address can be generated easily using
the prefix information of the HA address without using the IKEv2 processing between
the MN and HA. And more on this, the IKEv2 processing is performed using certificates without
using the dynamically assigned security keying material.
I think that the framework can be used for a general authentication and authorization processing
for a MN but, IMHO it is not so relevant to the MIPv6 bootstrapping.

AFAIK, the bootstrapping is for a dynamic configuration of HA, home address and security
keying material to support the MN's initial configuration set-up.

--Junghoon

_______________________________________________
Mip6 mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mip6

---

From: Alper Yegin <[email-masked]>
Date: Tue, 22 Feb 2005 12:36:29 -0800

Hi Junghoon,

> Is this mean that the pre-configuration of the HA address to the MN ?

It might be preconfigured, or learned via some other mechanism (e.g.,
DNS, DHCP, PANA, etc.)

> I would like to repeat my previous comments about this for clarity
because
> there is no answer
> about this.
> "As I know, dynamic HA assignment is owing to the issues of the home
agent
> discovery,
> as specified in the draft-ietf-mip6-bootstrap-ps-01.txt. Also it is
very
> related with the home address assignment."
> 
> I have a question whether the framework 4 is for a MIPv6 bootstrapping
or
> not.

Fwk 4 provides MN-HA SA generation. Therefore it solves a subset of the
"bootstrapping" problem. 

> the MN and HA. And more on this, the IKEv2 processing is performed
using
> certificates without
> I think that the framework can be used for a general authentication
and
> authorization processing

True. But the point is, not all bootstrapping issues have to be solved
by the same protocol/mechanism. It's OK to solve different parts of the
bootstrapping problem by using separate protocols/mechanisms. I tried to
capture that in my message (subject: "MIP6 bootstrapping solution
sets").

I hope this makes sense.

Alper