Subject: [Mip6] draft-ietf-mip6-precfgKbm-03.txt`

From: "Charles E.Perkins" <[email-masked]>
Date: Fri, 03 Jun 2005 14:12:46 -0700

Hello folks,

I have submitted a new revision of the aformentioned
Internet Draft.  It has been given a new title (but
still using the same filename):
  Securing Mobile IPv6 Route Optimization Using a Static Shared Key

I have also copied it to the following URL:
  http://people.nokia.net/~charliep/txt/mobilev6/precfg.txt

Regards,
Charlie P.

_______________________________________________
Mip6 mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mip6

---

From: Jari Arkko <[email-masked]>
Date: Mon, 20 Jun 2005 19:31:06 +0300

Hi Charlie,

I looked at http://people.nokia.net/~charliep/txt/mobilev6/precfg.txt
since -03 does not appear in the I-D directories.

Your new revision solves most of the issues I had. Thanks.
However, the following issues don't seem to have been
fixed (or I may have missed the change if it was in
an unexpected place in the text):

- A note about bidding down and why we can't allow
other RO mechanisms if a config for a key exists, to
be placed in the security considerations section

- New text for the applicability text. I think we agreed
to something in our original discussion, but I don't
see it in the above URL...

--Jari

---

From: "Charles E. Perkins" <[email-masked]>
Date: Mon, 20 Jun 2005 09:45:14 -0700

Hello Jari,

> be placed in the security considerations section

I would say that other mechanisms are disallowed if they
are vulnerable to bidding down.  Is that correct?

> see it in the above URL.

I thought I caught all the agreed-upon text offered for
this matter.  I can look again, but if you have some particular
text you notice is missing, I would much appreciate if you
could send it to me.

Regards,
Charlie P.

---

From: Jari Arkko <[email-masked]>
Date: Mon, 20 Jun 2005 20:00:30 +0300

> are vulnerable to bidding down.  Is that correct?

No, the issue is switching between your scheme and something
else. How about this:

"Note that where a node has been configured to use the
mechanism specified in this document with a particular peer,
it SHOULD NOT attempt to use another mechanism, even
if the peer requests this or claims to not support the mechanism
in this document. This is necessary in order to prevent
bidding down attacks."

> text you notice is missing, I would much appreciate if you
Sure. See
http://www1.ietf.org/mail-archive/web/mip6/current/msg02921.html
and search for "Overall applicability text"

--jari

---

From: "Charles E.Perkins" <[email-masked]>
Date: Tue, 21 Jun 2005 12:36:27 -0700

Hello Jari,

> in this document. This is necessary in order to prevent

Right -- I knew that!  I will use your wording.

If another mechanism is designed that does not subject
the configured nodes to a bidding-down attack, then that
mechanism should be allowed for use, but we don't have
to worry about that right now.

> http://www1.ietf.org/mail-archive/web/mip6/current/msg02921.html

That was an awfully long e-mail...

I updated the bullet points in the applicability statement,
and expanded the following paragraph.  I don't know why I
overlooked this before, but thanks for the reminder.

I have made the new text available at:
	http://people.nokia.net/charliep/txt/mobilev6/precfg.txt,
and I will probably send it in later today or tommorrow.

Regards,
Charlie P.

Regards,
Charlie P.