Subject: RE: [Mip6] Bootstrapping DT solution draft

From: "DENG, HUI -HCHBJ" <[email-masked]>
Date: Mon, 25 Jul 2005 00:09:16 +0800

The SRV record contains information that the operator can use to
establish a preference ordering on the servers for clients. That said, I
don't believe it is intended to provide fast, real time information
about preferences, say on the order of seconds., but more over longer
periods, since dynamic DNS updates require some time to propagate, and
it would also not be such a good idea to burden the DNS server with
having to handle such frequent updates. 
==> Do you mean that DNS is not suitable for dynamical home agent
assignment in this bootstrap solution?

Its also possible for the HAs themselves to refuse new IKEv2 connections
if they are loaded. 
==> We guess here need more discussion.

Since the MN will have a list of HAs, it will just roll over to trying
the next one.  
==> Do you think this way is very efficient?

The HAs could co-operate somehow (maybe using a protocol like HAHA?) to
establish which HA should be taking new connections. This could be used
to perform finer grained load balancing. 
==> Do you mean that home agent assignment should be in another
document, out of bootstrap?

-Hui

----- Original Message -----
From: "Li Qin" <[email-masked]>
To: "James Kempf" <[email-masked]>
Cc: "Li Qin" <[email-masked]>; "Gerardo Giaretta"
<[email-masked]>; <[email-masked]>
Sent: Thursday, July 21, 2005 8:33 AM
Subject: Re: [Mip6] Bootstrapping DT solution draft

> In my opinion I think its more like a HA discovery than HA assignment.
>
> If multiple HAs are deployed in home network, is it possible to assign
> a HA according to the user's profile, or according to current load of 
> the HAs in this solution?
>
> James Kempf wrote:
> > The home DNS server can contain multiple HA addresses in the SRV
> > record.
> >
> >         jak
> >
> >
> >
> > ----- Original Message -----
> > From: "Li Qin" <[email-masked]>
> > To: "Gerardo Giaretta" <[email-masked]>
> > Cc: <[email-masked]>
> > Sent: Wednesday, July 20, 2005 1:11 AM
> > Subject: Re: [Mip6] Bootstrapping DT solution draft
> >
> >
> >
> >>I guess that multiple home agents related issues, such as dynamic
> >>home agent assignment, have not been considered in this draft.
> >>
> >>if so , can you tell us the reason?
> >>
> >>Gerardo Giaretta wrote:
> >>
> >>>Dear WG,
> >>>
> >>>the bootstrapping DT has submitted a solution draft. The document
> >>>defines how a Mobile Node can bootstrap MIPv6 operations from 
> >>>non-topological information and pre-configured security 
> >>>credentials.
The
> >>>solution solves the boostrapping problem when the Mobile Node's
mobility
> >>>service is authorized by a different service provider than basic
network
> >>>access (i.e. split scenario).
> >>>
> >>>The draft can be found at
>
>>>http://www.ietf.org/internet-drafts/draft-ietf-mip6-bootstrapping-spl
>>>it-
> >>>00.txt.
> >>>
> >>>The DT is currently working on optimized solutions for integrated
> >>>scenario (i.e. mobility service and basic network access are 
> >>>authorized by the same entity).
> >>>
> >>>Please read the document and provide comments.
> >>>
> >>>Thanks and regards,
> >>>
> >>>--Gerardo (DT editor)
> >>>
> >>>
> >>>
> >>>
> >>>
> >>>
> >>>
> >>>
> >>>Gruppo Telecom Italia - Direzione e coordinamento di Telecom Italia
> >
> > S.p.A.
> >
> >>>===================================================================
> >>>=
> >>>CONFIDENTIALITY NOTICE
> >>>This message and its attachments are addressed solely to the 
> >>>persons above and may contain confidential information. If you have

> >>>received the message in error, be informed that any use of the 
> >>>content hereof is prohibited. Please return it immediately to the 
> >>>sender and delete the message. Should you have any questions, 
> >>>please send an e_mail to [email-masked]. Thank you 
> >>>===================================================================
> >>>=
> >>>
> >>>_______________________________________________
> >>>Mip6 mailing list
> >>>[email-masked]
> >>>https://www1.ietf.org/mailman/listinfo/mip6
> >>
> >>_______________________________________________
> >>Mip6 mailing list
> >>[email-masked]
> >>https://www1.ietf.org/mailman/listinfo/mip6
> >
> >
> >
>

_______________________________________________
Mip6 mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mip6

_______________________________________________
Mip6 mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mip6

---

From: "Junghoon Jee" <[email-masked]>
Date: Mon, 25 Jul 2005 15:35:15 +0900

Hi Hui,

> The SRV record contains information that the operator can use 
> to establish a preference ordering on the servers for 
> clients. That said, I don't believe it is intended to provide 
> fast, real time information about preferences, say on the 
> order of seconds., but more over longer periods, since 
> dynamic DNS updates require some time to propagate, and it 
> would also not be such a good idea to burden the DNS server 
> with having to handle such frequent updates. 
> ==> Do you mean that DNS is not suitable for dynamical home 
> agent assignment in this bootstrap solution?

Nope, definitely not.
James is talking about the rationale why DNS update does not need to happen
so frequently.
 
> Its also possible for the HAs themselves to refuse new IKEv2 
> connections if they are loaded. 

It would be helpful if you can share your thoughts more specifically.
Then, let's start discussion.

> Since the MN will have a list of HAs, it will just roll over 
> to trying the next one.  

Do you see any problem from the James' thought ?

> The HAs could co-operate somehow (maybe using a protocol like 
> HAHA?) to establish which HA should be taking new 
> connections. This could be used to perform finer grained load 
> balancing. 
> ==> Do you mean that home agent assignment should be in 
> another document, out of bootstrap?

I can not quite understand what you said.
More clarification would be helpful.

Regards,
Junghoon

---

From: "James Kempf" <[email-masked]>
Date: Tue, 26 Jul 2005 02:06:21 -0700

What I mean is that the operater can use the SRV record preference field for
long term load balancing, and connection refusal for short term load
balancing, due to flash crowds and such. Since such short term loads tend to
be rare in a properly provisioned network, I see no problem with connection
refusal requiring more time on the part of the MN, since it should not
happen often (if it does, the operater has a provisioning problem, and
better buy a couple more HAs). I believe that the DNS is perfectly fine for
bootstrapping. Every other service on the Internet uses it, there's no
reason why Mobile IP can't use it too. I think the solution outlined in the
bootstrapping draft is just fine, and aligns mobility service discovery
consistently with the general Internet service architecture model, for the
split scenerio case. For the integrated scenerio case, other solutions may
be somewhat more optimal on a couple of metrics. The DT is looking at that
case right now.

        jak

----- Original Message -----
From: "DENG, HUI -HCHBJ" <[email-masked]>
To: "James Kempf" <[email-masked]>; "Li Qin"
<[email-masked]>
Cc: "Gerardo Giaretta" <[email-masked]>; <[email-masked]>
Sent: Sunday, July 24, 2005 9:09 AM
Subject: RE: [Mip6] Bootstrapping DT solution draft

-Hui

----- Original Message -----
From: "Li Qin" <[email-masked]>
To: "James Kempf" <[email-masked]>
Cc: "Li Qin" <[email-masked]>; "Gerardo Giaretta"

The
mobility
network