Subject: [Mip6] Binding Authorization Data option query

From: "Sameer T." <[email-masked]>
Date: Thu, 18 Aug 2005 14:20:46 +0530

Hi,
Can anyone please explain me, why the authenticator field in Biniding authorization data mobility option is a variable length field? eventhough rfc 3775 states "   the first 96 bits from the MAC result are used as the Authenticator field ...  Authenticator = First (96, HMAC_SHA1 (Kbm, Mobility Data))."  
So why is it NOT considered as fixed length (12)? 

Thanks,
Sameer

#####################################################################
THIS EMAIL MESSAGE IS FOR THE SOLE USE OF THE INTENDED RECIPIENT(S) AND MAY CONTAIN CONFIDENTIAL AND PRIVILEGED INFORMATION. ANY UNAUTHORIZED REVIEW, USE, DISCLOSURE OR DISTRIBUTION IS PROHIBITED. BEFORE OPENING ANY ATTACHMENTS PLEASE CHECK FOR VIRUSES AND DEFECTS. IF YOU ARE NOT THE INTENDED RECIPIENT, PLEASE NOTIFY US IMMEDIATELY BY REPLY EMAIL AND DELETE THE ORIGINAL MESSAGE.
#####################################################################

_______________________________________________
Mip6 mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mip6

---

From: Jari Arkko <[email-masked]>
Date: Thu, 18 Aug 2005 14:43:31 +0300

Sameer T. wrote:

> Hi,
> Can anyone please explain me, why the authenticator field in Biniding 
> authorization data mobility option is a variable length field? 
> eventhough rfc 3775 states "  / the first 96 bits from the MAC result 
> are used as the Authenticator field ...  Authenticator = First (96, 
> HMAC_SHA1 (Kbm, Mobility Data))." /
>
Two answers:

1) Considering the mobility option layer formatting, all options except 
Pad1 have
a lenth field. This is necessary just to be able to process the options 
in a clean
manner without necessarily having to understand all options.

2) Considering the BAD option definition itself, it does say that the
length has to be 96 bits. If you are asking why the length field
is still included, see answer #1. Also, its not impossible that
at some future time we choose a new algorithm and need to
use some other number of bits. An update to the BAD
option definition would allow this, without breaking the
format itself.

Hope this clarifies it,

Jari