Subject: [Mip6] Mobile node communicating with Mobile node

From: "Sameer T." <[email-masked]>
Date: Tue, 23 Aug 2005 18:34:05 +0530

Hi all,
This is regarding Mobile node communicating with another mobile node, 
When there are two mobile nodes, N1 & N2  (both are MIPv6 capable and initially at home network).
 
1) when N1 moves to a new n/w, ...it finishes home registration,  it  then updates N2 (Return routability and BU message).  
Now N2 has a binding cache for N1.

2) then  N2 moves to a new n/w, finishes home registration, then N2 receives a tunneled packet from N1 with home address option (tunneled thru its home agent) . Now it should update N1 with its  care of address (Return routability and BU message) right? 
In this case 
	a) home test init message and care of test init message will be sent to N1's care of address or N1's home address.? 
	b) What about Bu message, it also will be sent to N1's c/o address or home address?
If they are sent to N1's home address, N1's home agent should tunnel and send this packet to N1's care of address right?
Does rfc 3775 mention this scenario? or am I missing any concept here? 

Thanks,
Sameer

#####################################################################
THIS EMAIL MESSAGE IS FOR THE SOLE USE OF THE INTENDED RECIPIENT(S) AND MAY CONTAIN CONFIDENTIAL AND PRIVILEGED INFORMATION. ANY UNAUTHORIZED REVIEW, USE, DISCLOSURE OR DISTRIBUTION IS PROHIBITED. BEFORE OPENING ANY ATTACHMENTS PLEASE CHECK FOR VIRUSES AND DEFECTS. IF YOU ARE NOT THE INTENDED RECIPIENT, PLEASE NOTIFY US IMMEDIATELY BY REPLY EMAIL AND DELETE THE ORIGINAL MESSAGE.
#####################################################################

_______________________________________________
Mip6 mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mip6

---

From: Alexandru Petrescu <[email-masked]>
Date: Thu, 25 Aug 2005 13:43:45 +0200

Sameer T. wrote:
> /Hi all,/
> /This is regarding Mobile node communicating with another mobile node, /
> /When there are two mobile nodes, N1 & N2  (both are MIPv6 capable and
> initially at home network)./
> /** /
> /1) when N1 moves to a new n/w, ...it finishes home registration,  it 
> then updates N2 (Return routability and BU message).  /
> 
> /Now N2 has a binding cache for N1./
> 
> /2) then  N2 moves to a new n/w, finishes home registration, then N2
> receives a tunneled packet from N1 with home address option (tunneled
> thru its home agent) . Now it should update N1 with its  care of address
> (Return routability and BU message) right? /

Right.

> 
> /In this case /
> /        a) home test init message and care of test init message will be
> sent to N1's care of address or N1's home address.? /
> 
> /        b) What about Bu message, it also will be sent to N1's c/o
> address or home address?/
> /If they are sent to N1's home address, N1's home agent should tunnel
> and send this packet to N1's care of address right?/
> 
> /Does rfc 3775 mention this scenario? or am I missing any concept here? /

I think rfc3775 describes behaviour of an MN talking to a correspondent.
 That "correspondent" could be either HA or a CN or another MN.  Which
means that the case MN talking RR to another MN has been looked at, at
least pencil on paper.

Please do not get confused by terminology.  Often it is useful for text
writers to have a simple terminology that is easy to grasp.  Questions
get quickly answered at implementation and test time.

Alex