Subject: [Mip6] Query on Neighbor cache and route cache

From: "Sameer T." <[email-masked]>
Date: Mon, 22 Aug 2005 19:53:04 +0530

Hi,
Can someone please clarify this query.
When a mobile node moves to a foreign network from his home network, and comes back to home network again after some time, does he need to remember all the route cache entries  and neighbor cache entries, which were present in his home network?
For example, in his home network he had a neighbor cache entry which is in STALE state, and its lifetime will expire only after 10 hours. Then he goes to foreign network, after two hours it comes back to home network. Now should he remember this old entry? 

also the default router list? can we flush all these tables once we move to a new network?

Thanks,
Sameert

#####################################################################
THIS EMAIL MESSAGE IS FOR THE SOLE USE OF THE INTENDED RECIPIENT(S) AND MAY CONTAIN CONFIDENTIAL AND PRIVILEGED INFORMATION. ANY UNAUTHORIZED REVIEW, USE, DISCLOSURE OR DISTRIBUTION IS PROHIBITED. BEFORE OPENING ANY ATTACHMENTS PLEASE CHECK FOR VIRUSES AND DEFECTS. IF YOU ARE NOT THE INTENDED RECIPIENT, PLEASE NOTIFY US IMMEDIATELY BY REPLY EMAIL AND DELETE THE ORIGINAL MESSAGE.
#####################################################################

_______________________________________________
Mip6 mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mip6

---

From: Alexandru Petrescu <[email-masked]>
Date: Thu, 25 Aug 2005 13:36:05 +0200

Sameer T. wrote:
> /Hi,/
> /Can someone please clarify this query./
> /When a mobile node moves to a foreign network from his home network,
> and comes back to home network again after some time, does he need to
> remember all the route cache entries  and neighbor cache entries, which
> were present in his home network?/
> 
> /For example, in his home network he had a neighbor cache entry which is
> in STALE state, and its lifetime will expire only after 10 hours. Then
> he goes to foreign network, after two hours it comes back to home
> network. Now should he remember this old entry? /
> 
> /also the default router list? can we flush all these tables once we
> move to a new network?/

I wouldn't flush anything, just save them in some hidden tables when
moving away from home.  When coming back home copy these entries back to
the original tables if they've not expired.

Alex