Subject: RE: [Mip6] Mobile node communicating with Mobile node

From: "Sameer T." <[email-masked]>
Date: Thu, 25 Aug 2005 17:59:53 +0530

Alex, Thanks for your reply,  

I do agree that in rfc 3775 "correspondent" could be either HA or a CN or another MN. And  my exact query is in the third case, when the correspondent is MN. 

> > /        a) home test init message and care of test init 
> message will be
> > sent to N1's care of address or N1's home address.? /
> > 
> > /        b) What about Bu message, it also will be sent to N1's c/o
> > address or home address?/
> > /If they are sent to N1's home address, N1's home agent 
> should tunnel
> > and send this packet to N1's care of address right?/
> > 

What I really wanted to know was, in my example both N1 and N2 are away from home. So when N2 sends Home test init message, as a part of RR, it sends to home address of N1. So Home test init message first goes to N2's home agent (since it is a home test init message), then it goes to N1's home agent, finally to N1 (thru his care of address). Is my understanding correct here?
 
Sameer

> -----Original Message-----
> From: Alexandru Petrescu [mailto:[email-masked]]
> Sent: Thursday, August 25, 2005 5:14 PM
> To: Sameer T.
> Cc: [email-masked]; Jari Arkko
> Subject: Re: [Mip6] Mobile node communicating with Mobile node
> 
> 
> Sameer T. wrote:
> > /Hi all,/
> > /This is regarding Mobile node communicating with another 
> mobile node, /
> > /When there are two mobile nodes, N1 & N2  (both are MIPv6 
> capable and
> > initially at home network)./
> > /** /
> > /1) when N1 moves to a new n/w, ...it finishes home 
> registration,  it 
> > then updates N2 (Return routability and BU message).  /
> > 
> > /Now N2 has a binding cache for N1./
> > 
> > /2) then  N2 moves to a new n/w, finishes home registration, then N2
> > receives a tunneled packet from N1 with home address option 
> (tunneled
> > thru its home agent) . Now it should update N1 with its  
> care of address
> > (Return routability and BU message) right? /
> 
> Right.
> 
> > 
> > /In this case /
> > /        a) home test init message and care of test init 
> message will be
> > sent to N1's care of address or N1's home address.? /
> > 
> > /        b) What about Bu message, it also will be sent to N1's c/o
> > address or home address?/
> > /If they are sent to N1's home address, N1's home agent 
> should tunnel
> > and send this packet to N1's care of address right?/
> > 
> > /Does rfc 3775 mention this scenario? or am I missing any 
> concept here? /
> 
> I think rfc3775 describes behaviour of an MN talking to a 
> correspondent.
>  That "correspondent" could be either HA or a CN or another MN.  Which
> means that the case MN talking RR to another MN has been looked at, at
> least pencil on paper.
> 
> Please do not get confused by terminology.  Often it is 
> useful for text
> writers to have a simple terminology that is easy to grasp.  Questions
> get quickly answered at implementation and test time.
> 
> Alex
> 

#####################################################################
THIS EMAIL MESSAGE IS FOR THE SOLE USE OF THE INTENDED RECIPIENT(S) AND MAY CONTAIN CONFIDENTIAL AND PRIVILEGED INFORMATION. ANY UNAUTHORIZED REVIEW, USE, DISCLOSURE OR DISTRIBUTION IS PROHIBITED. BEFORE OPENING ANY ATTACHMENTS PLEASE CHECK FOR VIRUSES AND DEFECTS. IF YOU ARE NOT THE INTENDED RECIPIENT, PLEASE NOTIFY US IMMEDIATELY BY REPLY EMAIL AND DELETE THE ORIGINAL MESSAGE.
#####################################################################

_______________________________________________
Mip6 mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mip6

---

From: Alexandru Petrescu <[email-masked]>
Date: Thu, 25 Aug 2005 14:50:21 +0200

Sameer T. wrote:
> I do agree that in rfc 3775 "correspondent" could be either HA or a 
> CN or another MN. And  my exact query is in the third case, when the 
> correspondent is MN.
> 
> 
>>> /        b) What about Bu message, it also will be sent to N1's 
>>> c/o address or home address?/ /If they are sent to N1's home 
>>> address, N1's home agent
>> 
>> should tunnel
>> 
> What I really wanted to know was, in my example both N1 and N2 are 
> away from home. So when N2 sends Home test init message, as a part of
>  RR, it sends to home address of N1. So Home test init message first 
> goes to N2's home agent (since it is a home test init message),

Yes, first goes to N2's HA, but not because it is a HoTI, it's because
all packets out of an MN go through their HA before RR (the Ho in HoTI
stands for the Home Address of N1 not of N2).  The N2 acts as CN for N1
which acts as MN.

This is my understanding based on protocol description, not on
implementation.  Once implemented it should be easier to understand.

> then it goes to N1's home agent, finally to N1 (thru his care of
> address). Is my understanding correct here?

I guess so.

Alex