Subject: RE: [Mip6] WG Last call: draft-ietf-mip6-ikev2-ipsec-06.txt

From: "Soliman, Hesham" <[email-masked]>
Date: Mon, 24 Apr 2006 14:41:14 -0700

>     > => you want to use a transport mode with a HAO for the 
 >     > tunneled traffic,
 >     > i.e.:
 >     >     IPv6 header (src=CoA, dst=HA)
 >     >     HAO (with HoA)
 >     >     ESP header
 >     >     IPv6 header (src=HoA, dst=*)
 >     >     Payload
 >     > Is your proposal?
 >    
 >    B. For protecting payload traffic (VPN style) we can do the packet
 >    format you describe above. 
 >    
 > => so your proposal is some kind of "transport all" mode. I am not
 > in favor of it because it adds a HAO to every packets. If we consider
 > the HAO as a degenerate tunnel, it is a spurious double tunneling.

=> Well, if someone is bothered by the additional bits, they can
compress it using any compression protocol we have today. you do that
for the CN anyway. This is a tiny problem compared to what we have now
IMO. 

Hesham

 > 
 > Regards
 >    
 > [email-masked]
 > 

_______________________________________________
Mip6 mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mip6

---

From: Francis Dupont <[email-masked]>
Date: Wed, 26 Apr 2006 08:42:43 +0200

> the HAO as a degenerate tunnel, it is a spurious double tunneling.
   
   => Well, if someone is bothered by the additional bits,

=> this is not my concern (this is already a tunnel so to avoid MTU
madness the internal packet will be limited to 1280, the extra header
doesn't really matter). I don't like the transport all mode for
architectural reasons.

Regards

PS: my concern is specific to MIPv6/NEMO, look at my comment about
draft-ietf-v6ops-ipsec-tunnels-02.txt for the other cases.