Subject: RE: [Mip6] WG Last call: draft-ietf-mip6-ikev2-ipsec-06.txt

From: "Soliman, Hesham" <[email-masked]>
Date: Sun, 23 Apr 2006 15:24:42 -0700

> you are mixing up things. you should look up the
 > discussion on the mobopts WG. it is working on
 > a solution for generating temporary HoAs and use
 > them instead of the actual HoA. but this requires
 > some support on the CN too. the CN needs to know
 > how to deal with the temporary HoA.
 > 
 > the "tunnel all" mode is used to hide the HoA
 > from the access network. this requires no support
 > on the CN. the "tunnel all" mode is already there.
 > it is *not* a new solution.

=> I think you're confusing two separate issues:
 - BU sent to the HA
 - BU sent to the CN

The draft in the subject of this email deals with the 
former, there is *no* CN involvement here. If you want
to create a pseudo HoA between the MN and HA you can 
do that without involving the CN. You only involve the 
CN when you're sending the BU *to* the CN. So you can't
claim that the proposed section 3 goes around the problem
of involving the CN, if that's what you're claiming. 

Hesham

 > Vijay

_______________________________________________
Mip6 mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mip6

---

From: Vijay Devarapalli <[email-masked]>
Date: Sun, 23 Apr 2006 15:36:48 -0700

> => I think you're confusing two separate issues:

ofcourse not.

> former, there is *no* CN involvement here. 

for using temporary HoA instead of actual HoA in
payload traffic, there is a need to modify the CN.

If you want
> do that without involving the CN. 

why would I? if I am sending a BU to the HA and
do not want the access network to see the HoA, I
just tunnel it and put ESP with non-null
encryption between the two IP headers. simple.
no pseudo HoA stuff.

> You only involve the 
> CN when you're sending the BU *to* the CN. 

yes. the privacy solutions are trying to address
route optimization too.

> So you can't

the claim is simple. I can hide the HoA from the
access network *without* requiring the HA or the
CN to support the use of pseudo HoA by tunneling
everything.

Vijay