Subject: RE: [Mip6] WG Last call: draft-ietf-mip6-ikev2-ipsec-06.txt

From: "Soliman, Hesham" <[email-masked]>
Date: Thu, 20 Apr 2006 21:49:45 -0700

> well, the tunnel mode BU has been around for
 > a long time. draft-ietf-mip6-ikev2-ipsec also
 > explicitly mentioned the tunnel mode in
 > version 03 or 04, when the "Selector
 > Granularity Considerations" section was
 > introduced.

=> Tunnel mode was never around for the BU and it should not
be. I see no reason for this change; in fact I think it's
bad to allow this for several reasons. If we want to open 
the tunnel mode discussion again then I would suggest that 
we eliminate it for everything except for the HOTI/HOT
exchange. It has clearly been a problem with implementations
that don't interface with IPsec and it's completely unnecessary. 

In any case, even if this is to be done, it should not be done 
in this draft, in the last minute after WGLC. 

Hesham

_______________________________________________
Mip6 mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mip6

---

From: Vijay Devarapalli <[email-masked]>
Date: Fri, 21 Apr 2006 11:49:02 -0700

Soliman, Hesham wrote:
> be. 

go and take a look at the MIP6 issues list at
Jari's page. it was discussed numerous times.
it was even advocated as the default mode for
MIPv6.

> in this draft, in the last minute after WGLC. 

thats why we are having another WGLC.

Vijay

---

From: Francis Dupont <[email-masked]>
Date: Sat, 22 Apr 2006 11:35:35 +0200

In your previous mail you wrote:

   => Tunnel mode was never around for the BU and it should not be.

=> Hesham, you should defend this opinion with arguments.
This discussion is about this.

   I see no reason for this change; in fact I think it's
   bad to allow this for several reasons. If we want to open 
   the tunnel mode discussion again then I would suggest that 
   we eliminate it for everything except for the HOTI/HOT
   exchange.

=> IMHO we need the whole spectrum. HOTI/HOT only is the other end,
I like both ends which correspond to real world situations.
The medium case (regular RFC 3775/3776 one) is still needed for compatibility.

   It has clearly been a problem with implementations
   that don't interface with IPsec and it's completely unnecessary. 
   
=> you mean unnecessary of mobility purpose?

=> I've really tried to get this discussion, the way it is done is
not from me. But the important point is we have it, isn't it?

Regards
   
[email-masked]