Subject: [Mip6] Questions on draft-ietf-mip6-bootstrapping-integrated-dhc-00.txt

From: Alexandru Petrescu <[email-masked]>
Date: Fri, 28 Apr 2006 18:29:34 +0200

Dear authors of draft-ietf-mip6-bootstrapping-integrated-dhc-00.txt, I
have some questions and comments on this draft.

Shouldn't the DHCP options defined in this draft be proposed to the DHC
WG and not to the MIP6 WG?

> [fallback case] In the fallback case, the mobile node is not able to
>  acquire the home agent information via DHCPv6.  The mobile node 
> performs DNS queries to discover the home agent address as defined in
>  [BOOT-SPLIT].  To perform DNS based home agent discovery, the mobile
>  node needs to know the DNS server address.  How the mobile node 
> knows the DNS server address is outside the scope of this document.

What are the conditions in which the fallback case occurs?  Is it
because DHCP does not respond?  Or just that the DHCP responds with an
error when queried about HA?

If the latter then the DNS address could be still obtained from DHCP.
Otherwise, the DNS address can be pre-configured (in /etc/resolv.conf)
or from a LCP (link-control protocol).  I don't understand why it's left
outside the scope of this document.

> (2) The mobile node sends a DHCPv6 Information Request message 
> [RFC3315] to the All_DHCP_Relay_Agents_and_Servers multicast address.
>  In this message the mobile node (DHCP client) SHALL include the 
> Option Code for Home Network Identifier Option [HAOPT] in the 
> OPTION_ORO, Home Network Identifier Option with id-type set to 1 and 
> the Home Network Identifier field set to the network realm of the 
> home MSP [HAOPT].

Currently a network realm part of NAI designates several subnets (HAOPT 
uses NAI).  So if in a network domain (realm) there are several subnets, 
there should be several home agents there.  How does DHCP and AAAH know 
which HA to return to MN when the identifier is only a generic network 
realm?

Alex

_______________________________________________
Mip6 mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mip6

---

From: "Junghoon Jee" <[email-masked]>
Date: Sat, 29 Apr 2006 01:56:48 +0900

Hi Alex,
Let me try to reply to your questions.

----- Original Message ----- 
From: "Alexandru Petrescu" <[email-masked]>
To: <[email-masked]>
Sent: Saturday, April 29, 2006 1:29 AM
Subject: [Mip6] Questions ondraft-ietf-mip6-bootstrapping-integrated-dhc-00.txt

> WG and not to the MIP6 WG?

There's already a draft for that purpose:
http://www.ietf.org/internet-drafts/draft-jang-dhc-haopt-02.txt

> error when queried about HA?

If I understood your question correctly,
the fallback case here means where the integrated scenario does not apply,
more specifically ASA != MSA.

> which HA to return to MN when the identifier is only a generic network 

Not so sure if I understood your question here:
Anyway, MSP/AAAH assigns a HA in the integrated scenario.

Thanks,
-Junghoon

---

From: Alexandru Petrescu <[email-masked]>
Date: Fri, 28 Apr 2006 19:03:20 +0200

Junghoon Jee wrote:
> Hi Alex, Let me try to reply to your questions.
> 
> ----- Original Message ----- From: "Alexandru Petrescu" 
> <[email-masked]> To: <[email-masked]> Sent: Saturday,
>  April 29, 2006 1:29 AM Subject: [Mip6] Questions 
> ondraft-ietf-mip6-bootstrapping-integrated-dhc-00.txt
> 
> 
>> Dear authors of 
>> draft-ietf-mip6-bootstrapping-integrated-dhc-00.txt, I have some 
>> questions and comments on this draft.
>> 
>> Shouldn't the DHCP options defined in this draft be proposed to the
>>  DHC WG and not to the MIP6 WG?
> 
>>> [fallback case] In the fallback case, the mobile node is not able
>>>  to acquire the home agent information via DHCPv6.  The mobile 
>>> node performs DNS queries to discover the home agent address as 
>>> defined in [BOOT-SPLIT].  To perform DNS based home agent 
>>> discovery, the mobile node needs to know the DNS server address. 
>>> How the mobile node knows the DNS server address is outside the 
>>> scope of this document.
>> because DHCP does not respond?  Or just that the DHCP responds with
>>  an error when queried about HA?
> 
> If I understood your question correctly, the fallback case here means
>  where the integrated scenario does not apply,

Nowhere in the draft-integrated does it say that the fallback case
happens that the integrated scenario does not apply.

> more specifically ASA != MSA.

How does the MN know that ASA!=MSA?

>> If the latter then the DNS address could be still obtained from 
>> DHCP. Otherwise, the DNS address can be pre-configured (in 
>> /etc/resolv.conf) or from a LCP (link-control protocol).  I don't 
>> understand why it's left outside the scope of this document.
>> 
>>> [RFC3315] to the All_DHCP_Relay_Agents_and_Servers multicast 
>>> address. In this message the mobile node (DHCP client) SHALL 
>>> include the Option Code for Home Network Identifier Option 
>>> [HAOPT] in the OPTION_ORO, Home Network Identifier Option with 
>>> id-type set to 1 and the Home Network Identifier field set to the
>>>  network realm of the home MSP [HAOPT].
>> Currently a network realm part of NAI designates several subnets 
>> (HAOPT uses NAI).  So if in a network domain (realm) there are 
>> several subnets, there should be several home agents there.  How 
>> does DHCP and AAAH know which HA to return to MN when the 
>> identifier is only a generic network realm?
> 
> Not so sure if I understood your question here: Anyway, MSP/AAAH 
> assigns a HA in the integrated scenario.

Yes, it does.  But for draft-integrated MN is querying DHCP using as key 
the realm of NAI (i.e. example.com).  I think this assumption is 
correct, no?

If yes, how does the responder (DHCP, AAA) know that in example.com
there are several subnets and that each has a different prefix and a
different set of HAs on each link?

Alex

---

From: Vijay Devarapalli <[email-masked]>
Date: Fri, 28 Apr 2006 10:18:33 -0700

> WG and not to the MIP6 WG?

nope. I checked with Ralph. DHCP options can be
specified in any WG as long as they are reviewed
by the DHC WG.

this is similar to MIP6 WG introducing new IKEv2
config payload attributes instead of going to the
IPsec WG, the SIP WG introducing new DHCP options
instead of going to the DHC WG or the MIPSHOP WG
introducing new mobility options instead of going
to the MIP6 WG.

Vijay

---

From: "Junghoon Jee" <[email-masked]>
Date: Sat, 29 Apr 2006 02:19:13 +0900

> happens that the integrated scenario does not apply.

If my understanding is correct then we may explicitly say about this in this I-D,
if you really want.

> How does the MN know that ASA!=MSA?

MN cannot and needs not know about the whole details about the varying network infrastructure situations.

> different set of HAs on each link?

In the integrated scenario that is describe in this I-D, MSP/AAAH assigns/prepares a HA in his part.
This HA may not be actually used by a MN in case where ASP/AAAv can assign a HA and MN wish to use that HA
by setting the id-type field to zero.
Not still sure we are in the same understaning and context here.

-Junghoon

---

From: Vijay Devarapalli <[email-masked]>
Date: Fri, 28 Apr 2006 10:21:59 -0700

Alexandru Petrescu wrote:
>>  node needs to know the DNS server address.  How the mobile node knows 
>> the DNS server address is outside the scope of this document.
> 

the DHCP server in the visited link might just
not have the information about the HA for a
particular mobile node.

> outside the scope of this document.

I think its left out of scope because DNS
information is obtained through many mechanisms.
for e.g. DNS information could be delivered as
part of PPP setup, GTP setup and running IKEv2
with a PDG. getting it through DHCP will also
work ofcourse.

Vijay

---

From: Alexandru Petrescu <[email-masked]>
Date: Fri, 28 Apr 2006 20:19:33 +0200

Vijay Devarapalli wrote:
> nope. I checked with Ralph. DHCP options can be specified in any WG
> as long as they are reviewed by the DHC WG.

So they should be reviewed by the DHC WG right?

It's still uncommon to see a document titled "MIPv6 bootsrapping" in the
MIP6 WG only with DHCP messages modified, no MIP6 messaging, no MIP6
data structure, no keyword "binding" present, no CoA and only one
occurence of "home address" (the one to be boot-strapped).  Maybe the
title should be "DHCPv6-based MIPv6 bootstrapping for integrated scenario"?

Alex

---

From: Vijay Devarapalli <[email-masked]>
Date: Fri, 28 Apr 2006 11:23:25 -0700

> So they should be reviewed by the DHC WG right?

yes.

Vijay

---

From: Alexandru Petrescu <[email-masked]>
Date: Fri, 28 Apr 2006 20:24:16 +0200

Junghoon Jee wrote:
> If my understanding is correct then we may explicitly say about this
>  in this I-D, if you really want.
> 
> MN cannot and needs not know about the whole details about the 
> varying network infrastructure situations.

Right, MN doesn't need to know the details about the network infrastructure.

>>>> /etc/resolv.conf) or from a LCP (link-control protocol).  I 
>>>> don't understand why it's left outside the scope of this 
>>>> document.
>>>> 
>>>>> (2) The mobile node sends a DHCPv6 Information Request 
>>>>> message [RFC3315] to the All_DHCP_Relay_Agents_and_Servers 
>>>>> multicast address. In this message the mobile node (DHCP 
>>>>> client) SHALL include the Option Code for Home Network 
>>>>> Identifier Option [HAOPT] in the OPTION_ORO, Home Network 
>>>>> Identifier Option with id-type set to 1 and the Home Network
>>>>>  Identifier field set to the network realm of the home MSP 
>>>>> [HAOPT].
>>>> Currently a network realm part of NAI designates several 
>>>> subnets (HAOPT uses NAI).  So if in a network domain (realm) 
>>>> there are several subnets, there should be several home agents
>>>>  there.  How does DHCP and AAAH know which HA to return to MN 
>>>> when the identifier is only a generic network realm?
>> Yes, it does.  But for draft-integrated MN is querying DHCP using 
>> as key the realm of NAI (i.e. example.com).  I think this 
>> assumption is correct, no?
>> 
>>  there are several subnets and that each has a different prefix and
>>  a different set of HAs on each link?
> 
> In the integrated scenario that is describe in this I-D, MSP/AAAH 
> assigns/prepares a HA in his part. This HA may not be actually used 
> by a MN in case where ASP/AAAv can assign a HA and MN wish to use 
> that HA by setting the id-type field to zero. Not still sure we are 
> in the same understaning and context here.

Ok, let's put it this way: what is the key (or the id) that the MN uses
to query the DHCP or any other entity in the network in order to obtain
its Home Agent Address and Home Address.  What is the pre-configured
information on MN in the integrated scenario?  I thought that is the NAI
converted into the realm name (example.com).  Is it so?

Or maybe MN isn't pre-configured with anything in order for
bootstrapping to work in integrated scenario?

Alex

---

From: "Junghoon Jee" <[email-masked]>
Date: Sat, 29 Apr 2006 03:26:54 +0900

> converted into the realm name (example.com).  Is it so?

Yes.

-Junghoon

---

From: Alexandru Petrescu <[email-masked]>
Date: Fri, 28 Apr 2006 20:27:11 +0200

Vijay Devarapalli wrote:
> the DHCP server in the visited link might just not have the 
> information about the HA for a particular mobile node.

Right.

> I think its left out of scope because DNS information is obtained 
> through many mechanisms. for e.g. DNS information could be delivered 
> as part of PPP setup

That is LCP.

> GTP setup and running IKEv2 with a PDG. getting it through DHCP will 
> also work ofcourse.

Just list them.  It's not out of scope.  Just list them.

Alex

---

From: Alexandru Petrescu <[email-masked]>
Date: Fri, 28 Apr 2006 20:53:46 +0200

Junghoon Jee wrote:
>> Ok, let's put it this way: what is the key (or the id) that the MN
>> uses to query the DHCP or any other entity in the network in order
>> to obtain its Home Agent Address and Home Address.  What is the
>> pre-configured information on MN in the integrated scenario?  I
>> thought that is the NAI converted into the realm name
>> (example.com).  Is it so?
> 
> Yes.

Now, if the pre-configured information is NAI, and only NAI, how does
the intervening infrastructure (DHCP, AAA, DNS) know how to convert
example.com into the corresponding home subnet address, or home agent
address?  In example.com there may be very many subnets and each needs
its different subnet address.

Realm of NAI is especially designed so that it covers either a large 
network, or sometimes even a network that has no subnet at all, i.e. 
zero.  Which of these two cases does the integrated scenario consider?

Alex