Subject: RE: [Mip6] HA reliability issue

From: "Faizan, Jahanzeb" <[email-masked]>
Date: Tue, 25 Apr 2006 11:28:25 -0500

HA reliability is already a "solved" problem. Look at the references below. I am not sure though what the design team is trying to do.....reinventing the wheel or something else?

[1]     J. Faizan, H. El-Rewini, and M. Khalil, "Problem Statement: Home Agent Reliability," IETF Draft, draft-jfaizan-mipv6-ha-reliability-01.txt (work in progress), November 2003.

[2]     J. Faizan, H. El-Rewini, and M. Khalil, "Virtual Home Agent Reliability Protocol (VHARP)," IETF Draft, draft-jfaizan-mipv6-vhar-02.txt (work in progress), April 2004.

[3]     J. Faizan, H. El-Rewini, and M. Khalil, "VHARP: Virtual Home Agent Reliability Protocol for Mobile IPv6 based Networks," in Proceedings of IEEE International Conference of Wireless Networks, Communications, and Mobile Computing - WirelessCom 2005, Hawaii, USA, June 13-16, 2005.

[4]     J. Faizan, H. El-Rewini, and M. Khalil, "Efficient Dynamic Load Balancing for Multiple Home Agents in Mobile IPv6 based Networks," in Proceedings of IEEE International Conference on Pervasive Services - ICPS 2005, Santorini, Greece, July 11-14, 2005. 

[5]     J. Faizan, H. El-Rewini, and M. Khalil, "Introducing Reliability and Load Balancing in Mobile IPv6 based Networks," submitted to Wireless Communications and Mobile Computing, Wiely.

[6]     J. Faizan, H. El-Rewini, and M. Khalil, "Introducing Reliability and Load Balancing in Home Link of Mobile IPv6 based Networks," submitted to IEEE International Conference on Pervasive Services - ICPS 2006, Santorini, , Lyon, France, June 26-29, 2006.

[7]     J. Faizan, H. El-Rewini, and M. Khalil, "Virtual Home Agent Reliability Protocol - Implementation Details," Southern Methodist University, Technical Report     (04-CSE-03), May 2005.

[8] J.Faizan, "INTRODUCING RELIABILITY AND LOAD BALANCING IN MOBILE IPV6 BASED NETWORKS", Southern Methodist University, Ph.D. Thesis, December 2005.

Thanks
Jahanzeb Faizan
________________________________

From: Richard Frisby [mailto:[email-masked]]
Sent: Tue 4/25/2006 10:58 AM
To: [email-masked]
Subject: [Mip6] HA reliability issue

Can anyone on the HA reliability design team tell me what the status of the problem/scope/solution documents are ?

_______________________________________________
Mip6 mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mip6

---

From: Brian Haley <[email-masked]>
Date: Tue, 25 Apr 2006 14:55:12 -0400

> [2]     J. Faizan, H. El-Rewini, and M. Khalil, "Virtual Home Agent Reliability Protocol (VHARP)," IETF Draft, draft-jfaizan-mipv6-vhar-02.txt (work in progress), April 2004.

These drafts all expired in 2004, and have references to other expired 
drafts.  I also noticed that the CUR message isn't implementable since 
it doesn't precisely define the "data" portion of the message, there 
might be more.  Are there any updates planned?

-Brian

---

From: Behcet Sarikaya <[email-masked]>
Date: Tue, 25 Apr 2006 14:22:04 -0500

Brian Haley wrote:

> Faizan, Jahanzeb wrote:
>
>> HA reliability is already a "solved" problem. Look at the references 
>> below. I am not sure though what the design team is trying to 
>> do.....reinventing the wheel or something else?
>>  
>>
>> [1]     J. Faizan, H. El-Rewini, and M. Khalil, "Problem Statement: 
>> Home Agent Reliability," IETF Draft, 
>> draft-jfaizan-mipv6-ha-reliability-01.txt (work in progress), 
>> November 2003.
>>
>>  
>>
>> [2]     J. Faizan, H. El-Rewini, and M. Khalil, "Virtual Home Agent 
>> Reliability Protocol (VHARP)," IETF Draft, 
>> draft-jfaizan-mipv6-vhar-02.txt (work in progress), April 2004.
>
>
Please take this thread to the HA reliability DT mailing list.

Thanks.

Behcet

---

From: Behcet Sarikaya <[email-masked]>
Date: Tue, 25 Apr 2006 14:21:08 -0500

Thanks.

Behcet

 ietf-mx.ietf.org with esmtp (Exim 4.43) id 1FYT6p-0001mR-CY
	for [email-masked]; Tue, 25 Apr 2006 15:22:17 -0400
Date: Tue, 25 Apr 2006 14:21:08 -0500
From: Behcet Sarikaya <[email-masked]>
Subject: Re: [Mip6] HA reliability issue
To: Brian Haley <[email-masked]>
Cc: [email-masked], "Faizan, Jahanzeb" <[email-masked]>,
	Richard Frisby <[email-masked]>

Thanks.

Behcet