Subject: RE: [Mip6] WG Last call: draft-ietf-mip6-ikev2-ipsec-06.txt

From: "Soliman, Hesham" <[email-masked]>
Date: Fri, 21 Apr 2006 14:12:54 -0700

> > => I don't think it's a tradeoff that is worth the trouble. 
 > > You get an additional header, more complexity in the 
 > implementation, 
 > > more trouble classifying packets in the access, potential
 > > interoperability
 > > problems ...etc and the gain is one SA instead of 2. 
 > 
 > one SA instead of four. you can end up with
 > one SA for BU/BAck, one for HoTi/HoT, one
 > for MPS/MPA and one for tunneling payload
 > traffic. you could send all this traffic
 > through one SA.

=> So I take you understand the other points I've raised in
addition to the number of SAs. I think we all know that we
wouldn't end up with 4 SAs if we used the HAO, so this statement
is not accurate.

Hesham

_______________________________________________
Mip6 mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mip6

---

From: Vijay Devarapalli <[email-masked]>
Date: Fri, 21 Apr 2006 14:16:32 -0700

> wouldn't end up with 4 SAs if we used the HAO, so this statement

if we tunnel everything we end up with one
tunnel SA. the packet format would be

IPv6 hdr (src=CoA, dst=HA)
ESP header in tunnel mode
IPv6 hdr (src=HoA, dst=CN/HA)
Payload

the "Payload" can be BU, MPS, HoTi or any
traffic to the CN.

Vijay