Subject: RE: [Mip6] WG Last call: draft-ietf-mip6-ikev2-ipsec-06.txt

From: "Soliman, Hesham" <[email-masked]>
Date: Wed, 26 Apr 2006 08:58:32 -0700

>     > => so your proposal is some kind of "transport all" 
 > mode. I am not
 >     > in favor of it because it adds a HAO to every packets. 
 > If we consider
 >     > the HAO as a degenerate tunnel, it is a spurious 
 > double tunneling.
 >    
 >    => Well, if someone is bothered by the additional bits,
 > 
 > => this is not my concern (this is already a tunnel so to avoid MTU
 > madness the internal packet will be limited to 1280, the extra header
 > doesn't really matter). I don't like the transport all mode for
 > architectural reasons.

=> Ok. can you please elaborate? I know you never liked it
but I don't know what the architectural reasons are. I think
it's a more "correct" use of IPsec to not use tunnel mode
between two end nodes. IMO tunnel mode only needs to be used
when an intermediate node is terminating/initiating IPsec. 

Hesham

 > 
 > Regards
 >    
 > [email-masked]
 > 
 > PS: my concern is specific to MIPv6/NEMO, look at my comment about
 > draft-ietf-v6ops-ipsec-tunnels-02.txt for the other cases.
 > 

_______________________________________________
Mip6 mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mip6

---

From: Francis Dupont <[email-masked]>
Date: Fri, 28 Apr 2006 22:28:55 +0200

In your previous mail you wrote:

    > I don't like the transport all mode for architectural reasons.
   
   => Ok. can you please elaborate?

=> I consider the HAO as a degenerated tunnel so you have double
tunneling (one tunnel for IPsec, one for MIPv6) when obviously only
one is needed.

   I know you never liked it
   but I don't know what the architectural reasons are.

=> double tunneling.

   I think
   between two end nodes.

=> but is the right end the HA or the CN (:-)?

   IMO tunnel mode only needs to be used
   when an intermediate node is terminating/initiating IPsec. 
   
=> this is the case here: the intermediate node is the HA.
   
Regards