Subject: RE: [Mip6] How to store DNS records about HAs, (draft-ietf-mip6-bootstrapping-split-02.txt)?

From: "Chowdhury, Kuntal" <[email-masked]>
Date: Fri, 28 Apr 2006 10:57:41 -0400

Hello,

What is proposed here (although looks simple) will only allow the MN to
have a "fixed" home link. Operators who use Mobile IP today assign a
home agent (i.e. home link) that is geographically close to the point of
attachment of the MN or even a home agent in the visited network.
Therefore, the concept based on "always the same home link" may not work
in real deployment.

-Kuntal

> -----Original Message-----
> From: COMBES Jean-Michel RD-MAPS-ISS
> [mailto:[email-masked]]
> Sent: Wednesday, April 26, 2006 8:53 AM
> To: Alexandru Petrescu; [email-masked]
> Subject: RE: [Mip6] How to store DNS records about
HAs,(draft-ietf-mip6-
> bootstrapping-split-02.txt)?
> 
> Hi,
> 
> > -----Original Message-----
> > From: Alexandru Petrescu [mailto:[email-masked]]
> > Sent: Tuesday, April 25, 2006 9:38 PM
> > To: [email-masked]
> > Subject: [Mip6] How to store DNS records about
> > HAs,(draft-ietf-mip6-bootstrapping-split-02.txt)?
> >
> > I have a question about deploying a home network supporting
> > the bootstrapping solution described in
> > draft-ietf-mip6-bootstrapping-split-02.txt.  If it's been
> > already discussed please ignore it: how to store DNS records
> > that would work for this bootstrapping?
> 
> For me: store the HA anycast address in the DNS (+ DNSSEC) and after
use
> draft-dupont-ikev2-haassign-01.txt to get the right HA
> 
> The advantages of such a solution:
> + Only one address to store in the DNS
> + HA assignment
> + Security
> 
> >
> > Suppose I'm owner of domain example.com that has a bunch of
> > subnets and I'd like all the hosts to be able to move, i.e.
> > run MIP6.  Subnet1 is served by ha1 and ha2 and subnet2 by
> > other ha1 and ha2.  Should I store in DNS:
> >
> > ha1.subnet1.example.com, ha2.subnet1.example.com...
> > ha1.subnet2.example.com, ha2.subnet2.example.com ?
> >
> > Because I guess it is not sufficient to store all HAs
> > directly under example.com, because DNS wouldn't know to
> > return which HAs to which MN.
> >   And also because I think there are many deployments that
> > don't do a sub-domain per IP subnet.
> >
> > Second, would this recommendation apply when the SRV method
> > is used too?
> >
> > If the above recommendations is right, it could be put in
> > various ways in the draft.  The simplest way would be to go
> > where example.com is first mentioned and say: "(it is assumed
> > that example.com is not subnetted for MNs, all MNs served by
> > example.com are under a unique subnet)".  The longer
> > recommendation would try to describe an example deployment.
> >
> > Alex
> >
> > _______________________________________________
> > Mip6 mailing list
> > [email-masked]
> > https://www1.ietf.org/mailman/listinfo/mip6
> >
> 
> Best regards.
> 
> JMC.
> 
> France Telecom - R&D Division - MAPS/NSS
> Jean-Michel COMBES, Internet/Intranet Security
> E-Mail: [email-masked]
> Phone: +33 (0)1 45 29 45 94
> Fax: +33 (0)1 45 29 65 19
> Mobile: +33 (0)6 07 29 30 16
> 
> _______________________________________________
> Mip6 mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/mip6

_______________________________________________
Mip6 mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mip6

---

From: Alexandru Petrescu <[email-masked]>
Date: Fri, 28 Apr 2006 17:08:57 +0200

Chowdhury, Kuntal wrote:
> Hello,
> 
> What is proposed here (although looks simple) will only allow the MN 
> to have a "fixed" home link. Operators who use Mobile IP today assign
>  a home agent (i.e. home link) that is geographically close to the 
> point of attachment of the MN or even a home agent in the visited 
> network. Therefore, the concept based on "always the same home link" 
> may not work in real deployment.

If operator has 3 locations where HAs are present, it could
pre-configure on each phone 3 anycast HA fqdns or 3 home links prefixes.
  Would this work?

If operator considers storing 3 fqdns in each phone as not minimal, what 
protocol would operator use to store each location's HA address in the 
DNS?  And how would MN know to query the DNS for a specific location HA 
when all it has is just one fqdn?

Alex

---

From: Alexandru Petrescu <[email-masked]>
Date: Fri, 28 Apr 2006 17:12:58 +0200

Chowdhury, Kuntal wrote:
> Therefore, the concept based on "always the same home link" may not
> work in real deployment.

Right, but changing the home link involves loss of permanent home 
address, session continuity and reachability.

I.e. if I change my home link then I won't obtain same home address so 
all communications at the previous home address are lost, no?

Alex