Subject: RE: [Mip6] MOBIKE and MIP

From: "Vijay Devarapalli" <[email-masked]>
Date: Mon, 3 Apr 2006 11:25:53 -0700

hi Jim,

draft-ietf-mip4-vpn-problem-solution-02 assumes
legacy VPNs. this would mean, the VPN GW cannot
be touched while running Mobile IPv4. the 
solution requires a external HA and an internal 
HA so that the VPN gateways can be traversed
without touching them and at the same time 
provide mobility while crossing trust boundaries.

draft-ietf-mip4-mobike-connectivity-00 addresses
the same problem as 
draft-ietf-mip4-vpn-problem-solution-02 but 
assumes that the VPN GW on the path is actually 
a VPN GW that uses IKEv2 and supports MOBIKE. 
not a legacy VPN GW. then it is possible to setup
a Mobile IPv4 tunnel inside the MOBIKE tunnel.

both the above drafts assume the VPN GW and 
the home agent are two separate boxes.

draft-meghana-mip4-mobike-optimizations-00 takes
the concept further and reduces the overhead by 
having FA functionality or HA functionality on 
the VPN GW in addition to IKEv2 and MOBIKE
functionality.

MIPv4 and MIPv6 are very different protocols.
with MIPv6 you set up an IPsec protected Mobile
IP tunnel between the mobile node and the HA.
so you already have the VPN functionality. the 
'K' bit also allows you to update the IKE SA 
associated with the tunnel. this is what MOBIKE 
tries to do too. so that's why I don't expect 
someone to use MOBIKE and MIP6 at the same time 
to the same box (or gateway).

there was an email on this list from Jouni 
Korhonen asking if we can write up something 
for MIP6 and MOBIKE along the lines of 
draft-ietf-mip4-mobike-connectivity-00. I 
had told him yes. but this assumes the VPN GW
and the home agent as two separate boxes, 
with a MIP6 tunnel to the home agent inside 
the IPsec tunnel to the VPN gateway. I have 
already written up a draft on this, but didn't 
submit it because I didn't see a need for it. 
it is a very obvious solution.

Vijay

> -----Original Message-----
> From: James Kempf [mailto:[email-masked]] 
> Sent: Monday, April 03, 2006 9:44 AM
> To: [email-masked]
> Subject: [Mip6] MOBIKE and MIP
> 
> There is some discussion going on in the MIP4 group about 
> running MOBIKE and 
> MIP together. The following drafts have been written on the topic:
> 
> - draft-ietf-mip4-vpn-problem-solution-02 (this one is pre-MOBIKE)
> - draft-ietf-mip4-mobike-connectivity-00
> - draft-meghana-mip4-mobike-optimizations-00
> 
> I haven't read the drafts, but I'm told that their 
> recommendation is not to 
> avoid using MIP and MOBIKE together, which seemed to be the 
> conclusion of 
> the discussion during the WG meeting at IETF 65. I don't know 
> whether that 
> conclusion would apply to MIP6, since IKE/IPsec is more 
> tightly integrated 
> with MIP6 and MOBIKE might have a larger effect on interoperation.
> 
>             jak
> 
> 
> 
> _______________________________________________
> Mip6 mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/mip6
> 

_______________________________________________
Mip6 mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mip6

---

From: Behcet Sarikaya <[email-masked]>
Date: Mon, 03 Apr 2006 14:52:17 -0500

>it is a very obvious solution.
So you are saying that in fact MOBIKE does not introduce a new mobility 
architecture, it just carries MIP tunnels?
What if there is no tunnel, i.e. RO case?

Regards,

Behcet