Subject: RE: [Mip6] New charter item: HA assignment

From: "Chowdhury, Kuntal" <[email-masked]>
Date: Tue, 18 Jul 2006 14:26:38 -0400

Alex,

What you describe will require many round trips for the network (MSP) to
assign a HA. There is a fundamental difference between discovery and
assignment. What Jean-Michel brought up is the need in the industry for
HA assignment.

In the integrated scenario solution document we used AAA infrastructure
and DHCP to _assign_ the HA. May be operators interested in HA
assignment should use that instead of DNS.

-Kuntal

> -----Original Message-----
> From: Alexandru Petrescu [mailto:[email-masked]]
> Sent: Tuesday, July 18, 2006 11:49 AM
> To: Jean-Michel Combes
> Cc: Mobile IPv6 Mailing List
> Subject: Re: [Mip6] New charter item: HA assignment
> 
> Jean-Michel Combes wrote:
> > Hi,
> >
> > as promised during the mip6 session, here is a point which, IMO, is
> > important from a MSP's point of view: Actually, the bootstrapping
> > solution, in the split scenario, only propose a HA discovery
> > mechanism (i.e. the MN receives a list of HA, from DNS, and chooses
> > one of them). The MSP has no easy solution to enforce one MN to have
> > a specific HA.
> 
> One possible way is for a HA to stop sending BAck, at which point an
MN
> would send DHAAD Request again, and a different HA replies back DHAAD,
> so end result is MN is assigned a new HA.
> 
> Another way is for the new HA to send Binding Refresh Request to MN
> (even if it has no BC entry for it).
> 
> Another way, if the split bootstrapping advances, is for the MSP to
> dynamically update the DNS data about HAs, so when MN bootstraps it
> obtains a different HA.
> 
> If the HA address is discovered with DHCP then I think the DHCP Server
> can send specific messages to MN (unsolicited by MN).
> 
> It would require relaxing some language in rfc 3775 and probably
> extending BRR.
> 
> It would be helpful to know when would an MSP like the MN to choose a
> different HA, for what reasons.
> 
> Alex
> 
> 
> _______________________________________________
> Mip6 mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/mip6

"This email message and any attachments are confidential information of Starent Networks, Corp. The information transmitted may not be used to create or change any contractual obligations of Starent Networks, Corp.  Any review, retransmission, dissemination or other use of, or taking of any action in reliance upon this e-mail and its attachments by persons or entities other than the intended recipient is prohibited. If you are not the intended recipient, please notify the sender immediately -- by replying to this message or by sending an email to [email-masked] -- and destroy all copies of this message and any attachments without reading or disclosing their contents. Thank you."

_______________________________________________
Mip6 mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mip6

---

From: "Jean-Michel Combes" <[email-masked]>
Date: Thu, 20 Jul 2006 16:22:58 +0200

Hi Kuntal,

2006/7/18, Chowdhury, Kuntal <[email-masked]>:
> assign a HA.

I totally agree with you.

> There is a fundamental difference between discovery and

Exactly :)

> assignment should use that instead of DNS.

But this only works in the case there is a DHCP Relay in the Access Network.
BTW, I asked sometime ago on the DHC ML, why is it not possible to use
directly the unicast address of a DHCP Server (cf. RFC 3315, section
18.2.1) and I never had a clear answer :(

Best regards.

JMC.