Subject: RE: [Mip6] Consensus call: DHCPv6 options for bootstrapping

From: "Shengyou Zeng \(szeng\)" <[email-masked]>
Date: Tue, 8 Aug 2006 08:44:27 -0400

I participate in DHC WG and know a little about MIPv6, and my 
opinion is 2 is the right way to do it.  -Shengyou 

> -----Original Message-----
> From: Pekka Savola [mailto:[email-masked]] 
> Sent: Tuesday, August 08, 2006 8:06 AM
> To: Basavaraj Patil
> Cc: [email-masked]
> Subject: Re: [Mip6] Consensus call: DHCPv6 options for bootstrapping
> 
> On Mon, 7 Aug 2006, Basavaraj Patil wrote:
> > We are seeking WG consensus in order to resolve the issue. Please
> > express your opinion w.r.t the approaches mentioned below:
> >
> > Options:
> >
> > 1. Have a single document which specifies the solution describing
> >   bootstrapping with DHCPv6 which includes the DHCPv6 options that
> >   are needed.
> >
> > 2. Specify the DHCP options needed for bootstrapping with 
> DHCPv6 in a
> >   separate document and have this referenced in the solution I-D.
> 
> Does DHC WG (which has to do significant review for the 
> document) have 
> an opinion on this ?
> 
> If I were a member of DHC WG and knew nothing (and didn't 
> want to know 
> for that matter) about MIPv6, I'd argue for 2...
> 
> -- 
> Pekka Savola                 "You each name yourselves king, yet the
> Netcore Oy                    kingdom bleeds."
> Systems. Networks. Security. -- George R.R. Martin: A Clash of Kings
> 
> _______________________________________________
> Mip6 mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/mip6
> 

_______________________________________________
Mip6 mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mip6

---

From: "Kent Leung \(kleung\)" <[email-masked]>
Date: Fri, 11 Aug 2006 16:25:40 -0700

I'm assuming that Option #1 would not include the Home Address Option.
This is needed in 3GPP2's TIA-835 Rev D.

I vote for #2 so various schemes could make use of the DHCP Options.

Kent 

> From: Basavaraj Patil [mailto:[email-masked]] 
> Sent: Monday, August 07, 2006 1:58 PM
> To: [email-masked]
> Subject: [Mip6] Consensus call: DHCPv6 options for bootstrapping
> 
> 
> Hello,
> 
> We have been debating the issue of how to specify the DHCP 
> options needed for bootstrapping for a while now and have not 
> been able to reach any conclusions. This issue was discussed 
> at the WG meeting at
> IETF66 and has been debated on the mailing list as well.
> 
> 
> I-Ds of interest here:
> a. MIP6-bootstrapping via DHCPv6 for the Integrated Scenario
>    draft-ietf-mip6-bootstrapping-integrated-dhc-01.txt
> 
> b. DHCP Option for Home Information Discovery in MIPv6
>    draft-jang-mip6-hiopt-00.txt
> 
> Issue: MIP6 bootstrapping can be done using DHCPv6. The WG document
> (draft-ietf-mip6-bootstrapping-integrated-dhc-01) describes 
> the use of DHCP in the integrated scenario. In order to use 
> DHCP for bootstrapping several DHCP options need to be 
> specified. The WG I-D in section 3.5 has specified a couple 
> of DHCPv6 options. I-D draft-jang-mip6-hiopt-00 specifies 
> several other DHCP options which are essential for bootstrapping.
> 
> The issue is if the DHCP options need to be specified
>     (i) as part of the solution I-D describing bootstraping using DHCP
>     or 
>     (ii) in a separate document which would then be referenced by the
>     bootstrapping with DHCP solution doc.
> 
> We are seeking WG consensus in order to resolve the issue. 
> Please express your opinion w.r.t the approaches mentioned below:
> 
> Options:
> 
> 2. Specify the DHCP options needed for bootstrapping with DHCPv6 in a
> Please submit your preference to the list by Aug 14th, 06.
> 
> -Raj
> 
>

---

From: "Giaretta Gerardo" <[email-masked]>
Date: Wed, 16 Aug 2006 17:46:14 +0200

I'm in favor of option 1. If option 2 is chosen, I'm wondering if we really need the integrated scenario document (since it is named "DHCP-based" and does not add too much to the split document).

--Gerardo

> From: Basavaraj Patil [mailto:[email-masked] <mailto:[email-masked]> ]
> Sent: lunedì 7 agosto 2006 22.58
> To: [email-masked]
> We have been debating the issue of how to specify the DHCP options
> needed for bootstrapping for a while now and have not been able to
> reach any conclusions. This issue was discussed at the WG meeting at
> (draft-ietf-mip6-bootstrapping-integrated-dhc-01) describes the use of
> DHCP in the integrated scenario. In order to use DHCP for
> bootstrapping several DHCP options need to be specified. The WG I-D in
> section 3.5 has specified a couple of DHCPv6 options. I-D
> draft-jang-mip6-hiopt-00 specifies several other DHCP options which
> are essential for bootstrapping.
>
> https://www1.ietf.org/mailman/listinfo/mip6 <https://www1.ietf.org/mailman/listinfo/mip6> 
> 

--------------------------------------------------------------------

CONFIDENTIALITY NOTICE

This message and its attachments are addressed solely to the persons above and may contain confidential information. If you have received the message in error, be informed that any use of the content hereof is prohibited. Please return it immediately to the sender and delete the message. Should you have any questions, please contact us by replying to [email-masked].

        Thank you

                                        www.telecomitalia.it

--------------------------------------------------------------------