Subject: RE: [Mip6] Consensus call: DHCPv6 options for bootstrapping

From: "Vijay Devarapalli" <[email-masked]>
Date: Mon, 7 Aug 2006 17:12:27 -0700

I prefer option 1) since I don't really see the need for
a separate document specifying the DHCP options.

Vijay 

> -----Original Message-----
> From: Basavaraj Patil [mailto:[email-masked]] 
> Sent: Monday, August 07, 2006 1:58 PM
> To: [email-masked]
> Subject: [Mip6] Consensus call: DHCPv6 options for bootstrapping
> 
> 
> Hello,
> 
> We have been debating the issue of how to specify the DHCP options
> needed for bootstrapping for a while now and have not been able to
> reach any conclusions. This issue was discussed at the WG meeting at
> IETF66 and has been debated on the mailing list as well.
> 
> 
> I-Ds of interest here:
> a. MIP6-bootstrapping via DHCPv6 for the Integrated Scenario
>    draft-ietf-mip6-bootstrapping-integrated-dhc-01.txt
> 
> b. DHCP Option for Home Information Discovery in MIPv6
>    draft-jang-mip6-hiopt-00.txt
> 
> Issue: MIP6 bootstrapping can be done using DHCPv6. The WG document
> (draft-ietf-mip6-bootstrapping-integrated-dhc-01) describes the use of
> DHCP in the integrated scenario. In order to use DHCP for
> bootstrapping several DHCP options need to be specified. The WG I-D in
> section 3.5 has specified a couple of DHCPv6 options. I-D
> draft-jang-mip6-hiopt-00 specifies several other DHCP options which
> are essential for bootstrapping.
> 
> The issue is if the DHCP options need to be specified
>     (i) as part of the solution I-D describing bootstraping using DHCP
>     or 
>     (ii) in a separate document which would then be referenced by the
>     bootstrapping with DHCP solution doc.
> 
> We are seeking WG consensus in order to resolve the issue. Please
> express your opinion w.r.t the approaches mentioned below:
> 
> Options:
> 
> 1. Have a single document which specifies the solution describing
>    bootstrapping with DHCPv6 which includes the DHCPv6 options that
>    are needed.
> 
> 2. Specify the DHCP options needed for bootstrapping with DHCPv6 in a
>    separate document and have this referenced in the solution I-D.
> 
> 
> Please submit your preference to the list by Aug 14th, 06.
> 
> -Raj
> 
> 
> _______________________________________________
> Mip6 mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/mip6
> 

_______________________________________________
Mip6 mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mip6

---

From: "Narayanan, Vidya" <[email-masked]>
Date: Mon, 7 Aug 2006 20:15:19 -0700

I've been following the discussion and option 1 makes sense to me too. 

Vidya 

> From: Vijay Devarapalli [mailto:[email-masked]] 
> Sent: Monday, August 07, 2006 5:12 PM
> To: Basavaraj Patil; [email-masked]
> Subject: RE: [Mip6] Consensus call: DHCPv6 options for bootstrapping
> 
> I prefer option 1) since I don't really see the need for a 
> separate document specifying the DHCP options.
> 
> Vijay 
>