Subject: RE: Local HA assignment using DNS (was Re: [Mip6] AD review ofdraft-ietf-mip6-bootstrapping-split)

From: "Chowdhury, Kuntal" <[email-masked]>
Date: Thu, 1 Mar 2007 20:46:01 -0500

> One mechanism
>     is to provision the mobile node with an FQDN for a local home
agent
>     when it attaches to the local link through an access link specific
>     mechanism.  For example the FQDN of the local home agent can be
sent
>     to the mobile node using DHCP.

Why only FQDN? The local HA address can be sent directly to the MN. Why
asking the MN to do one more roundtrip with DNS? Just use the DHCP
options in HIOPT. If DHCP is used by the MN, and if the DHCP server has
local HA address info, it should be able to give it out to the MN.

-Kuntal

> -----Original Message-----
> From: Vijay Devarapalli [mailto:[email-masked]]
> Sent: Thursday, March 01, 2007 5:04 PM
> To: Jari Arkko
> Cc: Mobile IPv6 Mailing List
> Subject: Local HA assignment using DNS (was Re: [Mip6] AD review
ofdraft-
> ietf-mip6-bootstrapping-split)
> 
> Jari Arkko wrote:
> > Vijay,
> >> There was an explicit requirement to support local HA
> >> assignment using DNS. IMO, local HA assignment is
> >> required for any HA discovery/assignment mechanism. So
> >> I would like to keep the text instead of saying it is
> >> out of scope.
> >>
> >> The example is trying to describe how a particular
> >> operator may "name" the home agents, what entries appear
> >> in the DNS servers, and what FQDNs are provisioned in
> >> the mobile node.
> >>
> >> This particular paragraph underwent multiple changes.
> >> I can re-write the text to better explain how it can be
> >> done or to address any specific concern.
> >
> > The reason that I am reacting on this is that we should
> > either explain, fully, how to do it or otherwise declare
> > it out of scope.
> >
> > I see several holes in the example text, including, for
> > instance, how the mobile nodes determine the locations,
> > how changes in the available locations are managed
> > between the MN and HA implementations, etc.
> 
> I re-wrote the text a bit. Here is the new text.
> 
>     Additionally, the ability to provide a mobile node with a
localized
>     home agent (e.g. on the visited link) can help to optimize
handover
>     signaling and improve routing efficiency in bi-directional
tunneling
>     mode.  There are many mechanisms to assign a local home agent to a
>     mobile node.  These mechanisms are out of scope for this document,
>     but a couple of them are described here as examples.  One
mechanism
>     is to provision the mobile node with an FQDN for a local home
agent
>     when it attaches to the local link through an access link specific
>     mechanism.  For example the FQDN of the local home agent can be
sent
>     to the mobile node using DHCP.  Another mechanism is to specify an
>     interoperable naming convention for constructing home agent FQDNs
>     based on the mobile node's location.  For example, a mobile
network
>     operator may assign the FQDN "ha.locationA.operator.com" to the
Home
>     Agent located in "location A" and the FQDN
>     "ha.locationB.operator.com" to the Home Agent located in "location
>     B".  If the Mobile Node is attached to "location A" and wants to
use
>     a Home Agent located in "location A", it will set the QNAME to
>     "ha.locationA.operator.com" in the DNS request.  The Mobile Node
>     determines that it is attached to "location A" through access link
>     specific mechanisms.  If the mobile operator changes the location
>     information for a particular local link, the FQDNs for the home
>     agents on the local link should also be updated with the new
location
>     information.
> 
>     If the mobile node is unable to discover a local home agent, it
MUST
>     use the home agent on its home link.
> 
> Comments?
> 
> _______________________________________________
> Mip6 mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/mip6

_______________________________________________
Mip6 mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mip6

---

From: "Gerardo Giaretta" <[email-masked]>
Date: Fri, 2 Mar 2007 10:38:31 +0100

> local HA address info, it should be able to give it out to the MN.

Kuntal, this text is for split scenario draft. The DHCP option is not
a solution for split scenario.

--Gerardo