Subject: RE: [Mip6] DSMIP6 solution and integrated bootstrap scenario

From: "Chowdhury, Kuntal" <[email-masked]>
Date: Thu, 1 Mar 2007 11:00:38 -0500

> -----Original Message-----
> From: Gerardo Giaretta [mailto:[email-masked]]
> Sent: Thursday, March 01, 2007 4:05 AM
> To: Vijay Devarapalli
> Cc: Chowdhury, Kuntal; [email-masked]; [email-masked]
> Subject: Re: [Mip6] DSMIP6 solution and integrated bootstrap scenario
> 
> On 3/1/07, Vijay Devarapalli <[email-masked]> wrote:
> > Chowdhury, Kuntal wrote:
> >
> > >> [email-masked] wrote:
> > >>> Okay.. I see your point now.
> > >>> I agree that the DS-MIP6 I-D could either refer or mention the
> > > methods
> > >>> by which the MN can discover the HA.
> > >> We can mention in the DS-MIPv6 spec, that if DS-MIPv6
> > >> is being used in the integrated scenario, DHCPv6 may
> > >> also be used for HA bootstrapping. Thats not a big
> > >> deal.
> > >>
> > > [KC>] IMHO, section 2.1 should just point to the two bootstrapping
> > > solutions (i.e. split and integrated) so that deployments
utilizing
> > > either of the bootstrapping solution can use DSMIP6.
> >
> > No. We need to show at least one mechanism for MN to
> > obtain the IPv4 address of the HA. Otherwise we are
> > left only with manual configuration of HA's IPv4
> > address on the mobile node. We have three paragraphs
> > in section 2.1 that describes how one can add the
> > 'A' record for the HA in the DNS entry in addition to
> > the 'AAAA' record and how the mobile node may obtain
> > the HA's IPv4 address.
> >
> 
> I agree with Vijay. Text on section 2.1 is needed since in
> bootstrapping-split draft we refer only to IPv6 HA addresses and AAAA
> records.
> 
[KC>] OK. I can live with some _additional_ clarification around the use
of DNS for DSMIP6 bootstrapping in the DSMIP6 I-D. But, we should also
add references to the integrated scenario which uses DHCP (albeit with
caveats like v4 only ASP).

> --Gerardo
> 
> > Kuntal, I don't have a problem listing DHCP also as
> > one of the solutions for DS-MIPv6 HA discovery,  but
> > we need to extend DHCPv4 (only DHCPv4 is available
> > on an IPv4 access network) to return the IPv6 and
> > IPv4 address of the DS-MIPv6 home agent. Please work
> > on these extensions before demanding that we add
> > references to other solutions.
> >
> > Vijay
> >
> > _______________________________________________
> > Mip6 mailing list
> > [email-masked]
> > https://www1.ietf.org/mailman/listinfo/mip6
> >

_______________________________________________
Mip6 mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mip6

---

From: "Alper Yegin" <[email-masked]>
Date: Fri, 2 Mar 2007 11:57:29 +0200

> caveats like v4 only ASP).

This makes sense. Why would there be an objection to such a thing?

Alper