Subject: Re: [Mip6] DSMIP6 solution and integrated bootstrap scenario

From: "Gerardo Giaretta" <[email-masked]>
Date: Thu, 1 Mar 2007 11:05:07 +0100

On 3/1/07, Vijay Devarapalli <[email-masked]> wrote:
> Chowdhury, Kuntal wrote:
>
> >> [email-masked] wrote:
> >>> Okay.. I see your point now.
> >>> I agree that the DS-MIP6 I-D could either refer or mention the
> > methods
> >>> by which the MN can discover the HA.
> >> We can mention in the DS-MIPv6 spec, that if DS-MIPv6
> >> is being used in the integrated scenario, DHCPv6 may
> >> also be used for HA bootstrapping. Thats not a big
> >> deal.
> >>
> > [KC>] IMHO, section 2.1 should just point to the two bootstrapping
> > solutions (i.e. split and integrated) so that deployments utilizing
> > either of the bootstrapping solution can use DSMIP6.
>
> No. We need to show at least one mechanism for MN to
> obtain the IPv4 address of the HA. Otherwise we are
> left only with manual configuration of HA's IPv4
> address on the mobile node. We have three paragraphs
> in section 2.1 that describes how one can add the
> 'A' record for the HA in the DNS entry in addition to
> the 'AAAA' record and how the mobile node may obtain
> the HA's IPv4 address.
>

I agree with Vijay. Text on section 2.1 is needed since in
bootstrapping-split draft we refer only to IPv6 HA addresses and AAAA
records.

--Gerardo

> Kuntal, I don't have a problem listing DHCP also as
> one of the solutions for DS-MIPv6 HA discovery,  but
> we need to extend DHCPv4 (only DHCPv4 is available
> on an IPv4 access network) to return the IPv6 and
> IPv4 address of the DS-MIPv6 home agent. Please work
> on these extensions before demanding that we add
> references to other solutions.
>
> Vijay
>
> _______________________________________________
> Mip6 mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/mip6
>

_______________________________________________
Mip6 mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mip6

---

From: "Chowdhury, Kuntal" <[email-masked]>
Date: Thu, 1 Mar 2007 10:31:00 -0500

> -----Original Message-----
> From: Gerardo Giaretta [mailto:[email-masked]]
> Sent: Thursday, March 01, 2007 4:09 AM
> To: Chowdhury, Kuntal
> Cc: Vijay Devarapalli; [email-masked]; [email-masked]
> Subject: Re: [Mip6] DSMIP6 solution and integrated bootstrap scenario
> 
> Kuntal,
> 
> we may add a reference to the integrated scenario draft, but you
> cannot hide the fact that the solution defined for the integrated
> scenario is based on DHCPv6 and cannot be used in IPv4-only access
> networks (that are the main scope of this draft).
> 
[KC>] Gerardo, I do not suggest that we hide any facts. So, stating
current limitation would be alright.

> Therefore the reference to the integrated scenario solution, if added,
> must come with a clear applicability statement that can be used only
> in case the access network from which the MN is bootstrapping is
> dual-stack.
> 
[KC>] I have no problem with such statement. It will clarify the current
limitation with DHCPv6 operation in an IPv4 only ASP and at the same
time remove any confusion that DSMIP6 works with split scenario only.

> --Gerardo
> 
> On 3/1/07, Chowdhury, Kuntal <[email-masked]> wrote:
> > Vijay,
> >
> > Let's not debate over specific cases like the IPv4 only access
network
> > case that you cite. There is no guarantee that the DNS method for
Home
> > Agent discovery will produce the information the MN is looking for
all
> > the time. What will the MN do in a situation when it fails to get
the HA
> > information from DNS? It will fallback on some other scheme, no?
> >
> > The MN needs to have fallback options regardless of which method is
used
> > i.e. DNS or DHCP or something else. There is no need in the DSMIP6
I-D
> > to get into "preference" for mip6 bootstrap solution. Depending on
the
> > use case, access network capabilities (e.g. v4 or v6 or dual stack),
> > deployment scenario, roaming agreement etc. either split or the
> > integrated modes of mip6 bootstrapping will be used. The current
draft
> > is unduly biased towards DNS option and I am raising the point to
fix
> > that.
> >
> > I want the DSMIP6 I-D to be agnostic to the bootstrapping solution.
> >
> > -Kuntal
> >
> >
> > > -----Original Message-----
> > > From: Vijay Devarapalli [mailto:[email-masked]]
> > > Sent: Wednesday, February 28, 2007 6:16 PM
> > > To: Chowdhury, Kuntal
> > > Cc: [email-masked]; [email-masked]
> > > Subject: Re: [Mip6] DSMIP6 solution and integrated bootstrap
scenario

---

From: "Chowdhury, Kuntal" <[email-masked]>
Date: Thu, 1 Mar 2007 10:57:54 -0500

> From: Hesham Soliman [mailto:[email-masked]]
> Sent: Wednesday, February 28, 2007 11:24 PM
> To: Chowdhury, Kuntal; 'Vijay Devarapalli'
> Cc: [email-masked]; [email-masked]
> Subject: RE: [Mip6] DSMIP6 solution and integrated bootstrap scenario
> 
> 
> 
>  > Let's not debate over specific cases like the IPv4 only
>  > access network
>  > case that you cite.
> 
> => This specific case forms about 70% of the rationale for the DSMIPv6
> work,
> so I don't see how you can ignore it.
> 
[KC>] I don't think your quantification of the rationale for DSMIP6 is
based on any fact. I may run DSMIP6 if I am connected to an IPv6 or dual
stack ASP and I want to obtain a v4 address. IMHO, ASP with only v4
capability is one scenario. ASP with dual stack capability is another
scenario where the integrated solution will work w/o any change. Already
two SDOs adopted the integrated scenario solution. The operators I have
spoken with, all have plans to deploy dual stack NASs (e.g. ASN-GWs for
WiMAX) when they roll out v6 service. So, I don't buy your argument that
v4 only ASP is the main scenario that we need to consider for DSMIP6.

>    There is no guarantee that the DNS
>  > method for Home
>  > Agent discovery will produce the information the MN is
>  > looking for all
>  > the time. What will the MN do in a situation when it fails
>  > to get the HA
> => May be and may be not. If there is a general failure in the DNS
system
> today, there is very little that you can do. If you want to do online
> banking and DNS is not working then you simply won't do it. My point
is,
> there is very little that we can do to get around a DNS failure.
Similarly,
> if DHAAD failed in the basic spec, there is nothing that the MN can do
> unless it is manually configured, which is always possible.
> 
[KC>] Home Agent address discovery falls under the category of IP host
configuration. DHCP is the protocol for IP host configuration NOT DNS.
The MN should try to use DHCP as default for all IP config. That way,
operators can provision ALL IP config options/parameters in one place
i.e. DHCP server. DNS may be used as a fallback if DHCP cannot be run
(e.g. v4 only ASP) or DHCP comes back with no usable IP config
information. In other cases, DHCP should be used as default, IMHO.

> Hesham