Subject: Re: Local HA assignment using DNS (was Re: [Mip6] AD review ofdraft-ietf-mip6-bootstrapping-split)

From: Vijay Devarapalli <[email-masked]>
Date: Thu, 01 Mar 2007 17:51:02 -0800

Chowdhury, Kuntal wrote:
>> One mechanism
>>     is to provision the mobile node with an FQDN for a local home
> agent
>>     when it attaches to the local link through an access link specific
>>     mechanism.  For example the FQDN of the local home agent can be
> sent
>>     to the mobile node using DHCP.
> 
> Why only FQDN? The local HA address can be sent directly to the MN. Why
> asking the MN to do one more roundtrip with DNS? Just use the DHCP
> options in HIOPT. If DHCP is used by the MN, and if the DHCP server has
> local HA address info, it should be able to give it out to the MN.

Kuntal, I know you are very passionate about DHCP. :)
But here we are talking about using DNS to bootstrap
a home agent. The assumption is that support for
draft-ietf-mip6-hiopt-02.txt is not available on the
local network.

If DHCP-based HA assignment is available, it can of
course be used.

Vijay

> 
> -Kuntal
> 
> 
>> -----Original Message-----
>> From: Vijay Devarapalli [mailto:[email-masked]]
>> Sent: Thursday, March 01, 2007 5:04 PM
>> To: Jari Arkko
>> Cc: Mobile IPv6 Mailing List
>> Subject: Local HA assignment using DNS (was Re: [Mip6] AD review
> ofdraft-
>> ietf-mip6-bootstrapping-split)
>>
>> Jari Arkko wrote:
>>> Vijay,
>>>> There was an explicit requirement to support local HA
>>>> assignment using DNS. IMO, local HA assignment is
>>>> required for any HA discovery/assignment mechanism. So
>>>> I would like to keep the text instead of saying it is
>>>> out of scope.
>>>>
>>>> The example is trying to describe how a particular
>>>> operator may "name" the home agents, what entries appear
>>>> in the DNS servers, and what FQDNs are provisioned in
>>>> the mobile node.
>>>>
>>>> This particular paragraph underwent multiple changes.
>>>> I can re-write the text to better explain how it can be
>>>> done or to address any specific concern.
>>> The reason that I am reacting on this is that we should
>>> either explain, fully, how to do it or otherwise declare
>>> it out of scope.
>>>
>>> I see several holes in the example text, including, for
>>> instance, how the mobile nodes determine the locations,
>>> how changes in the available locations are managed
>>> between the MN and HA implementations, etc.
>> I re-wrote the text a bit. Here is the new text.
>>
>>     Additionally, the ability to provide a mobile node with a
> localized
>>     home agent (e.g. on the visited link) can help to optimize
> handover
>>     signaling and improve routing efficiency in bi-directional
> tunneling
>>     mode.  There are many mechanisms to assign a local home agent to a
>>     mobile node.  These mechanisms are out of scope for this document,
>>     but a couple of them are described here as examples.  One
> mechanism
>>     is to provision the mobile node with an FQDN for a local home
> agent
>>     when it attaches to the local link through an access link specific
>>     mechanism.  For example the FQDN of the local home agent can be
> sent
>>     to the mobile node using DHCP.  Another mechanism is to specify an
>>     interoperable naming convention for constructing home agent FQDNs
>>     based on the mobile node's location.  For example, a mobile
> network
>>     operator may assign the FQDN "ha.locationA.operator.com" to the
> Home
>>     Agent located in "location A" and the FQDN
>>     "ha.locationB.operator.com" to the Home Agent located in "location
>>     B".  If the Mobile Node is attached to "location A" and wants to
> use
>>     a Home Agent located in "location A", it will set the QNAME to
>>     "ha.locationA.operator.com" in the DNS request.  The Mobile Node
>>     determines that it is attached to "location A" through access link
>>     specific mechanisms.  If the mobile operator changes the location
>>     information for a particular local link, the FQDNs for the home
>>     agents on the local link should also be updated with the new
> location
>>     information.
>>
>>     If the mobile node is unable to discover a local home agent, it
> MUST
>>     use the home agent on its home link.
>>
>> Comments?
>>
>> _______________________________________________
>> Mip6 mailing list
>> [email-masked]
>> https://www1.ietf.org/mailman/listinfo/mip6
> 
> 
> "This email message and any attachments are confidential information of Starent Networks, Corp. The information transmitted may not be used to create or change any contractual obligations of Starent Networks, Corp.  Any review, retransmission, dissemination or other use of, or taking of any action in reliance upon this e-mail and its attachments by persons or entities other than the intended recipient is prohibited. If you are not the intended recipient, please notify the sender immediately -- by replying to this message or by sending an email to [email-masked] -- and destroy all copies of this message and any attachments without reading or disclosing their contents. Thank you."

_______________________________________________
Mip6 mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mip6

---

From: "Chowdhury, Kuntal" <[email-masked]>
Date: Fri, 2 Mar 2007 23:14:03 -0500

> Sent: Thursday, March 01, 2007 7:51 PM
> To: Chowdhury, Kuntal
> Cc: Jari Arkko; Mobile IPv6 Mailing List
> Subject: Re: Local HA assignment using DNS (was Re: [Mip6] AD review
> ofdraft-ietf-mip6-bootstrapping-split)
> 
> Chowdhury, Kuntal wrote:
> >> One mechanism
[KC>] I think a DSMIP6 MN can attach to a v6 access network (ASP). In
that case, it can obtain the local Home Agent address by setting the
id-type = 0 in the Home Network Identifier Option. This saves it from
doing another DNS roundtrip. I think this need to be clarified in the
DSMIP6 I-D.

> If DHCP-based HA assignment is available, it can of
[KC>] OK. I hope you will clarify this in the draft.

> > "This email message and any attachments are confidential information
of
> Starent Networks, Corp. The information transmitted may not be used to
> create or change any contractual obligations of Starent Networks,
Corp.
> Any review, retransmission, dissemination or other use of, or taking
of
> any action in reliance upon this e-mail and its attachments by persons
or
> entities other than the intended recipient is prohibited. If you are
not
> the intended recipient, please notify the sender immediately -- by
> replying to this message or by sending an email to
> [email-masked] -- and destroy all copies of this
message
> and any attachments without reading or disclosing their contents.
Thank
> you."

---

From: "Chowdhury, Kuntal" <[email-masked]>
Date: Fri, 2 Mar 2007 23:23:44 -0500

> From: Gerardo Giaretta [mailto:[email-masked]]
> Sent: Friday, March 02, 2007 3:39 AM
> To: Chowdhury, Kuntal
> Cc: Vijay Devarapalli; Jari Arkko; Mobile IPv6 Mailing List
> On 3/2/07, Chowdhury, Kuntal <[email-masked]> wrote:
> > > One mechanism
> Kuntal, this text is for split scenario draft. The DHCP option is not
> a solution for split scenario.
> 
[KC>] Gerardo, I understand. But, we are talking about local HA
assignment in the ASP. The proposed text says that the MN will first
figure out the local network name via DHCP, then the MN will use DNS to
figure out an HA in the local domain. The point is, if the MN can do
DHCPv6 and if it can send Home Network Identifier Option in the first
place, it won't have to do two roundtrips. Do you think it will be bad
to refer to an easier option for the MN in the split I-D.? i.e. If
possible, use DHCPv6 directly to obtain local HA address. I think it
makes sense since it reduces the number of roundtrips.

> --Gerardo