Subject: Re: [Mip6] concensus on [issue94] fixing encapsulation mechanism in IPv4 network

From: Tim Enos <[email-masked]>
Date: Wed, 28 Mar 2007 09:12:16 -0500 (CDT)

I also prefer option 'A'.

>From: Hesham Soliman <[email-masked]>
>Date: 2007/03/28 Wed AM 02:33:25 CDT
>To: 'Keiichi SHIMA' <[email-masked]>
>Cc: [email-masked]
>Subject: [Mip6] concensus on [issue94] fixing encapsulation mechanism in	IPv4 network

>Kiichi, all, 
>
>I think we've seen the different angles of this issue now and it's time to
>close it. 
>So I suggest that we choose one of the two options listed below. 
>
>Folks, 
>
>The "new" issue is about whether or not the MN can request one form of
>tunnelling (i.e. UDP) when sending a BU to the HA. The two choices we have
>are:
>
>A. Add a flag that allows the MN to request UDP tunnelling interface
>(independently of the presence of a NAT) from the HA, when sending the BU.
>The HA can override the MN's request. Or, 
>
>B. Do nothing. I.e. the MN sends the BU as described in the spec today and
>the HA tells the MN in the BA whether it should use UDP tunnelling or IP in
>IP. 
>
>Please express your preference for one of the options above. Let's not make
>things complicated and get into negotiating the tunnelling mechanism, one of
>the two above will suffice. 
>
>I'll leave it open till next Tuesday. 
>
>Thanks,
>Hesham
>
>
>
>_______________________________________________
>Mip6 mailing list
>[email-masked]
>https://www1.ietf.org/mailman/listinfo/mip6

_______________________________________________
Mip6 mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mip6

---

From: "Pascal Thubert \(pthubert\)" <[email-masked]>
Date: Wed, 28 Mar 2007 16:19:35 +0200

Same here, A. It's more open. Seems to me that if the MN demands it, the HA should not refuse... 
This would enable a simpler MN implementation that does UDP all the time.
 
Pascal

________________________________

From: Tim Enos [mailto:[email-masked]]
Sent: Wed 3/28/2007 3:12 PM
To: Hesham Soliman; 'Keiichi SHIMA'
Cc: [email-masked]
Subject: Re: [Mip6] concensus on [issue94] fixing encapsulation mechanism inIPv4 network