Subject: RE: [Mip6] FW: I-D ACTION:draft-muhanna-mip6-binding-revocation-00.txt

From: "Vijay Devarapalli" <[email-masked]>
Date: Mon, 4 Jun 2007 14:23:39 -0700

Hi Ahmad,

I don't see a need for reserving two mobility header messages
for this mechanism. My preference is to use the generic mobility
header signaling message (draft-haley-mip6-mh-signaling) and 
define mobility options to carry the revocation information. You 
can extend the mobility option as much as you want to indicate 
the various error codes and the various identifiers used by the
mobile node.

Vijay

> -----Original Message-----
> From: Ahmad Muhanna [mailto:[email-masked]] 
> Sent: Monday, May 28, 2007 5:44 AM
> To: [email-masked]
> Subject: [Mip6] FW: I-D 
> ACTION:draft-muhanna-mip6-binding-revocation-00.txt
> 
>  
> Hello Folks,
> 
> We submitted this draft for Binding Revocation for IPv6 Mobility. It
> handles several use cases which are applicable to Client 
> Mobile IPv6 and
> PMIPv6. Please take a look and we appreciate your comments.
> 
> Thanks in advance.
> 
> Regards,
> Ahmad Muhanna
> 
> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] 
> Sent: Friday, May 25, 2007 2:50 PM
> To: [email-masked]
> Subject: I-D ACTION:draft-muhanna-mip6-binding-revocation-00.txt
> 
> A New Internet-Draft is available from the on-line Internet-Drafts
> directories.
> 
> 
> 	Title		: Binding Revocation for IPv6 Mobility
> 	Author(s)	: A. Muhanna, et al.
> 	Filename	: draft-muhanna-mip6-binding-revocation-00.txt
> 	Pages		: 18
> 	Date		: 2007-5-25
> 	
>    The service binding revocation semantics are missing in Mobile IPv6
>    Specificaion [RFC-3775] and PMIPv6 [PMIP6-SPEC].  This document
>    defines the semantics of the revocation of a mobile node 
> registration
>    binding, which could have been established using a Client 
> Mobile IPv6
>    or a Proxy Mobile IPv6 signaling.  The proposed revocation 
> mechanism
>    uses generic message properties which is applicable to Mobile IPv6
>    and Proxy Mobile IPv6 and can be used by any two mobility entities.
>    As an example, this mechanism allows local mobility agent, involved
>    in providing IP mobility services to a mobile node, to notify the
>    mobility access gateway of the termination of the mobile node
>    registration.
> 
> 
> 
> A URL for this Internet-Draft is:
> http://www.ietf.org/internet-drafts/draft-muhanna-mip6-binding
> -revocatio
> n-00.txt
> 
> To remove yourself from the I-D Announcement list, send a message to 
> [email-masked] with the word unsubscribe in 
> the body of 
> the message. 
> You can also visit 
> https://www1.ietf.org/mailman/listinfo/I-D-announce 
> to change your subscription settings.
> 
> Internet-Drafts are also available by anonymous FTP. Login with the 
> username "anonymous" and a password of your e-mail address. After 
> logging in, type "cd internet-drafts" and then 
> "get draft-muhanna-mip6-binding-revocation-00.txt".
> 
> A list of Internet-Drafts directories can be found in
> http://www.ietf.org/shadow.html 
> or ftp://ftp.ietf.org/ietf/1shadow-sites.txt
> 
> Internet-Drafts can also be obtained by e-mail.
> 
> Send a message to:
> 	[email-masked].
> In the body type:
> 	"FILE
> /internet-drafts/draft-muhanna-mip6-binding-revocation-00.txt".
> 	
> NOTE:	The mail server at ietf.org can return the document in
> 	MIME-encoded form by using the "mpack" utility.  To use this
> 	feature, insert the command "ENCODING mime" before the "FILE"
> 	command.  To decode the response(s), you will need "munpack" or
> 	a MIME-compliant mail reader.  Different MIME-compliant mail
> readers
> 	exhibit different behavior, especially when dealing with
> 	"multipart" MIME messages (i.e. documents which have been split
> 	up into multiple messages), so check your local documentation on
> 	how to manipulate these messages.
> 
> Below is the data which will enable a MIME compliant mail reader
> implementation to automatically retrieve the ASCII version of the
> Internet-Draft.
> 

_______________________________________________
Mip6 mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mip6

---

From: "Ahmad Muhanna" <[email-masked]>
Date: Mon, 4 Jun 2007 16:28:18 -0500

Hi Vijay,

Thanks for you suggestion. Brian, Sri, and I (on behalf of muhanna et.
Al.) agreed on a generic mechanism that draft-haley will adopt which
will preserve the MH Types and at the same time gives flexibility for
defining Binding revocation messages.

Please take a look at the email Brian just posted few minutes back on
the consensus call for adopting draft-haley as a wg document. Hope you
would agree with that concept.

Thanks again.

Regards,
Ahmad

> From: Vijay Devarapalli [mailto:[email-masked]] 
> Sent: Monday, June 04, 2007 4:24 PM
> To: Muhanna, Ahmad (RICH1:2H10); [email-masked]
> Subject: RE: [Mip6] FW: I-D 
> for this mechanism. My preference is to use the generic 
> mobility header signaling message 
> (draft-haley-mip6-mh-signaling) and define mobility options 
> to carry the revocation information. You can extend the 
> mobility option as much as you want to indicate the various 
> error codes and the various identifiers used by the mobile node.
> 
> Vijay
> 
> > and PMIPv6. Please take a look and we appreciate your comments.
> > 
> > Thanks in advance.
> > 
> > Regards,
> > Ahmad Muhanna
> > 
> >    binding, which could have been established using a Client Mobile 
> > IPv6
> > logging in, type "cd internet-drafts" and then "get 
> > draft-muhanna-mip6-binding-revocation-00.txt".
> > 
> > http://www.ietf.org/shadow.html or 
> > ftp://ftp.ietf.org/ietf/1shadow-sites.txt
> > 
> > 	a MIME-compliant mail reader.  Different MIME-compliant 
> mail readers