Subject: [Mip6] Re: AD review of draft-ietf-mip6-bootstrapping-integrated-dhc

From: Jari Arkko <[email-masked]>
Date: Tue, 12 Jun 2007 16:12:50 +0300

Kuntal,

> [KC>] May be it did not come clear, but I proposed the following text in
> my earlier email:
>
> "
> if assignment of home agent in the home MSP is not required by a
> deployment, collocation of NAS and the DHCP relay functions won't be
> necessary. In such a case, the implementation of the options and
> procedures defined in [HIOPT] should suffice.
> "
>   

OK.

>   
>> Please ensure that its clear to the reader
>> what the requirements are for an implementation that conforms
>> to this specification.
>>
>>     
> [KC>] We have a section called "Assumptions", section 3. This was added
> during WGLC. May be we can add the proposed sentence to the assumption
> number c as a caveat:
>
> "
>    c.  DHCP relay and NAS are collocated or there is a mechanism to pass
>    received AAA information from the NAS to the DHCP relay.
> "
>
> Do you suggest we rename this section and call it "Requirements of the
> solution" instead?
>   

No, the issue is whether to claim conformance to your spec
a device needs to have those interfaces or not. Perhaps
you can say something on the lines of "A minimal implementation
of this specification supports only the delivery of information
from the DHCP server or relay through [HIOPT]. However,
an implementation MAY also support assignment of home
agent in MSP. In this case the NAS and relay parts need to be
collocated, or they need to have means to communicate."

Jari

_______________________________________________
Mip6 mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mip6

---

From: "Chowdhury, Kuntal" <[email-masked]>
Date: Tue, 12 Jun 2007 12:01:52 -0400

Hi Jari,

> collocated, or they need to have means to communicate."

I think home agent assignment in Home MSP is a very important aspect of
the solution. For that matter, "MAY also support...." seems to be a
rather weak statement. Can we use a SHOULD instead?

BR,
Kuntal

> -----Original Message-----
> From: Jari Arkko [mailto:[email-masked]]
> Sent: Tuesday, June 12, 2007 8:13 AM
> To: Chowdhury, Kuntal
> Cc: [email-masked];
Mobile
> IPv6 Mailing List
> Subject: Re: AD review of draft-ietf-mip6-bootstrapping-integrated-dhc
> 
> Kuntal,
>

---

From: Vijay Devarapalli <[email-masked]>
Date: Tue, 12 Jun 2007 11:15:08 -0700

> rather weak statement. Can we use a SHOULD instead?

It has to be a 'MUST'. The main focus of the document is to still be
able to assign a home agent from the MSP. Assigning a local home agent
is an additional feature we have in the spec.

Vijay

---

From: "Alper Yegin" <[email-masked]>
Date: Tue, 12 Jun 2007 22:45:01 +0300

> is an additional feature we have in the spec.

"Assigning local HA" is the default capability of
draft-ietf-mip6-hiopt-04.txt. Through AAA plumbing, as described in
draft-ietf-mip6-bootstrapping-integrated-04, now the HA delivered via DHCP
can be from a remote network.

Alper