Subject: RE: [Mip6] I-D ACTION:draft-korhonen-mip6-service-02.txt

From: "Ji Zhang" <[email-masked]>
Date: Wed, 13 Jun 2007 18:01:15 +0100

Hi Jouni,

Just come across this I-D... IMHO, it might be good if there are some
more concrete scenarios/examples to show why this option is necessary or
works better (e.g. reduce additional signaling?).

BTW, does one Service Selection Mobility Option encode a single
identifier or allow multiple as well? If an MN wants to change the
service or the set of services the home agent is offering, would a
deregistration be required before re-registration(s)?

Cheers,
Ji

----- Original Message ----- 
From: <[email-masked]>
To: <[email-masked]>
Sent: Friday, June 08, 2007 6:42 AM
Subject: [Mip6] FW: I-D ACTION:draft-korhonen-mip6-service-02.txt

FYI.. The I-D on service selection for MIP6 has been
revised based on the received comments & feedback.

Cheers,
Jouni

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]
> Sent: Thursday, June 07, 2007 10:50 PM
> To: [email-masked]
> Subject: I-D ACTION:draft-korhonen-mip6-service-02.txt
>
> A New Internet-Draft is available from the on-line
> Internet-Drafts directories.
>
>
> Title : Service Selection for Mobile IPv6
> Author(s) : J. Korhonen, et al.
> Filename : draft-korhonen-mip6-service-02.txt
> Pages : 9
> Date : 2007-6-7
>
> In some Mobile IPv6 deployments identifying the mobile node or the
>    mobility service subscriber is not enough to distinguish between
>    multiple services possibly provisioned to the said mobile node and
>    its mobility service subscription.  A capability to
> specify different
>    services in addition to the mobile node identity can be
> leveraged to
>    provide flexibility for mobility service providers on provisioning
>
>    multiple services to one mobility service subscription.  This
>    document describes a Service Selection Mobility Option for both
>    conventional Mobile IPv6 or Proxy Mobile IPv6 that is intended to
>    assist home agents to make a specific service selection for the
>    mobility service subscription during the binding update procedure.
>
> A URL for this Internet-Draft is:
> http://www.ietf.org/internet-drafts/draft-korhonen-mip6-service-02.txt
>
> To remove yourself from the I-D Announcement list, send a message to
> [email-masked] with the word unsubscribe in
> the body of
> the message.
> You can also visit
> https://www1.ietf.org/mailman/listinfo/I-D-announce
> to change your subscription settings.
>
> Internet-Drafts are also available by anonymous FTP. Login with the
> username "anonymous" and a password of your e-mail address. After
> logging in, type "cd internet-drafts" and then
> "get draft-korhonen-mip6-service-02.txt".
>
> A list of Internet-Drafts directories can be found in
> http://www.ietf.org/shadow.html
> or ftp://ftp.ietf.org/ietf/1shadow-sites.txt
>
> Internet-Drafts can also be obtained by e-mail.
>
> Send a message to:
> [email-masked].
> In the body type:
> "FILE /internet-drafts/draft-korhonen-mip6-service-02.txt".
>
> NOTE: The mail server at ietf.org can return the document in
> MIME-encoded form by using the "mpack" utility.  To use this
> feature, insert the command "ENCODING mime" before the "FILE"
> command.  To decode the response(s), you will need "munpack" or
> a MIME-compliant mail reader.  Different MIME-compliant
> mail readers
> exhibit different behavior, especially when dealing with
> "multipart" MIME messages (i.e. documents which have been split
> up into multiple messages), so check your local documentation on
> how to manipulate these messages.
>
> Below is the data which will enable a MIME compliant mail reader
> implementation to automatically retrieve the ASCII version of the
> Internet-Draft.
>

------------------------------------------------------------------------
--------

> _______________________________________________
> Mip6 mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/mip6
> 

 To report this email as spam click
https://www.mailcontrol.com/sr/wQw0zmjPoHdJTZGyOCrrhg==
DVRCyMKb4W2rVPx0tCfiV5ruvelr6GGHlrhkKDkjC48R5jZ8u+yuWgmclsxI18lIwgo2iePp
TOxHdM3SfspoO2Ssycnc+6w8cgYCSu4!ZYbjtL0Y78QDCjIsKr6JDmowvSNRHGLgFBgW0a5o
rvq5o5c2UheNrFfQqvV2TFd3OCSGuAx0XL3InfQ .

_______________________________________________
Mip6 mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mip6

---

From: <[email-masked]>
Date: Sat, 23 Jun 2007 14:08:42 +0200

Hi Ji,

Thanks for comments and sorry for the delay. See my responses
inline.

> Hi Jouni,
> 
> Just come across this I-D... IMHO, it might be good if there 
> are some more concrete scenarios/examples to show why this 
> option is necessary or works better (e.g. reduce additional 
> signaling?).

Ok.. Will add some more verbal scenario descriptions.

> BTW, does one Service Selection Mobility Option encode a 
> single identifier or allow multiple as well? If an MN wants 

A single identifier.

> to change the service or the set of services the home agent 
> is offering, would a deregistration be required before 
> re-registration(s)?

The current text indicates that Service Selection option should
only be used in the initial BU as the configuring the 'service'
in the HA might need setting up subsequent tunnels and routing
rules to the destination network hosting the 'service' etc.
However, based on the deployment I think it is possible to
'renumber' the services during the MIP6 session without a 
need to deregister first.

Cheers,
	Jouni