Subject: Re: [MEXT] Scope of generic notification

From: "Mohamed Khalil" <[email-masked]>
Date: Thu, 29 May 2008 15:28:04 -0500

Hi Vijay,

Please se inline.

Regards,
Mohamed

> 
> > For example, how would this generic notification mechanism
> support the
> > first very simple usecase "A simple notification message which you
> > just send and forget about it", for example, your prepaid 
> balance is
> > $25.09.
> > which MAY NOT require IPsec protection while at the same
> time support
> > usecase 2 Which impact the BCE and require IPsec protection, while
> > both use the same MH type?
> 
> In this case, you are right. Even if one notification message
> requires IPsec protection, you would end up using IPsec 
> protection on all notification messages. I don't necessarily 
> see that as a bad thing, though. 
>

[MK]
But this means that this generic mechanism is not flexible to allow
simple notification message and notification message which impact the
BCE to coexist when they have different IPsec requirements.

> Vijay
_______________________________________________
MEXT mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/mext

---

From: marcelo bagnulo braun <[email-masked]>
Date: Fri, 30 May 2008 08:12:27 +0200

> BCE to coexist when they have different IPsec requirements.

This is not obvious to me

I understand that if IPsec protection is needed, it is a problem if it 
is not provided

But i don't see a problem in the other way around. I see it more as a 
tradeoff. Maybe it would be possibl to define a mechanism that is 
generic enough to support both, but it is likely to e more complex. 
Avoiding using IPsec is another form of optimizations, since using IPSec 
has costs. The question is whether this is worth it

regards, marcelo