Subject: Re: [MEXT] Adoption of draft-droms-mext-nemo-pd-00.txt?

From: Behcet Sarikaya <[email-masked]>
Date: Mon, 2 Jun 2008 08:18:10 -0700 (PDT)

Hi Romain,
  Please see inline.

Regards,

Behcet

----- Original Message ----
From: Romain KUNTZ <[email-masked]>
To: Behcet Sarikaya <[email-masked]>
Cc: [email-masked]
Sent: Sunday, June 1, 2008 6:08:19 PM
Subject: Re: [MEXT] Adoption of draft-droms-mext-nemo-pd-00.txt?

Hi,

On 2008/05/31, at 0:13, Behcet Sarikaya wrote:
I think this is a good point, we should not hurry up a solution just because it was long overdue.
I have the same concern. Instead of MR, HA could be a better place for DHCP PD. 
http://tools.ietf.org/id/draft-sarikaya-mext-prefix-delegation-00.txt explains this and it is a much simpler document.

I think this document is a companion document to draft-ietf-nemo-prefix-delegation-02, which is based on the MIPv6 signaling (BU/BA) between the MR and the HA for prefix delegation. If I understand well, your document tells how to provision the HA with a list of prefixes, but in the end the MIPv6 signaling is used to delegate a prefix to the MR. This is different from what is proposed in draft-droms-mext-nemo-pd which uses DHCP in all the prefix delegation process. 
[behcet] You are right. I claim that from MR complexity point of view BU/BA signaling leads to a simpler solution. Also BU/BA  guarantees that MR registration with HA is valid at the times of prefix provisioning, this is a big plus.

As DHCP already got the consensus of the WG, that would be better to not debate again on "DHCP versus MIP6 signaling".

[behcet] I was in the room when consensus call was made. The call was if the floor agrees with the use of DHCPv6 PD but did not specify from MR or from HA. 
So the consensus applies to my document as well which proposes to use DHCPv6 PD from HA. 
I mentioned this to the chair on a face to face meeting after the session.
_______________________________________________
MEXT mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/mext

---

From: Romain KUNTZ <[email-masked]>
Date: Tue, 3 Jun 2008 12:03:04 +0200

Hi Behcet,

On 2008/06/02, at 17:18, Behcet Sarikaya wrote:
> [behcet] You are right. I claim that from MR complexity point of  
> view BU/BA signaling leads to a simpler solution.

It also leads to the definition of 2 solutions: DHCPv6 between the HA  
and the DHCP server, and BU/BA extensions. I don't think this makes it  
simpler.

> Also BU/BA  guarantees that MR registration with HA is valid at the  
> times of prefix provisioning, this is a big plus.

A point that was already raised is the home link support: how do you  
delegate prefixes when the MR boots in the Home Link and thus does not  
exchange BU/BA messages? By defining a third solution maybe? ;-)

Synchronizing the MR registration and the DHCP exchange is just an  
implementation matter, and IMHO, not so big to deal with.

> [behcet] I was in the room when consensus call was made. The call  
> was if the floor agrees with the use of DHCPv6 PD but did not  
> specify from MR or from HA.

Ok, what was their opinion on that?

Regards,

-- 
Romain KUNTZ
[email-masked]
Louis Pasteur University - Networks and Protocols Team