Subject: Re: [MEXT] Adoption of draft-droms-mext-nemo-pd-00.txt?

From: Behcet Sarikaya <[email-masked]>
Date: Tue, 3 Jun 2008 08:53:06 -0700 (PDT)

Hi Romain,
  The main point is the additional requirements on the upstream interface of MR. If DHCP PD is used from HA then MR is not required any additional software while if DHCP PD is used from MR then there are additional requirements. This could result in MRs not being implementable on certain kinds of devices as pointed out by Arnaud.

I think this is the main point that WG has to decide.

More in line below.

Regards,

Behcet

----- Original Message ----
From: Romain KUNTZ <[email-masked]>
To: Behcet Sarikaya <[email-masked]>
Cc: [email-masked]
Sent: Tuesday, June 3, 2008 5:03:04 AM
Subject: Re: [MEXT] Adoption of draft-droms-mext-nemo-pd-00.txt?

Hi Behcet,

On 2008/06/02, at 17:18, Behcet Sarikaya wrote:
> [behcet] You are right. I claim that from MR complexity point of  
> view BU/BA signaling leads to a simpler solution.

It also leads to the definition of 2 solutions: DHCPv6 between the HA  
and the DHCP server, and BU/BA extensions. I don't think this makes it  
simpler.

[behcet] You mean two drafts? Firstly they can be combined if the coauthors agree, secondly Ralph's draft could also be divided into two or three drafts, or solutions as you call them.
The simplicity is from MR point of view, our design criteria was to let MR operation be as simple as possible so that MR can be implemented in simpler devices. I think this is the point you are missing.
DHCP PD at the HA solution does not any new requirements on the upstream interface of MR, sending BU receiving BA is already required.

> Also BU/BA  guarantees that MR registration with HA is valid at the  
> times of prefix provisioning, this is a big plus.

A point that was already raised is the home link support: how do you  
delegate prefixes when the MR boots in the Home Link and thus does not  
exchange BU/BA messages? By defining a third solution maybe? ;-)
[behcet] This is good point. We will find a solution for this in a separate third draft 
(just a joke).
I think the same problem exists in Ralph's draft and they need to deal with that as well.

Synchronizing the MR registration and the DHCP exchange is just an  
implementation matter, and IMHO, not so big to deal with.

[behcet] Well, I already had a solution in our draft draft-sarikaya-mext-relay-dhcpv6pd, they can use it.

> [behcet] I was in the room when consensus call was made. The call  
> was if the floor agrees with the use of DHCPv6 PD but did not  
> specify from MR or from HA.
> So the consensus applies to my document as well which proposes to  
> use DHCPv6 PD from HA.
> I mentioned this to the chair on a face to face meeting after the  
> session.

Ok, what was their opinion on that?

[behcet] I would let Marcelo answer this.

_______________________________________________
MEXT mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/mext

---

From: Romain KUNTZ <[email-masked]>
Date: Wed, 4 Jun 2008 10:43:05 +0200

Hi Behcet,

> I think the same problem exists in Ralph's draft and they need to  

I don't think this is a problem in Ralph's draft. When the MR is at  
home, it just operates DHCP as usual. Messages are not exchanged via  
the MR-HA a tunnel but directly on the home link.

> [behcet] I would let Marcelo answer this.

I think his answer to Frank Xia makes it clear.

Regards,

-- 
Romain KUNTZ
[email-masked]
Louis Pasteur University - Networks and Protocols Team