Subject: Re: [MLS] MLS: the WG name should include "group"

From: Jon Millican <[email-masked]>
Date: Thu, 19 Jul 2018 22:43:12 +0000

This discussion came up again at the hackathon, and I think there was a fair bit of sympathy for the idea of at least changing the protocol name to MSG; for the reasons described in this thread.

Personally I'd be keen to have something slightly more uniquely Googleable than MSG, but I don't think that MLS is any better in this regard.

On 27/03/2018, 19:03, "MLS on behalf of [email-masked]" <[email-masked] on behalf of [email-masked]> wrote:

    +1
    
    Quoting Daniel Kahn Gillmor <[email-masked]>:
    > On Sun 2018-03-25 21:33:42 +0200, Nadim Kobeissi wrote:
    >> I do not believe the name should be changed:
    >>
    >> 1. MLS is a protocol that is equally suited for pairwise messaging  
    >> as it is for group messaging
    >> 2. The MLS name is elegant and mirrors TLS.
    >
    > "Mirroring TLS" is exactly what i'm afraid of.  This is a radically
    > different protocol, performing demonstrably different work at a
    > different position within the stack, with a different view on what
    > interoperability even means.
    >
    > Let's make it very clear that this *is not* TLS, and that it is not a
    > substitute for TLS.
    >
    > The protocol described in the documents is *not* equally-suited for
    > pairwise messaging -- it has a number of subtle features that are
    > included solely because it is intended to handle group messaging.  As
    > other people have written upthread, the protocol this nascent WG aims to
    > describe will handle pairwise messaging as a special case of group
    > messaging.  It is not designed intentionally for pairwise messaging and
    > if it were, it would have a different design.
    >
    >           --dkg

    _______________________________________________
    MLS mailing list
    [email-masked]
    https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_mls&d=DwICAg&c=5VD0RTtNlTh3ycd41b3MUw&r=M0CVEJydBVUX_bvEqMa84Q&m=rfhSuK8vpcpFLcVQ8OMeZLwppm8O9uVb1XZ27wXlf60&s=BQG3-r7qCBQlhrrPGVNVJj6heSZcsNivR8jfE1ZmqzY&e=

---

From: Joseph Lorenzo Hall <[email-masked]>
Date: Thu, 19 Jul 2018 18:50:39 -0400

+1
On Thu, Jul 19, 2018 at 6:43 PM Jon Millican <[email-masked]> wrote:
> https://www.ietf.org/mailman/listinfo/mls

-- 
Joseph Lorenzo Hall
Chief Technologist, Center for Democracy & Technology [https://www.cdt.org]
1401 K ST NW STE 200, Washington DC 20005-3497
e: [email-masked], p: 202.407.8825, pgp: https://josephhall.org/gpg-key
Fingerprint: 3CA2 8D7B 9F6D DBD3 4B10  1607 5F86 6987 40A9 A871

---

From: Richard Barnes <[email-masked]>
Date: Thu, 19 Jul 2018 19:11:06 -0400

I don't have strong feelings here.  I'm not wedded to MLS, but I don't want
to move from that to something lame :)  MLS has the benefit of getting some
"trustiness" from the resonance with TLS, and we already have the top
Google hits for "MLS protocol".  I'm not sure MSG is enough better to
motivate a change.

On Thu, Jul 19, 2018 at 6:51 PM Joseph Lorenzo Hall <[email-masked]> wrote:

> > This discussion came up again at the hackathon, and I think there was a
> fair bit of sympathy for the idea of at least changing the protocol name to
> MSG; for the reasons described in this thread.
> >
> > Personally I'd be keen to have something slightly more uniquely
> Googleable than MSG, but I don't think that MLS is any better in this
> regard.
> >
> > On 27/03/2018, 19:03, "MLS on behalf of [email-masked]"
> <[email-masked] on behalf of [email-masked]> wrote:
> >
> >     +1
> >

---

From: Peter Saint-Andre <[email-masked]>
Date: Thu, 19 Jul 2018 17:15:40 -0600

Many people have allergic reactions to MSG. ;-)

On 7/19/18 5:11 PM, Richard Barnes wrote:
> I don't have strong feelings here.  I'm not wedded to MLS, but I don't
> want to move from that to something lame :)  MLS has the benefit of
> getting some "trustiness" from the resonance with TLS, and we already
> have the top Google hits for "MLS protocol".  I'm not sure MSG is enough
> better to motivate a change.
> 
> On Thu, Jul 19, 2018 at 6:51 PM Joseph Lorenzo Hall <[email-masked]
> <mailto:[email-masked]>> wrote:
> 
>     +1
>     On Thu, Jul 19, 2018 at 6:43 PM Jon Millican <[email-masked]
>     <mailto:[email-masked]>> wrote:
>     >
>     > This discussion came up again at the hackathon, and I think there
>     was a fair bit of sympathy for the idea of at least changing the
>     protocol name to MSG; for the reasons described in this thread.
>     >
>     Googleable than MSG, but I don't think that MLS is any better in
>     this regard.
>     >
>     > On 27/03/2018, 19:03, "MLS on behalf of
>     [email-masked]
>     <mailto:[email-masked]>" <[email-masked]
>     <mailto:[email-masked]> on behalf of
>     [email-masked]
>     <mailto:[email-masked]>> wrote:
>     >
>     >     +1
>     >
>     >     Quoting Daniel Kahn Gillmor <[email-masked]
>     <mailto:[email-masked]>>:
>     >     > On Sun 2018-03-25 21:33:42 +0200, Nadim Kobeissi wrote:
>     >     >> I do not believe the name should be changed:
>     >     >>
>     >     >> 1. MLS is a protocol that is equally suited for pairwise
>     messaging
>     >     >> as it is for group messaging
>     >     >> 2. The MLS name is elegant and mirrors TLS..
>     >     >
>     >     > "Mirroring TLS" is exactly what i'm afraid of.  This is a
>     radically
>     >     > different protocol, performing demonstrably different work at a
>     >     > different position within the stack, with a different view
>     on what
>     >     > interoperability even means.
>     >     >
>     >     > Let's make it very clear that this *is not* TLS, and that it
>     is not a
>     >     > substitute for TLS.
>     >     >
>     >     > The protocol described in the documents is *not*
>     equally-suited for
>     >     > pairwise messaging -- it has a number of subtle features
>     that are
>     >     > included solely because it is intended to handle group
>     messaging.  As
>     >     > other people have written upthread, the protocol this
>     nascent WG aims to
>     >     > describe will handle pairwise messaging as a special case of
>     group
>     >     > messaging.  It is not designed intentionally for pairwise
>     messaging and
>     >     > if it were, it would have a different design.
>     >     >
>     >     >           --dkg
>     >
>     >
>     >
>     >     [email-masked] <mailto:[email-masked]>
>     >   
>     > [email-masked] <mailto:[email-masked]>
>     e: [email-masked] <mailto:[email-masked]>, p: 202..407.8825, pgp:
>     https://josephhall.org/gpg-key
>     [email-masked] <mailto:[email-masked]>

---

From: Robert Moskowitz <[email-masked]>
Date: Thu, 19 Jul 2018 20:21:17 -0400

If I would make a change it would be to MLK or MLSK.

This effort is (per the charter) about installing and managing Message 
Level **KEYING**

Message Level Security includes how the messages are protected (securely 
enveloped) over the communication channel.  That is out of scope of this 
effort.  (see my SSE draft if you want a general session level secure 
envelope).

And is it just message level or multicast message level (MMLK).  :)

Bob

On 07/19/2018 07:11 PM, Richard Barnes wrote:
> have the top Google hits for "MLS protocol".  I'm not sure MSG is 
> enough better to motivate a change.
>
>     > This discussion came up again at the hackathon, and I think
>     there was a fair bit of sympathy for the idea of at least changing
>     the protocol name to MSG; for the reasons described in this thread.
>     >
>     >     > Let's make it very clear that this *is not* TLS, and that
>     it is not a
>     >     > substitute for TLS.
>     >     >
>     >     > describe will handle pairwise messaging as a special case
>     of group