Subject: [MLS] Fwd: I-D Action: draft-omara-mls-federation-00.txt

From: Sean Turner <[email-masked]>
Date: Wed, 13 Mar 2019 14:56:33 -0400

At the interim in January, the WG discussed the possibility of adopting work to address federations.  Part of that process is to consider and individual draft first and then do a WG call for adoption.  Emad promised to get a draft in before the deadline and he and Raphael met the deadline.  They did their bit so now it is time for the WG to discuss the draft.  We have tentatively allocated some time on the agenda for this draft on the assumption that it will generate some discussion based on the amount of interest at the interim.

Note that this “federation” we are talking about here is only about federating some/all of the key establishment, authentication, and confidentiality services because this would be in scope of the WG.

spt

> Begin forwarded message:
> 
> From: [email-masked]
> Subject: I-D Action: draft-omara-mls-federation-00.txt
> Date: March 11, 2019 at 11:51:14 EDT
> To: <[email-masked]>
> Reply-To: [email-masked]
> 
> 
> A New Internet-Draft is available from the on-line Internet-Drafts directories.
> 
> 
>        Title           : The Messaging Layer Security (MLS) Federation
>        Authors         : Emad Omara
>                          Raphael Robert
> 	Filename        : draft-omara-mls-federation-00.txt
> 	Pages           : 8
> 	Date            : 2019-03-11
> 
> Abstract:
>   This document describes how the Messaging Layer Security (MLS) can be
>   used in a federated environment where different MLS implementations
>   can interoperate by defining the message format for user key
>   retrieval.  The document also describes some use cases where
>   federation could be useful.
> 
> 
> The IETF datatracker status page for this draft is:
> https://datatracker.ietf.org/doc/draft-omara-mls-federation/
> 
> There are also htmlized versions available at:
> https://tools.ietf.org/html/draft-omara-mls-federation-00
> https://datatracker.ietf.org/doc/html/draft-omara-mls-federation-00
> 
> 
> Please note that it may take a couple of minutes from the time of submission
> until the htmlized version and diff are available at tools.ietf.org.
> 
> Internet-Drafts are also available by anonymous FTP at:
> ftp://ftp.ietf.org/internet-drafts/
> 
> _______________________________________________
> I-D-Announce mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/i-d-announce
> Internet-Draft directories: http://www.ietf.org/shadow.html
> or ftp://ftp.ietf.org/ietf/1shadow-sites.txt

---

From: Ted Hardie <[email-masked]>
Date: Wed, 13 Mar 2019 12:08:25 -0700

Howdy,

I found one of the use cases a bit confusing.  The text says:

3.2.  Different client applications

   Different client applications operated by the same server can use MLS
   to exchange E2EE handshake and application messages.  For example
   different browsers can implement the MLS protocol, and web developers
   write web applications that use the MLS implementation in the browser
   to encrypt and decrypt the messages.  This will require a new
   standard Web API to allow the client applications to set the address
   of the delivery service in the browser.  A more concrete example is
   using MLS in the browser to exchange SRTP keys for multi-party
   conference call.

It wasn't clear to me whether the intent was to cover single entities
who have multiple client applications (e.g. a phone and browser sharing
state on an exchange for a single user) or to cover the case where
different client applications wanted to exchange messages for different
users (the multi-party conference call among users on phones and
different browsers).    Given the overall topic, I assume that the first
of these is covered here and that the second is more basic to MLS, but
it might be useful to revise the text here to clarify.

regards,

Ted Hardie

On Wed, Mar 13, 2019 at 11:56 AM Sean Turner <[email-masked]> wrote:

> At the interim in January, the WG discussed the possibility of adopting
> work to address federations.  Part of that process is to consider and
> individual draft first and then do a WG call for adoption.  Emad promised
> to get a draft in before the deadline and he and Raphael met the deadline.
> They did their bit so now it is time for the WG to discuss the draft.  We
> have tentatively allocated some time on the agenda for this draft on the
> assumption that it will generate some discussion based on the amount of
> interest at the interim.
>
> Note that this “federation” we are talking about here is only about
> federating some/all of the key establishment, authentication, and
> confidentiality services because this would be in scope of the WG.
>
> spt
>
> Begin forwarded message:
>
> *From: [email-masked]
> *Subject: **I-D Action: draft-omara-mls-federation-00.txt*
> *Date: *March 11, 2019 at 11:51:14 EDT
> *To: *<[email-masked]>
> *Reply-To: [email-masked]
>
>
> MLS mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/mls
>

---

From: Emad Omara <[email-masked]>
Date: Wed, 13 Mar 2019 12:18:56 -0700

Hi Ted,

Actually the intent was to support both scenarios and what is needed from
MLS to support them, which I think will be the same for both cases
(ignoring how different server entities communicate as mentioned in the
draft).

 I agree the text needs more clarification, will work on that!

Emad