Subject: [MLS] Comments on open PRs

From: Nick Sullivan <[email-masked]>
Date: Thu, 28 May 2020 19:35:51 -0700

MLSWG,

There are several open pull requests on the protocol document:
https://github.com/mlswg/mls-protocol/pulls

We discussed three PRs during the last meeting:
PR #336 PSK Injection
PR #331 Making ratcheting optional for Adds
PR #337 n-PRF (multi-PSK injection)

The discussion of #331 was not completely captured in the draft meeting
notes, so if someone has something to add, please comment on this PR:
https://github.com/mlswg/wg-materials/pull/9

If you'd like to advocate for or against any of these changes, either reply
on this thread or start a new thread on the mailing list. We'll discuss the
changes at the next interim meeting (next Tuesday).

Nick & Sean

---

From: "Hale, Britta (CIV)" <[email-masked]>
Date: Fri, 29 May 2020 20:09:58 +0000

One comment on PR #331, although the PR has already been merged:

Ratcheting (hashing forward) should be sufficient for FS guarantees to the original group.
The lack of update/new entropy when just hashing forward does affect PCS:

  *   Since the original group may/may not have updated irrespective of the add, this should not significantly affect those in that group.
  *   It does affect the new member, as that member does not know when the group was last updated, and therefore does not know how “vulnerable” of a group it is entering. However, if new members are mandated to update and commit immediately, the window of vulnerability is limited.

The latter point is related to the ‘HPKE key reuse’ question raised by Joël & Sandro in an earlier email – namely, what happens if an added member is unable to update immediately.

Britta

From: MLS <[email-masked]> on behalf of Nick Sullivan <nick=[email-masked]>
Date: Thursday, May 28, 2020 at 7:36 PM
To: Messaging Layer Security WG <[email-masked]>
Subject: [MLS] Comments on open PRs

MLSWG,

The discussion of #331 was not completely captured in the draft meeting notes, so if someone has something to add, please comment on this PR: https://github.com/mlswg/wg-materials/pull/9

If you'd like to advocate for or against any of these changes, either reply on this thread or start a new thread on the mailing list. We'll discuss the changes at the next interim meeting (next Tuesday).

Nick & Sean