Subject: Re: [MLS] draft structure feedback and suggestions

From: Konrad Kohbrok <[email-masked]>
Date: Mon, 5 Oct 2020 14:35:35 +0200 (CEST)

Hi everyone,

I think Franziskus make some good points here. We've been making individual changes all over the document, but the structure hasn't really changed for quite a while. Maybe this would be a good time to take a look at the document as a whole?

In addition to his mail below, Franziskus has also filed an issue https://github.com/mlswg/mls-protocol/issues/409. 

@Sean: Any chance we can put it on the agenda for the meeting tomorrow?

Cheers,
Konrad

> Franziskus Kiefer <[email-masked]> hat am 17.09.2020 13:18 geschrieben:
> 
> 
> Hi all,
> 
> 
> While trying to implement the MLS protocol from scratch I ran into a couple issues and I think there’s a general problem regarding the structure of the draft. Note that these are all editorial issues.
> Right now I see no straightforward way to implement the spec as there’s no clear structure. To implement even the basic tree structure it’s necessary to jump through the entire document. There’s also a lot of prose and examples and very little implementable parts.
> 
> Let me give some examples:
> 
> 
> Section 5 (Ratchet Trees) reads like a non-normative section (or paper). The really interesting bit related to trees is in Appendix A. I suggest moving the formal description of the tree from Appendix A to this section. It’s impossible to implement this from the hand full examples here.
> There’s no description in here on how the tree actually works. For example, adding a node to the tree is defined in 10.1.1 (Add).
> The ratchet tree nodes as described in Section 5 don't hold a KeyPackage. But Section 7 says “As the KeyPackage is a structure which is stored in the Ratchet Tree and updated depending on the evolution of this tree”.
> The tree nodes have a parent hash field, which is of course part of the ratchet tree but shouldn’t be necessary for the description of the tree structure.
> Also, the description of the tree hash (Section 7.5) follows the definition of the parent_hash extension in Section 7.4 such that it is not entirely clear which parent_hash is used there (extension or node value).
> Section 5 also talks about commit messages without linking to them or introducing them. Having to talk about commit messages in this section is also a little confusing.
> The term “handshake message” is first used in Section 7.8 (Key Schedule) but never introduced. This should probably happen in 10 (Group Evolution), which doesn’t talk about handshake messages at all until 10.3 (Ratchet Tree Extension).
> 
> 
> There are probably plenty more issues like this. But I don’t think addressing any of these issues individually makes sense. I therefore suggest having an overhaul of the document structure.
> 
> 
> The way I see MLS there are a set of high-level structures and components that should be clearly described and built upon each other. There’s a data structure (tree) that is used to represent a group. Then there is the MLSgroupthat implements a specific semantic on the tree. Operations to modify the group are specified in thehandshake protocol. Andapplication messagesdefine messages encrypted with keys derived in the handshake protocol with the key schedule.
> The tree is a basic left-balanced binary tree and defines functions to create a tree, and add and remove nodes.
> A group is the main part of MLS, a tree with nodes of a certain type. So this part should describe whatnodeslook like and how the tree is used to compute tree invariants and keys.
> The handshake protocol defines all messages needed to perform operations on the MLS group.
> 
> 
> This is certainly not exhaustive and would need further refinement. But it’s the high-level structure I’d expect from the document. I’m sure other structures would work as well. But what we currently have isn’t what is needed to implement MLS imho.
> 
> 
> Cheers,
> Franziskus
> 
> 
> _______________________________________________
> MLS mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/mls

---

From: Brendan McMillion <[email-masked]>
Date: Mon, 5 Oct 2020 11:11:55 -0700

I don't think this belongs on the agenda. What Franziskus says is right,
the MLS protocol document has become nonsensical over time. But right now
we're focusing on substantive changes to the protocol and can rearrange
when we've finished.

On Mon, Oct 5, 2020 at 5:35 AM Konrad Kohbrok <[email-masked]>
wrote:

> Hi everyone,
>
> I think Franziskus make some good points here. We've been making
> individual changes all over the document, but the structure hasn't really
> changed for quite a while. Maybe this would be a good time to take a look
> at the document as a whole?
>
> In addition to his mail below, Franziskus has also filed an issue
> https://github.com/mlswg/mls-protocol/issues/409.
>
> > While trying to implement the MLS protocol from scratch I ran into a
> couple issues and I think there’s a general problem regarding the structure
> of the draft. Note that these are all editorial issues.
> > Right now I see no straightforward way to implement the spec as there’s
> no clear structure. To implement even the basic tree structure it’s
> necessary to jump through the entire document. There’s also a lot of prose
> and examples and very little implementable parts.
> >
> > Section 5 (Ratchet Trees) reads like a non-normative section (or paper).
> The really interesting bit related to trees is in Appendix A. I suggest
> moving the formal description of the tree from Appendix A to this section.
> It’s impossible to implement this from the hand full examples here.
> > There’s no description in here on how the tree actually works. For
> example, adding a node to the tree is defined in 10.1.1 (Add).
> > The ratchet tree nodes as described in Section 5 don't hold a
> KeyPackage. But Section 7 says “As the KeyPackage is a structure which is
> stored in the Ratchet Tree and updated depending on the evolution of this
> tree”.
> > The tree nodes have a parent hash field, which is of course part of the
> ratchet tree but shouldn’t be necessary for the description of the tree
> structure.
> > Also, the description of the tree hash (Section 7.5) follows the
> definition of the parent_hash extension in Section 7.4 such that it is not
> entirely clear which parent_hash is used there (extension or node value).
> > Section 5 also talks about commit messages without linking to them or
> introducing them. Having to talk about commit messages in this section is
> also a little confusing.
> > The term “handshake message” is first used in Section 7.8 (Key Schedule)
> but never introduced. This should probably happen in 10 (Group Evolution),
> which doesn’t talk about handshake messages at all until 10.3 (Ratchet Tree
> Extension).
> >
> >
> > There are probably plenty more issues like this. But I don’t think
> addressing any of these issues individually makes sense. I therefore
> suggest having an overhaul of the document structure.
> >
> >
> > The way I see MLS there are a set of high-level structures and
> components that should be clearly described and built upon each other.
> There’s a data structure (tree) that is used to represent a group. Then
> there is the MLSgroupthat implements a specific semantic on the tree.
> Operations to modify the group are specified in thehandshake protocol.
> Andapplication messagesdefine messages encrypted with keys derived in the
> handshake protocol with the key schedule.
> > A group is the main part of MLS, a tree with nodes of a certain type. So
> this part should describe whatnodeslook like and how the tree is used to
> compute tree invariants and keys.
> > This is certainly not exhaustive and would need further refinement. But
> it’s the high-level structure I’d expect from the document. I’m sure other
> structures would work as well. But what we currently have isn’t what is
> needed to implement MLS imho.
> >
> >
> > Cheers,
> > Franziskus
> >
> >

---

From: Konrad Kohbrok <[email-masked]>
Date: Mon, 5 Oct 2020 21:14:58 +0200 (CEST)

It's not something we're going to decide on this meeting, for sure. However, I was under the impression that the last big changes are already foreseeable and starting to outline a new document structure now makes sense in my opinion. I don't think any of the big upcoming PRs are going to change much w.r.t. the structure.

Konrad

> Brendan McMillion <brendan=[email-masked]> hat am 05.10.2020 20:11 geschrieben:
> 
> 
> I don't think this belongs on the agenda. What Franziskus says is right, the MLS protocol document has become nonsensical over time. But right now we're focusing on substantive changes to the protocol and can rearrange when we've finished.
> 
> 
> On Mon, Oct 5, 2020 at 5:35 AM Konrad Kohbrok <[email-masked]> wrote:
> > Hi everyone,
> >