Subject: Re: [MMUSIC] I-D ACTION:draft-ietf-mmusic-sdp-new-05.txt

From: Colin Perkins <[email-masked]>
Date: Tue, 12 Feb 2002 19:40:28 -0500

I don't really care which is chosen, but it'd be good if we could have a
single definition. RFC 2327 doesn't specify and offer/answer uses "s= ".
I was following offer/answer, but maybe that conflicts with other use?

Colin

--> Rajesh Kumar writes:
>Some h.248/MGCP applications use the old definition. I know of several that 
>are out there in the field. Therefore, I do not know if we can or should 
>alter it, short of defining a new protocol which this draft does not 
>purport to do.
>
>Anyway, I believe s=- is still canonical since '-' is ISO 10646. So there 
>should be no backward compatibility problems.
>
>Rajesh
>
>At 07:27 PM 2/12/2002 -0500, you wrote:
>>I changed it to "s= " to match offer/answer, and because I was told that
>>was what SIP clients expected.
>>
>>Colin
>>
>>
>>
>>--> Rajesh Kumar writes:
>> >Colin,
>> >I suggest that acceptance of "s=-" when there is no meaningful session name
>> >be retained for backwards compatibility.  After all, we're fixing an
>> >existing standard, and not creating a new one. Backward compatibility
>> >should be an important consideration. I believe "s=-" will satisfy the ABNF
>> >definition of the session name, and therefore there is no backward
>> >compatibility issue, right?
>> >
>> >Thanks,
>> >Rajesh
>> >
>> >At 11:00 AM 2/12/2002 -0500, Colin Perkins wrote:
>> >>Changes in this version are:
>> >>- Clarify that a=recvonly does NOT mean that you don't send RTCP, and
>> >>   similarly for sendonly and inactive.  These only effect the RTP stream.
>> >>- Fix ABNF to include a unicast-address element, allowing comedia to
>> >>   align with both this and RFC2327
>> >>- "s= " rather than "s=-"
>> >>- Fix ABNF to reflect that s= is mandatory
>> >>- Clarify that s= is non-empty, and the contents SHOULD be ISO 10646
>> >>
>> >>Any comments would be appreciated.
>> >>
>> >>Colin

_______________________________________________
mmusic mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mmusic

---

From: Rajesh Kumar <[email-masked]>
Date: Tue, 12 Feb 2002 16:46:27 -0800

>I was following offer/answer, but maybe that conflicts with other use?

It does conflict, as I indicated. Since offer/answer is a draft, why not 
stick to s=- as stated in RFC 2327? What does the change buy for 
offer/answer?-Rajesh

---

From: Joerg Ott <[email-masked]>
Date: Wed, 13 Feb 2002 01:58:03 +0100 (MET)

Offer/answer follows the idea of referencing other documents.  Quite a
few implementations seem to use it this way.  And offer/answer will
be referenced by SIP.

MEGACO has created its own "profile" of SDP anyway.  And MEGACO does
not become less SDP compliant than it currently is.  Nor will existing
implementations break.

BTW: "s=-" is not stated in RFC2327.  At least I can't find anything like
that.

Joerg

> 
> --=====================_833386246==_.ALT
> Content-Type: text/plain; charset="us-ascii"; format=flowed
> 
> --=====================_833386246==_.ALT
> Content-Type: text/html; charset="us-ascii"
> 
> <html>
> At 07:40 PM 2/12/2002 -0500, Colin Perkins wrote:<br>
> <blockquote type=cite cite>I don't really care which is chosen, but it'd
> be good if we could have a<br>
> single definition. RFC 2327 doesn't specify and offer/answer uses
> &quot;s= &quot;.<br>
> I was following offer/answer, but maybe that conflicts with other
> use?</blockquote><font face="Comic Sans MS"><br>
> offer/answer?-Rajesh<br>
> <br>
> <br>
> </font><blockquote type=cite cite>Colin<br>
> <br>
> <br>
> <br>
> --&gt; Rajesh Kumar writes:<br>
> &gt;Some h.248/MGCP applications use the old definition. I know of
> several that <br>
> &gt;are out there in the field. Therefore, I do not know if we can or
> should <br>
> &gt;alter it, short of defining a new protocol which this draft does not
> <br>
> &gt;purport to do.<br>
> &gt;<br>
> &gt;Anyway, I believe s=- is still canonical since '-' is ISO 10646. So
> there <br>
> &gt;should be no backward compatibility problems.<br>
> &gt;<br>
> &gt;Rajesh<br>
> &gt;<br>
> &gt;At 07:27 PM 2/12/2002 -0500, you wrote:<br>
> &gt;&gt;I changed it to &quot;s= &quot; to match offer/answer, and
> because I was told that<br>
> &gt;&gt;was what SIP clients expected.<br>
> &gt;&gt;<br>
> &gt;&gt;Colin<br>
> &gt;&gt;<br>
> &gt;&gt;<br>
> &gt;&gt;<br>
> &gt;&gt;--&gt; Rajesh Kumar writes:<br>
> &gt;&gt; &gt;Colin,<br>
> &gt;&gt; &gt;I suggest that acceptance of &quot;s=-&quot; when there is
> no meaningful session name<br>
> &gt;&gt; &gt;be retained for backwards compatibility.&nbsp; After all,
> we're fixing an<br>
> &gt;&gt; &gt;existing standard, and not creating a new one. Backward
> compatibility<br>
> &gt;&gt; &gt;should be an important consideration. I believe
> &quot;s=-&quot; will satisfy the ABNF<br>
> &gt;&gt; &gt;definition of the session name, and therefore there is no
> backward<br>
> &gt;&gt; &gt;compatibility issue, right?<br>
> &gt;&gt; &gt;<br>
> &gt;&gt; &gt;Thanks,<br>
> &gt;&gt; &gt;Rajesh<br>
> &gt;&gt; &gt;<br>
> &gt;&gt; &gt;At 11:00 AM 2/12/2002 -0500, Colin Perkins wrote:<br>
> &gt;&gt; &gt;&gt;Changes in this version are:<br>
> &gt;&gt; &gt;&gt;- Clarify that a=recvonly does NOT mean that you don't
> send RTCP, and<br>
> &gt;&gt; &gt;&gt;&nbsp;&nbsp; similarly for sendonly and inactive.&nbsp;
> These only effect the RTP stream.<br>
> &gt;&gt; &gt;&gt;- Fix ABNF to include a unicast-address element,
> allowing comedia to<br>
> &gt;&gt; &gt;&gt;&nbsp;&nbsp; align with both this and RFC2327<br>
> &gt;&gt; &gt;&gt;- &quot;s= &quot; rather than &quot;s=-&quot;<br>
> &gt;&gt; &gt;&gt;- Fix ABNF to reflect that s= is mandatory<br>
> &gt;&gt; &gt;&gt;- Clarify that s= is non-empty, and the contents SHOULD
> be ISO 10646<br>
> &gt;&gt; &gt;&gt;<br>
> &gt;&gt; &gt;&gt;Any comments would be appreciated.<br>
> &gt;&gt; &gt;&gt;<br>
> &gt;&gt; &gt;&gt;Colin </blockquote></html>
> 
> --=====================_833386246==_.ALT--
> 
>

---

From: Rajesh Kumar <[email-masked]>
Date: Tue, 12 Feb 2002 17:04:32 -0800

I guess I was looking at username which RFC 2327 mentions can be dummied 
out to a "-".

Notwithstanding, I do know several implementations that use a "s=-". The 
question is: Is "-" an illegal session name? That is all I need to know.

Thanks,

Rajesh

---

From: Colin Perkins <[email-masked]>
Date: Tue, 12 Feb 2002 21:19:07 -0500

>question is: Is "-" an illegal session name? That is all I need to know.

No, it's not illegal. The "s= " is just a recommendation if there's nothing
better to use; you can use whatever you like for a session name.

Colin

---

From: Jonathan Rosenberg <[email-masked]>
Date: Tue, 12 Feb 2002 22:48:12 -0500

I don't understand the problem. A valid SDP implementation should accept
anything. Whether its " " or "-" is irrelevant. As Colin says, these are
just suggestions in any case.

-Jonathan R.

-- 
Jonathan D. Rosenberg, Ph.D.            72 Eagle Rock Avenue
Chief Scientist                         First Floor
dynamicsoft                             East Hanover, NJ 07936
[email-masked]                 FAX: (973) 952-5050
http://www.jdrosen.net                  PH:  (973) 952-5000
http://www.dynamicsoft.com