Subject: [MMUSIC] I-D ACTION:draft-ietf-mmusic-kmgmt-ext-03.txt

From: [email-masked]
Date: Tue, 05 Mar 2002 06:31:38 -0500

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Multiparty Multimedia Session Control Working Group of the IETF.

	Title		: Key Management Extensions for SDP and RTSP
	Author(s)	: j. Arkko et al.
	Filename	: draft-ietf-mmusic-kmgmt-ext-03.txt
	Pages		: 12
	Date		: 04-Mar-02
	
This document defines general extensions for SDP and RTSP to carry
the security information needed by a key management protocol, in
order to secure the media. These extensions are presented as a
framework, to be used by one or more key management protocols. As
such, its use is meaningful only when it is completed by the key
management protocol in use.

A URL for this Internet-Draft is:
http://www.ietf.org/internet-drafts/draft-ietf-mmusic-kmgmt-ext-03.txt

To remove yourself from the IETF Announcement list, send a message to 
ietf-announce-request with the word unsubscribe in the body of the message.

Internet-Drafts are also available by anonymous FTP. Login with the username
"anonymous" and a password of your e-mail address. After logging in,
type "cd internet-drafts" and then
	"get draft-ietf-mmusic-kmgmt-ext-03.txt".

A list of Internet-Drafts directories can be found in
http://www.ietf.org/shadow.html 
or ftp://ftp.ietf.org/ietf/1shadow-sites.txt

Internet-Drafts can also be obtained by e-mail.

Send a message to:
	[email-masked].
In the body type:
	"FILE /internet-drafts/draft-ietf-mmusic-kmgmt-ext-03.txt".
	
NOTE:	The mail server at ietf.org can return the document in
	MIME-encoded form by using the "mpack" utility.  To use this
	feature, insert the command "ENCODING mime" before the "FILE"
	command.  To decode the response(s), you will need "munpack" or
	a MIME-compliant mail reader.  Different MIME-compliant mail readers
	exhibit different behavior, especially when dealing with
	"multipart" MIME messages (i.e. documents which have been split
	up into multiple messages), so check your local documentation on
	how to manipulate these messages.

Below is the data which will enable a MIME compliant mail reader
implementation to automatically retrieve the ASCII version of the
Internet-Draft.

---

From: "Martin Euchner" <[email-masked]>
Date: Mon, 18 Mar 2002 02:39:07

Dear editors of kmgt-ext,

let me ask some questions to the draft:

>> * If used, the "keymgmt-auth" attribute is filled in by using the key management protocol interface to obtain key management data. Note that what data from SDP are supposed to be provided to the interface MUST be specified by the key management protocol itself.<<

The draft mentions an option for using keymgmt-auth attribute. However, I was not able to locate that attribute in the MIKEY-01 draft.

>> * If the optional "keymgmt-auth" attribute is included, this is processed as the "keymgmt-data".<<

I further do not understand, what that attribute is exactly good for. Should the keymgmt-auth attribute hold a digital signature or HMAC upon the conveyed key management message, or is that an authentication just upon the SDP and the key management part  together?

So I guess this deserves some more descriptions…

>> Note however, the "keymgmt-auth" cannot work when NATs are present (as this may require that fields in the SDP are changed).<<

This is true. The question is, if it is considered useful to have something in SDP such as "mutable fields" that are excluded from the authentication/integrity computation? With such a facility, NAT traversal could be accomplished much better.

With kind regards

Martin Euchner

+---------------------------------

+

+ email: [email-masked]

+

+---------------------------------

MSN Photos is the easiest way to share and print your photos: Click Here

_______________________________________________
mmusic mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mmusic