Subject: [MMUSIC] Question on the offer answer draft 02

From: "Chen, Xin (Xin)" <[email-masked]>
Date: Fri, 15 Mar 2002 16:04:52 -0000

Hi, offer-answer draft says that 

						"A port number of zero in
the offer indicates that the
						stream is offered but MUST
NOT be used."

So if I send the first offer with port zero with a m line, after I get the
answer, I send a new offer with a valid port number for the same m line, my
question is that if this behaviour is allowed? According to the text, it
seems this is not allowed since this steam must not be used.

Another question, I send an offer containing a m line with a valid port
number, and in answer, the port number is changed to zero which means this
media is rejected. Can I send a new offer to re-offer this m line with a
valid port number? 

Xin Chen

Lucent Technologies
Tel: +44 1793 883137
Mobile: +44 7799 034668

_______________________________________________
mmusic mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mmusic

---

From: "Brett Tate" <[email-masked]>
Date: Fri, 15 Mar 2002 11:42:18 -0500

> "A port number of zero in the offer 
> indicates that the stream is offered 
> but MUST NOT be used."
> 
> question is that if this behaviour is 
> allowed?

Yes, it is allowed.

Section 8.1 mentions that disabled media 
slots within the SDP can be reused.

> 
> Another question, I send an offer containing 
> a m line with a valid port number, and in 
> answer, the port number is changed to zero 
> which means this media is rejected. 
> Can I send a new offer to re-offer this m 
> line with a valid port number?

Yes, it is allowed.

Section 8.1 mentions that disabled media 
slots within the SDP can be reused.