Subject: [MMUSIC] I-D ACTION:draft-ietf-mmusic-sdpng-04.txt

From: [email-masked]
Date: Fri, 08 Mar 2002 06:59:55 -0500

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Multiparty Multimedia Session Control Working Group of the IETF.

	Title		: Session Description and Capability Negotiation
	Author(s)	: D. Kutscher, J. Ott, C. Bormann
	Filename	: draft-ietf-mmusic-sdpng-04.txt
	Pages		: 79
	Date		: 07-Mar-02
	
This document defines a language for describing multimedia sessions
with respect to configuration parameters and capabilities of end
systems. 
This document is a product of the Multiparty Multimedia Session
Control (MMUSIC) working group of the Internet Engineering Task
Force. Comments are solicited and should be addressed to the working
group's mailing list at [email-masked] and/or the authors.

A URL for this Internet-Draft is:
http://www.ietf.org/internet-drafts/draft-ietf-mmusic-sdpng-04.txt

To remove yourself from the IETF Announcement list, send a message to 
ietf-announce-request with the word unsubscribe in the body of the message.

Internet-Drafts are also available by anonymous FTP. Login with the username
"anonymous" and a password of your e-mail address. After logging in,
type "cd internet-drafts" and then
	"get draft-ietf-mmusic-sdpng-04.txt".

A list of Internet-Drafts directories can be found in
http://www.ietf.org/shadow.html 
or ftp://ftp.ietf.org/ietf/1shadow-sites.txt

Internet-Drafts can also be obtained by e-mail.

Send a message to:
	[email-masked].
In the body type:
	"FILE /internet-drafts/draft-ietf-mmusic-sdpng-04.txt".
	
NOTE:	The mail server at ietf.org can return the document in
	MIME-encoded form by using the "mpack" utility.  To use this
	feature, insert the command "ENCODING mime" before the "FILE"
	command.  To decode the response(s), you will need "munpack" or
	a MIME-compliant mail reader.  Different MIME-compliant mail readers
	exhibit different behavior, especially when dealing with
	"multipart" MIME messages (i.e. documents which have been split
	up into multiple messages), so check your local documentation on
	how to manipulate these messages.

Below is the data which will enable a MIME compliant mail reader
implementation to automatically retrieve the ASCII version of the
Internet-Draft.

---

From: Graham Klyne <[email-masked]>
Date: Mon, 11 Mar 2002 10:04:54 +0000

You guys seem determined to continue reinventing the wheel.

There is a body of work that you seem to be completely ignoring:

(a) IETF work on content negotiation (RFC 2506, RFC 2533, etc.)

(b) W3C work on client capability descriptions (http://www.w3.org/Mobile/CCPP/)

(c) a good deal of work from the past 10 years under the heading 
"description logics", whose fundamental computation is a subsumption over 
sets of values described by restricted logical expressions.  See 
http://dl.kr.org/.  This was used many years ago in industrial contexts 
(look for CLASSIC).

(d) based on (c), W3C/DARPA/EU work on an XML language DAML+OIL for 
conveying DL-type descriptions: http://www.daml.org/, 
http://www.daml.org/2001/03/daml+oil-index.

Of these, (a) and (c) provide significant background work that I think is 
far better worked out than the "collapsing algorithm" described here.  (b) 
introduces an XML-based format for conveying capability descriptions 
(already widely implemented for mobile phone devices, as UAProf), and (d) 
provides the basis for extending this to deal with negotiable features in 
the required fashion.

#g
--

At 06:59 AM 3/8/02 -0500, [email-masked] wrote:
>Content-Type: text/plain
>Content-ID:     <[email-masked]>
>
>ENCODING mime
>FILE /internet-drafts/draft-ietf-mmusic-sdpng-04.txt
>
><ftp://ftp.ietf.org/internet-drafts/draft-ietf-mmusic-sdpng-04.txt>

-------------------
Graham Klyne
<[email-masked]>

_______________________________________________
mmusic mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mmusic