Subject: [MMUSIC] I-D ACTION:draft-ietf-mmusic-sdp-ipv6-03.txt

From: [email-masked]
Date: Fri, 01 Mar 2002 07:06:38 -0500

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Multiparty Multimedia Session Control Working Group of the IETF.

	Title		: Support for IPv6 in SDP
	Author(s)	: S. Olson et al.
	Filename	: draft-ietf-mmusic-sdp-ipv6-03.txt
	Pages		: 5
	Date		: 28-Feb-02
	
This document describes the use of IPv6 addresses [1] in conjunction 
with the Session Description Protocol (SDP) [2]. Specifically, this 
document clarifies existing text in SDP with regards to the syntax of 
IPv6 addresses.

A URL for this Internet-Draft is:
http://www.ietf.org/internet-drafts/draft-ietf-mmusic-sdp-ipv6-03.txt

To remove yourself from the IETF Announcement list, send a message to 
ietf-announce-request with the word unsubscribe in the body of the message.

Internet-Drafts are also available by anonymous FTP. Login with the username
"anonymous" and a password of your e-mail address. After logging in,
type "cd internet-drafts" and then
	"get draft-ietf-mmusic-sdp-ipv6-03.txt".

A list of Internet-Drafts directories can be found in
http://www.ietf.org/shadow.html 
or ftp://ftp.ietf.org/ietf/1shadow-sites.txt

Internet-Drafts can also be obtained by e-mail.

Send a message to:
	[email-masked].
In the body type:
	"FILE /internet-drafts/draft-ietf-mmusic-sdp-ipv6-03.txt".
	
NOTE:	The mail server at ietf.org can return the document in
	MIME-encoded form by using the "mpack" utility.  To use this
	feature, insert the command "ENCODING mime" before the "FILE"
	command.  To decode the response(s), you will need "munpack" or
	a MIME-compliant mail reader.  Different MIME-compliant mail readers
	exhibit different behavior, especially when dealing with
	"multipart" MIME messages (i.e. documents which have been split
	up into multiple messages), so check your local documentation on
	how to manipulate these messages.

Below is the data which will enable a MIME compliant mail reader
implementation to automatically retrieve the ASCII version of the
Internet-Draft.

---

From: Pekka Pessi <[email-masked]>
Date: 01 Mar 2002 15:14:17 +0200

Hello Sean/Gonzalo/Adam,

>      IP6-multicast =       hexpart
>                            ; IPv6 address starting with FF

	Is there any specific reason not to allow combined hexpart-IPv4
	notation in IP6-multicast? It is allowed (along with other
	things) in sdp-new-05.

	So, should this fragment be like

      IP6-multicast =       hexpart  [ ":" IPv4address ]
                            ; IPv6 hexpart starting with FF
      IPv4address = 1*3DIGIT "." 1*3DIGIT "." 1*3DIGIT "." 1*3DIGIT

	Best regards,
					Pekka

_______________________________________________
mmusic mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mmusic

---

From: Allison Mankin <[email-masked]>
Date: Fri, 01 Mar 2002 10:02:03 -0500

Hi, 

This document was reviewed by the IESG already, and
the new rev is to address IESG discussion comments.
Among those comments was a recommendation to provide
only the absolute minimum of detail about IPv6 address
types in the SDP BNF (and point to IPv6 address documents
for more definition).

So the definitions in sdp-new might need to be modified
to reflect the view for having the SDP doc point to v6
address documents. 

Allison

(wearing AD hat).

---

From: Colin Perkins <[email-masked]>
Date: Fri, 01 Mar 2002 10:37:19 -0500

>to reflect the view for having the SDP doc point to v6

I submitted an update to SDP-new last night that copies the ABNF from
sdp-ipv6-03

Colin