Subject: [MMUSIC] SDP static and dynamic codecs

From: "Tulpule, Naren" <[email-masked]>
Date: Wed, 11 Sep 2002 16:43:33 -0700

In m= line, there are payload types specified after RTP/AVP.
e.g.
m=audio 1234 RTP/AVP 0 1 2 97 98 99
0, 1, 2 are static codecs (defined at
http://www.iana.org/assignments/rtp-parameters)
while 97, 98, 99 are dynamic codecs, and will be specified later in a=rtpmap
lines
e.g.
a=rtpmap:98 L16/16000/1

My question is, if the codecs are e.g. 0 (PCM mu law) and 98 (L16), will
a=ptime lines appear for both or just L16 or just PCMU or none? And where?
In other words, is this a good SDP media description:

m=audio 1234 RTP/AVP 0 98
a=ptime:40
a=rtpmap:98 L16/16000/1
a=ptime:20

What I want to describe is, choose from 2 codecs: PCMU(40 ms) or L16(20 ms),
preference is PCMU(40 ms)
If this is not a good description, how will you describe it?
How do you correlate packetization times with codec types?

These views are mine alone, not those of Intel or Trillium (yet ;-)
-- Naren
Narendra C. Tulpule         310-442-9222
SMTS, Trillium (an Intel company)
12100 Wilshire Bl #1800 Los Angeles CA 90025

-- Trap and rule uncle. Curl under a planet. Plan real undercut. Pull under
a trance. Turn candle real up. Plunder a cruel ant.

What do they use to ship styrofoam?

_______________________________________________
mmusic mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mmusic

---

From: Magnus Westerlund <[email-masked]>
Date: Thu, 12 Sep 2002 09:31:12 +0200

Hi Tulpule,

See comments inline.

>How do you correlate packetization times with codec types?
You can't have multiple ptime lines. It is a media attribute and valid 
for all payload types declared.

Cheers

Magnus

-- 

Magnus Westerlund 

Multimedia Technologies, Ericsson Research ERA/TVA/A
----------------------------------------------------------------------
Ericsson AB                | Phone +46 8 4048287
Torshamsgatan 23           | Fax   +46 8 7575550
S-164 80 Stockholm, Sweden | mailto: [email-masked]