Subject: RE: [MMUSIC] Comments on RTSP Draft: Important Issues

From: "Anders Klemets" <[email-masked]>
Date: Mon, 25 Nov 2002 19:48:14 -0800

Tom Marshall wrote: 
> >The client_port and server_port transport attributes specify where
data
> >is to be sent (see section 12.40).  It is not written that the
reverse is
> >true (eg. server's data packets originate from the server_port).  

Magnus Westerlund wrote:
> I think we should 
> mandate that one must also send from the specified receiver port. 
> Otherwise we might have problem that firewalls that block traffic
coming 
> from ports that are not signaled in the transport header. The same
issue 
> is present for NAT's that do binding to a to fine degree and actually 
> cares of sender port.

I am not sure I fully understand this point.  The "server_port"
attribute only specifies which port the server uses for receiving any
packets that are sent by the client.  So, if there is an RTSP firewall
that attaches a different meaning to the "server_port" attribute, then
that firewall is not compliant with the RFC.  Should we be concerned
about such firewalls?  

Perhaps the answer depends on how common these kinds of firewalls are.
If a lot of these firewalls are deployed, I suppose we would want to
update the RTSP spec to be better aligned with this usage of RTSP.  

Do we have any firewall or NAT vendors on the mailing list that would
like to comment on how their products handle the "server_port"
attribute?

Anders

_______________________________________________
mmusic mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mmusic

---

From: "Amir Wolf" <[email-masked]>
Date: Tue, 26 Nov 2002 17:00:18 +0200

-----Original Message-----
From: Amir Wolf 
Sent: Tuesday, November 26, 2002 5:00 PM
To: 'Anders Klemets'
Subject: RE: [MMUSIC] Comments on RTSP Draft: Important Issues

Anders and All,

Once you are facing such a RTSP aware firewall, you will not have NAPT problems, therefore no harm was done.
The problem is when you are facing a firewall/NAPT that is not RTSP aware - then you will have to create an entry in the NAPT by sending a packet from the client to the server - This will work only if the server sends data from the same port it listens.

-----Original Message-----
From: Anders Klemets [mailto:[email-masked]]
Sent: Tuesday, November 26, 2002 5:48 AM
To: Magnus Westerlund; Tom Marshall
Cc: [email-masked]
Subject: RE: [MMUSIC] Comments on RTSP Draft: Important Issues

data
reverse is

coming 
issue 

Anders

**************************************************************************************************
The contents of this email and any attachments are confidential.
It is intended for the named recipient(s) only.
If you have received this email in error please notify the system manager or  the 
sender immediately and do not disclose the contents to any one or make copies.

** eSafe scanned this email for viruses, vandals and malicious content **
**************************************************************************************************