Subject: RE: [MMUSIC] A Framework for Internet Program Guides

From: [email-masked]
Date: Thu, 7 Nov 2002 12:19:52 +0200

Yuji, Henning & mmusic folk,

The submission on Internet Program Guides is very valuable and I would like to support this work. (Literally, draft-nomura-mmusic-pguide-framework-00.txt & draft-nomura-mmusic-pguide-requirements-00.txt at this time).

We are currently without a comprehensive framework for the delivery and discovery of user service metadata from the Internet domain and it would be fantastic to drive this in the IETF - the natural home of standards for IP services and their delivery. So I believe the need for this work is clear and the IETF is the natural home. The results of the work will impact session announcement and description methods and so MMUSIC seems to have the best-fit to own this item. 

Relationships with other WGs needs consideration and discussion, especially RMT and AVT which may provide support to, and benefit from support from, "service guides".

A particularly important aspect of these drafts is that both point-to-point / unicast and point-to-multipoint / multicast delivery methods are explicitly within scope. This lends the work to creating a single system and framework specification that includes requirements of separate delivery specifications. In turn, these delivery spec's should cater for multicast and unicast delivery methods and specifically include use cases for unidirectional links with, and without, intermittent uplink capability. That would make the standard very versatile with a solid and stable baseline. Hopefully, it could then follow the successful lead of RTP (RFC1889 and subsequent drafts) with multiple companion specifications and numerous implementations. Furthermore, it would allow maximum reuse of the existing RFCs and IETF work-in-progress (such as for SIP) and optimize the additional effort put in.

The applicability of the framework is suitably broad - for Internet (and intranet) service metadata delivery in a variety of network environments. This includes metadata on MPEG style programs, webcasts, multicast filecasting, stock market alerts, multiparty communications, multiplayer gaming, pre-scheduled and on-demand delivery (practically everything in RFC3170). So I would like to suggest the rather trivial change of metadata naming to "Internet Service Guide" (ISG) from "Internet Program Guide" (IPG). These are practically the same, although the first is implicitly general where as the second is implicitly TV-centric.

I will gladly contribute to this work item and hope to bring constructive insights from wireless and cellular multicast application cases, and IP over broadcast networks (becoming known as IP Datacast). My aim is to provide a more specific critique of what I see as the most important aspects next week and then progressively contribute over time.

Thank you for this excellent initiative.

Warm regards,
Rod Walsh.

========================================
  Rod Walsh
  Nokia Research Center
  Tampere, Finland.
  [email-masked]
  +357 50 483 5632
========================================

-----Original Message-----
From: ext Yuji Nomura [mailto:[email-masked]]
Sent: 30 October, 2002 10:59
To: [email-masked]
Subject: [MMUSIC] A Framework for Internet Program Guides

Hi,

We have submitted a draft: "A Framework for Internet Program Guides"
It can be found at the following website until it is available at the official website.
http://www.cs.columbia.edu/~nomura/framework/draft-nomura-mmusic-pguide-framework-00.txt

Abstract

   This memo provides a framework for Internet program guides (IPG). An
   IPG is a set of meta-data describing the features of multimedia
   content in order to subscribe to, manage and exchange multimedia
   content. We present an architecture, protocol model and program
   guide data model for several scenarios.

Feedback is appreciated.

Thanks,
-----
Yuji Nomura
Fujitsu Laboratories Ltd.

_______________________________________________
mmusic mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mmusic
_______________________________________________
mmusic mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mmusic

---

From: Yuji Nomura <[email-masked]>
Date: Tue, 12 Nov 2002 19:48:02 +0900

Rod,

Thank you for your comments.

I agree with you.

 On Thu, 7 Nov 2002 12:19:52 +0200 
 [email-masked] wrote:

> So I would like to suggest the rather trivial change of metadata
> naming to "Internet Service Guide" (ISG) from "Internet Program
> Guide" (IPG). These are practically the same, although the first is
> implicitly general where as the second is implicitly TV-centric.

Originally, I intended to use "IPG" to focus on multimedia content,
but "IPG" is a subset of metadata, which is widely applicable to other 
services.

Thus, it's quite natural to apply this framework to other
applications, and it's better to use more general title in this case.

Thank you,
-----
Yuji Nomura