Subject: [MMUSIC] mid values in draft-ietf-mmusic-fid-06.txt

From: [email-masked]
Date: Tue, 26 Nov 2002 14:56:53 +0530

Hi all,
     I have couple of doubts with the usgae of *mid* values.

     mid-attribute      = "a=mid:" identification-tag
      identification-tag = token

1) The grammar in "draft-ietf-mmusic-fid-06.txt" suggests
the values that mid can have is a *token*. But, all the examples in
the draft seems to use a *integer* as "mid" values.

Can "mid" values be *alpha numeric* ?.

eg:
m=audio 30000 RTP/AVP 0
a=mid: abc123

Is this a valid mid attrbiute representation?

2) Assuming "mid" values to be integer,is it mandatory
to have the "mid" values in media streams to be in
increasing order.

Also is it mandatory to start the *mid* values from 1 ?

eg:
m=audio 30000 RTP/AVP 0
a=mid: 2
m=video 30002 RTP/AVP 31
a=mid: 4

Is this a valid mid attrbiute representation?

Thanks in advance
srikanth

This message is proprietary to Hughes Software Systems Limited (HSS) and is
intended solely for the use of the individual to whom it is addressed.  It
may contain privileged or confidential information and should not be
circulated or used for any purpose other than for what it is intended.  If
you have received this message in error, please notify the originator
immediately.  If you are not the intended recipient, you are notified that
you are strictly prohibited from using, copying, altering, or disclosing
the contents of this message.  HSS accepts no responsibility for loss or
damage arising from the use of the information transmitted by this email
including damage from virus.

_______________________________________________
mmusic mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mmusic

---

From: Gonzalo Camarillo <[email-masked]>
Date: Tue, 26 Nov 2002 12:14:18 +0200

Hi,

inline:

> Can "mid" values be *alpha numeric* ?.

Yes.

> Is this a valid mid attrbiute representation?

Yes.

regards,

Gonzalo