Subject: [MMUSIC] Multiple connection lines in sdp-new-11 grammar

From: Pekka Pessi <[email-masked]>
Date: 27 Nov 2002 15:34:00 +0200

Hello,

	There is a change in the media-descriptions syntax between
	sdp-new-10 and sdp-new-11. The original form

media-descriptions =  *( media-field
                      information-field
                      *connection-field
                      bandwidth-fields
                      key-field
                      attribute-fields )

	was changed to

media-descriptions =  *( media-field
                      information-field
                      connection-field
                      bandwidth-fields
                      key-field
                      attribute-fields )

	I hope this is a typo or something. 
	
	The old form was ambiguous, but you can fix it better with
	something like this:

media-descriptions =  *( media-field
                      information-field
                      connection-fields
                      bandwidth-fields
                      key-field
                      attribute-fields )

connection-fields  = *( connection-line )

connection-field   = [ connection-line ]
	
connection-line    = "c=" nettype SP addrtype SP connection-address CRLF

	BR,
					Pekka
_______________________________________________
mmusic mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mmusic

---

From: Colin Perkins <[email-masked]>
Date: Wed, 27 Nov 2002 12:48:20 -0500

This was done for consistancy with the description of c= where it states: 

  A session announcement MUST contain either one ``c='' field in each media
  description (see below) or a ``c='' field at the session-level.  It MAY
  contain a session-level ``c='' field and one additional ``c='' field per
  media description, in which case the per-media values override the
  session-level settings for the respective media.

However, further down in that section, in the discussion of layering, it
also says:

  Multiple addresses or ``c='' lines MAY be specified on a per-media
  basis.  They MUST NOT be specified for a session-level ``c='' field.

which seems inconsistant. I suspect the correct resolution is to re-add the
"*" in the ABNF, and change the description of c= to read

  A session announcement MUST contain either at least one ``c='' field 
  in each media description (see below) or a single ``c='' field at the
  session-level.  It MAY contain a single session-level ``c='' field and
  additional ``c='' field(s) per media description, in which case the 
  per-media values override the session-level settings for the respective
  media.

Comments?
Colin

---

From: Pekka Pessi <[email-masked]>
Date: 27 Nov 2002 21:32:52 +0200

Colin Perkins <[email-masked]> writes:
...

>Comments?

	None. This sounds better.

					Pekka