Subject: AW: [MMUSIC] I-D ACTION:draft-ietf-mmusic-sdp-new-11.txt

From: Kreuter Ruediger <[email-masked]>
Date: Thu, 7 Nov 2002 16:44:05 +0100

If I understand this correct, then it is allowed to signal several codecs with a session description, e.g.
m=audio 49170 RTP/AVP 0 4 18
indicating that PCMU G.723.1 or G.729 may be used within the session;

But there is only one media description for packetization time, e.g.
a=ptime:10
which is then the recommendation for encoding the packet.

So, if it is allowed to use any codec in the list we get in trouble by using 10ms packets with G.723.1
On the other side, if we use a=ptime:30, since this is the smallest common value, then we add extra delay to G.711 packets without need.

That is, it would be useful to have a ptime per codec.

> -----Ursprüngliche Nachricht-----
> Von: [email-masked] [mailto:[email-masked]]
> Gesendet: Donnerstag, 7. November 2002 12:26
> Cc: [email-masked]
> Betreff: [MMUSIC] I-D ACTION:draft-ietf-mmusic-sdp-new-11.txt
> 
> 
> A New Internet-Draft is available from the on-line 
> Internet-Drafts directories.
> This draft is a work item of the Multiparty Multimedia 
> Session Control Working Group of the IETF.
> 
> 	Title		: SDP: Session Description Protocol
> 	Author(s)	: M. Handley, V. Jacobson, C. Perkins
> 	Filename	: draft-ietf-mmusic-sdp-new-11.txt
> 	Pages		: 46
> 	Date		: 2002-11-6
> 	
> This memo defines the Session Description Protocol (SDP). SDP
> is intended for describing multimedia sessions for the
> purposes of session announcement, session invitation, and
> other forms of multimedia session initiation.
> 
> A URL for this Internet-Draft is:
> http://www.ietf.org/internet-drafts/draft-ietf-mmusic-sdp-new-11.txt
> 
> To remove yourself from the IETF Announcement list, send a message to 
> ietf-announce-request with the word unsubscribe in the body 
> of the message.
> 
> Internet-Drafts are also available by anonymous FTP. Login 
> with the username
> "anonymous" and a password of your e-mail address. After logging in,
> type "cd internet-drafts" and then
> 	"get draft-ietf-mmusic-sdp-new-11.txt".
> 
> A list of Internet-Drafts directories can be found in
> http://www.ietf.org/shadow.html 
> or ftp://ftp.ietf.org/ietf/1shadow-sites.txt
> 
> 
> Internet-Drafts can also be obtained by e-mail.
> 
> Send a message to:
> 	[email-masked].
> In the body type:
> 	"FILE /internet-drafts/draft-ietf-mmusic-sdp-new-11.txt".
> 	
> NOTE:	The mail server at ietf.org can return the document in
> 	MIME-encoded form by using the "mpack" utility.  To use this
> 	feature, insert the command "ENCODING mime" before the "FILE"
> 	command.  To decode the response(s), you will need "munpack" or
> 	a MIME-compliant mail reader.  Different MIME-compliant 
> mail readers
> 	exhibit different behavior, especially when dealing with
> 	"multipart" MIME messages (i.e. documents which have been split
> 	up into multiple messages), so check your local documentation on
> 	how to manipulate these messages.
> 		
> 		
> Below is the data which will enable a MIME compliant mail reader
> implementation to automatically retrieve the ASCII version of the
> Internet-Draft.
> 
_______________________________________________
mmusic mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mmusic

---

From: Colin Perkins <[email-masked]>
Date: Thu, 07 Nov 2002 10:52:30 -0500

--> Kreuter Ruediger writes:
>So, if it is allowed to use any codec in the list we get in trouble by
>using 10ms packets with G.723.1 On the other side, if we use a=ptime:30,
>since this is the smallest common value, then we add extra delay to G.711
>packets without need.
>

Changing the definition of ptime would break backwards compatibility. If
this functionality is needed, you should make sure that it's in SDPng.

Colin