Subject: Re: [MMUSIC] Usage of maxptime and ptime

From: John Lazzaro <[email-masked]>
Date: Thu, 27 Mar 2003 10:51:55 -0800

> Magnus Westerlund <[email-masked]> writes:
>
>  Also I don't see a big 
> problem. As maxptime provides a upper boundary when having a codec with 
> frame length of 7.7 milli seconds it seems obvious that if you want to
> limit this to three frames one simple uses 24 ms in maxptime.

MWPP is an audio payload that is neither frame nor sample based;
the interactive norm may be ptime:0 -- i.e. all commands
in a payload execute at the same moment in time, and thus the 
interval of time coded in a packet is 0 ms.

But you can also use MWPP to do content-streaming type work, in
which case you'd probably specify ptime values in keeping with   
what MPEG audio codecs use ...

So, ptime and maxptime are the hints that will be used for 
senders and receivers to know which broad application class
the session falls into ... as well as to provide hints for
sender timing accuracy and receiver buffer sizing. This will
all be informative text tucked into an Appendix in the MWPP
normative memo ... 

-------------------------------------------------------------------------
John Lazzaro -- Research Specialist -- CS Division -- EECS -- UC Berkeley
lazzaro [at] cs [dot] berkeley [dot] edu     www.cs.berkeley.edu/~lazzaro
-------------------------------------------------------------------------
_______________________________________________
mmusic mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mmusic

---

From: John Lazzaro <[email-masked]>
Date: Fri, 28 Mar 2003 10:04:28 -0800

> Magnus Westerlund <[email-masked]> writes
>
> I would change the value from a unsigned integer to the much more
> common DIGIT definition.

Yes, that definition was stolen from MWPP parameters that needed
32-bit explicit constraints ... not needed here though.