Subject: Re: [MMUSIC] Usage of maxptime and ptime

From: John Lazzaro <[email-masked]>
Date: Thu, 27 Mar 2003 10:31:48 -0800

> Colin Perkins <[email-masked]> writes:
>
> History. I have no objection to including ABNF, if you want
> to suggest the appropriate form.

Here's one alternative, adapted from the MWPP ABNF ... 

                  ;
                  ; sub-rules of 'a='
                  ;

attribute-fields  =  *("a=" attribute CRLF)

                  ; ABNF for attributes defined in this memo

attribute         = "cat"      ":"  cat-fields

attribute        /= "keywds"   ":"  keyword-fields

attribute        /= "tool"     ":"  tool-fields

attribute        /= "ptime"    ":" four-octet-int

attribute        /= "maxptime" ":" four-octet-int

                  ;
                  ; todo: complete list of defined attributes 
                  ;
                  ; last entry (below) guides authors of new attributes

attribute        /= (att-field ":" att-value) / att-field

                  ;
                  ; ABNF for specific attribute fields
                  ;

four-octet-int    = %d0-429496729
                  ; unsigned 32-bits integer

                  ; add cat-fields, keyword-fields ... below

att-field         =  token

att-value         =  byte-string

-------------------------------------------------------------------------
John Lazzaro -- Research Specialist -- CS Division -- EECS -- UC Berkeley
lazzaro [at] cs [dot] berkeley [dot] edu     www.cs.berkeley.edu/~lazzaro
-------------------------------------------------------------------------
_______________________________________________
mmusic mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mmusic

---

From: Magnus Westerlund <[email-masked]>
Date: Fri, 28 Mar 2003 11:03:49 +0100

John Lazzaro wrote:

>attribute        /= "ptime"    ":" 1*DIGIT
>
>attribute        /= "maxptime" ":" 1*DIGIT
>
>  
>
I would change the value from a unsigned integer to the much more common 
DIGIT definition.

Best Regards

Magnus Westerlund 

Multimedia Technologies, Ericsson Research ERA/TVA/A
----------------------------------------------------------------------
Ericsson AB                | Phone +46 8 4048287
Torshamsgatan 23           | Fax   +46 8 7575550
S-164 80 Stockholm, Sweden | mailto: [email-masked]