Subject: RE: [MMUSIC] WG Last Call on draft-rajeshkumar-mmusic-gpmd-02.txt

From: Kreuter Ruediger <[email-masked]>
Date: Tue, 6 May 2003 10:23:53 +0200

> > Kreuter Ruediger wrote:
> 
> > > -----Ursprüngliche Nachricht-----
> > > Von: Flemming Andreasen [mailto:[email-masked]]
> > > Gesendet: Freitag, 2. Mai 2003 04:01
> > > An: Joerg Ott
> > > Cc: [email-masked]; Colin Perkins; [email-masked]
> > > Betreff: Re: [MMUSIC] WG Last Call on
> > > draft-rajeshkumar-mmusic-gpmd-02.txt
> > >
> > >
> > > In some off-line discussions, it was suggested, that we add
> > > the following
> > > as a new paragraph #3 in Section 3 (which defines the "vbd" gpmd
> > > parameter):
> > >
> > > When use of a "vbd" media format has been negotiated, 
> voice-band data
> > > SHOULD be transported using either a "vbd" media format or another
> > > negotiated media format suitable for transporting the
> > > voice-band data in
> > > question. Examples of such media formats include RFC 2833
> > > (with support
> > > for relevant data modem and fax tones),
> >
> > Up to now my understanding of RFC2833 was, that it can be used
> > to relay the connection setup negotiation tones between fax/modem
> > terminals, but not the fax/modem payload. Am I wrong with this ?
> 
> No. The above was trying to capture that transport of such 
> things as V.25
> ANS and V.8 ANSam using RFC 2833 would be just fine. Do you have any
> suggested wording changes that would make that clearer ?

How about:

*****************************************************
When use of a "vbd" media format has been negotiated, 
voice-band data SHOULD be transported using either a 
"vbd" media format or another negotiated media format 
suitable for transporting the voice-band data in 
question. 
Examples of such media formats include T.38 fax relay 
and V.150 modem relay. Non-examples include G.723.1, 
G.729, and PCMA/PCMU without an accompanying "vbd" 
gpmd parameter. 
Note that selection of specific suitable media formats 
is typically done on the basis of stimuli, such as the 
detection of a calling or an answer tone, a V.21 preamble 
with fax flags or a modem CM signal, which may occur at 
different times.
In any case RFC 2833 may be used to relay relevant data 
modem and fax events.
*****************************************************

Regards, Ruediger

> 
> -- Flemming
> 
> > > T.38 fax relay, and
> > > V.150 modem
> > > relay. Non-examples include G.723, G729, and PCMU without an
> > > accompanying "vbd" gpmd parameter. Note that selection of specific
> > > suitable media formats is typically done on the basis of 
> stimuli, such
> > > as the detection of an answer tone, a fax preamble and a modem CM
> > > signal, which may occur at different times.
> > >
 
_______________________________________________
mmusic mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mmusic

---

From: Flemming Andreasen <[email-masked]>
Date: Tue, 06 May 2003 07:49:00 -0400

> How about:

Looks good to me.

-- Flemming