Subject: [MMUSIC] Experiences with Media Discovery (for IMG)

From: [email-masked]
Date: Fri, 2 May 2003 16:04:50 +0300

Hello

In San Francisco we loudly hummed to work on Internet Media Guides in MMUSIC.

(As a reminder, the IETF56 MMUSIC minutes and Internet Media Guide (IMG) presentations are at http://www.dmn.tzi.org/ietf/mmusic/ - see cut text below too)

I really need to find out about YOUR experience in media announcements and descriptor delivery. SDP and SAP love and hate knowledge as well as moving the metadata point-to-point (FTP, HTTP are pretty well used) and new work (SIP, SDPng, etc.) are very important so we can put together a picture of what a really needed by our IP world. Ultimately, our purpose is to be able to specify really useful protocols, etc. as IDs -> RFCs. But first we have a basic goal to compile:
* requirements for Delivery of Media Metadata for Multicast Media
* study how a framework of the existing IETF standards and work-in-progress can be used

This way we can spot the gaps and set some sort of priority to more-than-just-our needs.

So tell us a story, set some requirements, praise and condemn what we already have. Just do it now!

My own mini-epic goes:
I am working on a service announcement application for unidirectional (aka. broadcast) service/media/content IP delivery. The sorts of media involved are streaming audio and video, and files - both huge and tiny. So, with a few Nokia colleagues, I set to work on SDP and SAP a couple of years ago and after a lot of SDP extensions and SAP heart-ache ended up with a mix of proprietary XML + extended SDP over SAP and then over a couple of proprietary multicast file delivery protocols instead.

Fortunately, most of the pain has faded with time, but we wished that our simple needs were already in IETF protocols from the beginning. Fixes for some of the issues of multicast and unidirectional "media announcement" transport and an elementary specification on framing media metadata are just as essential now. So we would very much like to gent involved with a next generation of service/session announcement and description based on MMUSIC's impressive background and specifications for this.

In the process of this work we've already come up with a few requirements and an idea of the sort of tasks / specifications which we felt were needed. If you have a moment, check out the IDs on IMG which are a start at sharing this in MMUSIC (also linked from the IMG presentation @ http://www.dmn.tzi.org/ietf/mmusic/). There's also some earlier emails threads on this reflector based on the -pguide- IDs (precursor to IMG).

Meanwhile, please email your needs and experiences to the reflector so we have much wider material and contributors, to make the work even more worthwhile.

Thanks in advance,
Rod Walsh.

==========

To make life a little easier I cut and pasted some text on IMGs from IETF-56 (http://www.dmn.tzi.org/ietf/mmusic/) as a reminder...

----------

Multiparty Multimedia Session Control (MMUSIC) Working Group Minutes

Reported by Colin Perkins

    The MMUSIC working group met once at the 56th IETF meeting in San
    Francisco. The group discussed connection oriented media, various
    SDP extensions, Offer/Answer examples, SDPng, Internet Media Guides,
    and RTSP.

Introduction and Status Update

    Joerg Ott began the meeting with an introduction and status update.
...
    The working group has completed its charter, and a draft for a revised
    charter was sent to the mailing list prior to the meeting. This draft
    is under discussion between the chairs and area director, and comments
    are solicited from the group. It is expected that the revision will
    include work on SDP, SDPng, RTSP and Internet Media Guides. Conference
    Control has been ruled out of scope at this time.
...
Internet Media Guides

    Rod Walsh outlined Internet Media Guides (IMGs), a potential new work
    item for the group. An Internet Media Guide (IMG) is a collection of
    multimedia session descriptions expressed using SDP, SDPng or some
    similar session description format. It is used to describe a collection
    of multimedia sessions (e.g.  television programme schedules).  The IMG
    must be delivered to a potentially large audience, who use it to join a
    subset of the sessions described, and who may need to be notified of
    changes to the IMG.

    This problem lends itself to solution by (extensions of) some existing
    mechanisms: SAP and SDP/SDPng. MMUSIC therefore seems the natural home
    for the work. Other groups (e.g. DVB-IPI, TV Anytime, and the IP datacast
    forum) have identified similar needs, but do not have the experience to
    solve the problem.

    The chairs presented some initial charter text discussing the problem
    (subject to modification/approval from the area directors) and asked
    if the working group considered this an appropriate work item? Strong
    support was received.
...

----------
Draft text for charter:

An Internet Media Guide (IMG) is a set of multimedia session descriptions expressed using SDP, SDPng or some similar session description format. It is used to describe a collection of multimedia sessions (e.g. television programme schedules). The IMG must be delivered to a potentially large audience, who use it to join a subset of the sessions described, and who may need to be notified of changes to the IMG. 

MMUSIC will investigate work on delivery mechanisms for IMGs, generalizing our work on session announcement and discovery protocols (SAP, RTSP, SIP). We will investigate and document requirements for IMG delivery mechanisms, and identify the requirements that these delivery mechanisms impose on the session description formats used by the IMG. We will then work to produce a framework document outlining the use of (existing) protocols to create an IMG delivery infrastructure. After successful completion of these initial milestones for IMG delivery, the MMUSIC charter will be updated to reflect the actual steps for IMG delivery specifications. 

----------

Cheers,
Rod Walsh.

_______________________________________________
mmusic mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mmusic

---

From: Hitoshi Asaeda <[email-masked]>
Date: Fri, 02 May 2003 17:38:44 +0200 (MEST)

Hi Rod.

> I really need to find out about YOUR experience in media
> announcements and descriptor delivery. SDP and SAP love and hate
> knowledge as well as moving the metadata point-to-point (FTP, HTTP
> are pretty well used) and new work (SIP, SDPng, etc.) are very
> important so we can put together a picture of what a really needed
> by our IP world. Ultimately, our purpose is to be able to specify
> really useful protocols, etc. as IDs -> RFCs. But first we have a
> basic goal to compile:

I've put a draft version of my paper related to this discussion before
the last IETF.
Our new "channel announcement mechamism" is called "Channel Reflector".
The purpose of this proposal is to provide a feasible channel
announcement mechanism for SSM environment without using SAP
advertisement. By using Channel Reflector, we can eliminate source
discovery procedure from multicast service model.
Some parts of the idea can be overwrapped to IMG, therefore we may be
able to collaborate.

If you are interested in, you'd be able to get it from;
<http://www.inria.fr/rrrt/rr-4762.html>.

Any comment would be appreciate.

Thanks.
--
Hitoshi Asaeda