Subject: [MMUSIC] On hold when the stream is sendonly

From: [email-masked]
Date: Tue, 6 May 2003 19:02:29 +0300

Hi,

Apologies if this question has been addressed before.

RFC3264 says:

"If the stream to be placed on hold was previously a sendrecv media
   stream, it is placed on hold by marking it as sendonly.  If the
   stream to be placed on hold was previously a recvonly media stream,
   it is placed on hold by marking it inactive."

So, if the stream is sendonly, I presume that the sender simply stops sending RTP.

My question is: in the 2 cases indicated in the quote above, the receiver of the media gets to learn that the other side is not going to send media on that stream anymore. But if the case I describe, the receiver will not know. Is there a way for it to know?

- Does it use RTCP? 
- or can the sender send a new offer changing the stream from sendonly to inactive (seems a bit redundant, but its a way for the sender to inform the receiver that the stream is on hold)?

What is recommended?

Much appreciated,
Hisham
_______________________________________________
mmusic mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mmusic

---

From: [email-masked]
Date: Thu, 8 May 2003 16:42:14 +0300

Let me simply the question:

How does A tell B that A will not send media to B on a certain media stream for a little while?

Thanks,
Hisham

> -----Original Message-----
> From: ext [email-masked] 
> [mailto:[email-masked]]
> Sent: Tuesday, May 06, 2003 7:02 PM
> To: [email-masked]
> Subject: [MMUSIC] On hold when the stream is sendonly
> 
> 
> Hi,
> 
> My question is: in the 2 cases indicated in the quote above, 
> the receiver of the media gets to learn that the other side 
> is not going to send media on that stream anymore. But if the 
> case I describe, the receiver will not know. Is there a way 
> for it to know?
> 
> - Does it use RTCP? 
> - or can the sender send a new offer changing the stream from 
> sendonly to inactive (seems a bit redundant, but its a way 
> for the sender to inform the receiver that the stream is on hold)?
> 
> What is recommended?
> 
> Much appreciated,
> Hisham