Subject: RE: [MMUSIC] Testing compliance to RTSP

From: "Amir Wolf" <[email-masked]>
Date: Mon, 12 May 2003 10:20:44 +0300

Magnus,

As one that is active in an interoperability group , we had also some discussion about compliance and interoperate - these are 2 different things - Interoperability is achieved by some vendors who understand in the same way the standard - it does not mean that they implement it all and that they are compliant, but together they will work perfect. 

so basically I am against giving any compliance certifications since practically I believe that there is no fully compliant system living out there today.

> -----Original Message-----
> From: Magnus Westerlund [mailto:[email-masked]]
> Sent: Wednesday, May 07, 2003 6:07 PM
> To: Mark Hansen
> Cc: [email-masked]'
> Subject: Re: [MMUSIC] Testing compliance to RTSP
> 
> 
> Hi Mark,
> 
> They may be products out there that claim that they verify RTSP 
> compliance. However the real picture in regards to RTSP is that the 
> specification is not clear enough to result in fully 
> interoperable RTSP 
> implementations. Basic interoperability has been achieved for basic 
> playback functionality. However a number of features or behavior that 
> are rather centric to RTSP has been implemented differently 
> by different 
> vendors. This is the reason that in my opinion no one can currently 
> develop a tool that test compliance.
> 
> Due to this differences we in this WG are currently working 
> on updating 
> the RTSP specification to something that will be possible to 
> implement 
> in an interoperable way. The latest version of the draft is 
> "draft-ietf-mmusic-rfc2326bis-03.txt". This draft does not 
> yet cover all 
> the known issues. A list of bugs can be found at 
> http://rtspspec.sourceforge.net. We also have teleconferences 
> where we 
> discuss issues and resolutions. A list of the minutes of meeting for 
> these, see http://rtsp.org. I would recommend that you look at the 
> changes list in the draft, the bugs and their resolutions, 
> and what we 
> discussed in the telecons to discover which changes we 
> propose and areas 
> where there has been unclearities regarding RTSP. I would 
> also encourage 
> you to write to this mailing list any question you have 
> regarding RTSP 
> issues. You are also welcome to join the RTSP telecons if you 
> have input 
> on anything on the agenda.
> 
> Best Regards
> 
> Magnus
> 
> Mark Hansen wrote:
> 
> >Hello,
> >
> >During the course of my work, we have developed a software 
> system, a part of
> >which which acts as a proxy server between a freely 
> available video server
> >and end user client video software. We would like to check 
> the compliance of
> >the server side interface to the proxy with the complete RTSP. 
> >
> >I was wondering if anyone knew of any tools available to 
> RTSP developers
> >that could, by interrogation of the specified RTSP interface 
> that has been
> >developed, determine which parts of the protocol are being 
> adhered to and
> >which are not.
> >
> >Any information would be greatly appreciated.
> >
> >Mark
> >
> >
> >Mark Hansen
> >Design Engineer
> >
> >Cirrus Real Time Processing Systems Pty. Ltd.
> >Level 9, 99 Elizabeth Street,
> >Sydney, 2000
> >P.O. Box A2298,
> >Sydney South 1235
> >AUSTRALIA
> >Phone: +61 2 9231-2225
> >Fax: +61 2 9231-2252
> >Email: [email-masked]
> >
> >***********************************************
> >Cirrus wins Cisco Systems Innovation Award, and
> >Telstra NSW Small Business of the Year 2002.
> >See NEWS section at www.cirrusrtps.com.au
> >***********************************************
> >
> >COMMERCIAL-IN-CONFIDENCE
> >
> >CAUTION - This message may contain privileged and 
> confidential information
> >intended only for the use of the addressee named above. If 
> you are not the
> >intended recipient of this message you are hereby notified 
> that any use,
> >dissemination, distribution or reproduction of this message 
> is prohibited.
> >If you have received this message in error please notify 
> Cirrus immediately.
> >Any views expressed in this message are those of the 
> individual sender and
> >may not necessarily reflect the views of Cirrus. Cirrus cannot accept
> >liability for any virus damage caused by this message.
> >
> >
> >_______________________________________________
> >mmusic mailing list
> >[email-masked]
> >https://www1.ietf.org/mailman/listinfo/mmusic
> >
> >  
> >
> 
> -- 
> 
> Magnus Westerlund 
> 
> Multimedia Technologies, Ericsson Research ERA/TVA/A
> ----------------------------------------------------------------------
> Ericsson AB                | Phone +46 8 4048287
> Torshamsgatan 23           | Fax   +46 8 7575550
> S-164 80 Stockholm, Sweden | mailto: [email-masked]
> 
> 
> 
> _______________________________________________
> mmusic mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/mmusic
> 

**************************************************************************************************
The contents of this email and any attachments are confidential.
It is intended for the named recipient(s) only.
If you have received this email in error please notify the system manager or  the 
sender immediately and do not disclose the contents to any one or make copies.

** eSafe scanned this email for viruses, vandals and malicious content **
**************************************************************************************************

_______________________________________________
mmusic mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mmusic

---

From: Magnus Westerlund <[email-masked]>
Date: Mon, 12 May 2003 12:47:19 +0200

Hi Amir,

I can agree with you that there is differnce between compliance and 
interoperability. In the end, it is the interoperability that is 
important. However I hope that you agree that interoperability is easier 
to accomplish if one is tries to be compliant with a standard. This as 
long as everyone agree what compliant means in regards to protocol actions.

My point being, due to the many shortcommings in the RTSP specification 
there is hard to achieve a common view that one can be compliant against.

Regards

Magnus

-- 

Magnus Westerlund