Subject: [MMUSIC] STUN vs Symmetric RTP

From: "Gamze Seckin" <[email-masked]>
Date: Tue, 11 Nov 2003 10:01:30 -0800

Hi,

I checked the rtsp nat traversal draft (draft-ietf-mmusic-rtsp-nat-01.txt) but could not find a comprehensive comparison between STUN vs Symmetric RTP.

Is anybody actually using STUN?
How about symmetric RTP?

Which one would you recommend if you had to actually deploy it ?
Any pointers appreciated.

Br

g

-----------------------------------------------------------
Gamze Seckin, Ph.D.
Director of Research
Vidiator Technology (US) Inc.
411 108th Avenue NE. Suite 688
Bellevue, WA 98004 USA.
www.vidiator.com

Phone: 1.425.688.8811x2108
Email: [email-masked]

This e-mail message (including any attachment) is intended only for the personal use of the recipient(s) named above. This message is confidential and may be legally privileged. If you are not an intended recipient, you may not review, copy or distribute this message. If you have received this communication in error, please notify us immediately by e-mail and delete the original message. Any views or opinions expressed in this message are those of the author only. Furthermore, this message including any attachment does not create any legally binding rights or obligations whatsoever, which may only be created by the exchange of hard copy documents signed by a duly authorized representative of Vidiator Technology (US) Inc.
-----------------------------------------------------------

_______________________________________________
mmusic mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mmusic

---

From: Cullen Jennings <[email-masked]>
Date: Sat, 15 Nov 2003 17:02:15 -0800

STUN is shipping in several vendors SIP phones. STUN like things that are
not exactly STUN but work about the same way are are also done by many
vendors.

If you could only do one, I would do STUN before commedia but of course
doing all the stuff in ICE (draft-ietf-mmusic-ice) would probably work out
best. 

Cullen

On 11/11/03 10:01 AM, "Gamze Seckin" <[email-masked]> wrote:

> 
> Hi,
> 
> I checked the rtsp nat traversal draft (draft-ietf-mmusic-rtsp-nat-01.txt) but
> could not find a comprehensive comparison between STUN vs Symmetric RTP.
> 
> This e-mail message (including any attachment) is intended only for the
> personal use of the recipient(s) named above. This message is confidential and
> may be legally privileged. If you are not an intended recipient, you may not
> review, copy or distribute this message. If you have received this
> communication in error, please notify us immediately by e-mail and delete the
> original message. Any views or opinions expressed in this message are those of
> the author only. Furthermore, this message including any attachment does not
> create any legally binding rights or obligations whatsoever, which may only be
> created by the exchange of hard copy documents signed by a duly authorized
> representative of Vidiator Technology (US) Inc.

---

From: Jonathan Rosenberg <[email-masked]>
Date: Mon, 17 Nov 2003 12:09:53 -0500

> doing all the stuff in ICE (draft-ietf-mmusic-ice) would probably work out

To add to that, if you do ICE, the client to client tests that use 
STUN would get you equivalent functionality to symmetric RTP. The 
benefit is that ICE will allow your client to work in lots of 
different cases, not just the limited ones where symmetric RTP works. 
In particular, if both clients are behidn NAT, symmetric RTP doesnt help.

-Jonathan R.

-- 
Jonathan D. Rosenberg, Ph.D.                600 Lanidex Plaza
Chief Technology Officer                    Parsippany, NJ 07054-2711
dynamicsoft
[email-masked]                     FAX:   (973) 952-5050
http://www.jdrosen.net                      PHONE: (973) 952-5000
http://www.dynamicsoft.com