Subject: [MMUSIC] RTSP SET_PARAMETER with no parameters.

From: [email-masked]
Date: Mon, 10 Nov 2003 11:45:22 +0200

Dear MMUSIC members and RTSP experts,

I have a question related to the RTSP SET_PARAMETER method.
Is it possible to issue an RTSP SET_PARAMETER method without a parameter ?
Here is an example:

	SET_PARAMETER rtsp://server/content.3gp RTSP/1.0
	CSeq: 123
	Session: 12345678
	Bandwidth: 64000
	Standard_Defined_Header: some_parameter=new_value_of_some_parameter
	Content-length: 0 
	Content-type: text/parameters

Basically the aim is to update the "Standard_Defined_Header" header field. I was wondering if this update could be done with such a SET_PARAMETER request. And if so, how should be the response behaviour of the server to that?

Another alternative may be the usage of OPTIONS method with a Session ID. Could you experts comment on which way is better?

Cheers,
Emre

_________________________________
Emre Baris Aksu
Nokia Mobile Software
P.O. Box 88, FIN-33100 Tampere
Tel: +358 7180 08000
e-mail: [email-masked]

_______________________________________________
mmusic mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mmusic

---

From: Magnus Westerlund <[email-masked]>
Date: Mon, 10 Nov 2003 19:29:43 +0100

Hi Emre,

Please see my comments inline.

>Is it possible to issue an RTSP SET_PARAMETER method without a parameter ?

Yes, but is rather a SET_PARAMETER without a body.

>	Content-type: text/parameters
Therfore it would not contain any of the Content-x headers.

>Basically the aim is to update the "Standard_Defined_Header" header field. I was wondering if this update could be done with such a SET_PARAMETER request. And if so, how should be the response behav…

The response to such a request is a 200 OK. However that will not 
necessary mean that the recipient has understood all headers, only the 
mandatory. Therefore if one has important functionality and do not know 
appriori that it will behave in this way one should use a Require header 
with a feature tag for the functionality.

>Another alternative may be the usage of OPTIONS method with a Session ID. Could you experts comment on which way is better?

Options is not better. Options has another semantics and induce other 
overhead. So the usage of SET_PARAMETER is the right one.

Cheers

Magnus