Subject: [MMUSIC] draft-rajeshkumar-mmusic-gpmd-03.txt

From: Tom Taylor <[email-masked]>
Date: Mon, 12 Jan 2004 16:26:54 -0500

The IESG ID tracker shows that the IESG requested changes to 
draft-rajeshkumar-mmusic-gpmd-03.txt.  What was the nature of those 
changes, and where does the process stand?

_______________________________________________
mmusic mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mmusic

---

From: Flemming Andreasen <[email-masked]>
Date: Tue, 13 Jan 2004 22:35:13 -0500

At the risk of misrepresenting the IESG, let me offer my interpretation
of the comments we got from the IESG:

1. Concerns about the mechanism itself inasmuch as it may be (mis)used
to essentially redefine the meaning of an otherwise well-defined MIME
type. You may also have general "bucket" MIME types, the meaning of
which depend on parameters provided by something like gpmd. There are
some concerns with what that means for interoperability.
2. Overlap with existing media feature tagging mechanims defined in RFCs
2533, 2534, 2912, 2938, and 2987

The authors have yet to figure out if and how those issues should be
resolved. One option is simply to kill the draft and just fallback to
the specifc vbd-definition already provided in ITU-T Recommendation
V.150.1. The intent with the draft of course was precisely not to do
that, but considering that the vbd-definition is really all we were
after, this may be getting into being a bit of an overkill. The only
"real" issue that would leave us with is getting the parameter
registered, and although Standards Track RFCs are preferred for that,
sdp-new does permit attributes to be registered per the "Specification
Required" policy; for at least the vbd-specific usage of gpmd, I believe
we would be close enough to pass that bar.

-- Flemming

---

From: Tom Taylor <[email-masked]>
Date: Wed, 14 Jan 2004 14:00:40 -0500

Thanks for the update.  I did see Ned Freed's remarks on the IESG I-D tracker, but 
wasn't sure if they were the cause of the remit to the authors.

I know we've been there before, but one quick fix would be to add a parameter to 
the PCMU and PCMA MIME types to indicate voice-band data.

---

From: Flemming Andreasen <[email-masked]>
Date: Wed, 14 Jan 2004 21:27:01 -0500

> the PCMU and PCMA MIME types to indicate voice-band data.

It wouldn't address the V.150.1 issue though, which is already using the gpmd
parameter. Also, some medium bw codecs are capable of passing lower-rate modulations
inband, so you could still support voice-band data with codecs other than PCMU and
PCMA. Admittedly, the set of relevant codecs is fairly manageable in practice, but it
would be nice to have a general parameter to address it.

-- Flemming