Subject: RE: [MMUSIC] And one more SDP-quiz question on protocol IDs

From: [email-masked]
Date: Thu, 29 Apr 2004 16:05:57 +0300

> How does the receiver know the contents of the FLUTE session if more 
> than one file type is transported? Are you trying to signal that list 
> in SDP? Or is it picked up from the FLUTE session somehow?

It can be picked up from the FLUTE session. One or more FDT Instances describe the files and include the MIME type. FDT (File Decription Table) Instances are XML objects/files.

I not convinced that it is necessary to provide a list of several file types of the session for two reasons: the MIME types are available from FLUTE; and in some advanced media discrovery system (IMG stuff) the client would select the files, most likely already needing to knwo MIME types then (why what you can't use?). But I'm open to ideas!

Cheers, Rod.

_______________________________________________
mmusic mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mmusic

---

From: Colin Perkins <[email-masked]>
Date: Thu, 29 Apr 2004 19:30:44 +0100

On 29 Apr 2004, at 14:05, [email-masked] wrote:
> It can be picked up from the FLUTE session. One or more FDT Instances 
> describe the files and include the MIME type. FDT (File Decription 
> Table) Instances are XML objects/files.
>
> I not convinced that it is necessary to provide a list of several file 
> types of the session for two reasons: the MIME types are available 
> from FLUTE; and in some advanced media discrovery system (IMG stuff) 
> the client would select the files, most likely already needing to knwo 
> MIME types then (why what you can't use?). But I'm open to ideas!

It's beginning to sound like "m=data 49000 FLUTE/UDP" would be the 
right way to go, letting the application pick up the media types from 
the FLUTE session.

Unfortunately, though, the <fmt> parameter is mandatory in SDP "m=" 
lines. Unless there is something specific to FLUTE that could be used, 
we might need a dummy value?

-- 
Colin Perkins
http://csperkins.org/