Subject: [MMUSIC] Summary of IMG discussion

From: Henning Schulzrinne <[email-masked]>
Date: Tue, 02 Aug 2005 08:38:55 -0400

About 9 interested individuals, including the WG chairs, had a lunch 
meeting to discuss IMG future. Some of the results:

- The current envelope draft contains extraneous architecture material 
that obscures the mechanical aspects of the envelope. The draft should 
be slimmed down to focus on sections 5 through end, including offering 
an example.

- Alignment of the draft with the related 3GPP effort may be desirable; 
if possible, the IMG draft could be a superset of the 3GPP effort. 
Apparently, the 3GPP effort contains an XML envelope, with references to 
objects in MIME parts. Action item: those with detailed knowledge please 
provide background.

Rod Walsh, as current editor, will provide a date by which a revised 
version will be available.

- Additional drafts needed include:
   - a SIP event package for notifications of IMG object changes;
   - a URN definition for IMG objects
   - a DDDS (NAPTR) definition for resolving these URNs to an 
"actionable" URL such as http (for retrieval) or sip (for events)
   - an architecture document describing how these 4 efforts (three 
above  + envelope) work together, using some of the text cut from the 
envelope draft;

Parties interested in contributing to these drafts are invited to make 
themselves known.

- These drafts will start as individual contributions, but there is some 
expectation that they'll become WG items later.

Henning

_______________________________________________
mmusic mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mmusic

---

From: [email-masked]
Date: Fri, 5 Aug 2005 12:12:48 +0300

Thanks Henning for the excellent summary.

As a note for all interested, here are some more specific notes on envelope, architecture, HTTP and MUPPET - including those from the IMG Envelope specific meeting we had the following day:

ENVELOPE - I promised an updated I-D by the end of September. (That's the hard deadline, though earlier could happen). As Henning described, this will lose sections 3 and 4 (some of §4 text may remain)and some of the secuirty considerations which are IMG (not envelope) general or architectural, and these will enter a new "architecture" draft. An informational note on the use of XML-DSIG will be added (like in FLUTE - in case you've read that). The schema will allow extension by element (as well as by attribute). Internal (optional) URL resoluiton will be supported (multiple URL values in a URI element) in addition to the DDDS I-D option Henning described. Discussion on the use of a single XML object as an "indexing envelope" to reference multiple metadata fragments will be included, as well as the option to stuff into a multipart MIME structure incase multiple fragments are wanted in a single transport object. There's a good chance that another I-D version will be needed after this once some MIME experts checkout that new text - but apart from the MIME part it should be complete.

ARCHITECTURE - both the name of this I-D and the reuse and referencing of framework (I-D/RFC)sections is currently undecided. At the moment, we don't have an editor for this or an 00 submission dead-line. We do have the understanding that by definition, this would be the last document to be complete since it would glue together each other complete IMG component.

HTTP - there will also be an I-D on HTTP as IMG transport, which Joerg promised to get done (and a few others were also keen to be involved in)

FLUTE/MUPPET - the value of the multicast service announcement protocol is as high as ever. It would be desirable to offer a solution in harmony with other standards bodies. 3GPP have already frozen the standards using FLUTE for service announcement. In OMA & DVB (and I think 3GPP2) this is not totally resolved (I think there is active discussion on use of FDT Instances in terms of frequency and providing them out of band). These groups are also working on carousel delivery with one and multiple channels (carousels), as well as efficient update mechanisms to help the client out. So in short, there might be several IETF-extrenal advancements over the next few months which we can capitalise on for the Internet community. Also, there are other IMG I-Ds to work on in the mean time, so a new MUPPET I-D is not expected in the next couple of months.

Have a safe journey back from Paris (physically or meta-physically) everyone!

Cheers, Rod. 

> -----Original Message----- 
> From: [email-masked] 
> [mailto:[email-masked]]On Behalf 
> Of ext Henning Schulzrinne 
> Sent: Tuesday, August 02, 2005 3:39 PM 
> To: [email-masked] 
> Subject: [MMUSIC] Summary of IMG discussion 
> 
>