Subject: RE: [MMUSIC] Re: draft-ietf-mmusic-ice-05: TCP keep-alive of bindings

From: "Even, Roni" <[email-masked]>
Date: Wed, 17 Aug 2005 11:20:07 +0300

Gunnar
The current
http://www.ietf.org/internet-drafts/draft-ietf-avt-rtp-no-op-00.txt has
media types of audio, video and text
Roni Even 

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf
Of Gunnar Hellstrom
Sent: Wednesday, August 17, 2005 11:15 AM
To: Jonathan Rosenberg; Magnus Westerlund
Cc: mmusic (E-mail)
Subject: RE: [MMUSIC] Re: draft-ietf-mmusic-ice-05: TCP keep-alive of
bindings

You say:
>It would need to be something application specific. For RTP, RTP no-op 
>would work.

That means that we must start work in avt on defining an RTP no-op for
all media types:
audio, text, video, image etc.
At the moment, I think that the no-op aims at MIME registration only for
m=audio.

Gunnar
-------------------------------------------
Gunnar Hellstrom
Omnitor AB
[email-masked]
--------------------------------------------

>-----Original Message-----
>From: [email-masked] [mailto:[email-masked]]On Behalf

>Of Jonathan Rosenberg
>Sent: Wednesday, August 17, 2005 1:46 AM
>To: Magnus Westerlund
>Cc: mmusic (E-mail)
>Subject: [MMUSIC] Re: draft-ietf-mmusic-ice-05: TCP keep-alive of 
>bindings
>
>
>inline.
>
>Magnus Westerlund wrote:
>
>> Hi,
>>
>> How is keep-alive really done in the TCP case for the active
>session.
>
>It would need to be something application specific. For RTP, RTP no-op 
>would work.
>
>> It
>> is clear that the demultiplexing that can be used for RTP over UDP 
>> doesn't work.
>
>Right.
>
>> With the TCP framing of RTP there will be for all RTP packets of 
>> shorter length 256 will have a 0 octet initially for each packet. 
>> Thus STUN and RTP framing can't be disambiguied.
>
>Right. I'll calrify that it needs to be an apploication layer keepalive

>for TCP, and recommed RTP no-op for RTP.
>
>-Jonathan R.
>
>
>--
>Jonathan D. Rosenberg, Ph.D.                   600 Lanidex Plaza
>Director, Service Provider VoIP Architecture   Parsippany, NJ
>07054-2711
>Cisco Systems
>[email-masked]                              FAX:   (973) 952-5050
>http://www.jdrosen.net                         PHONE: (973) 952-5000
>http://www.cisco.com
>
>_______________________________________________
>mmusic mailing list
>[email-masked]
>https://www1.ietf.org/mailman/listinfo/mmusic
>

_______________________________________________
mmusic mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mmusic

_______________________________________________
mmusic mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mmusic

---

From: "Gunnar Hellstrom" <[email-masked]>
Date: Wed, 17 Aug 2005 10:29:37 +0200

Roni,
Thanks, excellent that text and video are now included in the possible
media for no-op.

Will you consider including m=application as well for your work with
remote camera control and H.224 transport. Its intermittent use will
surely require keep-alive when passing SIP-unaware NATs.

Gunnar
Omnitor

>From: Even, Roni [mailto:[email-masked]]
>Sent: Wednesday, August 17, 2005 10:20 AM
>To: Gunnar Hellstrom; Jonathan Rosenberg; Magnus Westerlund
>Cc: mmusic (E-mail)
>>From: [email-masked]
>[mailto:[email-masked]]On Behalf
>
>>Of Jonathan Rosenberg

---

From: Jonathan Rosenberg <[email-masked]>
Date: Wed, 17 Aug 2005 09:48:18 -0400

The idea with RTP no-op was to be media independent, so to me it makes 
sense to make sure there are registrations in place for all media types 
that we have.

-Jonathan R.

Gunnar Hellstrom wrote:

>>>It would need to be something application specific. For RTP,
>>
>>RTP no-op
>>
>>>would work.
>>
>>>It would need to be something application specific. For RTP,
>>
>>RTP no-op
>>
>>>would work.
>>>
>>>
>>>>It
>>>Right. I'll calrify that it needs to be an apploication layer
>>
>>keepalive
>>
>>

-- 
Jonathan D. Rosenberg, Ph.D.                   600 Lanidex Plaza
Director, Service Provider VoIP Architecture   Parsippany, NJ 07054-2711
Cisco Systems
[email-masked]                              FAX:   (973) 952-5050
http://www.jdrosen.net                         PHONE: (973) 952-5000
http://www.cisco.com