Subject: [MMUSIC] draft-ietf-mmusic-ice-05: TCP keep-alive of bindings

From: Magnus Westerlund <[email-masked]>
Date: Tue, 02 Aug 2005 15:14:01 +0200

Hi,

How is keep-alive really done in the TCP case for the active session. It 
is clear that the demultiplexing that can be used for RTP over UDP 
doesn't work. With the TCP framing of RTP there will be for all RTP 
packets of shorter length 256 will have a 0 octet initially for each 
packet. Thus STUN and RTP framing can't be disambiguied.

Cheers

Magnus Westerlund

Multimedia Technologies, Ericsson Research EAB/TVA/A
----------------------------------------------------------------------
Ericsson AB                | Phone +46 8 4048287
Torshamsgatan 23           | Fax   +46 8 7575550
S-164 80 Stockholm, Sweden | mailto: [email-masked]

_______________________________________________
mmusic mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mmusic

---

From: Jonathan Rosenberg <[email-masked]>
Date: Tue, 16 Aug 2005 19:46:13 -0400

inline.

Magnus Westerlund wrote:

> Hi,
> 
> How is keep-alive really done in the TCP case for the active session. 

It would need to be something application specific. For RTP, RTP no-op 
would work.

> It 
> doesn't work.

Right.

> With the TCP framing of RTP there will be for all RTP 

Right. I'll calrify that it needs to be an apploication layer keepalive 
for TCP, and recommed RTP no-op for RTP.

-Jonathan R.

-- 
Jonathan D. Rosenberg, Ph.D.                   600 Lanidex Plaza
Director, Service Provider VoIP Architecture   Parsippany, NJ 07054-2711
Cisco Systems
[email-masked]                              FAX:   (973) 952-5050
http://www.jdrosen.net                         PHONE: (973) 952-5000
http://www.cisco.com

---

From: "Gunnar Hellstrom" <[email-masked]>
Date: Wed, 17 Aug 2005 10:14:36 +0200

>It would need to be something application specific. For RTP, RTP no-op

That means that we must start work in avt on defining an RTP no-op for
all media types:
audio, text, video, image etc.
At the moment, I think that the no-op aims at MIME registration only for
m=audio.

Gunnar
-------------------------------------------
Gunnar Hellstrom
Omnitor AB
[email-masked]
--------------------------------------------

>-----Original Message-----
>From: [email-masked] [mailto:[email-masked]]On Behalf
>Of Jonathan Rosenberg
>Sent: Wednesday, August 17, 2005 1:46 AM
>To: Magnus Westerlund
>Cc: mmusic (E-mail)
>Subject: [MMUSIC] Re: draft-ietf-mmusic-ice-05: TCP keep-alive of
>bindings
>
>
>inline.
>
>Magnus Westerlund wrote:
>
>> Hi,
>>