Subject: [MMUSIC] mutually exclusive streams in SDP

From: sunil bhargo <[email-masked]>
Date: Wed, 26 Oct 2005 11:38:29 -0700 (PDT)

Hi,
 reposting the query again. 
 Is there any way to signal the receiver of the SDP
that certain streams can't be asked together.
 For example 
  This might be required for the case of two video
streams which might have been shot from two separate
angles(or different bit rate video streams) or for the
audio which is in x language and another in y language
or the case of streamed text with different languages
but  all these alternatives should not be subscribed
at the same time by the receiver of these media types.

sunil bhargo

		
__________________________________ 
Yahoo! Mail - PC Magazine Editors' Choice 2005 
http://mail.yahoo.com

_______________________________________________
mmusic mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mmusic

---

From: Per Fröjdh (KI/EAB) <[email-masked]>
Date: Fri, 28 Oct 2005 01:28:44 +0200

Hi Sunil,

Well, in PSS (Packet-switched Streaming Service) of 3GPP 
Release 6 we define extensions to SDP that basically do
what you ask for. They define alternatives at media level
and suitable groupings at session level.

This internet draft gives a short description of these
extensions (see clause 3.4):
http://www.ietf.org/internet-drafts/draft-westerlund-mmusic-3gpp-sdp-rtsp-02.txt

The relevant specifictaion in 3GPP is TS 26.234:
http://www.3gpp.org/ftp/Specs/archive/26_series/26.234/26234-650.zip

Best regards,
Per (editor of TS 26.234)

----------------------------------------------------------------
Per Fröjdh, Ph.D.                              Tel +46 8 4048188
Ericsson Research, Multimedia Technologies     Mob +46 730312413