Subject: Re: [MMUSIC] I-D ACTION:draft-ietf-mmusic-file-transfer-mech-01.txt

From: Colin Perkins <[email-masked]>
Date: Fri, 11 May 2007 12:51:11 +0100

On 27 Apr 2007, at 20:50, [email-masked] wrote:
> A New Internet-Draft is available from the on-line Internet-Drafts
> directories.
> This draft is a work item of the Multiparty Multimedia Session  
> Control Working Group of the IETF.
>
> 	Title		: A Session Description Protocol (SDP) Offer/Answer  
> Mechanism to Enable File Transfer
> 	Author(s)	: M. Garcia-Martin, et al.
> 	Filename	: draft-ietf-mmusic-file-transfer-mech-01.txt
> 	Pages		: 38
> 	Date		: 2007-4-27

One issue which still concerns me about this draft is that it spreads  
new values all over the SDP attribute namespace. Looking at section  
11.1, we see the following registrations:

file-sector        (should be file-selector, I assume?)
disposition
file-date
icon
file-range

How feasible would it be to rename the "disposition" and "icon"  
attributes to have a "file-" prefix (allowing for others types of  
icons, or the disposition of things other than files, in future)?

Colin

_______________________________________________
mmusic mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mmusic

---

From: Miguel Garcia <[email-masked]>
Date: Wed, 16 May 2007 15:16:06 +0300

Hi Colin:

I have no problems with your suggestion to rename these attributes.

Since I haven't heard any comments against it, I will rename these 
attributes in the next version of the draft.

/Miguel

Colin Perkins wrote:
>> This draft is a work item of the Multiparty Multimedia Session Control 
>> Working Group of the IETF.
>>
> attributes to have a "file-" prefix (allowing for others types of icons, 
> or the disposition of things other than files, in future)?
> 
> Colin
> 

-- 
Please note my new e-mail address: miguel.garcia at nsn.com
Miguel A. Garcia           tel:+358-50-4804586
Nokia Siemens Networks     Helsinki, Finland