Subject: [MMUSIC] ABNF errors in draft-ietf-mmusic-file-transfer-mech-01.txt

From: sudhakar an <[email-masked]>
Date: Wed, 16 May 2007 04:41:53 -0700 (PDT)

1)
    filename-selector    = "name:"  DQUOTE filename-string DQUOTE
                                        ; DQUOTE defined in RFC 4234
    filename-string      = byte-string ;byte-string defined in RFC 4566
 
From rfc4566
   byte-string =         1*(%x01-09/%x0B-0C/%x0E-FF)
                         ;any byte except NUL, CR, or LF
 
As it can be seen, the regular expression for byte-string would eat up the second DQUOTE and all subsequent character until CRLF. Possibly the draft needs to be modified to mention that any DQUOTE appearing within byte—string should be escaped properly.
 
2)
 
   hash-selector        = "hash:" hash-algorithm ":" hash-value
    hash-algorithm       = token     ;see IANA Hash Function
                                     ;Textual Names registry
    hash-value           = hex-val   ;hex-val defined in RFC 4234
 
From rfc4234
 
        hex-val        =  "x" 1*HEXDIG
                           [ 1*("." 1*HEXDIG) / ("-" 1*HEXDIG) ]
 
All examples in draft-ietf-mmusic-file-transfer-mech-01.txt seem to show the hash selector like this
 
    a=file-selector:name:"My cool picture.jpg" type:image/jpeg
          size:32349 hash:sha-1:72245FE8653DDAF371362F86D471913EE4A2CE2E
 
Please remove the ambiguity in specifying hash selector
 
Thanks 
Sudhakar

____________________________________________________________________________________
Be a PS3 game guru.
Get your game face on with the latest PS3 news and previews at Yahoo! Games.
http://videogames.yahoo.com/platform?platform=120121

_______________________________________________
mmusic mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mmusic

---

From: Miguel Garcia <[email-masked]>
Date: Mon, 21 May 2007 17:08:56 +0300

Hi Sudhakar:

Thanks for your comments. See inline discussion:

> As it can be seen, the regular expression for byte-string would eat up the second DQUOTE and all subsequent character until CRLF. Possibly the draft needs to be modified to mention that any DQUOTE…

I agree with you, we ought to say that if quotes are used they should be 
escaped along other characters that we already mention.

So, I have modified the filename-string ABNF, which is now defined as:

    filename-string      = 1*(%x01-09/%x0B-0C/%x0E-21/%x23-FF)
                          ;any byte except NUL, CR, LF, or double quotes

And I have added the following sentence later in the description:

    If a file name contains double quotes, they MUST be percent-encoded.

> Please remove the ambiguity in specifying hash selector

I am not sure if I understood where the problem is. I was comparing the 
ABNF and the example and to my knowledge, the example fits the ABNF. Can 
you please elaborate?

> Sudhakar

Thanks for you review.

/Miguel

-- 
Please note my new e-mail address: miguel.garcia at nsn.com
Miguel A. Garcia           tel:+358-50-4804586
Nokia Siemens Networks     Helsinki, Finland